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1 FOREWORD

This programmer's manual describes the operating software vcwin pro, an
external test program editor for the use with the vision systems (intelligent
cameras and multi-camera systems) by Vision & Control GmbH.

In this manual, the use of the operating software vcwin pro and the most
important functions are described.

The available functionality depends on the the vision system that is used. This
document describes the options for full function scope.

Please refer to the hardware manual for more detailed information about the
vision systems.

As well as the software, this programmer's manual is regularly improved and
extended. The current version can be found on the home page at www.vision-
control.com.
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2 THESE INSTRUCTIONS OF USE

We recommend introductory training at the Vision Academy. Before you start
writing your own programs you should be familiar with the way the software
works. The instructions of use provide a good basis.

Using the table of contents at the beginning or the index at the end of the
manual you will quickly find the menu item or command that you want to know
more.

Part 1 - Menu
Reference

The Menu Reference describes the menu structure of the operating software.

The fundamentals of working with programs and program elements are
explained in the Working with the User Interface section. The chapters
explain the entire menu items in the order of their position in the relevant
menus. >> see "Working with the User Interface", Page 21

Part 2 -
Command Reference

The command reference describes the commands available in the operating
software's Command Selection. The commands are structured into the
following groups:

• Image commands
• Locate commands
• Evaluation commands
• Control commands
• Obsolete commands

Part 3 - Appendices The appendix contains a description of the principles of detection and have
program listings for a number of demonstration programs.

Additional
Instructions of use

Instructions of use vision system

Please refer to the instructions of use delivered with each vision system
manufactured by Vision & Control GmbH. These documents describes the
resources available for your vision system.

ADVICE
As a rule, the various vision systems do not all have the same range of
functions and do not support the full functional range of the operating
software.

Instructions of use vicorem

These documents describes how the commands used are parametrized with
the transfer between vicorem and the vision system. This manual is necessary
for writing your own program modules.
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3 CONVENTIONS OF PRESENTATION

The formatting and the symbols in this document help you to use the
instructions of use and the device quickly and safely.

Product name The instructions of use are valid for the products listed at the beginning. If not
referred to expressly by the specific product name, the products described are
referred to as "devices".

Advice ADVICE
Indicates tips for users and useful additional information.

Enumeration Indicates a listing of issues or possibilities:

Heading or topic of the enumeration

• Example list item 1
• Example list item 2

Operating steps Listing of work steps, the given order of which must be followed. Numbering
starts at 1. for each individual sequence.

1. Example work step 1

Result work step 1

2. Example work step 2

Cross-references Cross-references help you to make quick reference to particular sections of the
manual, providing valuable supplements of information. The cross-reference
shows you the page of the relevant section. Example: see "These instructions of
use", Page 9

Links Links lead to documents outside the instructions for use. Expressly, no
guarantee or liability is accepted for the accuracy and security of these
documents (such as Internetpages). Links are only active in online-help and
the PDF version and with a connection to the Internet. Example: www.vision-
control.com

Spelling Commands, menus and dialogues are highlighted in bold. The spelling Utilities
indicated the menu Utilities.

References to subordinate entries are indicated by arrows.The spelling Utilities
> I/O Test indicates the command I/O Test in the Utilities menu.

The character formatting TEXT Indicates instructions, commands, and names
that you need to enter as shown.

Buttons are marked with square brackets. [OK] indicates the OK button.

Images and Tables Figures and tables shown as such are numbered consecutively. Individual
details in figures are marked by item numbers and lines. Each item number is
explained in the legend accompanying the figure.

http://www.vision-control.com/
http://www.vision-control.com/
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4 USING THE SOFTWARE

vcwin pro is an external test program editor for Vision & Control GmbH supplied
vision systems (intelligent cameras and multi-camera systems).

You use vcwin pro to create, change, test and start test programs. cutable.
vcwin pro runs under Microsoft Windows.

Previous Experience It is assumed that you are familiar with other applications which make use of
the Microsoft Windows environment. Programming skills are not necessary. We
recommend introductory training at the Vision Academy. Before you start writing
your own programs you should be familiar with the way vcwin pro works. You
should be able to follow the example programs and have a good idea of the
range of functions available within vcwin pro.

Available Functions vcwin pro inquires which functions the vision system supports and activates/
deactivates menu items and options accordingly during connection.

vcwin pro only displays the functions, commands and command options that are
supported by your vision system. Under "Function and Command Reference
(Firmware Overview) ", Page 375 you will find a short list. Please contact us
for more information.

Optional Commands Various commands are optional and are only available for certain vision
systems, hardware and firmware versions. Information concerning this is
available from your supplier.

Command codes ADVICE
All the command codes are described in the vicorem reference manual.
However, it is possible that your vision system cannot interpret all the
commands. Therefore, please always refer to the hardware manual for your
vision system.

Also add short, self-defined commands to the test program using Command
Selection > Control > Direct Code Input as HEX code. Please ensure
that your vision system – e.g. via firmware upgrade – can interpret these
commands.

Available Languages The program interface can be switched between English and German.

Scope of Delivery • Installation DVD
• Programmer’s manual vcwin pro
• When buying a vision system from Vision & Control GmbH respective

manuals are provided on DVD
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4.1 Communicating with Vision Systems

Operating vision
systems with a PC

PC

Vision System
vicosys
pictor

exteral module
PLC, slave, master

command mode

load job

run mode

remote control connection vicorem

serial / RS232
ethernet
digital I/O
field busses

external
camera(s)

vcwin pro

RUN

test program (job)

Image 1: Block diagram of a vision system with possible types of editor and link to
internal processes

Vision systems communicate with a processing environment in one of these
ways:

• Serial / RS232
• Ethernet
• Digital I/Os
• Several fieldbuses

Communication via
vicorem

vicorem is a block-oriented protocol used for communication between the vision
system and the master system (vcwin pro, PLC, ...).

vcwin pro sets all programs in this code.

Format:

• 2 byte block length
• 1 byte command recognition (ID)
• n byte command parameter
• 1 byte checksum

Example:

vcwin pro command:
Determine Point 0 (Image); Max. Gradient [10, 1, 2]; Dark/
Light Search Arrow: [249, 286/109, 259]

vicorem-remote code (hexadecimal):
[ 10 00 00 00 01 00 F9 01 1E 00 6D 01 03 02 07 0A 02 01 00
00 ]

ADVICE
More information about vicorem and its use can be found in the vicorem
manual. Please contact our support.
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Communication via
PC

vcwin pro or another compatible external editor is installed on the PC.

ADVICE
External editors are programs that run on a host computer and use remote
communication to link to the vision system. vcwin pro also belongs to this
category of external editors.

Communication is characterised as follows:

• Programs can be read into the vision system and tested via the remote
interface from the PC.

• The results are sent back from the vision system to the PC.
• Tried and tested programs are transferred from the PC to the vision system

and will run there automatically.

Communication
between vcwin pro
and Vision Systems

vcwin pro use the command mode to call any commands, to test and modify
them and then to create the program text. The test program is either loaded into
the vision system's RAM or directly as a file into the flash (load job).

In run mode (RUN) the program is executed on the vision system. vcwin pro
can log single functions (e.g. send image for the user interface).

Command Mode

In the command mode, the vision system works as a client of the PC. The
communication is characterised as follows:

The PC sends single commands to the vision system.
The vision system executes each command.
The vision system returns a result (success, failure or test value) to the PC.
Results are processed and evaluated by the PC.

Job Mode (Load Job)

The PC loads a complete test program (job) into the processing system
using the remote control interface vicorem.
The program is converted into a for the vision system understandable
language (e.g. ASCII).
The processing system stores the program on the flash or RAM.

Run Mode

The processing system transfers the program from RAM to flash and
executes the program cyclically.
An interaction with the PC will take place only by means of special
commands.
Special commands or functions send the results to the PC. e.g. Send Image,
Send Measuring Values, Online Debugging

Communicating with
PLC Devices

The vision system can also be connected via the signal I/O port or the RS-232
interface, ethernet or fieldbus interface to Programmable Logic Control devices
(PLC). The PLCs send or request event data and can thus be integrated into
the test runs. Direct control of actuators is also possible.

External modules can also control the processing system by remote control
interface vicorem.
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4.2 Installing and starting

Minimum
requirements of the
computer

• Operating systems: Windows Vista, Windows 7, Windows 8.1- Both 32 and
64 bit versions (Windows RT is not supported)

• DVD drive (for installation from DVD) or Internet connection (for installation
after download)

• Minimum 1 GB free RAM
• Monitor with a resolution of at least 800 x 600 pixels
• Ethernet interface
• Serial interface (optional for sending and receiving via RS232)

Installing Vision
System

ADVICE
Please refer to the instructions of use of the vision system for the exact
connection of the vision system.

Connect the vision system to the host computer with one of the following
methods:

• via a serial cable to a free serial interface
• via a ethernet cable with a free ethernet port

Optional:

If the vision system has a monitor interface, connect the video screen to the
vision system with a video cable.

Connecting cables, e.g. PLC, can be connected to the parallel I/Os (In- and
Outputs) of the vision system.

Installing vcwin pro Execute vcwin pro setup from the installation medium and follow the
instructions. The vcwin pro software will create an own icon on the Windows
desktop.

Image 2: vcwin pro Icon

Start and Quit vcwin
pro

The vcwin pro software is started by either double-clicking on the vcwin pro
icon or from the Windows start menu by calling Start > Programs > Vision &
Control GmbH > vcwin pro> Vision & Control vcwin pro.

Terminate vcwin pro with ALT+F4 or with the menu item File > Exit.

Designating the Port
in vcwin pro

After having started vcwin pro, you should designate the port to which the vision
system is connected by calling Communication > Interface from the menu. For
more information, see the section see "Interface", Page 93.

Connecting vcwin pro
with a Vision System

Before starting program teach-in, you must connect the vision system by
using the command Communication > Connect. The vcwin pro software
initialises the connection to the vision system and automatically activates all the
commands that the vision systems supports.
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4.3 From Single Commands to Test Programs

Summary of
Commands

Test programs consist of a list of commands. The commands are enumerated
chronologically and contain a single executable instruction each. Comments
can be inserted to help make the program more readable.

Test Program Size

With vicosys systems, the maximum program size is limited only by the Flash
memory. pictors allow a maximum program size of 512kB.

ADVICE
It must be considered here that, due to different coding, the size of a
vcwin pro program differs from the actual size of the test program on
the vision system. You can see the actual size of the test program under
Communication > System Resources.

Because the individual test commands can have different vicorem lengths, the
maximum program size cannot be given exactly as the number of test program
lines. As a rough guide, a maximum program size of 512kb corresponds to
around 7000 lines.

Number of Test Programs

The number of test programs is limited only by the total size of the flash
memory.

Image Acquisition
Commands

Configure the image acquisition commands for controlling the acquisition of
visual data by the vision system or the external cameras of the vicosys. This
group of commands contains:

• Image acquisition
• Configuring shutter mode
• Synchronous flash
• Selecting video mode, e. g. live image, memory image, overlay display and

image acquisition
• Deleting image information
• Setting acquisition page, work page, demo page, display page
• Displaying configuration of image-memory pages
• Image preprocessing
• Image difference
• Color binarization
• Color conversion
• Utilities for vicosys
• Line scan camera

Locate Commands
(Investigation and
Detection)

Configure test procedures for the analysis of test object properties with the
detection commands. The results are interpreted as quality criteria and the
geometry variables determined are saved. This group of commands contains:

• Testing geometry (points, lines, circles, contours, blobs, edges)
• Testing gray value and brightness
• Recognizing patterns, Data-Matrix code and characters
• Counting pixels
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• Compensating brightness
• Checking focus
• Teaching-in, searching and identifying objects
• etc.

Evaluation Commands With evaluation commands, you combine already determined geometries and
results, and configure the corresponding outputs in the test program. This group
of commands contains:

• Calculating geometries from existing geometry variables (points, lines,
circles, contours, distances, angles, angular positions)

• Evaluating and issuing results
• Superimpose parameters
• Counting
• etc.

Control Commands With control commands, you coordinate how the test program interacts
with other equipment, such as a PLC and handling systems. This group of
commands contains:

• Checking and branching the program
• Controlling the inputs and outputs of the camera
• Communicating with robots and transforming coordinates
• Calibrating
• Sending measured values and results via several interfaces
• etc.

Obsolete Commands Obsolete commands are commands that have been superseded by newer
commands. Although these commands are no longer supported, they are found
in some versions yet, due to backward compatibility of vcwin pro.

ADVICE
The commmands in the category Obsolete should no longer be used for test
programs, see also see "Obsolete commands", Page 364.

Checklist for Planning
Tests

Test programs are similar to any other programs in that they consist of a list
of commands. The commands are enumerated chronologically and contain
a single executable instruction each. Comments (only with contents) can be
inserted to help make the program more readable.

Establishing Procedures during a Test

• Decide which contours and points should be included to determine
geometry.

• Establish the best order.
• Define the screen output: verbal messages (e.g. errors, status etc.), values,

superimpose with geometric figures.
• Define the requirements for the communication (PLC, Ethernet and serial):

start signal, standby message, error messages (general, special), output of
values.

Assigning Variables according to the Test Plan/Drawing

• Adherence to systematology (e.g. points to circle 3: P31, P32, P33).
• Establish areas in which variables only temporary required will be stored so

that they can be overwritten.
• Use the Comment command for the program documentation.
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Structuring Test Programs Efficiently

• Find repetitions in the program and rewrite them as loops with break
conditions.

• Find often-used routines in the main body of the program and rewrite them
as subroutines.

Use the Support Available

• Please take note of the demonstration programs included in the appendix.
These programs can be used as frameworks for adapting to individual tasks.

• Please take advantage of the up-to-date know-how available at training
courses run at the Vision Academy.
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Combining
Commands and
Command Groups

Find important command groups and processes for program generation from
the following diagram.

Image Analysis

Point
Line
Circle

Definition
Point
Line
Circles

Geometry Lists

Point, Line, Circle
Contour, ...
Blob Analysis, ..
Pattern Search

...

Detect, Analysis

Gray Value
Count Pixels
Color Test

Test Commands

Read Character
Inspect Surface
Angular Position

Data Matrix Code
Check Point Distance
...

Image Aquisition

Test Element

Image Aquisition

Best Circle, Roundness
Best Line, Straightness

Evaluation

Distance
AngleCombine Results

Evaluation

Evaluation
Evaluation

Result Structure

Evaluate Result

OK / Bad
Classes / Sorts

Selection

...
Send Values

HMI, ...
Display on Monitor

Representation

...
Send Image

Send Result

Handling Systems, ...
Control of PLC,

Parameter Transfer

...

Control

Running Test
Programs

Step 1: Image Acquisition

The image captured by the vision system is stored in an image page in the
image memory.

Step 2: Image Analysis

Use the following options to describe the test objects:

• geometric variables and the geometric relations between them
• qualitative attributes of the test objects
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The determination of geometric variables and the check of quality properties
are carried out by the detection command. New geometric variables and further
numeric measurement results can be calculated from the immediate geometric
results.

Step 3: Evaluation

Evaluation of results can take on several forms:

• comparing results in dialog box with nominal values
• using the Evaluate Result command
• using the Combine Results command

Step 4: Control Commands

Control commands and the commands for calibration and justification
guarantee that the program can be properly adjusted to the existing hardware
environment, e. g. the parameterizing of the communication to industrial robots.

Moreover, several communication options are available:

• sending values over serial/RS232
• sending values over ethernet
• sending signal states over the digital I/Os
• Communication via several field busses

Variables and
Elements in Programs

You can see the type and number of commands that are supported by your
vision system displayed in a window when connecting the vision system.

Reference Geometry

Parameter sets describing the geometry of test objects can be saved so that
the data can be re-used later on. The parameter sets can contain points, lines,
circles, contours and results.

Result Numbers / Result Structure

A sequence of commands leads to arithmetic results or test results which can
be stored under result numbers and are available for further processing. All the
results together form a result structure.

4.4 Checklist for Operating the Software

Preparation for Editing
Test Programs

Execute the following steps prior to editing programs:

1. Install the vision system. Follow the instructions for use for the
corresponding vision system. Install the user software vcwin pro.
>> see "Installing and starting", Page 14

2. Start vcwin pro.

3. Register the interface between the host computer and the vision system in
vcwin pro by calling Communication > Interface.
>> see "Interface", Page 93

4. Connect the vision system by Communication > Connect. 
This causes the vcwin pro menu to contain only commands which are
supported by the connected vision system. The vision system will be in
Command Mode.
>> see "Operating vision systems with a PC", Page 12
The vision system can now be remote-controlled from the host computer.

5. Select Live Image in the Video Control Panel see "Docking Window Video
Control Panel", Page 41, then position the test object and adjust the
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sharpness of the vision system image on the control monitor or alternatively
in the monitor window see "Docking Window Monitor Window", Page 42.
Also ensure that the aperture is correctly adjusted.

6. Now select the Memory Image option in the Video Control Panel.

7. Click on the Grab Image button to load the current image into the image
memory page.

Inserting and Editing
Commands

1. Move the cursor to the position in the command list following which you want
the new command to be inserted. 
>> see "Command Display", Page 32

2. To insert a new command: Select the required menu entry in the command
selection. 
To edit an existing command: Double click on the program line you want to
change.

3. In the case of Locate commands you should define the detection windows or
beams directly on the control monitor or monitor window.
see "Teaching in Detection Windows and Test Windows", Page 110

4. Enter the input and output parameters of the result structure or geometry
structure as well as measured values and tolerances or select these from the
displayed resources.

5. Test the command with the [Test] button. If this returns the desired result
e.g. it finds an edge in the video image, go on to item 6. If not, adjust the
parameters or the detection/ test window.

6. Press the [OK] button. The command will be added to the command list as
text in vcwin pro.

You can use commands also in the following manner:

• copying
• cutting
• deleting
• saving in a special file (as a block)
• commenting out

Testing the Program
and Transferring it to
the Vision System

1. Test in Command Mode using the commands in the Utilities menu. 
>> see "The Utilities Menu", Page 68

2. If this test is successful, copy the test program into the main memory of the
vision system by calling Communication > Transfer.
>> see "Transfer", Page 82

3. In run mode, test by calling Communication > Run.
>>see "Disconnect", Page 82

4. If there are no errors, connect the vision system by calling Communication
> Connect. 
The vision system returns to the Command Mode.

5. Transfer the test program into the vision system by calling Communication
> Transfer or with the [Transfer] button. The test program is stored in the
vision system’s own file system.

Special Features Vision Systems with Flash give you the opportunity to transfer programs via
Communication > Save File System in Flash.
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5 WORKING WITH THE USER INTERFACE

This chapter deals with the general surface of vcwin pro. It is described for
which the several Windows and bars are used and how they are handled.

The first part deals with the Programming Window and its elements. see
"Overview over the Programming Window", Page 21

The second part explains the function of the see "Measurement User Window",
Page 44.

Under see "Customize interface", Page 48you will learn how to optimise the
user interface and how you can suite the elements according to your wishes.

5.1 Overview over the Programming Window

Command
Selection

Menu Bar

Status Bar

Toolbar Command Display Monitor Window

Video Control Panel

Control Area

Geometry List

Image 3: Elements of the programming window
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The fist time you start vcwin pro, the user interface is shown with the
Programming Window. In this view, you can establish a connection to the vision
system, create test programs and parametrise commands.

The Programming Window consist of following elements:

Element Description

Menu Bar Area with drop-down menus, where commands are
grouped according to categories.
Categories: File, Edit, View, Utilities, Communication,
Options, Help

Tool Bars Draggable bars with buttons for menu options and
other commands.
Categories: Default, Docking Windows , Debugging,
Communication

Status Bar Area that displays system- and programinformations.

Command Display Area in which the editable commands of the test
program are displayed and edited.

Docking Window Window, containing additional instructions and infor-
mation.
Categories: Command Selection, Results, Points,
Lines, Circles, Project, Labels, Debug History, Video
Control Panel, Monitor Window

5.2 Menu Bar

The menu bar is located in the upper left corner of the Programming Window. It
is an area with a drop down menu where commands are grouped by categories.
In the default setting, the menu bar contains of the File, Edit, View, Utilities,
Communication, Options and Help menus.

How you customise the Menu Bar and the menus to your needs, please refer to
the section "Customize interface", Page 48

The particular menus of the menu bar are described in detail as follows.

Menu File The File menu contains functions that relate test programs.

In the drop-down menu you will find:

• commands for creating, opening, closing, and saving test programs
• Tools for the handling of projects
• User information, as well as print settings and page setup
• recently opened files (if present)
• command to terminate the operating software

For further information please refer to: "The File Menu", Page 52.
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Menu Edit The Edit menu contains instructions for editing an open test program.

In the drop-down menu you will find:

• bookmarks to find specific parts of the program, the command to change
dialogues, and command selection for classification of right-linked
commands.

• options for searching text, labels or commands
• commands to cut, copy, paste, delete and undo
• Command to save and load a command block
• option to enable and disable individual commands
• a comment function for documentation
• the name assignment of variables

For further information please refer to: "The Edit Menu", Page 57.

Menu View The View menu allows to display or hide user interface objects and switch to
the user interface.

In the drop-down menu you will find:

• switching to the user interface
• a list of all docking windows and options for showing and hiding them
• a list of all toolbars and options for showing and hiding them
• Option to show and hide the Status Bar

For further information please refer to: "The View Menu", Page 66.

Menu Utilities The Utilities menu contains tools for testing and setting up test programs.

In the drop-down menu you will find:

• Online Debugging
• Options for testing of commands and the step test
• Options for testing of command sections and programs
• Ability to set and clear breakpoints
• Image Report
• Options for image transfer (send and receive)
• Options for resetting of geometry variables, to calibrate the vision system,

white balance and shading correction
• functions for testing the I/O hardware

For further information please refer to: "The Utilities Menu", Page 68.

Menu Communication The Communication menu contains functions for organising the
communication between the host computer and the vision system.

In the drop-down menu you will find:

• Functions to connect to the vision system, for program transmission and run
of the vision system

• Functions to make and restore data backups
• Options for managing test programs, geometrie sets, pattern, images and

modules on the vision system
• Options for managing date and time, the settings on the vision system and

licences for special functions
• settings for the interface to be used
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• Options for changing the IP address of the vision system or the fieldbus
settings

• Information about the vision system

For further information please refer to: "The Communication Menu",
Page 80.

Menu Options With the Options menu you can change the appearance of the user
interface.There is also the user management.

In the drop-down menu you will find:

• Settings to display commands
• Adjustments to the surface such as language, font and colour, settings for

timeouts, breaks and display time and the quality of images with the JPEG
option

• Settings for user management

For further information please refer to: "The Options Menu", Page 101.

Menu Help The Help menu contains the menu item to invoke the help and the program
information.

In the drop-down menu you will find:

• the online-help (these instructions of use)
• Informations about the user interface and the processing system

For further information please refer to: "The Help Menu", Page 107.

5.3 Toolbars

The toolbars are located in the upper left corner of the programming window,
below the menu bar.

The toolbars consists of buttons, symbolized by icons (thumbnails), enabling
quick access to menu items and individual functions. They include a selection of
frequently used commands.
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In the default setting the toolbars contains of following toolbars: Default,
Docking Windows, Debugging and Communication. In the default view, the
predefined toolbars Commands: Image, Commands: Locate, Commands:
Definition, Commands: Control, Commands: Evaluation and Commands:
Check are not displayed.

How you customize the Toolbars, please refer to the section "Customize
Toolbars", Page 49

Hereinafter the toolbars are listed, and each of the buttons are explained.

Toolbar Default

The Default toolbar, provides the following functions as buttons:

Icon Designation Description

New Create a new program.

Open Open an existing program.

Save Save the current program.

Cut Cut the selection and put it on the Clipboard.

Copy Copy the selection and put it on the Clipboard.

Paste Insert Clipboard contents.

Print Print the current program.

About Display program information, version number and
copyright.

Toolbar
Docking Window

The Docking Windows toolbar, provides all docking windows of the menu View
as buttons.

Icon Designation Description

Monitor
Window

Shows/Hides the Monitor Window.

Command
Selection

Shows/Hides the Command Selection.

Video Control
Panel

Shows/Hides the Video Control Panel.

Project Tree Shows/Hides the Project Tree.

Labels Tree Shows/Hides the Labels Tree.

Debug History Shows/Hides the Debug History.

Result List Shows/Hides the Results List.
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Icon Designation Description

Point List Shows/Hides the Points List.

Lines List Shows/Hides the Lines List.

Circles List Shows/Hides the Circles List.

Strings List Shows/Hides the Strings List.

Contours List Shows/Hides the Contours List.

Toolbar Debugging

With the Debugging toolbar, you can insert breakpoints in your program in
order to control the flow of the Online Debugging better. Information about
Online Debugging and the use of breakpoints, see "Online Debugging ",
Page 124.

The Debugging toolbar, provides the following functions from the menu
Utilities as buttons:

Icon Designation Description

Start/Continue
Debugging

Starts or resumes the online debugging.

Stop Debug-
ging

Stops the Online Debugging.

Set/Delete
Unconditioned
Breakpoint

Sets or deletes an unconditioned breakpoint.

Set/Delete
Conditional
Breakpoint
(error)

Sets or deletes a breakpoint that is triggered if the
previous command failed.

Set/Delete
Conditional
Breakpoint
(good)

Sets or deletes a breakpoint that is triggered if the
previous command was free of errors.

Delete All
Breakpoints

Deletes all breakpoints.

Toolbar
Communication

The Communication toolbar gives you quick access to functions to set the
communication between the host computer and the vision system. Information
about connecting and other points of communication can be found at "The
Communication Menu", Page 80.
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The Communication toolbar, provides the following functions from the menu
Communication as buttons:

Icon Designation Description

Interface Opens the dialog for configuring the Communication
Parameters.

Selection of
the vision
system

Select the vision system you want to be connected to.

Update List Updates the list of vision system connected via
Ethernet.

Connect Connects to the vision system.

Transfer Transfers the program to the vision system.

Disconnect Disconnects from vision system. Starts program in
vision system.

Toolbar
Commands: Image

The toolbar Commands: Image gives you quick access to the most commonly
used image commands. If you click on the button, the dialog box of the relevant
command opens. Information about the commands and their usage, please see
the command reference under "Image Commands", Page 127.

ADVICE
In the default view the toolbar Commands: Image is not displayed.

To show toolbars:
Click the menu View > Toolbar, and then click the toolbar Commands:
Image. A check mark next to the toolbar's name indicates that the toolbar is
displayed.

The toolbar Commands: Image provides the following functions from the
command selection Image as buttons:

Icon Designation Description

Grab Image Captures an image.

Video Mode Selection of live image and memory image.

Display Configure Acquisition, Work, Demo and Display Page.

Configure
Shutter

Configures the exposure time.

Synchronous
Flash

To trigger signal synchronized image capturing
including lighting control.

Delete Image Clears the image or the overlay.
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Toolbar
Commands: Locate

The toolbar Commands: Locate gives you quick access to the most commonly
used locate commands. If you click on the button, the dialog box of the relevant
command opens. Information about the commands and their usage, please see
the command reference under "Locate Commands", Page 167.

ADVICE
In the default view the toolbar Commands: Locate is not displayed.

To show toolbars:
Click the menu View > Toolbar, and then click the toolbar Commands:
Locate. A check mark next to the toolbar's name indicates that the toolbar is
displayed.

The toolbar Commands: Locate provides the following functions from the
command selection Locate as buttons:

Icon Designation Description

Locate Point Locates a point in the image.

Locate Line Locates a line in the image.

Locate Circle Locates a circle in the image.

Locate
Contour

Locates a contour in the image.

Blob Analysis Finds related areas (blobs) in the image.

Search
Pattern

Found a previously taught in pattern in the image.

Toolbar
Commands: Definition

The toolbar Commands: Definition gives you quick access to the most
commonly used definition commands. If you click on the button, the dialog box
of the relevant command opens. Information about the commands and their
usage, please see the command reference under "Evaluation Commands",
Page 265.

ADVICE
In the default view the toolbar Commands: Definition is not displayed.

To show toolbars:
Click the menu View > Toolbar, and then click the toolbar Commands:
Definition. A check mark next to the toolbar's name indicates that the toolbar
is displayed.
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The toolbar Commands: Definition provides the following functions from the
command selection Evaluation as buttons:

Icon Designation Description

Define Point Defines a point from other geometry variables or fixed
values.

Define Line Defines a line from other geometry variables.

Define Circle Defines a circle from other geometry variables.

Center of
Gravity of
Contour

Determines the center of gravity and the area of a
contour.

Best Fit Line Calculates a straight line from points or contours and
determines their straightness.

Best Fit Circle Calculates a circle from contours or points and deter-
mines their roundness.

Toolbar
Commands: Control

The toolbar Commands: Control gives you quick access to the most
commonly used control commands. If you click on the button, the dialog box
of the relevant command opens. Information about the commands and their
usage, please see the command reference under "Control Commands",
Page 314.

ADVICE
In the default view the toolbar Commands: Control is not displayed.

To show toolbars:
Click the menu View > Toolbar, and then click the toolbar Commands:
Control. A check mark next to the toolbar's name indicates that the toolbar is
displayed.

The toolbar Commands: Control provides the following functions from the
command selection Control as buttons:

Icon Designation Description

Datatransfer Sends and receives geometry variables.

Line I/O Queries single digital inputs or sets single digital
outputs.

Counter Sets or edits a counter.

Branch Sets labels and condition blocks and jumps with and
without condition to labels and subroutines.

Port I/O Queries multiple digital inputs or sets multiple digital
outputs.

Wait Stops the inspection process for the specified time.
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Toolbar
Commands: Evaluation

The toolbar Commands: Evaluation gives you quick access to the most
commonly used evaluation command. If you click on the button, the dialog box
of the relevant command opens. Information about the commands and their
usage, please see the command reference under "Evaluation Commands",
Page 265.

ADVICE
In the default view the toolbar Commands: Evaluation is not displayed.

To show toolbars:
Click the menu View > Toolbar, and then click the toolbar Commands:
Evaluation. A check mark next to the toolbar's name indicates that the
toolbar is displayed.

The toolbar Commands: Evaluation provides the following functions from the
command selection Evaluation as buttons:

Icon Designation Description

Distance Calculates the distance between points, lines and
circles.

Combine
Results

Sets results or combines them to other mathematical
results.

Angle Calculates angles between lines.

Superimpose Superimposes geometry variables and text on the
image.

Toolbar
Commands: Check

The toolbar Commands: Check gives you quick access to the most commonly
used check commands. If you click on the button, the dialog box of the relevant
command opens. Information about the commands and their usage, please see
the command reference under "Locate Commands", Page 167.

ADVICE
In the default view the toolbar Commands: Check is not displayed.

To show toolbars:
Click the menu View > Toolbar, and then click the toolbar Commands:
Check. A check mark next to the toolbar's name indicates that the toolbar is
displayed.
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The toolbar Commands: Check provides the following functions from the
command selection Locate as buttons:

Icon Designation Description

Test Gray
Value

Determines gray values in an image region.

Count Pixels Determines the number of pixels of a specific gray
value range in an image region.

Test Bright-
ness
Percentage

Determined the percentage of bright pixels in an
image region.

Inspect
Surface

Determines disruptions in an image region.

Focus Determines the focus value as a measure of image
sharpness.

Brightness
Offset

Compensates variations in the brightness of the
image.

5.4 Status Bar

The status bar is located at the bottom of the programming window.

In this section are displayed cyclically read program and system information.

1 2 43 5 6 7 8 9
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(1) Number and result of the last executed command, or a quick help on
menu items, symbols and commands.

(2) Displays the connection type (COM, TCP) between vision system and
host computer or respectively simulator and host computer– and if
possible – the connection parameters and the vision system type or the
name of the simulator.

(3) Displays the active Video mode: live image or memory image. If there is
no connection to a vision system or simulator, it shows "Not connected".

(4) In command mode, the camera number appears when the vision
system is initialised.

(5) In command mode, the image page number appears when the vision
system is initialised.

(6) Displays whether the Demomode (graphic overlays in monitor window)
is currently on (ON) or off (OFF).

(7) Total number of lines in the program as well as the line number of the
selected command.

(8) Time protocol: displays the duration of the last command executed.
Use the time protocol to optimise the timing in test programs. For Test
Section and Test Steps, vcwin pro displays the time required for each
step, in turn.

(9) The system time of the host.

ADVICE
Time protocol: The time shown for the display of graphics during a test (step
mode F7) serves only as a rough guide. The expected time in run mode is
somewhat lower.

5.5 Command Display

The command display is located centrally in the programming window.

The command display contains the editable commands of the test program in
text representation. It contains important information about parameters and
variables.
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Insert Commands Commands can be entered via the docking window Command Selection by
clicking on the desired command.

Alternatively, you can open a command by simply typing the name with your
keyboard. To do so, click in the Command Display and start typing the name
of a command. Now a select field pops up and suggests commands based on
your input. To choose and open your desired command, click on the name and
press [ENTER]. To cancel this operation, press [ESCAPE].

In both cases, the command dialog opens. After completing the configuration,
the command is then insert after the last active command (marked in blue).

Edit Commands Commands can be edited via calling the command dialog. To do this, double-
click the desired command in the command display.

Command appearance Commands are displayed as text in the command list of the command display.

You can change the appearance of the text between short display (abbreviated)
or full display via Options > Full Display.

Full Display No. Label Command
00003 Determine Line 3 (World Coordinates);

10 Single Detections to 156 Pixels; Search
Arrow: [557, 154/472, 154]; Max. Gradient [5,
1, 1]; Dark > Light

Short Display No. Label Command
00003 Determine Line 3 (World Coordinates);

Font Color To improve the clarity of the program, different colors are assigned to the
program elements.

How you can change the font and font colour, please see: "Application
Settings", Page 103.

Active commands These commands are shown in black, with serial number, command type and
parameters.
No. Label Command
00001 Standard Image Acquisition with camera 4
00002 Determine Line 3 (World Coordinates);

10 Single Detections to 156 Pixels; Search
Arrow: [557, 154/472, 154]; Max. Gradient [5,
1, 1]; Dark > Light

Deactivated
commands

These commands are shown in red without serial number, with command type
and parameters. Automatically it is switched to short display.
No. Label Command
----- Standard Image Acquisition with camera 4
----- Determine Line 3 (World Coordinates);

Commands can be activated or deactivated via Menu Edit > Activate /
Deactivate or via the key [F4].
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Comments Comments are shown in green without serial number.
No. Label Command
*****
*****
*****
*****
*****

This is a comment.
This is a comment,
that spans multiple lines and

contains blank lines.

Comments can paste from the Edit menu > Insert Comment or via the key
[F2].

Branch command These commands are shown in blue, with serial number, label name and
parameter.
No. Label Command
00000 Start
00001 ---> Jump to Label "Start" (unconditional)

Commands for program control (Branch) are:

• Branch
• Indexed Branch
• Port Control

5.6 Docking Windows

An important part of the user interface are docking windows. The docking
windows contain commands, tools or indicators for specific tasks and functions.

The default setting includes a selection of the most commonly used docking
windows.

• Command Selection
• Geometry Lists: Results, Points, Lines, Circles
• Geometry Lists: Strings, Contours (hidden)
• Project, Labels, Debug History (grouped)
• Video Control Panel
• Monitor Window (floated)

How you customise the user interface by using docking windows to your needs,
please refer to the section see "Customize interface", Page 48.

Subsequently, the docking windows are listed and explained.
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5.6.1 Docking Window Command Selection

In the default view, the docking window Command Selection is located in the
left-hand area of the programming window.

The docking window command selection contains all usable image processing
commands. They are separated into the categories Image, Locate,
Evaluation, Control, and Obsolete (deprecated features). The category All
Commands includes all commands in alphabetical order. To open an image
processing command from the command selection, click on the appropriate
categoryname and click on the required command. The command is opened in
an dialog box.

After being connected to a vision system, commands that are not supported by
the vision system, are grayed out in the command selection.

To show or hide docking window Command Selection

Click in the View menu > Command Selection or click on the corresponding
icon in the toolbar Docking Window. A frame around the icon indicates that the
docking window is displayed.
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5.6.2 Docking Window Geometry Lists

In the default view, the docking windows Geometry Lists are located in the lower
area of the programming window.

The geometry lists contain the geometry variables that are generated by
executing programs.

Docking Window
Results

In this docking window, you can see all currently defined results of the program.

ADVICE
The value of a result is always specified in world coordinates.

Information:

• number or name of the result
• evaluation of the result
• value of the result (in world coordinates)

To show or hide docking window Results

Click in the View menu > Result or click on the corresponding icon in the
toolbar Docking Window. A frame around the icon indicates that the docking
window is displayed.
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Docking Window
Points

In this docking window, you can see all currently defined points of the program.

Information:

• number or name of the point
• type of coordinate (world- or imagecoordi-

nate)
• x coordinate
• y coordinate

To show or hide docking window Points

Click in the View menu > Points or click on the corresponding icon in the
toolbar Docking Window. A frame around the icon indicates that the docking
window is displayed.

Docking Window
Lines

In this docking window, you can see all currently defined lines of the program.

Information:

• number or name of the line
• type of coordinate (world- or imagecoordi-

nate)
• x coordinate point 1
• y coordinate point 1
• x coordinate point 2
• y coordinate point 2

To show or hide docking window Lines

Click in the View menu > Lines or click on the corresponding icon in the toolbar
Docking Window. A frame around the icon indicates that the docking window is
displayed.

Docking Window
Circles

In this docking window, you can see all currently defined circles of the program.

Information:

• number or name of the circle
• type of coordinate (world- or imagecoordi-

nate)
• x coordinate of the centre of circle
• y coordinate of the centre of circle
• radius

To show or hide docking window Circles

Click in the View menu > Circles or click on the corresponding icon in the
toolbar Docking Window. A frame around the icon indicates that the docking
window is displayed.
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Docking Window
Strings

ADVICE
The geometry list Strings is not displayed in the default view

In this docking window, you can see all currently defined strings of the program.

Information:

• number or name of the string
• content of the string

To show or hide docking window Strings

Click in the View menu > Strings or click on the corresponding icon in the
toolbar Docking Window. A frame around the icon indicates that the docking
window is displayed.

Docking Window
Contours

ADVICE
The geometry list Contours is not displayed in the default view.

In this docking window, you can see all currently defined contours of the
program.

Information:

• number or name of the contour

To show or hide docking window Contours

Click in the View menu > Contours or click on the corresponding icon in the
toolbar Docking Window. A frame around the icon indicates that the docking
window is displayed..
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5.6.3 Docking Window Control Area

In default view, the docking window Control Area (Project, Labels, Debug
History) is located in the lower right-hand area of the programming window.

The docking windows Project, Labels and Debug History are in grouped
arrangement.

Docking Window
Project

In the docking window Project you will find the project-tree. You can create
and organize your Machine Vision projects here. You can assign and organize
program and image files for individual projects within this window.

You can find following functions in the toolbar:

• New Project
• Open Project
• Save Project
• Save Project as
• Add Program File to the project
• Add Image File to the project
• Remove File (Program or Image) from the

project

To show or hide docking window Project

Click in the View menu > Project Tree or click on the corresponding icon in the
toolbar Docking Window. A frame around the icon indicates that the docking
window is displayed.
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Docking Window
Labels

In the docking window Labels you will find the Labels tree.

In the Labels window you can see the labels you set with the control command
Branch (see "Branch", Page 349).

For reasons of clarity, there is a search filter
located above. If you  enter a search term here,
only labels including the search term will be
displayed. Use the "X"  behind the search filter
to reset the filter and display all labels.

To show or hide docking window Labels

Click in the View menu > Labels Tree or click on the corresponding icon in the
toolbar Docking Window. A frame around the icon indicates that the docking
window is displayed.

Docking Window
Debug History

In the docking window Debug History you will find the results of the online
debugging.

The debug history displays the results of
processed commands from the current debug-
ging process.
For more information, please see "Online
Debugging ", Page 124.

To show or hide docking window Debug History

Click in the View menu > Debug History or click on the corresponding icon in
the toolbar Docking Window. A frame around the icon indicates that the docking
window is displayed.
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5.6.4 Docking Window Video Control Panel

In default view, the docking window Video Control Panel is located in the upper
right-hand area of the programming window.

Use the Video Control Panel for grab an image in command mode. It does not
write the command into the test program that is being edited. You can set the
camera directly in live image mode before the image is grabbed.

The image output take place via the build-in Monitor Window (see "Docking
Window Monitor Window") or an external control monitor.

To show or hide docking window Video Control Panel

Click in the View menu > Video Control Panel or click on the corresponding
icon in the toolbar Docking Window. A frame around the icon indicates that the
docking window is displayed.

Image Acquisition The current image from the vision system is sent to image memory of the
selected image memory page. The number of cameras and image pages
available depends on the vision system concerned.

Parameters Description

Camera Defines the camera for the image acquisition (via radio buttons
or combo box).

Page Defines the image page for the image acquisition (via radio
buttons or combo box).

Grab Image You grab an image from the set camera onto the defined
image page with the [Grab Image] button.

Overexpose /
Underexpo-
sure

Option for displaying overexposed and underexposed areas
in an acquired image. Displays gray values from 0 to 10 in red
and gray values from 245 to 255 in blue. The display is only on
the control monitor.
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Overlay Graphic Parameters Description

Demo Mode This mode enables/disables the display of overlay graphics
(e.g., from detection beams, contours or points) on the control
monitor or in the monitor window. At the same time, the Demo
Mode ON/OFF text is displayed in the status bar.

Delete
Graphics

With the button [Delete Graphics] you delete the overlay
graphics of the current image page on the vision system.

Video Mode Parameters Description

Live Image In Live Image mode the video image from the current camera
appears on the video monitor or Monitor View. At the same
time the text Live Image appears in the status bar.

Memory
Image

In memory image mode the current memory image page
appears on the video monitor or Monitor View. At the same
time the textMemory Image appears in the status bar.

5.6.5 Docking Window Monitor Window

In default view, the docking window Monitor Window is floating and located in
the upper right-hand area of the command display.

Video Image

Zoom Fullscreen grey value and coordinates

Load / Save Image

Image 4: Monitor Window

Use the monitor window to evaluate live- or memory images, to teach in
patterns or search windows or check parameters and variables, if no control
monitor is connected.

To show or hide docking window Monitor Window

Click in the View menu > Monitor Window or click on the corresponding icon in
the toolbar Docking Window. A frame around the icon indicates that the docking
window is displayed.

Image 5: show or hide Monitor Window



vcwin pro 2.21
Working with the User Interface

© Vision & Control GmbH
2015

999.994.306.10-en-1.15 43

By using the toolbar of the monitor window, you can run the following
commands:

Icon Designation Description

Load Image Opens an image from a file.

Save Image Saves the current image in a file.

Fast Image
Loading

Activates/Deactivates the lossy image transfer (JPEG
compressed) from the Vision System.

Zoom Sets the magnification factor. Standard: "Auto".

Fullscreen Activates/Deactivates the fullscreen mode.

Automatic
Fullscreen
Mode

Activates/Deactivates the automatic fullscreen mode
for teach-in mode and live image mode.

Display grey
value

Displays the grey value for the current mouse cursor
position.

Display coor-
dinates

Displays the coordinates for the current mouse cursor
position.

ADVICE
Use of lossy image compression!

If activated (JPG), the picture is fetched from the vision system as
compressed and lossy JPG. This enables a faster image transmission at the
cost of a lower image quality. It is recommended to not activate this option
due to the alteration of grey values that comes with the compression. Also
for colour images, some colour values are not consistent with the original.
Because of the faster transmission speed, the JPG mode is suited for remote
maintenance via VPN.

The JPG quality is set to 75% by default. You can adjust the level of
compression in the section Application Settings >>Advanced<<, see
"Application Settings", Page 103.

5.7 User Window

The User Windows are specific user interfaces for different tasks. You can
select among the following options:

• Standard User Window … used for the execution of completed programs
• Measuring User Window … used for good/bad evaluation and measurement

statistics

The user window can be determined in the programming window via Options >
Application Settings > Look.
>> see "Application Settings", Page 103
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5.7.1 Standard User Window

The standard user interface is a tool with that the image processing task can be
visualized, during the runtime of the vision system.

With the standard user interface, you can:

– start and stop the currently loaded program
– alternate between live- und memory image
– display of transmitted images
– load a program on the vision system 

– switch to the program window (user right based)

Image

Start Videomode
Programming

Load ExitWindow
Image 6: Dialogue Standard User Interface

5.7.2 Measurement User Window

The measurement user window is a tool with which a Vision & Control
GmbH image processing system manages, controls and archives a machine
application. The statistics that are displayed show the relationship between
positive and negative test procedures.

The user window maintains information independently from the programming
window. The user window filters a great deal of data out of the test program
when it is loaded. In order that the user window can work correctly, it is
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therefore essential that the test program in the image processing system is
identical with the test program last loaded by the user window.

Image

Measurements

Statistics

Tolerances

Graphic 1 Graphic 2 Preferences

Start
Videomode Programming Window

Load

Image 7: Dialogue Measurement User Window

Load The Load button transfers a test program optionally to working storage or to the
image processing system’s flash. During this process, the user window extracts
information from the test program about results and images to be sent.

Start/Stop With the Start and Stop buttons, you start the test program that is currently
loaded or interrupt it. Stop also initialises the vision system.

Programming window With the Programming Window button, you arrive at the programming dialog.
This button can be protected by a password against unauthorised access (see
"User Management", Page 106).

Image window The image window (upper left) contains the latest test images that were
transferred during run time. All detections and superimpositions are shown in
this window.

Measurement values In the measurement values window (lower left), data and parameters
determined during the test program are displayed.

The Graphic 1/ Measurement Values button lets you choose to have the
measurement values displayed either as a table or as a graph. In the graphic
representation, green is used for good evaluations and red for bad evaluations.

It is always displayed only one measurement value. You can set them by using
the Preferences button.

Tolerances In the tolerances window (lower right) the tolerance areas parameterised in the
test program are shown. The relevant parameters are:

• Upper and lower tolerance thresholds
• Nominal size
• Good measurement values (green)
• Bad measurement values (red)
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The Graphic 2/ Measurement Values button lets you choose to have the
measurement values displayed either as a table or as a graph. In the graphic
representation, green is used for good evaluations and red for bad evaluations.

It is always displayed only one measurement value. You can set them by using
the Preferences button.

Change Tolerances

Image 8: Dialogue Measurement User Window, Measuring Values - Edit Presets

To adjust tolerances double-click on the corresponding measurement line. The
dialogue Measuring Values - Edit Presents opens. Set the desired new values
here.

The tolerances are changed and stored in the respective program on the PC.
Upload the program with the button [Load] to the vision system, to apply the
changes.

Bar chart/statistics The bar chart (upper right) gives you a statistical representation of the process
variables. It contains good/poor statistics for a percentage-based evaluation of
the determined values.

Settings dialog The settings dialog allows the user to save events and images in the computer
that were received during the process.

Image 9: Dialogue Measurement User Window, User Windows Preferences

Measurement values and statistics can be reset by the user if necessary. In
addition, automatic reception of images and data during program start can be
enabled or disabled by means of a check mark.
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Save measurement
values

If the Save Data option is enabled, measurement values that were received are
stored in a text file with the name Log File or with a user-defined name, as the
case may be. If no path is given, the storage location for the data relates to the
installation folder. Measurement values are stored line for line in the text file.

Each line contains the following information:

• Date & time: (coded in time_t: seconds since 1.1.1970)
• Block ID
• Overall result (0: good, 1: bad)
• List of measurement values

Saved measurement values can be loaded back to the user window via
Settings > Load Measurement Values. To allow the data to be interpreted
correctly it is essential that the test program that was last loaded is identical with
the test program used for saving the values.

The current statistics are deleted with the Reset good/bad statistics button.

Saving images Images are saved in the path supplied under Settings > Image Files. A file
prefix defines the first part of the file name. The rest of the file name is made up
from the date and time. The following options can be selected for the image file:

• Displays of the images
• Save image
• Circular buffer (maximum 10,000 images)

Display images In order to display images with the user window, the Send Image command
must be used in the test program (see "Send Image", Page 320). The user
window detects the settings for this command when loading the test program
and displays the image after it is received. The Settings > Display option in the
Settings > Image Files dialog must be enabled in order to display the images.

Display results Results can be displayed in the user window by using the Evaluate
Result command in the test program with the send option enabled (Send
Measurement Values) and by configuring the interface accordingly.
When transferring via the serial interface (/com) the setting must be made
according to that of the image processing system in Programming Window >
Communication > Interface.
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Image 10: Dialogue Evaluate Results

For communication via Ethernet, the image processing system must be set as
the TCP server on port 8500. This is done via the /ethernet selection, in the
field for the measurement window data. The settings for Port and IP remain
empty. The overall result from Evaluate Result will also be sent to the user
window. The overall result is used to produce the displayed statistics. The
block ID must be between 0xD0 and 0xDF for the display in the user window.
The names of the parameters (e.g. Test, Test2 and Test3) as well as target
values and tolerances are interpreted by the user window. The names of the
parameters are displayed as headings. The target values and tolerances are
used for the graphic representation.

5.8 Customize interface

You can modify and customize the presentation of the programming window. In
order to do so, use the docking windows and toolbars.

5.8.1 Customize Docking Windows

The windows within the user interface can be freely positioned, grouped with
other windows in indexes, and be shown or hidden as requested by the user.
These are special docking windows which can be docked on other elements in
the interface (e.g. other windows or the borders of the programming window).
When docked, they are anchored at this position but can be relocated to any
other position at any moment.

This works with the help of control elements which are displayed when you start
to relocate a docking window (see "Image X: Steuerelemente"). When you place
the window above a control element, a transparent blue background shows you
where the window will be positioned. You then just have to release the mouse to
finally relocate the window to the desired position.
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Image 11: Control elements

To group several windows into a tab window, you have to place the windows
directly on the central control element of the other window so that the target
window gets the transparent blue background before you drop the current
window (see "Image X: Fenster gruppieren"). The respective tab indexes will
be generated automatically, with which you can display the grouped windows.
There can only be one active window at a time.

Image 12: Group two windows

You can also place docking windows freely floating above the actual user
interface. Therefore you simply have to move the respective window over a
free space on the interface and not over a control element. The window will
then be detached from the programming window and placed accordingly. To
show or hide windows, you can use the options under View > Toolbars and
Docking Windows. Here you can choose which windows and toolbars are to
be displayed and which sould be hidden. Additionally, you can hide a window
temporarily by moving it automatically into the background. To do this, click on
the little pin icon in the top right of the window's title (see "Image X: Fenster
verstecken"). The window will then be moved in to the Customize interface 2
background and be replaced with a tab index at the border of the programming
window (see "Image X: Verstecktes Fenster"). When you move the mouse
cursor over the tab index, the window will be shown as long as you don't move
the mouse out of the window. In order to display the window permanently again,
you have to click on the pin icon once again. This function is particulary useful
for netbooks or laptops with low resolutions.

Image 13: Hide a window temporarily

Image 14: Tab index of a temporarily hidden window

5.8.2 Customize Toolbars

With the menu View > Toolbars > Custzomize, the user can make further
adjustments to the user interface. More information is shown below.
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This dialog is divided into five tab indexes. The first two, Commands and
Toolbars, allow the user to customize the toolbars and menus, the index
Keyboard enables the assignment of hotkeys to single commands, with Menu
you can reset the user interface to defalut, and Options offers settings for the
display of quick info texts.

Customize Toolbars
and Menus

While the Customize menu is open, you can change the postion, arrangement
or alignment of almost any interface item (including icons, lists, menu points and
entries) via drag and drop. Therefore the index Commands lists all commands
and options that are executable within the vcwin pro-interface in separate
categories. For example, if you want to move a command that is by default only
available in a menu into a toolbar, you simply pick it from the list and put it into
the desired toolbar with drag and drop. You can also pick the command directly
from the interface.

In the tab index Toolbars, you can delete, rename, reset, or create toolbars.
When you create a new one, you can fill it with commands from the Command
tab.

Create toolbar You create a new toolbar as follows

1. Go to the Toolbars tab and click on the New button.

2. Type in a name for the new toolbar and confirm it with OK.

An empty toolbar gets created on the middle of the screen.

3. Go to the Commands tab, choose a category and pick a command.

4. Click on the command and move it with the button pressed to the new
toolbar.

5. Alternatively you can add commands directly from the interface with drag
and drop. Choose a menu entry or icon and move it into the new toolbar.

6. Repeat steps 3 and 4 resp. 5 to add more commands. When finished, you
can dock the new toolbar to the others by moving it next to them.

Edit toolbar You edit a toolbar as follows

• Add commands: See above, steps 3, 4 and 5.
• Delete commands: Right-click on the item and select the context menu

entry Delete. Alternatively you can move the item into a disabled area in the
interface (marked by the x at the bottom of the mouse cursor) via drag and
drop.
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• Change an items appearance: Right-click on the item and select the
context menu entry Button Appearance. Now you can modify the icon
graphic, edit the displayed text and adjust further options.

• Reset toolbars: Go to the Toolbars tab in the Customize menu, mark the
toolbar in the list and click on the Reset button. To reset all toolbars, click on
the Reset All button.

• Rename toolbars: Go to the Toolbars tab in the Customize menu, mark the
toolbar in the list and click on the Rename button.

• Delete toolbars: Go to the Toolbars tab in the Customize menu, mark the
toolbar in the list and click on the Delete button.

Customize hotkeys 1. Go to the Keyboard tab.

2. Select a command category.

3. Mark the command that you want to assign a hotkey.

The current hotkey is shown under "Current Keys".

4. Type in your own hotkey into the "Press New Shortcut Key" text area. If the
new hotkey is already token, type in a different one.

5. Click on the Assign button.
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6 PART 1 - MENU REFERENCE

6.1 The File Menu

The File menu contains commands that relate to complete test programs
(program files). 

Lines separate groups of commands that belong together.

• The first group relates to opening, closing and saving test programs.
• The second group relates to project file manipulation.
• The third group relates to user information, printing and page set up.
• The fourth group shows the recently opened files.
• The last command exits the program.

6.1.1 New

File > New is used for creating a new empty test program. 

Any test program currently open will be closed automatically. If data has not
been saved after being edited, you will be given the chance to save.

6.1.2 Open

Use File > Open to open an existing test program. The program to be opened
can be either selected from the selection box (path: to the right, file name: to the
left in the menu) or typed into the File Name field. 

Files with the *.vc and *.* extensions can be loaded.

Only a single test program can be open at any one time.

Open the selected program with the [Open] button.

If you have already opened a test program which has not been saved since the
last time you edited it, you will be given the chance to save it.

Options during
Opening

Preview: After the program name is selected, further information will appear by
using the preview option of your Explorer.

• Name of the user
• Creation date
• Date of the most recent edit
• Comments

You can find the Explorer preview under Windows Vista via Organize > Layout

> Preview Pane and under Windows 7 via this icon  in the upper right of
the dialog.

The according information is written during editing into the test program via File
> Info and is saved together with the program itself by calling File > Save. >>
"Info", Page 55

After Opening After opening a new test program, you can insert, modify or delete commands
with the Editor.
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6.1.3 Save

File > Save is used for saving the current test program and all program-specific
settings to disk. While you are creating/editing test programs, any changes you
make will only change the data in memory. 

The Save command stores the edited test program, file information and all
relevant settings to harddisk, overwriting the original. The test program remains
open.

ADVICE
Newly created and edited test programs occupy volatile memory in the
computer. This means that the data will be lost if the computer is switched
off. To ensure that the edited test programs will be available the next time
you start the system, you should always remember to call File > Save before
switching off.

6.1.4 Save As

You can save a copy of the open test program under a different name on disk/
harddisk with File > Save as. The original program is kept with the original
name. 

A window prompts for the program copy's name.

ADVICE
Any changes which have not been saved will not be sent back to the original
program but to the copy instead.

6.1.5 New Project

Open a new empty project with File > New Project. 

If the project tree is not shown, it can be displayed via the corresponding icon in
the toolbar "Dock Panel".

Image 15: Show/hide the project tree

Every project has its own image and program files. Please note that you should
first save a new project before you can save the relevant data to the hard disk.
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In order to add image or program files, please use the object menu.

Programs can be opened from the Project Window by double-clicking the left
mouse button. Images can be loaded directly to a image memory page with
double-clicking the left mouse button

6.1.6 Open Project

You open an already saved project with File > Open Project. 

6.1.7 Insert

With File > Insert, you can add an image file or program file to the current
project. 

1. Select File > Insert, followed either by an image file or a program file and
then the required files in Open dialog box. 
The files added are displayed in the Project Window.

Use the Project Window icons or context menu as alternative to add image files
or program files to your project, see "Docking Window Control Area", Page 39.

Image 16: Project Window context menu

6.1.8 Save Project

You save a new project or the changes to an edited project with File > Save
Project. 

6.1.9 Save Project as

With File > Save Project as you save an existing project or the changes in an
edited project under a new name in any directory.

6.1.10 Close Project

Close the current project with File > Close Project. 
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6.1.11 Info

The File > Info command is used for adding further information about the
program: 

• Name of the user
• Creation date (display only)
• Date of the most recent edit (updated)
• From: Name of the editor (updated), if the user logged in via Options > User

Login.
• Comment
• Table with maximum 16 fields for additional information

All this information is saved together with the test program whenever the Save
or Save As commands are called.

6.1.12 Print

The File > Print command opens the operating systems standard print dialog
box so that the current test program list can be printed. For more information
about printing documents please refer to your operating system manual and the
printer manual.
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6.1.13 Print Preview

The File > Print Preview command opens a preview for printing the current test
program lists. 

Use this dialog box to check the layout prior to printing. Click the [Print] button at
the top left in the dialog box to start the print procedure.

6.1.14 Page Setup

The File > Page Setup menu item lets you define the margins of a page before
it is printed. Activating the checkbox causes page numbers to be printed on
each page.

These parameters are saved in a initialization file.

When you set up a new test program, vcwin pro sets up the standard defined
page margins automatically. These can be customized to your particular
requirements at any time however.

6.1.15 Print Setup

This menu item opens the printer setup menu of the operating system.
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6.1.16 Exit

Using this menu item, close vcwin pro. 

When you select the Exit command, without having previously saved any
changes made, vcwin pro asks you whether you wish to save the changes.

Select [Yes], if you want to save the changes, or [No], to exit the test program
without saving the changes.

6.2 The Edit Menu

The Edit menu contains functions used for manipulating an open test program.
In general, you previously use the File menu for opening an existing test
program or initiating an empty file for a new program. 

6.2.1 Bookmark

One way of finding particular points in a program is to make use of bookmarks.
They are very helpful in longer programs to find important sections. The
bookmark text is inserted in the command line. One bookmark number can be
used several times.

Parameters Description / key combination

Clear Deletes the selected bookmark.

Go to Book-
mark

Press keys <ALT> and 0…9 at the same time.

Set Bookmark
to Current
Position

Press keys <CTRL> and 0…9 at the same time.

6.2.2 Edit

In order to open the corresponding teach-in dialog box, in which all associated
parameters can be edited, use Edit > Edit. Alternatively, you can open the
teach-in dialog box as follows: 

1. Select the program line.

2. Double click on the line or press the Enter key.
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6.2.3 Command Selection

With Edit > Command Selection, the programmer can decide whether the
current command may also be changed by the foreman. This is recommended
e.g. for commands relating to setting tolerances. 

Under Name, enter a relevant name.

The commands that can be changed by the foreman are indicated in the
program window by an [M].
No. Label Command
***** Last Change at vcwin pro 2.17.136
00001 Start
00002 ForemanCommand Determine Line 25(M):

Determine Line 25 (World Coordinates];
30 Single Detections to 53 Pixels; Search
Arrow: [69,102/196, 192]; Max. Gradient [5];
Light > Dark

If later, a user logs on with Foreman rights, he is then shown only the
commands in the program that he has a right to change.
No. Start Command
***** >>> Edit Selected Commands <<<
00002 ForemanCommand Determine Line 25

The foreman changes commands as follows:

1. Double-click on a command.

2. Change the parameter in the dialog box.

3. Save the program.

6.2.4 Highlight with Color

Overview The function Highlight with Color is located in the Edit menu.

Image 17: Dialog: Highlight with Color

With Highlight with Color you can highlight commands in the Command
Window with color. The formatting is stored in the program.
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Highlight commands
with color

1. Mark the commands in the Command Window.

2. Open the dialog via the Edit menu > Highlight with Color.

3. Select the background color. The "Highlight Command Background with the
following Color" option is automatically enabled.

a) Choose from 20 predefined colors or
b) Click on the button [Other...].

Choose a color from the Windows system dialog. Close the dialog with
[OK].

4. Close the dialog with [OK].

The marked commands are highlighted with the selected color.

Remove colored
marking

1. Mark the commands in the Command Window.

2. Open the dialog via the Edit menu > Highlight with Color.

3. Activate the option "No color highlighting of command background".

4. Close the dialog with [OK].

The background color of the commands will be unmarked.

TIP
You can turn off the colored markings of the program temporarily.

Deactivate the option "Display Highlight Colors" in the Options
menu. This setting is a function of vcwin pro and is not stored in
the program.

6.2.5 Group Commands

Overview The function Group Commands is located in the Edit menu.

With Group Commands you can group any number of consecutive commands
into a group. The formatting is stored in the program.

Elements of a Group

1
2

3

4

5

1  and <>Groupname indicate a collapsed Group. Click  to expand the
group.

2  and >>Groupname indicate the start of an expanded group. Members of a
group are indicated by a solid line. Click  to collapse the group.

3  indicates a collapsed subgroup.
4  indicates an expanded subgroup.
5  and <<Groupname indicates the end of an expanded group.
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Working with groups

• Each group is defined by the beginning and the end of the group. In the
expanded state, the group name is at the beginning of the group and at the
end of the group. Group names can be assigned more than once.

• When selecting collapsed groups, all commands in the groups are
automatically selected. In this case, the function will apply to all commands
of the group (e.g. delete, search).

• When selecting the start group name or end group name of an expanded
group, functions like delete, cut, copy, or "Save Block in File" cause that the
other related group name is deleted, cut, copied or stored too. The content of
the group is not affected by the functions.

• Multiple groups can be combined to a new group.
• In a group sub-groups can be created.
• New groups must include complete existing groups.

Create a group

3

1

2

1. Mark in the command window the commands that should be grouped.

Open the dialog via Edit menu Group Commands.

2. In the dialog, enter the name of the command group.

3. Close the dialog with [OK].

The selected commands are grouped together.

Ungroup a group 1. Expand the group to be ungrouped. When deleting a collapsed group the
commands in the group will be deleted.

2. Select the group name and press the [Delete] key on your keyboard.

6.2.6 Find

With Edit > Find, you open a dialog box, then type the character string you
want to search for. 

Searching starts at the current line and will stop when the character string is
found or the end of the program is reached.
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6.2.7 Find More

With Edit > Find More you continue a search procedure. 

6.2.8 Find Label

The search for a label includes the entire test program.

1. Enter the full name of the label in the Go to Label field.

2. Confirm. The entered label is selected.

Searching starts at the first or last line and runs until the specified label or the
end or start of the program is reached..

6.2.9 Go to Command

The search for a command number includes the entire test program.

1. Enter the command number you want search for in the input field.

2. Confirm. 
The entered command is selected.

Searching starts at the first line and runs until the specified command or the end
of the program is reached.

6.2.10 Cut

You can copy sections of open test programs into the Windows clipboard using
Edit > Cut. This removes the cut section from the test program. The cut section
can then be re-inserted into the open test program in the position required via
Edit > Paste.

6.2.11 Copy

You can copy sections of open test programs into the Windows clipboard using
Edit > Copy. The copied section can then be inserted into the position required
in the open test program via Edit > Paste.

6.2.12 Paste

You can insert sections of test programs from the clipboard into the position
required in the open test program with Edit > Paste.



vcwin pro 2.21
Part 1 - Menu Reference

62 999.994.306.10-en-1.15 © Vision & Control GmbH 2015

6.2.13 Delete

Remove sections of a test program using Edit > Delete. 

6.2.14 Undo Command

With Edit > Undo Command you can remove the last commands that were
inserted into the program or reinsert the previously deleted commands. 

6.2.15 Save Block in File

Commands in an open test program can be saved as a block of commands
under a new program name. In order to do this, all the commands required to
be saved should be marked. The original program is not changed in any way. 

6.2.16 Insert File

Edit > Insert File is used for inserting a program block or a complete test
program into the program currently being edited. Select the file in the shown
dialog box.

Option Preview: If you use the Preview function of the Windows dialogue, the following
additional information appears:

• Name of the user
• Creation date
• Date of the most recent edit
• Comment

You can insert this additional information with File > Info into the test program
and then save it with File > Save-Info.

6.2.17 Activate / Deactivate

Deactivate and activate the commands currently highlighted in the test program
for test purposes using Edit > Activate / Deactivate respectively. Deactivated
commands are ignored by subsequent program testing. 
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6.2.18 Insert Comment

Image 18: Dialogue Comment

Enable the documentation of commands using Edit > Insert Comment.
Comments are shown as separate lines. In the dialog, you can write multi-line
comments with up to 1000 characters per line, which will then be inserted in
each case as a single line in the command display. The colour of a command is
green (standard). The color of the commentary text can be altered via Options
> Application Settings.

6.2.19 Names for Geometry Variables

You can assign identifiers (names) to the geometry variables (results, points,
etc.) with Edit > Names for Geometry Variables. Use this function in order to
make your test program more readable. 

You can also set the names for geometry variables during actual test command
parameterization.

There is a specific namespace for each type of variable (results, points, etc.).
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Define names via
Menu <Edit>

1. Select Edit > Names for Geometry Variables.

2. Select the Type of Variables from the drop-down menu.

3. Click on the geometry variable that you want to name on the Names column,
next to the geometry variable numbers.

4. Enter the name.

Define Names in
Dialog

1. Enter a new name into the geometry variable output field in the dialog, then
click in an other output field.
A window for defining a new variable name appears. You see names that are
already in use and you can define a new name here.

2. In this dialog, enter the name of the variable in the textbox Name.

3. Choose among the number of the geometry variable that you want to
rename.

Define names in
dialog
Multiple definition

Some commands allow, to determine and save several variables of one
parameter in one step. For examble Rotation based on Moments > Multiple
Objects.

The variables get their name automatically by the entered name and an index
that is attached.
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Parameters Description

Quantity Number of indexing. The Quantity is the sum of the nominal
value and the highest positive tolerance.

Prefix of
Name

Prefix of the name. It is taken from the declaration section
(here: Center of Gravity). But it can be adjusted.

Start With
Number

From this position in the variable list, the results (Prefix of
name and index) are stored.
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6.3 The View Menu

The View menu allows items in the user interface to be shown or hidden.

6.3.1 User Window

With View > User Window you switch to the respective selected user window.
For more information, please see see "User Window", Page 43.
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6.3.2 Docking Windows

In the menu View you can find a full listing of all docking windows.

For more detailed information, please see see "Docking Windows", Page 34.

Docking windows can be either docked or floating. Docking a docking window
attaches it to the user interface. Undocking detaches the docking window from
the user interface, so it can be moved around. To save space you can hide
docking windows. For more information see "Customize Docking Windows",
Page 48.

Docking windows can appear side by side or nested. Using nested docking
windows, only one docking window is displayed. To display the docking window
behind, click on the docking window's tab.
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Image 19: Docking window side by side

Image 20: Docking window nested

6.3.3 Toolbars

In this menu you can show or hide items in the user interface. To show or hide
one of those items, just click on the respective entry in the menu.

With the menu option Custzomize, the user can make further adjustments to the
user interface. For more information see see "Customize Toolbars", Page 49.

6.3.4 Status bar 

Under the Status Bar entry, you can display or hide the status bar at the bottom
edge of the user interface.

6.4 The Utilities Menu

The Utilities menu contains helpful functions for checking and setting of test
programs. 

6.4.1 Start/Continue Debugging

Start/continue the online debugging. (see "Online Debugging ", Page 124).

6.4.2 Stop Debugging

Stop the online debugging (see "Online Debugging ", Page 124).
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6.4.3 Test Command

ADVICE
Use the time protocol in the status bar to estimate the duration of commands
and to locate perpetual commands.

Test the first selected command using Utilities > Test Command. The result of
this test is displayed in the status bar. 

6.4.4 Test Step

Test a program step-by-step using Utilities > Test Step:

1. Highlight the command with which you want start the test.

2. Call Utilities > Test Step or press the F7 key. The command line is tested.
The result appears to the left in the status bar and the command marking
steps to the next command line.

3. Repeat step 2 as often as required.

The function includes the command call as well as displaying the results of the
commands in command mode.

6.4.5 Test Section

You test a marked section of the test program with Utilities > Test Section. 

The section is run repeatedly until it is actively stopped. The result of the test is
displayed in the status bar.

The function includes the command call as well as displaying the results of the
commands in command mode. Program control commands are not interpreted
by the host computer, i. e., branches are not implemented in testing.

Use the from Current Command function to test the section from a breakpoint
to the end of the section.

6.4.6 Test Program

The entire program can be tested via Utilities > Test Program. The result of
this test is displayed in the status bar. On reaching a breakpoint, the breakpoint
is noted and the program halts. 

Use the from Current Command function to test the section from the
command line marked until either another breakpoint is reached or to the end of
the program.
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6.4.7 Breakpoint

A command can be marked with a breakpoint using Utilities > Breakpoint. It is
possible to use multiple breakpoints within a program. 

If the program is tested using the commands Utilities > Test Program or
Utilities > Test Section, the program halts at the first breakpoint encountered.
The breakpoint is additionally displayed in the program in color.

To cancel a breakpoint, clear the marking in the command entry.

Breakpoints are not recognized in run mode.

6.4.8 Image Report

Image Report allows you to display the gray values of each pixel in a defined
area. 

You can define the image window by entering the position numerically or directly
with the mouse.

To enter the position with the mouse on the video screen and to switch
between the PC monitor and the video screen, double click with the right-
hand mouse button. The grey values of your position are determined and
displayed immediately. For better visualization the values are underlayed with
the corresponding gray value of each pixel.

Parameters Description

Copy to clip-
board

This is to copy the report files to the clipboard. Then the data
can be pasted directly into Microsoft® Excel, for example.
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6.4.9 Receive Image from Vision System

Save the contents of the Vision System’s image memory in a JPG or BMP file
using Utilities > Receive Image from Vision System..

The JPG quality is set to 75% by default. You can adjust the level of
compression in the section Application Settings >>Advanced<<, see
"Application Settings", Page 103.

Under Files of Type, you can choose whether you want to save the picture with
or without the overlay graphic.

6.4.10 Send Image to Vision System

Load a JPG or BMP file into the Vision System’s image memory using Utilities
> Send Image to Vision System. 
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6.4.11 Reset Geometry Variables

Set all the geometry variables which have previously been determined by
the program execution or testing to undefined in the vision systems memory
using Utilities > Reset Geometry Variables. The geometry list display is then
deleted. 

The geometry variables should be reset before compiling new programs
because the next free element is always used in the programming. Storage
locations occupied by old geometry variables are jumped over when
programming and are lost to the current program.

6.4.12 Calibrate Camera

ADVICE
Calibrate the vision system if you use it for measuring.

ADVICE
Re-calibration

You should re-calibrate the camera in the following cases:

• in case of mechanical, optical or electrical changes in the test set
• after changing camera
• changing the unit of measuring
• after maintenance and repair work

A re-calibration is recommended at regular intervals for preventive
maintenance.

Image 21: Dialogue Calibrate Cameras
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With Utilities> Calibrate Camera you can calibrate vision systems or the
cameras of the vicosys interactively without a test program. Absolute calibration
is used for determining the calibration factors.

The calibration factor – the scale between image and world coordinates – is
determined through a calibration command. Calibration is always active for the
currently selected vision system or camera.

Brief Guide Setting Scene

1. Select the camera that is to be calibrated.

2. Activate the checkbox Live Image. The Image is displayed on the control
monitor or in the monitor window.

3. Position calibration phantom in the center of the image. Ideally it should
cover 2/3 of the image field.

4. Enhance image sharpness and lighting.

Grab Image

5. Deactivate the checkbox Live Image.

6. Push the button [Grab Image].

Perform calibration

7. Teach-in the calibration window

° To switch to editing in the video image, double click on the right mouse
button.

° Set the size and position of the window, see "Teaching in Detection
Windows and Test Windows", Page 110.

8. Specify calibration phantom

° Chose the calibration object (from light to dark/ from dark to light).
° Chose the calibration shape of the calibration phantom (rectangle or

circle).
° Enter the exact (already known) dimensions of the calibration phantom.

9. Detection Algorithm

° Gray Value with Subpixel
° Gradient

10.Specify calibration direction

° Choose whether to calibrate in the x- or y- direction, or in both directions.

11.Start Calibration



vcwin pro 2.21
Part 1 - Menu Reference

74 999.994.306.10-en-1.15 © Vision & Control GmbH 2015

° Click the [Calibrate] button.
° Make a visual check on the control monitor or in the monitor window that

the calibration phantom is detected precisely.

Image 22: Calibration with rectangle object (left side) and circle object (right side)
° Perform the calibration for all cameras.

Finish Calibration

12.To save the calibration data permanently on the vision system click the
button [Save Settings].

Input Parameters Grab
Image

Grab the image with which the calibration is to be made using the [Grab Image]
button.

Parameter Description

Camera Number of the vision system's camera to be calibrated.

Live Image Option for displaying the live image.

Input Parameters
Calibration Object

Parameter Description

Dark/Light States whether the calibration body is brighter or darker than
the surroundings.
Dark: edge transition for calibrating from light to dark
Light: edge transition for calibrating from dark to light

Rectangle/
Circle

States the shape of the calibration phantom.

Width/Height Reference dimensions in µm of a rectangular calibration
phantom.

Diameter Reference dimension in µm of a round calibration phantom.

Input Parameters
Detection Algorithm

Parameter Description

Grey Value
with Subpixel

A particularly precise algorithm that should be applied at
nearly ideal specimens and test pieces.
Parameter: Threshold, Width, Noise Filter, Diffusion

Gradient A very stable and robust method that can be used in non-
optimum conditions.
Parameter: Threshold, Width, Noise Filter, Diffusion
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Input Parameters
Calibrate

Parameter Description

X Direction Only calibrate in the horizontal direction.

Y Direction Only calibrate in the vertical direction.

Both direc-
tions

Calibration in the horizontal and vertical directions.

Calibrate With the button [Calibrate] the procedure is started and deter-
mines the calibration factors.

ADVICE
Because of aberrations, it is always advisable to select both directions for
calibration.

Export Calibration
Data

With the button [Save on PC] you save the calibration data of all cameras to a
PC.

Image 23: Message: calibration data stored

The calibration data are stored in a file with the extension *.vcc. The calibration
data are correlated based on the data of the manufacturer, model name and
serial number.

Import Calibration
Data

With the button [Load to Vision System] you upload all stored calibration data on
the initialised vision system.

Image 24: Message: calibration data loaded
Image 25: Message: calibration data loaded/
not loaded

Save Settings With the button [Save Settings] you save all the calibration data permanently
on your vision system. Equivalently, you can choose Save Settings in the
Communication menu.

ADVICE
The function Save Settings stores in addition to the calibration data also the
demo mode and video mode.
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6.4.13 Display Calibration Data

Overview The dialog Display Calibration Data is located in the Utilities menu.

Image 26: Dialog Display Calibration Data

The dialog reads the current calibration data of the vision system and displays
them for each camera.

6.4.14 White Balance

ADVICE
The white balance is a compensation method for true colour reproduction. It
should be done absolutely by color cameras before use.

Use Utilities > White Balance to carry out the white balancing process. In this
case, an adjustment of the gain of individual RGB colour channels is performed.
A correctly calibrated colour camera yields identical values for R, G, and B
when viewing a grey surface.

Perform White
Balance

1. Select the camera from the drop-down list.

2. Direct the camera onto a white surface.

3. Adjust the current brightness of the image with the lens iris of the camera
between 120 and 180.
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4. Click on the button [White Balance] when in the lower part of the dialog No
Errors is displayed.

5. The white balance will be carried out. If the message White Balance OK
appears in the lower part of the dialog, the white balance is completed.

6. The white balance data are saved immediately.

Parameter White
Balance

Parameter Description

DX:/DY: Specifies the size of the test area. The test area is always
centred in the image. The area is default at devices of the type
pictor T and vicosys. When using devices of the type pictor M,
you can change the size of the area.

Camera: Number of the camera that is provided for white balance.

Current
Brightness:

Indicating the current brightness of the image. For white
balance, the brightness is ideally in the range of 120 to 180.

White Balance With the button [white balance] the process is started and the
factors are determined.

Export White Balance
Data

ADVICE
The export of white balance data is available from firmware version 4.16.239
and the devices pictor T and vicosys.

With the button [Save on PC] you save the white balance data of all cameras to
your PC.

Image 27: Message: white balance data stored

The white balance data are stored in a file with the extension *.vcw. The white
balance data are allocated based on the data of the manufacturer, model name
and serial number.

Import White Balance
Data

ADVICE
The import of white balance data is available from firmware version 4.16.239
and the devices pictor T and vicosys.

With the button [Load to Vision System] you upload all stored white balance
data on the initialised vision system.
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Image 28: Message: white balance data loaded

The white balance data will be associate to the vision system or the cameras of
the vision system based on the data by manufacturer, model name and serial
number.

6.4.15 Shading Correction

ADVICE
This command is specifically for line pictor M41EL.

Shading correction is a tool with which you can correct systematic brightness
errors in the test image. These errors can occur due to vignetting or
inhomogeneous lighting. Shading correction uses two differently lit images
to determine the greyscale value differences which occur as a result of these
brightness errors and writes them to a shading matrix. This matrix is then
applied to all images captured with the vision system and offsets the brightness
information against the correction values to ensure homogeneously illuminated
test images.

ADVICE
Shading correction should be carried out immediately after installing the
camera and lighting equipment.

Quick-start guide 1. Connect to the vision system.

2. Switch the video mode to Live Image in the Video Control Panel.

3. Open the monitor window and switch to full screen to best evaluate
the displayed image. Check to ensure that the image is sufficiently
homogeneously illuminated.

4. Click Exit to exit the live image. The video mode is automatically switched to
Memory Image.
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5. Open the command Utilities > Shading Correction.

6. Set the shutter for the two image sides using the controller on the left-
hand side. As specified in the dialog, ensure that the resulting greyscale
values are both between 20 and 240 and that the greyscale value difference
between side 1 and side 2 is at least 80.

As soon as you change the shutter setting, an image is captured
automatically and the average greyscale value displayed.

7. Once you have set the appropriate shutter values, click the button
[Calculate].

8. Then click the button [Exit] to save the settings.

The calculated shading matrix is saved in the FLASH of the device and
then applied for correction with each image capture.

6.4.16 I/O Test

Use Utilities > I/O Test to test the digital inputs and outputs e.g. when
connecting to a PLC. You can assign defined signal levels or impulses to the
outputs for this purpose. All input lines are scanned repeatedly. 

You can do the following tests:

• Test the state of an input.
• Switch output signals manually.
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Input Parameters Parameters Description

Hardware
Type

Select the hardware type for the I/O port. The options shown
depends on hardware you use. Choose between PS8 (4 digital
input and 4 digital output), DIO4/6 (4 digital input and 6 digital
output), DIO4 (4 digital input and 4 digital output), DIO8 (8
digital input and 8 digital output) or DIO16 (16 digital input and
16 digital output).

Inputs/
Outputs

Display of inputs and outputs and their states.

Change
of Name
Allowed

If activated the user may determine own names for the inputs
and outputs. To do so, click on the input or output you want
ro rename and click again shortly after. Now type in the new
name and confirm it with [ENTER]. The new name will then be
saved.

I/O Testing Method The method of testing outputs is practically the same for all types of hardware.

The available inputs and outputs are each displayed in a window.

All inputs are scanned repeatedly and the status is displayed. You can set
outputs by using the dialog box

6.5 The Communication Menu

Set the interface and organize communication between host computer and the
vision system using the Communication menu. 
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6.5.1 Connect

ADVICE
The vision system must be connect before test programs are taught or read
into the vision system. 

Use Communication > Connect to connect the host computer interface with
the vision system.

The connection to the vision system is activated, run mode is halted and the
available system resources are queried.

vcwin pro recognizes the available geometrical elements, results, contour
buffers, counters, cameras, image memory pages, the I/O hardware of the
connected vision system during connection.

After connection, the system is in command mode. 
The following information appears in the status bar:

• video mode (memory image, live image)
• image memory page
• camera number.

Configure the interface using Communication > Interface.

Interface not available! May be used by another application.

If, with a serial connection, the message »Interface not available! May be used
by another application.« appears:

• Check that the serial cable to the PC, configured in Communication >
Interface, is inserted and that a connection to the vision system exists.

• Check under System Control > Management > Computer Management >
Device Manager, whether the serial interface is actually able to function.

• Check in the Windows Task Manager whether vcwin pro is also in use by
others or whether other programs could be blocking the serial interface.
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6.5.2 Disconnect

Stop the communication between host computer and system using
Communication > Disconnect. This command executes the test program
repeatedly until it is reinitialized with Communication > Connect. 

If the test program is not configured to send back measuring results to the host
system in run mode, the RS-232 cable or the Ethernet cable between the host
computer and the vision system can be disconnected as the vision system
processes all data automatically.

You recognize run mode by the "Not connected" text in the status bar.

Editing a Test Program

In order to change a test program that is running cyclically in a loop, initialize
communication with the vision system, modify the program and then load the
modified program back into the vision system via Communication > Transfer.

Test Program Settings Without a vision system

You cannot edit and test interactive commands which require communication
with the vision system during teach-in (e.g. all the Locate commands). To edit
commands interactively, you switch from run mode to command mode using
Communication > Connect.

6.5.3 Transfer

ADVICE
Communication > Transfer is only possible if the program contains
commands.

Image 29: Dialog Transfer:
password protected
system

Image 30: Dialog Transfer:
non password protected
system

Image 31: Dialog Transfer:
not downloadable system

If communication is taking place (command mode), send the test program
loaded in the editor from the PC to a vision system using Communication >
Transfer. The test program can be loaded either into the volatile memory or as
a file to the vision system's non-volatile memory flash.
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Input Parameters Parameter Description

File Name The name under which the file should be saved in the vision
system. A maximum of 8 characters are allowed with pictor M.

in RAM The test program is loaded into the volantile memory of the
vision system. With this option, you are asked whether this
program should be started. The connection to the vision
system is terminated when confirmed.

as File The test program is loaded as a file in the flash of the vision
system and simultaneously set as the initial program. You can
execute the test program loaded with as File with Communi-
cation > Disconnect.

Set Pass-
word

With this option you can protect the vision system with a pass-
word to prevent the download of your test program. This func-
tion is active only in vision systems that can be protected by a
password or do not have a password protection yet.

Image 32: Dialog Transfer: in RAM mode Image 33: Dialog Transfer: as File mode

ADVICE
For devices of the type pictor MxxE

After the program is succesfully loaded the query "Save File System to Flash"
appears.

Confirm the query with [Yes] for perma-
nent storage.
By using [No] the program is deleted
in case of power interruption of the
device.
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6.5.4 System Resources / Initial Program

Overview The Function System Resources / Initial Program is located in the
Communication menu.

Image 34: Dialog System Resources / Initial Program

The dialog lists the files stored in the vision system, such as Test Programs,
Geometry Sets, Pattern, Images, Process Data and Modules.

Usage

• Upload files to the vision system.
• Load files from the vision system to a PC.
• Deleting files from the vision system.
• Set a test program as the initial program.
• List of image files on the external disk (see "External Storage Device",

Page 333).

Group Box Display Test Programs

Displays test programs saved on the vision system.
The Storing is performed with [Load to Vision System] or using
Communication > Transfer > Load as File (see "Transfer", Page 82).

Geometry Sets

Displays geometry sets saved on the vision system.
The Storing is performed with [Load to Vision System] or using Command
Selection > Control > Geometry Sets > Save (see "Geometry Sets",
Page 360).

Pattern

Displays patterns saved on the vision system.
The Storing is performed with [Load to Vision System] or using Command
Selection > Locate > Save Pattern (see "Save Pattern", Page 226).

Images

Displays images saved on the vision system.
The Storing is performed with [Load to Vision System] or using Command
Selection > Control > Save / Load Image (see "Save / Load Image",
Page 325).

Process Data

Displays process data saved on the vision system.
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The Storing is performed with Command Selection > Control > Save
Process Data (see "Save Process Data", Page 353).

Module

Displays modules saved on the vision system.
Modules are created using the vicosys SDK.

Initial Program With the button [Initial Program] you can set a selected program as initial
program.

This button is only active with Display: Test Programs.

1

3

2

Image 35: Dialog System Resources / Initial Program > Set Initial Program

1. Activate Test Programs.

2. Mark the desired program.

3. Click the [Initial Program] button.

° The current initial program is shown in bold.

ADVICE
The program listing can display a maximum of 1500 files in the system
resources dialog.



vcwin pro 2.21
Part 1 - Menu Reference

86 999.994.306.10-en-1.15 © Vision & Control GmbH 2015

Load in Image Page With the button [Load in Image Page] you can load a selected image in an
image page.

This button is only active with Display: Images.

1

3

2

Image 36: Dialog System Resources / Initial Program > Load in Image Page

1. Activate Images.

2. Mark the desired image.

3. Click the [Load in Image Page] button.

° The image is load in the image page. You can see it in the Monitor
Window.

Set Password Test Programs, Geometry Sets, Patterns and Modules can be secured with a
password to prevent unauthorized access.

When using the vcwin user management, only the "Programmer" is able to set
or change the password.

The password will be awarded globally on the respective vision system, with
which you are connected.

If the Current Password is grayed out, the vision system is not protected with a
password.

The password will be reset by entering the old and a blank password.

The password prompt only occurs once per active connection from the vcwin
pro to the vision system.
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1

2

3

Image 37: Dialog System Resources / Initial Program > Set Password

1. Click the [Set Password] button.

The dialog "Set Password" opens.

2. Enter a new password here. Retype the password in the next entry field.

3. Confirm with [OK].

Save on PC With [Save on PC] you can save Programs, Geometry Sets, Patterns, Images,
Process Data and Modules on a PC.

2

1

Image 38: Dialog System Resources / Initial Program > Save on PC

1. Mark the appropriate file (select multiple files by CTRL or SHIFT).

2. Click [Save on PC].

If the vision system is password protected, a dialog will appear for entering
the password (except for images and process data). Enter the password in
the dialog. Choose the directory in which the corresponding files are to be
saved.
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TIP
Saves Images

Using devices of the type pictor M and vicosys up to Version
4.16.239 the selected JPG files are saved as compressed JPG
's. The JPG quality is set to 75% by default. You can adjust
the level of compression in the section Application Settings
>>Advanced<<.

Load to Vision System With [Load to Vision System] you can save Programs, Geometry Sets, Patterns,
Images, Process Data and Modules on the vision system.

2

1

Image 39: Dialog System Resources / Initial Program > Load to Vision System

1. Activate under Display the appropriate file type.

2. Click [Load to Vision System].

Navigate to the folder where the file, that you want to load to the vision
system, is located. Select the appropriate file (select multiple files by
pressing CTRL or SHIFT) and click the [Open] button.

Notes on file names

To ensure that your files are loaded correctly, please note the following
guidelines for naming convention:

• Use only letters, numbers as well as the underscore, plus or minus.
• Do not use spaces.
• Do not use special characters such as !, §, $, %, &, #, /, or similar.
• Do not use umlauts like ä, ö, ü.
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6.5.5 Make Data Backup

With Communication > Make Data Backup you can perform a full or partial
backup of the data of your vision system.

The command includes the backup functions of the dialogs:

• Utilities > Calibrate Camera
• Utilities > White Balance
• Communication > System Resources / Initial Program

Brief Guide Open the dialog with Communication > Make Data Backup.

1

2

3

Image 40: Dialog: Make Data Backup (1)

1. Select here which data you want to backup.

2. Select here the backup folder.

Use the ICON [Browse For Folder] to select an existing folder or create a
new folder.

The backup is created exclusively in empty folders. It is not possible to
overwrite the folders content.

Confirm the folder selection with [OK].

3. Start the backup process with [OK].
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When the backup is started, in the selected empty folder new subfolders are
created and the data are stored there accordingly.

After completion of the process a window will appear with a summary of the
backup. Confirm with [OK] to complete the process.

Image 41: Dialog Make Data Backup (2)

6.5.6 Restore Data Backup

With Communication > Restore Data Backup you can perform a full or partial
restoring of the data of your vision system.

The command includes the import functions of the dialogs:

• Utilities > Calibrate Camera
• Utilities > White Balance
• Communication > System Resources / Initial Program
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Brief Guide Open the dialog with Communication > Restore Data Backup.

1

2

3

Image 42: Dialog: Restore Data Backup (1)

1. Select the folder containing the backup data.

Use the ICON [Browse For Folder] to select an existing folder or create a
new folder.

Confirm the folder selection with [OK].

2. Once you have selected the folder, the available data are displayed. Select
which data you want to restore.

3. Start the restore procedure with [OK].

At the start of the restoring, the data are transferred to your vision system and
stored there.

It is possible that files already exist on the vision system. In this case, you will
be asked if the files should be overwritten.

Image 43: Dialog: Restore Data Backup (2)
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After completion of the process a window will appear with a summary of the
restore process. Confirm with [OK] to complete the process.

Image 44: Dialog: Restore Data Backup (3)

6.5.7 Date and Time of Vision System

Use Communication > Date and Time of Vision System to configure the date
and the time of the Vision System. 

ADVICE
According to the model the Vision Systems also have a battery or a buffer-
capacitor. In case of power loss, the date and time are backed up for a certain
period (at least a few days, depending on device model). In case of a long
interruption of the power supply, date and time must be reset.

Set date and time 1 Set up the connection to the Vision System.
2 Choose the subject Date and Time of Vision System in

the Communication menu.

Image 45: The calendar and the field A show the current date and the current time of
the Vision System.

3 Select the desired day in the calendar and set the new time required in field
B. The new data are instantly transmitted to the Vision System.

4 Close the dialogue by clicking the [Close] button.
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Use date and time To evaluate the date and time of the Vision System in programs, use the
command Save System Time. see "Save System Time", Page 361

6.5.8 Save Settings

Save the current system modes (demo mode, video mode, shutter speed) and
the calibration factors to the flash using Communication > Save Settings. 

For vision systems of the type pictor MxxE data is not saved on the flash but in
the RAM disk. You should ultimately call Communication > Save File System
in FLASH to transfer the data in the flash to save them permanently.

6.5.9 Save File System in Flash

ADVICE
This function is only required for vision systems of the type pictor MxxE.

With Communikation > Save File System in Flash you save the contents of
the RAM disk to the nonvolatile memory / Flash of the vision system.

Image 46: Dialog: Save File System in Flash
(1)

Image 47: Dialog: Save File System in Flash
(2)

6.5.10 Licenses for Special Functions

This command allows you to enter and activate your licenses for the functions
"Edge Based Object Search" and "Advanced Data Matrix Read Function".

6.5.11 Interface

ADVICE
If you are not an experienced administrator, please request the instructions
for setting up image processing systems via LAN from the manufacturers
or attend a course at the Vision Academy. 
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Configure the communication interface between the host system and the vision
system using Communication > Interface:

• RS232 (serial V.24)
• Ethernet (TCP/IP)
• USB
• Simulator

The parameters set in this menu are later used with Communication >
Connect for setting-up the connection and must conform to the hardware
connection set-up.

If the vision system does not respond, this could be due to a faulty interface
configuration.

For Serial Connection
to the vision system

The baud rate of the serial interface is to set to 9600 after running the system.
(except for pictor M24 =115200.) You can alter baud rate after the connection
as required. (for example, if the program uses the command Send Image, to
115200.) Up to 16 serial interfaces can be supported.

For Connecting the
vision system to the
Ethernet

ADVICE
You can recognize active components that are connected to the Ethernet in
the address list by the following appended text after the vision systems name:
- in the Net. If a firewall is used, open UDP port 8500 on firewall. Otherwise
the firewall blocks Ethernet connection.
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To parameterize an Ethernet connection

1 Connect both the host and vision system to the Ethernet. Log on to the host
as Administrator.

2 For the host LAN connection, define an IP address from the sub-network of
the vision system to be connected. 
The IP address of the vision system can be obtained from the vision system
manufacturer. 
Example: For connecting a pictor M that still has the delivery settings (IP
address 192.168.0.65), select a spare address for the host from the range of
192.168.0.1 to 192.168.0.254.

3 Start vcwin pro.
4 Select the option TCP/IP in the Protocol Selection tab, then switch to the

TCP/IP tab.
5 Give a name for the connection.
6 Enter the current vision system IP address. 

In order to insert the type designation and serial numbers of vision systems
in the network into the address list automatically, click on the [Find] button. If
possible, fetch vcwin pro the IP address from the DHCP server.

7 Leave the Port nr. setting unchanged at 8500. (Only for administrators:
For remote maintenance, you can change the port in the registry via
HKEY_CURRENT_USER\Software\Vision&Control\vcwin\Communication
\Ethernet\Interface Adjust.)

In order to change the pictor IP address, use the Change Pictor IP Address
command.
>> "Change Vision System's IP-address", Page 98

USB Interface ADVICE
The USB interface is not available for the current vision products yet. The
implementation in vcwin pro is intended for future applications.
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Connection to a
simulator

Simulators let you execute almost all commands and functions without
connecting a vision system to the host computer. That allows you to test
commands and check parameters and variables without needing a connected
device. The simulator corresponds to a virtual vision system which imitates the
technical properties.

There is a variety of cameras available (AVT-models, pictors, and customs).
You can simulate up to 16 cameras with a simulator (matching the vicosys
camera system). You are able to define each camera individually when using
more than one camera for the simulator.

Other properties and features:

• Simulate different hardware types (PS8, DIO4/6, DIO4, DIO8, DIO16)
• Load single frames or image rows by image acquisition
• Supports command set of vicosys
• No RUN mode

To configure a simulator

1. Open the Communication Parameters dialog via Communication >
Interface.

2. Click on the Simulator tab (2).

3. Type in a name for the simulator (3).

4. Select the harware type (4).

° PS8 for pictor M
° DIO4/6 for pictor T-ECAN
° DIO4 for pictor T-SC
° DIO8 for vicosys 2xxx
° DIO16 for vicosys 4xxx

5. Click on the Edit button (5) to add cameras to the simulator:
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1. Select a camera model or use the "userdefined" option to create a camera
with individual properties (1).

If you selected a camera model, the resolution and type of the camera
are displayed.

2. If you selected "userdefined", enter the desired resolution here and select a
camera type.

3. Here you can select an image (3) which will be the default picture for the
image acquisition. In conjunction with the Save / Load image command
and the "Use running index for file name" option (see "Save / Load Image",
Page 325) you also can use already acquired images. Choose images or
image rows with the same resolution as the camera, if possible.

4. Click on the Insert button to add the camera to the simulator.

° When you select a camera in the list, you can

• delete the camera from the simulator (6),
• modify the default picture (7),
• change the order (8).

° When you added the cameras to the simulator, close the dialog (9) and
go back to the Communication Parameters dialog.
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° Click on the Insert button (6) to use the current simulator as the active
simulator.

° When you created more than one simulator, you can select the the active
simulator via Current Simulator (8)

° Use the Modify button (7) to save recent changes of the cameras or the
hardware type to the current simulator.

° To delete a simulator, click on the Delete button.
° When you finished the configuration, click on the OK button.

The simulator name is shown in the status bar.

To connect to a simulator, set the interface to Simulator via Communication >
Interface and click on the Connect button.

6.5.12 Offline Settings

ADVICE
This function can be used with all vision systems that can be connected via
vcwin pro .

With Communication > Offline Settings, you can also edit programs when
there is no vision system actually connected.

Edit programs without
a vision system

Image 48: Dialogue Select Vision System

1. Connect the vision system in vcwin pro. vcwin pro saves the vision system
type internally. Note: If the same vision system is connected again, the
internally saved vision system type will be erased.

2. Select Communication > Offline Settings, then select the vision system
from the above dialog box.

3. Create the programs desired.

6.5.13 Change Vision System's IP-address

With Communication > Change IP Addressof Vision System, configure the
IP address of the Ethernet pictor or vicosys using command mode.
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To change the vision
system`s IP address

1. Select Communication > Change IP Address of Vision System.

2. Confirm the following warning (“Do you really want to change?") with Yes. 
The dialog box for changing the IP address appears.
The preset parameters of pictor or vicosys appear under the Current IP
Address.

3. Enter the new parameters required under New IP Address (ask your
administrator if necessary.):

° IP address
° Subnet mask
° Gateway

4. Use the DHCP option: 
Activate the Use DHCP option, to enable automatic reception of an IP
adress from the DHCP server for vicosys or pictor . The IP address found
is then displayed on the boot screen. If no DHCP server can be found, the
standard IP address will be employed

5. Click on OK.

6. Confirm the message ("The new IP address will be activated when Pictor is
re-started.").

7. Terminate communications to vcwin pro then disconnect the image
processing system from the power supply

6.5.14 Fieldbus Settings

You can make changes to the fieldbus settings here. The dialog for CANopen or
sercos III is displayed here, depending on the supported interface.

ADVICE
The settings will be activated after rebooting the vision system.
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CANopen

With Communication > Fieldbus Settings you can configure the settings of
the fieldbus CAN.

Activate the checkbox if you want to use the fieldbus CAN. Unmarke the
checkbox if you do not want to use the CAN fieldbus.

You can make the following settings in the dialog for CANopen:

Parameter Description

Node ID You can set the node address here to uniquely identify the
device on the CAN network.

Bit Rate Here you can specify the transfer rate for the device.

sercos 3

With Communication > Fieldbus Settings you can configure the settings of
the fieldbus sercos III.

You can make the following settings in the dialog for sercos III:

Parameter Description

Slave
Address

You can set the node address here to uniquely identify the
device on the sercos network.

Measurement
Modules

Here you can set the number of measurement modules.
Measurement modules correspond to outputs. Each module
provides 6 outputs.

Parameter
Modules

Here you can set the number of paramter modules.
Parameter modules correspond to inputs. Each module
provides 6 inputs.
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6.5.15 Vision System Information

Using Communication > Vision System Information to display all
fundamental information about your vision system. Please note you must be
connected to a vision system or a simulator.

6.6 The Options Menu

Using the Options menu modify the appearance of vcwin pro, make application
settings and set passwords.
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6.6.1 Full Display

With this option, you can switch between the full display of the commands
containing the complete program text and a short display which shows the
command number, the command name and a short version of the parameter
list.
No. Label Command
***** Last Change at vcwin pro 2.17.136
00000 Standard Image Acquisition with camera 0
00001 Locate Point 0; Max. Gradient Algorithm; Search

Arrow: [625, 772/554, 762]
00002 Locate Point 1; Max. Gradient Algorithm; Search

Arrow: [1150, 205/1250, 305]
00003 Distance between Point 0 and Point 1

(directly); Result 1

Table 1: example program in option Short Display

No. Label Command
***** Last Change at vcwin pro 2.17.136;
00000 Standard Image Acquisition with camera 0
00001 Determine Point 0 (World); Max. Gradient [10,

1, 2]; Light > Dark
Search Arrow: [625, 772/554, 762]

00002 Determine Point 1 (World); Max. Gradient [10,
1, 2]; Light > Dark
Search Arrow: [1150, 205/1250, 305]

00003 Distance between Point 0 and Point 1 (directly)
Result: 1; Nominal 0 (+10/-10)

Table 2: example program in option Full Display

6.6.2 Display Highlight Colors

This disables or enables the presentation of the commands background color
in the command window (see "Highlight with Color", Page 58). This option is
active by default.

This setting is a setting of vcwin pro and is not stored within the program.
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6.6.3 Application Settings

Application Settings

Page >>Look<< Language settings:

Here you can define the language of the user interface. You have to restart
vcwin pro to activate this change.

Theme settings:

Here you can define the design of the user interface. The design is applied
immediately after clicking the "OK" or "Apply" button.

User Window settings:

This is used to select which User Window appears in vcwin pro. You have to
restart vcwin pro to activate this change.

Activate the checkbox "vcwin pro starts with User Window" if you want to start
vcwin pro with the choosen User Window. Deactivate the checkbox if vcwin pro
should be started with the programming window.
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Page >>Font<< 

Font settings:

Here you can define the font, the font size and the font style for the text display
of the check programms.

Font colour settings:

Here you can define colours for active commands, deactivated commands,
comments and Branch commands.
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Page >>Advanced<<

Connection Timeout:

Here you can set the time, after witch the vision system needs to answer at the
latest. For slower connections (like VPN) this time should be raised.

Interval in Program and Section Test:

Changes the length of the interval between the commands in a program- or
section test.

Decrease the value to used to speed up the programm- or section test.

Display Time for Vision System Information at Connection:

Changes the display time of the dialog "Vision System Information". Those
Informations can also be viewed under Communication > Vision System
Information.

TCP port for Online Debugging:

Here you can change the port used for debugging (Port 8499 is set as
standard for debbuging), if you want to use this port in a different manner (e.g.
datatransfer).

JPEG quality for saving images on the PC:

Here you can set the quality of a JPEG image that is to be saved on the PC.

This setting affects:

Menu: Utilities / Receive Image from vision system, see "Receive Image
from Vision System", Page 71
Menu: Communication / System Ressources/Initial Program / Images / Save
on PC, see "System Resources / Initial Program", Page 84

JPEG quality for the Monitor Window:
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Here you can set the quality of the JPEG images that are transferred from the
vision system to the Monitor Window (even at Live Image). This setting affects
also the saving of the images directly from the Monitor Window.

This setting affects:

Monitor Window / Save Image, see "Docking Window Monitor Window",
Page 42
Monitor Window / Live Image, see "Docking Window Monitor Window",
Page 42
Display of Monitor Window, see "Docking Window Monitor Window",
Page 42

Page >>Names of
Comments<<

Here you can change the names of the commands, that are used under File >
Info "Table".

6.6.4 User Management

Here, you can assign the users and their user rights as Craftsman, Foreman,
or Programmer.
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User group Rights in vcwin pro

Programmer Access to all functions without restrictions.

Foreman • In the Programming Window, the right to change
commands enabled for foreman in Edit > Command
Selection.

• Change settings in the User Window

Craftsman Operate programs in the User Window.

To create a new user 1. Click on Add User.

2. Enter the user name.

3. Select the user right.

4. Enter the password in the Password field, then enter the password again in
the Confirm Password field.

To delete a user 1. Mark the user.

2. Click on Delete User.

ADVICE
If you upgrade your vcwin pro from version 2.10 or less to a higher version
(2.11 or above), you have to create again all users you have created via
Options > User Management in the older version.

6.6.5 User Login

Here, you can switch the user during the programming, e.g. to test the program
using Foreman or Craftsman rights.

To log in 1. Select the user.

2. Enter the user password.

6.7 The Help Menu

The Help menu contains the menu for calling online help and the program
information.
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6.7.1 Help Content

vcwin pro Online Help Access the help with vcwin pro > Help > Help Content.

To start a new query on a particular subject use the tabs [Contents] or [Search]
located in the help windows menu bar.

The help is context sensitive. This means that you can call help about a dialog
box directly by pressing F1.

Help texts can be printed, copied to the clipboard or marked with a bookmark.

6.7.2 Info About

Info about displays information about the program, such as version number,
manufacturer and license etc.
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7 PART 2 - COMMAND REFERENCE

7.1 Introduction to Commands

7.1.1 Dialog Elements

In this section, you can find information regarding important elements that are
needed in order to parameterize commands.

Options Dialog for
Detection Algorithm

Use this dialog type for selecting the detection algorithm. Proceed as follows:

1. Select the desired option.

2. Configure the parameters using the arrows at the right-hand border or enter
the values directly.

Options Dialog for
Calculating Geometric
Variables

Use this dialog type for calculating geometric variables. Proceed as follows:

1. Select an entry in the left-hand list either by mouse or the cursor keys.

2. Highlight one of the options displayed in the center part.

3. Configure the parameters displayed at the right-hand by using the arrows at
the right-hand border or enter the values directly.

Selection Dialogs for
Variables, Strings and
Results

Image 49: Dialogs for Element Numbers and Geometry Elements (Examples)

vcwin pro uses drop-down menus (left-hand image) and element lists (right-
hand image) for selecting geometrical elements, strings and results. The
numbers of previously defined geometrical variables and results can be
selected or entered directly by keyboard. Use this type of dialogs for loading,
saving and transferring elements.
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To deactivate the selected element choose or type {-1} respectively {nd}. This
means that this element will not be loaded, saved or transferred on execution of
the command. The elements available are displayed as black characters in the
listings, elements that are not available are displayed in gray.

Dialog Box for
Determining Results

Use this type of dialogs for specifying results and the corresponding tolerance
tests.

What is the Result Structure?
The Result Structure is the totality of the result variables used. The result
variables, for example, save whether the result is good or bad. Simultaneously,
they always save the first value determined.

Input Fields
The individual fields should be considered in combination and have the
following meanings:

• Result (RES) determines the number under which the result is saved in
the result structure. The result is GOOD if the actual value assumes values
within the tolerance range and BAD otherwise.

• Nominal  and Tolerances determine the nominal value and the tolerance
range for the parameter to be checked.

7.1.2 Teaching in Detection Windows and Test Windows

Basics Use the detection and test windows to define a part of the image or to enclose
an object to be investigated. According to the different commands, the detection
window can assume a variety of forms. The standard form is a rectangular
window. In the special case of Locate Point, a detection beam is used.

Teach-in Tab
For most commands, the teach-in of windows takes place in the Teach-in tab.
On commands like 360° Pattern Search where a reference object has to be
found, there is a Teach-in Pattern and a Search Window tab instead. Both are
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built on the same principles as the Teach-in dialog. There are the following
principle options:

• Teach-in via video image (recommended)
• Teach-in via window dialog and enter the coordinates numerically
• Load a contour from the geometry structure and define as a test window

Method 1: Via the
Video Screen

Proceed as follows:

1. To use a new image for the teach-in process, click on the [Grab Image]
button. If you use more than just one camera in your vision system, you can
change the current camera via the arrow at the right of the button.

2. Double click the right-hand mouse button to switch from the edit window to
the video screen. 
All fields in the edit window are now locked.

3. Move the mouse pointer on the video screen over the border of the detection
window, it will turn into a small double-headed or quad-headed arrow.

4. Modify the dimension and position of the window using the mouse. In order
to do this, move the mouse whilst holding down the left mouse button:

° at the corners ... to resize the window in diagonal direction
° at the edges … to move the side borders perpendicular to the window

limits
° centrally … to move the window
° Proceed with the detection beam (with Locate Point) accordingly.

5. Double-click on the right mouse button again to return to the edit window. 
The changes made in the video image are adopted by the dialog window.

Image 50: Position an rezise a test window using the mouse

Method 2: In the
Teach-in Tab

Proceed as follows:

1. Enter the X and Y values for the top left-hand corner of a test window and
also its dimension (X, Y) into the appropriate fields in the Teach-in tab of the
edit dialog box. 
When using an ellipse-ring, enter also the width of the ring.

2. Modify the values as required with the arrows to the right of each field.

3. Follow any changes in the video screen. 
All numerical data for test window relate to pixels and are measured either
from the top left-hand corner of the screen or the reference point. >>
"Position Tracking of Objects", Page 118
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rectangle

dx

dy

screen origin
x

y

Image 51: test window rectangle

ellipse

dx

dy

screen origin
x

y

Image 52: test window ellipse

ellipsoid ring

dx

dy

screen origin
x

y

b

Image 53: test window ellipsoid ring

circular ring segment

screen origin
x

y
0°x,y

b

d c

a

Image 54: test window circular
ring segment (a = starting angle,
b = final angle, c = starting radius,
d = final radius)

Method 3: Via Contour Some commands allow a contour to be determined within which a test is to take
place:

1. Select the Contour option in the dialog box.

2. Select the contour number from the drop-down menu. 
The contour is superimposed on the video image and can be positioned as
described in method 2.
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More Options Button Description

Delete
Graphics

Deletes all overlay graphics from the monitor window or
control monitor except for the search window.

Reset
Graphics

Resets all changes made to the overlay graphics since the
opening of the dialog.

Grab Image Performs an image acquisition and saves the image in the
image memory. If you use more than one camera in your
vision system, you can select the camera for the image acqui-
sition via the arrow on the right.

Test (not all
commands)

Performs a test with the current settings.

7.1.3 Geometries

Standard Geometry:
Rectangle

x

dy

dx

(0,0)

y

Geometry Parameters:

X: X coordinate of the upper left corner
Y: Y coordinate of the upper left corner
dX: Width of the rectangle
dY: Height of the rectangle

Standard Geometry:
Ellipse

x

dy

dx

(0,0)

y

Geometry parameters:

X: X coordinate of the upper left corner of the bounding rectangle
Y: Y coordinate of the upper left corner of the bounding rectangle
dX: Width of the ellipse
dY: Height of the ellipse
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Standard Geometry:
Ellipsoid Ring

x

dy

dx

w

(0,0)

y

Geometry parameters:

X: X coordinate of the upper left corner of the bounding rectangle
Y: Y coordinate of the upper left corner of the bounding rectangle
dX: Width of the ellipse
dY: Height of the ellipse
w: Width of the ellipsoid ring, indication from the outer edge

Standard Geometry:
Contour

Geometry parameters:

Contour: Number or Name of the contour
(must be present on the vision system, for example Locate > Contour)

Standard Geometry:
Circular Ring Segment

rr
0°

s

ex

y

e s

(0,0)

Geometry parameters:

Center Point X: X coordinate of the center point
Center Point Y: Y coordinate of the center point
Start Radius: Start of the circular ring segment
End Radius: End of the circular ring segment
Start Angle: Starting angle of the arc (sector) in degrees
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End Angle: Ending angle of the arc (sector) in degrees

only at Locate Edges on Circle

With this command, in addition, the search direction is given.

• Clockwise:
The under Parameters selected edge transitions are searched only in
a clockwise direction.

• Counterclockwise:
The under Parameters selected edge transitions are searched only in
a counterclockwise direction.

Standard Geometry:
Circle

r

x

y

(0,0)

Geometry parameters:

Center Point X: X coordinate of the center point
Center Point Y: Y coordinate of the center point
Radius: Radius of the circle

Teach-in Geometry:
Mask Check

x

dy

dx

(0,0)

y

Geometry parameters:

X: X coordinate of the upper left corner
Y: Y coordinate of the upper left corner
dX: Width of the taught mask
dY: Height of the taught mask
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Teach-in Geometry:
Image Equalization

x
y dx

dy

(0,0)

Geometry parameters:

X: X coordinate of the upper left corner of the taught distortion
Y: Y coordinate of the upper left corner of the taught distortion
dX: Width of the taught distortion
dY: Height of the taught distortion

Detection Geometry :
Locate Line

w

xs

xe

ye

ys

(0,0)

Geometry parameters:

Start X: X coordinate of the starting point of the detection arrow
Start Y: Y coordinate of the starting point of the detection arrow
End X: X coordinate of the ending point of the detection arrow
End Y: Y coordinate of the ending point of the detection arrow
Width: Width of the detection window
Quantity of Detection Points: The quantity of detection points corresponds to
the detection arrows. These are evenly distributed over the width. On each
detection arrow a detection point is searched. From the detection points
found then the line is formed. The more detection points are used, the more
accurate the line forming is, but the longer the computation takes time.
Determine whether all detection points must be found so that a line is formed
from the single detections.
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Detection Geometry :
Locate Point xs

xe

ye

ys

(0,0)

Geometry parameters:

Start X: X coordinate of the starting point of the detection arrow
Start Y: Y coordinate of the starting point of the detection arrow
End X: X coordinate of the ending point of the detection arrow
End Y: Y coordinate of the ending point of the detection arrow

Detection Geometry :
Locate Circle

rr
0°

s

ex

y

e s

(0,0)

Geometry parameters:

Center Point X: X coordinate of the center point
Center Point Y: Y coordinate of the center point
Start Radius: Start of the circular ring segment
End Radius: End of the circular ring segment
Start Angle: Starting angle of the arc (sector) in degrees
End Angle: Ending angle of the arc (sector) in degrees
Quantity of Detection Points: The quantity of detection points corresponds
to the detection arrows. These are evenly distributed over the circular ring
segment. On each detection arrow a detection point is searched. From
the detection points found then the circle is formed. The more detection
points are used, the more accurate the circle forming is, but the longer the
computation takes time.
Determine whether all detection points must be found so that a circle is
formed from the single detections.

If the start radius is larger than the end radius the search direction changes
from inside -> outside to outside -> inside.
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Detection Geometry :
Locate Contour

x

dy

dx

y

N

E

S

W

(0,0)

Geometry parameters:

X: X coordinate of the upper left corner
Y: Y coordinate of the upper left corner
dX: Width of the rectangle
dY: Height of the rectangle
Search Direction:

° N(orth): bottom-up
° E(ast): left-to-right
° S(outh): top-down
° W(est): right-to-left

Detection Geometry :
Locate Angle

w
y

x

0°
l

(0,0)

The geometry parameters are entered separately for both Detection Windows.

Geometry parameters:

Center Point X: X coordinate of the center point of the detection window
Center Point Y: Y coordinate of the center point of the detection window
Length: Lenght of the detection window
Width: Width of the detection window
Angel: Rotation of the rectangle around the center point

7.1.4 Position Tracking of Objects

Principles of Position
Tracking

Position tracking is used if the object to be measured – with the detection
beams and/or window – can be moved or rotated in relation to the initial teach-
in. A differentiation is made between:

• Position tracking in the X/Y directions
• Angular position tracking

Principle

During teach-in with vcwin pro , the relative coordinates of the test window are
calculated from the fixed window coordinates and the compensated coordinates
of the reference points and lines. These coordinates can be changed in the
entry masks of the relevant dialog boxes.
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General Procedure

1. Search for clearly defined points or a line in the video image at which the
position of the detection beams and window should remain constant during
the testing.

2. Insert commands for determining these points/this line into the test program.

3. When teaching the image processing command with position tracking, select
the points/line detected under point 2 in the dialog fields for the position
tracking.

Commands Where Position Tracking is Available
The following commands' tech windows can be tracked:

Commands X/Y Tracking Angular Position
Tracking

Blob Analysis ×

Data-Matrix Code ×

Angular Position ×

Rotation Based on
Moments

× ×2)

Superimpose ×

Advanced Pattern
Search

×

Color Blob Analysis ×

Test Color ×

Focus ×

Locate Line × ×2)

Gray Value ×

Test Brightness
Percentage

×

Brightness Offset ×

Locate Edges on Circle ×

Transition at Line ×

Locate Contour ×

Locate Circle ×

Mask Check × ×2)

Save Pattern ×

Search Pattern ×

Inspect Surface × ×2)

Search and Identify
Object

×

Count Pixels × ×2)

Locate Point × 1)

Read Character ×
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Instructions for angular position tracking
1) When detecting with gradient and convolution algorithms, the detection
beams can only be rotated in steps of 45°.
2) In the case of test windows, only the central points are rotated. The window
alignment in the X-Y directions is maintained.

Input Dialog ADVICE
If the reference points/lines used for tracking are to be expressed in pixels
(image coordinates), they have to be defined for the same image page and
the same camera being used, otherwise you will get a type error.

Use the following parameters for position tracking of test windows and detection
beams:

Parameters Description

X Point The object will follow the X coordinate of the reference point.

Y Point The object will follow the Y coordinate of the reference point.

X and Y Point The object will follow both X and Y coordinates of a single
reference point or two different reference points.

phi Line The object to be followed is followed at a fixed angle to the
given line.

Endpoint
Only

Position tracking uses only the apex of the detection beam
as a reference point. The base always remains at the same
image position. In this way the position tracking of a point is
possible. Only available for Locate Point. If you do not want
any tracking you should enter either {1} or {-1} here. Points/
lines used for tracking must already be defined in the point
structure. They will then appear as resources in the selection
window for X Point, Y Point  and phi Line.
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Position Tracking in X/
Y Directions

Basics

With position tracking in X/Y direction, the detection beams and/or the central
points of the test windows are fixedly assigned to a new (moveable) coordinate
system.

The orign of the new coordinate system consists of the X coordinate of the X
reference point and the Y coordinate of the Y reference point.

During the position tracking, the relative position (X´, Y´) of the test windows
and detection beams to the reference points always remains constant.

If position tracking is not enabled, the coordinate of the reference point in the
corresponding direction is zero.

Example
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Angular Position
Tracking

ADVICE
• The angular position tracking should be linked with the X/Y position

tracking, whereby the same X and Y reference points should be used.
• In order to achieve angular position tracking up to 360°, the phi line must

be defined by two clearly defined points. Lines which are determined by
the Locate Line command can only be used for angular position tracking
up to 90 degrees.

Basics

You assign the detection beams and/or middle points of the test windows to a
new (rotatable) coordinate system using angular position tracking.

The X axis of the new coordinate system runs parallel to the reference line (phi
line). The zero point lies in the reference point.

To track the angular position

1. Determine a reference point. 
This can be, e.g. the center of gravity from Blob Analysis and Locate
Contour.

2. Execute the Angular Position command. 
Use the reference point for the angular position to compensate for
movement of the object in the image.

3. Use the angular position line from point 2 as phi line for following
commands. 
These commands – e.g. Count Pixels – must use both the reference point
and the phi line to compensate.

A Special Case for Angular Position Tracking

Only the center point of the window is rotated.
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The rotary angle is produced from the angle between the position tracking line
and the X axis. The direction and size of the window are maintained.

Example

7.1.5 Checking Variables

Before using values of previously saved variables in new commands, ensure
the variable contain correct values. If not, the test function in "Teach-in" will
raise an error. 

To check variables 1. Review the program using Utilities > Test Step until the point is reached
where the variables concerned are used.

2. Check the variables in the results list, points list, line list, circle list or string
list. You can use these variables for teach-in within further commands.

Example for points
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7.1.6 Command Test

Button [Test]

Click the [Test] button in order to test the commands during teaching-in. You
should do this before adding a command to the command list. 

The test displays the following:

• Whether the command was successful or unsuccessful.
• The calculated values and results.

7.1.7 Online Debugging 

Online debugging is a tool for diagnosing and locating errors in test programs.
The function enables you to efficiently optimise your commands and programs
and thus lays the foundation for successful test procedures.

For this purpose, the current test program is transferred to the RAM of the vision
system and executed there. In contrast to run mode, communication with vcwin
pro remains intact and the device transmits the line numbers of the currently
executed lines/commands. The user can therefore see which commands
have already been processed and respond accordingly. If the program on the
vision system is waiting for an external signal (LineIO, PortIO, Port Control,
Synchronous Flash, etc.), the cursor remains in the corresponding location.
Through the transfer of information between the vision system and vcwin pro,
debugging works with only a very slight delay in comparison to run mode.

To better monitor the progression of online debugging, the user can insert
breakpoints. These points can also be linked to certain conditions. If a
breakpoint is triggered, processing by the vision system is stopped and the
evaluation of the commands processed up to that point in time are displayed in
vcwin pro.

Image 55: "Debugging" toolbar

Starting, stopping and
continuing debugging

To start online debugging, click either Utilities > Start/Continue Debugging or the

 symbol in the toolbar. The current program is then transferred to the RAM
of the vision system, and existing programs in RAM are replaced (this does not
apply for programs in the FLASH). As soon as debugging starts, a dialog for
controlling the process appears. During the debugging process, you cannot use
functions or commands in vcwin pro.

Image 56: Dialog while debugging

If you click the Break button in the dialog, the debugging process is stopped
and you can work in vcwin pro again. The command currently being processed
is indicated via an arrow symbol  in the command display. In the debug
history, the previous commands (including test results and duration) are listed
(max. 50,000 commands), and the yellow arrow in the command display shows
the line where debugging was stopped. You can utilise this "paused" state to
check geometry elements or adjust individual commands, for example. While
debugging mode is active, you can only change commands. They cannot be
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deleted or added. To continue debugging, click Start/Continue Debugging
again.

If you click the Run Mode button, the connection between the vision system and
vcwin pro is broken and the test program is continued in the run mode of the
vision system.

To exit online debugging and switch back to command mode, click the blue stop
symbol in the "Debugging" toolbar or click Utilities > Stop Debugging.

Breakpoints Use breakpoints to stop your test program at specific points while debugging
and evaluate the previous results. With conditional breakpoints, you can also
specify that a program is only stopped if a specific condition has been fulfilled.
If the debugging process is stopped by a breakpoint, the program sections
processed up to that point are evaluated and displayed in the debug history. To
continue debugging from the same point, simply click Utilities > Start/Continue
Debugging or the symbol in the "Debugging" toolbar.

The following breakpoint types are available:

Type SymbolFunction

Unconditional break-
point

Interrupts the running program before
processing the line marked with the break-
point.

Conditional breakpoint
(good)

Only interrupts the running program if the
preceding command was tested as "good".
Otherwise, debugging is continued without
interruption.

Conditional breakpoint
(error)

Only interrupts the running program if the
preceding command was tested as "bad".
Otherwise, debugging is continued without
interruption.

Table 3: Breakpoints

A breakpoint can only be set within the command display. For this purpose, you
must select the desired line and then insert the breakpoint. The breakpoint is
always processed BEFORE the line in which it was inserted. This means that
when you set an unconditional breakpoint for a command with number 00005,
the program stops after processing command 00004. If you set a conditional
breakpoint at 00005, the test result of command 00004 determines whether
debugging is stopped or continues running.

There are a number of procedures for setting or deleting a breakpoint:

• Symbol in the toolbar: Click the corresponding icon in the "Debugging"
toolbar. Click it again to delete the breakpoint.

• F9 shortcut key: Press the F9 key to switch between the various breakpoint
types or remove the breakpoint.

• Menu Utilities > Breakpoint: Click the Breakpoint entry in the Utilities menu
to switch between the various breakpoint types or remove the breakpoint.

• To delete all breakpoints, click the Delete All Breakpoints symbol  in the
toolbar or click Utilities > Delete All Breakpoints.
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Debug History

The debug history shows the results of the processed commands of the current
debugging process. It represented the last 50.000 commands. They are divided
into pages of 100 entries. Use the blue arrow buttons at the top to switch
between categories.

The individual entries are comprised of a command number, command
designation, the time required and the error type (if present) in the brackets.
If the time specification is 0 ms, less than 1 ms was required to process the
command. It is not possible to add up times to determine the total time, as other
processes (e.g. triggers) are carried out between commands.

Type SymbolFunction

First/ Last Page Goes to the beginning/ end of the debug
history.

Previous/ Next Page Goes to the previous/ next page of the debug
history.

Number current page/
all pages

Display the current page / total number of
pages.

Save Debug History Stores the debug history on the PC.

Clear Debug History Clears the debug history.

Type SymbolFunction

Command "good" The command has been rated as "good".

Command "bad" The command has been rated as "bad".

Label Start Starting point of the program.

Label Branch This label indicates the command Branch with
option "Set Label". All subsequent commands
up to a return or a new label are grouped
together under this label. For more info:
"Branch", Page 349.

Label Return Indicates a return from subroutine. Any
commands that were executed up to the next
return or to the next label are listed under this
entry. For more info: "Branch", Page 349.

If you are in paused debug mode, you can quickly access the individual
commands using the debug history. Clicking an entry once selects the
corresponding line in the command display, and double-clicking it opens the
command dialog in the case of commands, where you can conveniently make
changes to parameters.
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7.2 Image Commands

7.2.1 Rotate Image

Image 57: Dialogue Rotate Image, tab
control Parameters

With Image > Rotate Image you can choose an angle and incorporate this in
the command for rotating a circular section of an image. The command can be
used with position tracking for its x/y positions and rotation. This enables image
contents to be rotated automatically by a determined angle.

Brief guide Define the following parameters in the Teach-in tab:

° The size and the position of the image section to be rotated
° Position tracking e.g. the position of a found pattern and the associated

line of rotation as a phi line
° Mirror mode, if the object to be rotated was found mirrored in the image

Define more conditions in the parameters tab:

° A fixed angle can be given for the rotation angle by which the image
section is to be rotated

° Under output window, enter the image storage page to which the rotated
image section is to be copied

° Specify the position in which the rotated image section is to be inserted in
the image using x/y coordinates

Test the command with the [Test] button and insert the command into the
test program with the [OK] button
Verify the result by displaying the specified image storage page via the
“Video Control Panel” dialog

Teach-in the Detection
Window

The Teach-in window can be only trained as circle.

Position and Appearance of the Search Window

After double clicking with the right mouse button on the Search Window tab,
you can position and adapt the search window on the control monitor or on the
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monitor window. 
>> "Teaching in Detection Windows and Test Windows", Page 110

Tracking the Position

The search window can either always remain at the same image position or
follow a reference object. 
>> "Position Tracking of Objects", Page 118

Input parameters Parameter Dialogue tab Description

Mirror mode Teach-in This option specifies whether the image
section being rotated is to be mirrored. This
directly affects tracking and is therefore
located in the teach-in dialog.

Rotation angle Offset angle by which the image is always
rotated

Image page The image page to which the rotated image
section is to be copied

X/Y

Parameter

x/y position in the image at which the rotated
image section is to be inserted

Test When testing, the selected section is rotated by the given rotation angle. The
rotated image section is shown in the selected image page.

7.2.2 Delete Image

Image 58: Dialogue Delete Image

Insert a deletion command into the test program using Image > Delete Image.
This way you clear the image memory, graphic page or overlay memory
depending on the selected option.
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Options Options Description

Image
Memory

Clears the content of the work page.

Graphic
Color

Clears the demo page superimpositions.

Overlay
Memory

The overlay memory is a separate memory for graphics
(statisticly displayed assistance lines, counters, numbers,
texts), which corresponds to the image memory. No image
information is overwritten when the overlay memory is used.
The overlay memory information is superimposed on the
image memory information. The demo page superimpositions
are likewise cleared. 
Note: Because the overlay memory is a separate memory,
there are differences between the different types of vision
systems.

7.2.3 Grab Image

Write a command in the test program to acquire an image and transfer it to
image memory using Image > Grab Image. 

Image 59: Dialogue Grab Image

Options Camera

Select one of the cameras installed. vcwin pro automatically recognizes the
number of cameras available during connection. The camera number for
vicosys can be checked with the Sort Cameras command in the utilities for
vicosys.
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Mode

Parameters
for Mode
option

Description

Default Acquiring an image takes place in the current image memory
page. The system waits until acquisition is complete before
carrying on with the next commands.

Start Only The image aquisition "start only" waits until a previous image
aquisition is terminated, if this still runs. That is called he
synchronizes itself with the processing time. Image acquisi-
tion starts. An image is written into the current image memory
page. At the same time, the system carries on with the next
commands.

Parallel The parallel image aquisition waits until a previous image
aquisition is terminated, if this still runs. That is called he
synchronizes itself with the processing time.The first image
is acquired in an image memory page, which then acts as an
image acquisition page. The previous image memory page
acts as the image acquisition page for the next image acqui-
sition. Each image acquired is processed on the same image
memory page as it was acquired in — this page changes its
function from the image acquisition page to the processing
page.

Image
Section

Allows substantially accelerated image acquisition within a
small limited region (ROI).

Image 60: Dialogue Grab Image > Image Section

To select an image
section

ADVICE
Use multiple adjacent image sections, each with the appropriate gain, in order
to capture inhomogeneously illuminated objects.

1. Activate the Image Section option, then click on the double arrow.

2. Set the area for image acquisition via either the options in the rectangle
parameters or by hand.



vcwin pro 2.21
Part 2 - Command Reference

© Vision & Control GmbH
2015

999.994.306.10-en-1.15 131

Input Parameters Image
Section Input
Parameters

Description

Position Position of the rectangle

Width /
Height

width/ height of the rectangle

Delete the
Outer Area

Option active: The area outside the rectangle selected is
deleted. 
Option inactive: Image pages outside the rectangle selected
remain unchanged.

Double-click
Right

Double-clicking the right-hand mouse button toggles from the
Image Section dialog to the control monitor. The position and
size of the rectangle for image acquisition in the video image
can then be changed as required. Double-clicking with the
right-hand mouse button again toggles back to the Image
Section dialog box.

Tuning Parameters The Half-frame Mode and Live Mode options enable program time to be
saved. These functions are not supported by all vision systems .

ADVICE
The camera must always be calibrated in the mode in which the image was
acquired (half-frame mode or live image mode). The calibration should be
made immediately after the image acquisition.

Tuning Para-
meters for
Half-frame
Mode and
Live Mode

Description

Half-frame
Mode

In order to save time, only every second image line is
acquired. The acquired image has only half the resolution.
This option is not released for progressive-scan cameras
(pictor M1208 … M1418) – for which a full image acquisition is
always performed.

Live Mode Only for pictor M type cameras. If the option is activated, the
camera remains in live image mode after the image acquisi-
tion.
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7.2.4 Image Difference

Image 61: Dialogue Image Difference

With the help of the command Image > Image Difference you can subtract
gray value information of a reference image from a comparison image. 

The difference image produced can be saved to an output page. This command
is for recording the difference between two images, or for making a copy of
an image, before using commands that alter images, such as image pre-
processing. To make a copy of an image, generate the image difference
between a black image and activate the  Save Image Difference option.

Brief Guide 1. Define in the Parameters tab:

° Comparison Page and Reference Page
° Methods: Overall Image, Image Section or Image Section with

Displacement

2. Only for the methods Image Section and Image Section with Displacement:

° Activate teach-in mode in the Teach-in tab by double-clicking with the
right-hand mouse button.

° Change the size and position of the image section in the video image with
the controls.

° Deactivate teach-in mode by double-clicking with the right-hand mouse
button.

3. Only for the method Image Section with Displacement, define in the
Parameters tab:

° Comparison Point
° Reference Point

4. Define in the Parameters tab:
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° Option for counting the different pixels with the associated settings
° Option for saving the image difference with the associated settings

5. Test and modify the parameters set in points 1-4 until the test result is error
free.

Input Parameters Input Para-
meters for
"Pages"

Description

Comparison
Page

Contains the image to be compared.

Reference
Page

Contains the reference image.

ADVICE
It always holds: comparison page minus reference page.

Input Para-
meters for
"Method"

Description

Overall
Image

The image difference is determined over the entire image.

Image
Section

The image difference is determined in the image section. The
image difference is set in the Teach-in tab.

Image
Section with
Displace-
ment

The image difference is determined in the image section. Addi-
tionally, vcwin pro can effect a displacement of the difference
in the positions of both the following points:

• Comparison point … Point on the comparison page
• Reference point … Point on the reference page

Evaluation Parameters Evaluation
Parameters
for "Test"

Description

Quantity of
Different
Pixels

If option is active difference pixels will be counted.

Difference
Threshold

Gray value difference between comparison page and refer-
ence page from which, when exceeded, the difference pixels
are evaluated.

Result Number for saving the result. The number of difference pixels
will be saved. The result is good, if the number of difference
pixels lies within the tolerance range.

Quantity of
Difference
Pixels and
Tolerances

Nominal values for the difference pixels.



vcwin pro 2.21
Part 2 - Command Reference

134 999.994.306.10-en-1.15 © Vision & Control GmbH 2015

Input Para-
meters for
"Output and
Saving"

Description

Save Image
Difference

If the option is active, image difference is saved in the output
page specified.

Gray Value
Difference

The gray value difference is saved for every pixel.

Difference
Pixels

The difference pixels become white, all the pixels that lie
under the difference threshold are saved as black.

The command "Image difference" works like that:

• Colour image - Colour image = Colour image
• Grey image - Grey image = Grey image
• Colour image - Grey image = error

Thus it is impossible to compare a grey image with a colour image.

7.2.5 Image Equalization

Overview
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Image 62: grid pattern found
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Image 63: points connected,
correction grid determined

Image 64: equalized image

With Image > Image Equalization you add a command for correction of
perspective distortions and for unwinding folded or circular bended surfaces
(e.g. half spheres, pipes, etc.). Image distortions caused by lenses (pillow-
shaped distortion, barrel-shaped distortion) can also be corrected with this
command.

ADVICE
For highly accurate measurements, the use of telecentric lenses is
recommended. Due to the recalculation and equalization measurement errors
can occur because of shifted pixels.

For the image equalization, respectively a grid pattern is required as the
template, so that the existing distortion of the lens or the object to be detected
can be detected by the software. Based on this grid pattern, a correction grid is
calculated which equalizes the image section in the image.

An example grid can be found in the appendix. see "Part 3 - Appendices",
Page 375
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Preparation Depending on the application, you have several options.

• Place the grid pattern in the field of view of the camera at the position where
later the test object is to be located. You achieve the correction of lens
distortion.

• Sheath the subsequent test object (blank, box, tube etc.) with the grid
pattern (see image in overview). Place the object at the position where later
the test object is to be located. You achieve the unwinding of the surface.

Work Flow: Teach-in
Distortion

1. Switch to the tab control "Teach-in Distortion".

2. Capture an image from the grid pattern by clicking the button [Grab Image].

3. Determine, by means of the geometry rectangle, which image content has to
be read as the distortion.

° the size and position of the area to be taught (ideally, the number of
points should be the same on each line in the x-direction).

° the gray value threshold for the grid pattern

Information for teaching, see also: "Teaching in Detection Windows and Test
Windows", Page 110.

4. Click on the Button [Teach Distortion]. If the pattern is not recorded correctly,
a message in the lower left part of the dialog appears. Accordingly, adjust
the parameters.

Image 65: Dialog Image Equalization, tab control Teach-in Distortion

Work Flow: Determine
Correction Area

1. Switch to the tab control "Teach-in".

2. Set the position of the correction window, the size is already given through
the window of "Teach-in Distortion". In this area the image will be equalized.
If the test object is always in the same place, you do not need to change this
option.
For correcting lens distortion, this area should not be changed; otherwise the
lens is equalized incorrect. (see also: "Teaching in Detection Windows and
Test Windows", Page 110)

3. If necessary, set the parameters (X Point, Y Point, phi Line) for position
tracking (see also: "Position Tracking of Objects", Page 118)

ADVICE
The position tracking rotates the grid to the angle change of the phi-line!
The moment where a phi-line is selected, the angle is saved. If the angle
changes (e.g. by Locate Line), the line is rotated about the difference of the
new angle and the stored angle.



vcwin pro 2.21
Part 2 - Command Reference

136 999.994.306.10-en-1.15 © Vision & Control GmbH 2015

Work Flow:
Parameterizing and
Testing 1

6

2

3

4

5

Image 66: Dialog Image Equalization, tab control Parameters

1. Switch to the tab control "Parameters".

2. Here the current distortion grid is displayed. This grid is used for equalization
of all with this command equalized images.

3. Specify the image page, to which the equalized image should be copied to
for further processing. The command copies the image that is determined
by the grid (regardless of its location) to the center of the target page. In
combination with position tracking images can be brought in to a stable
position, in which later tests can be carried out without further tracking.

ADVICE
The setting of -1 means that the respective current work page will be used.
This can be specified with the command Display (see also: "Display").

For optimum performance, the target page should be different from the
source page. Otherwise, the content of the source page is also copied
from the image processing system. This has a greater expenditure of time
as result.

4. Testing and Evaluate suitable parameters
The command is executed with the parameters by activating the [Test]
button. The selected area is equalized using the calculated correction grid
and the equalized image is shown in the chosen image page.

5. Use the [OK] button to insert the command into the test program.
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7.2.6 Image Preprocessing

Enable an image to be acquired and test the image, or a taught region of it,
using various filters with the Image > Image Preprocessing command.

Image 67: Dialogue Image Preprocessing,
tab control Parameters

Summary 1. Use the checkbox labeled In the entire image to determine whether the
image pre-processing should apply to the entire image or only to a section of
it.

2. When the checkbox is activated the needed geometry date can be defined
on the Teach-in tab.

3. Select and parameterize a filter.

4. Select between live image and memory image:

° Mark Live Video, if the image pre-processing should take place in live
image mode.

° Cancel Live Video, then click on Grab Image, if the image pre-
processing should take place in memory image mode.

5. Click Test.
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Filters All linear filters employ a 3 x 3 matrix.

Filters Use / Result of the filtering

Lowpass - Noise suppression. 
- Filter out higher frequencies.
- Multiple use increases the effect.

Median - Suppression of so-called ‘salt & pepper’ noise. 
- The edges remain preserved.

Sobel - Edge filter with integrated smoothing.
- The exact location of the edge is at the maximum brightness.
- The result image displays the contrast.

Prewitt - Edge filter without integrated smoothing.
- The exact location of the edge is at the maximum brightness.
- The result image displays the contrast.

Laplace - Every edge results in a double contour. 
- The edge location is not the maximum. 
- The direction of the edge is decided by the sign.

Min. - The edge location is shifted towards the darker direction. 
- Dark areas become somewhat larger. 
- Results in sharper lines from sharper edges.

Max. - The edge location is shifted towards the lighter direction. 
- Light areas become somewhat lighter. 
- Results in sharper lines from sharper edges.

7.2.7 Display

Specify the usage of the various image memory pages using Image > Display.
The following types are possible:

• Acquisition page
• Work page
• Demo page
• Display page

Image 68: Dialogue Display

Image Memory Pages Image memory pages are memory areas in the vision system, which you can
use for image acquisition, image display, image processing, for superimposing
geometry variables etc.

Depending upon the vision system, up to 24 images can be stored in different
image memory pages.
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ADVICE
Refer to the hardware manual for the number of image memory pages
available on the vision systems of the type pictor M.

Vision systems of the type pictor T have 24 image memory pages.

The number of image memory pages available on vision system vicosys
depends on the resolution of the connected cameras.

You can reserve four image memory pages for special tasks:

Image
Memory
Page

Image memory page reservation possibilities

Acquisition
page

This page is reserved for the image acquisition.

Work page The vision system operates with its image processing algo-
rithms on this page.

Demo page Demos for illustrating the processing are stored during the
image processing on this page. Superimposing takes place
either in graphic colour or with the colours 1, 2 or 3. In both
cases the image contents should not be overwritten. Informa-
tion about turning the demo mode on or off you will find here:
see "Docking Window Video Control Panel", Page 41

Display page The page is displayed on the monitor window or on the control
monitor.

ADVICE
Instead of specifying a page, you can also select "unchanged" or "next page".

If you want e.g. to set only the acquisition page on the next page and do not
change the other pages, you can set the acquisition page on "next page" and
the other 3 pages on "unchanged".

Working with Image Memory Pages

• Separate the acquisition page from the work page to increase the processing
speed of the test programs. Thus, in parallel processing mode (parallel
image acquisition), you can start, for example, an image acquisition (grab
image), and while the image acquisition is using on the acquisition page,
the previously acquired image is processed on the work page.

• Separate between the work and demo page if, e.g., a scene is analysed
under differing illuminations, but the results are only to be displayed in one
image.

Use of Next
Free Page

Description

All on next
page

When using this option, each of the 4 pages are placed on the
next page. 
Use: If there is a defective part in the testing process, the
image of this part remains on the previous image page even if
a new program sequence has already started to run.
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7.2.8 False Colors

Image 69: Dialogue False Colors

With Image > False Colors you can assign specific colours to an image. This
allows a better graphical visualisation with fine nuances.

The main use of false colours is particularly in the area of thermal imaging.
However the algorithm can be applied to every grey value image.

Parameters for RGB-
Mode

RGB-Mode Description

From gray
value

Beginning of the grey scale range.
Example: From gray value "100" equates to the grey value
"100".

Number of
gray values

Number of Grey values starting with "From gray value".
Example: Value of 50 starting with "From gray value" of 100
equates to a grey scale range from 100 to 149.

Color Declaration of the colour that will be assigned to the grey scale
range.

Parameters for HSI-
Modus

The HSI-Colourspace is a specific colour
model, which describes the colour with the help
of hue, saturation and intensity.
The HSI-Mode is applied to all 256 grey values.

Image 70: HSI-Colourspace
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HSI-Mode Description

Hue (H) Declaration of hue e.g.: 0 = red, 42 = yellow, 170 = blue, 255 =
red
This value is assigned to the grey value "0".

Range (dH) Declaration of the colour range that is applied consistently and
equally to all grey values. Starting with the hue you can set the
colour range clockwise or anti-clockwise. It can be either posi-
tive or negative.
The value of hue + colour range is assigned to the grey value
"255".

Saturation(S) Saturation of the colour range, e.g.: 0 = neutral grey, 128 =
slightly saturated colour, 255 = completely saturated pure
colour.
The saturation affects all 255 used colours consistently.

Intensity(I) Declaration of the colour lightness (colourfullness), the total
amount of light passing through a particular area. e.g.: Intesity
of "0" = no light passing (black); Intensity of "255" = full light-
ness.
The intensity affects all 255 used colours consistently.

Example:

Hue (H)= 50; Range (dH) = 100; Saturation (S) = 255; Intensity (I) = 127;

The values are: gray value "0" H = 50, S=255, I=127 and grey value "255" H =
149, S=255, I=127. The colours are applied consistently and equally to all grey
values of the grey scale range.

The resulting colour gradient is shown in the control window below.

Image 71: Dialogue False Colors > Resulting color gradient

7.2.9 Color Binarization

Image 72: Color Binarization before (left) and after (right)

With Image > Color Binarization you convert areas of a color image into a
binary (Black/White) image. Use this command for colored objects, in order
to process them with classical detection procedures. The areas that should
be binarized must contain similar color properties in RGB or HSI format. The
resulting black-and-white binary image contains only black pixels (gray value 0)
and white pixels (gray value 255).
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Work Flow
Define Area of
Binarization

1. Switch to the tab control "Teach-in".

2. Please set here the geometry, size and position of your binarization window.
In this area, your image is converted into a black-and-white image (see also:
"Teaching in Detection Windows and Test Windows", Page 110).

3. If necessary, set the parameters (X Point, Y Point, phi Line) for position
tracking (see also: "Position Tracking of Objects", Page 118).

Work Flow
Parameterizing and
Testing

1

2

3

4

5

6

7

Image 73: Dialog Color Binarization, tab control Parameters

1. Switch to the tab control "Parameters".

2. Please set in the area "Color Range" the parameters for color range,
nominal color and color deviation.
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Parameter Description

RGB Mode/
HSI Mode

Selection whether in the RGB and HSI color space should
be checked.
Use the HSI mode if you want to check the hue or the satu-
ration irrespective of the brightness.

Slider Red,
Green, Blue

If the selection "RGB Mode" is active.
Values of the corresponding color channel.

Slider H, S, I If the selection "HSI Mode" is active.
Values for color (Hue), saturation and intensity.

Tolerance Minimum and maximum tolerances of the respective color
channel.

[Get] The average color of the test window is taken as the default
for the target color.

ADVICE
Using the button [Get]

For best results, go to the tab control "Teach-in", here reduce the
binarization window and place it in a unique color range. Then, go to the
tab control "Parameters" and click the button [Get] to get the values of the
color the of the binarization window.

Then adjust the test window as usual.

3. In the area "Target Color", determine in which binary color the chosen target
color is shown.

Parameters Description

black After binarization, objects with the target color will be
displayed black (gray value 0), the rest is white.

white After binarization, objects with the target color will be
displayed white (gray value 255), the rest is black.

4. In the area "Pages" determine the source and the output page.

Parameters Description

Source Page The image page from which the image is taken for binariza-
tion.

Output Page The image page on which the binarized image is written.

ADVICE
The setting -1 means that the image page that is currently in use, will be
overwritten. You can specify the image page with the command Display
(see also: "Display", Page 138).

For optimum performance, the target page should be different from the
source page. Otherwise, in addition the content of the source page is
swapped from the vision system. This operation requires more time.

5. Testing and setting the appropriate parameters 
By activating the [Test] button the command with the set parameters is
executed. On the source page the corresponding binarized areas are
shown in red. On the output page the binarization is shown in the chosen
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colors. If necessary, change the settings in step 2 until the result meets your
requirements.

6. Evaluation Area
Eventually error messages are shown here.

7. Use the [OK] button to insert the command into the test program.

7.2.10 Color Conversion

Image 74: Color Conversion before (left) and after (right)

With Image > Color Conversion you convert an area of a color image into a
gray scale image. Use this command for colored objects, in order to process
them with classical detection procedures. The areas that should be converted
must contain similar color properties in RGB or HSI format. The resulting gray
scale image contains only black pixels (gray value 0) and white pixels (gray
value 255).

Work Flow
Define Area of
Conversion

1. Switch to the tab control "Teach-in".

2. Please set here the geometry, size and position of your conversion window.
In this area, your image is converted into a gray scale image (see also:
"Teaching in Detection Windows and Test Windows", Page 110).

3. If necessary, set the parameters (X Point, Y Point, phi Line) for position
tracking (see also: "Position Tracking of Objects", Page 118).
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Work Flow
Parameterizing and
Testing

1
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4

5

6
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Image 75: Dialog Color Conversion, tab control Parameters

1. Switch to the tab control "Parameters".

2. Please set in the area "Mode" the parameters for color space to be used.

Parameter Description

RGB- Gray
Conversion

The channels red, green and blue are summed by their
weight.

HSI- Gray
Conversion

The channels hue, saturation and intensity are summed by
their weight.
Use the HSI mode if you want to check the hue or the satu-
ration irrespective of the brightness.

3. Set in the area "Weights" how strongly the individual channels are factored
in the conversion.
For all weights, the sum is formed. Each channel is emphasized so strongly,
as his proportion to the sum.

Parameter Description

Red, Green,
Blue

If the selection "RGB Mode" is active.
Weighting parameters for the channels red, green and blue.

H, S, I If the selection "HSI Mode" is active.
Weighting parameters for the channels of hue, saturation
and intensity.

4. In the area "Pages" determine the source and the output page.
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Parameter Description

Source Page The image page from which the image is taken for conver-
sion.

Output Page The image page on which the converted image is written.

ADVICE
The setting -1 means that the image page that is currently in use, will be
overwritten. You can specify the image page with the command Display
(see also: "Display", Page 138).

For optimum performance, the target page should be different from the
source page. Otherwise, in addition the content of the source page is
swapped from the vision system. This operation requires more time.

5. Testing and setting the appropriate parameters
By activating the [Test] button the command with the set parameters is
executed. On the output page the converted area is shown in gray scales.
If necessary, change the settings in step 3 until the result meets your
requirements.

6. Evaluation Area
Eventually error messages are shown here.

7. Use the [OK] button to insert the command into the test program.

7.2.11 GenICam-Register

With the command Image > GenICam Register you can get access dirctly to
the GenICam register of your vicosys GigE Vision camera.

ADVICE
This command is only for GigE Vision cameras in combination with the vision
system vicosys.

Documents to GenICam registers can be obtained from the respective
camera manufacturer.

Frequently used settings were applied as pre-defined functions (Presettings).

Only one register of a camera is read or written per command.
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Work Flow
Parametrize
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Image 76: Dialog: GenICam Register

1. All cameras connected to vicosys are listed here. Select from the drop-down
list the GigE vision camera to be edit.

2. Set here whether you want to manually change a register or you want to use
a pre-defined function (Presetting). If you choose a presetting, the following
parameters are automatically selected/filled and grayed out.

3. Select here, if the register is to be read or written.
This Option is only active if you choose "No presetting / user-defined" in step
2.

4. Enter here the name of the register.
This Option is only active if you choose "No presetting / user-defined" in step
2.

5. Enter here the type and the value of the register.
The value depends on the choosen register and the access (read/write).

Read

° Enter the type of the register (Integer, Float, Boolean, String,
Enumeration).

° Enter the result number or name under which the value should be stored.
° When using Register type "Float" enter the Multiplier. This determines by

witch value the result is multiplied. Example: Multiplier 10 means that the
result is multiplied by 10.

Write
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° Enter the type of the register (Integer, Float, Boolean, String,
Enumeration, Command).

° Select if the value should be taken from a result/string or from a fixed
value.

° Specify the appropriate value of the register (e.g.: True / False in
Boolean).

° If write a "Float" from Result is choosen, enter the Divisor. This
determines by which value the result is divided. Example: Divisor 10
means that the result is divided by 10.

This Option is only active if you choose "No presetting / user-defined" in step
2.

6. Use the [OK] button to insert the command into the test program.

7.2.12 Camera Lighting

ADVICE
This command is specifically for line pictor T.

Image 77: Dialogue Camera Lighting

Use Image > Camera Lighting to control the internal lighting or the lighting
connection of the pictor T devices.

Input Parameters Parameters Description

Camera Here you can select the camera you want to control/set.
Devices of the pictor T series have only one camara. For this
reason the field is deactivated.

Lighting
Mode

Here you can select the mode of the lighting.

Lighting Modes Mode Status

Lighting off The lighting is always off.

Lighting on The lighting is always on.

Automatic The lighting is generally off and is only switched on for the
period of the image recording (Commands: Crab Image,
Synchronous Flash and Video Mode "Live Image").
This modus is recommended.

ADVICE
With a low lighting load the Automatic mode prevents a high thermal load and
therefore extends the LEDs' service life and saves energy.
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7.2.13 Configure Shutter

Image 78: Dialogue Configure Shutter

Add a command to set the shutter mode and the exposure time in the program
using Image > Configure Shutter. The set values will remain valid until you
actively change them. 

Options Options Description

Switch Off
Shutter Mode

You set the exposure time to 20 ms with this option.

Short Time
Shutter

The exposure lasts for the duration of the image acquisition
command. You should use short time shutter for grabbing
moving test objects.
Exposure Time … Reciprocal value of the exposure time in
seconds (see the table below). For Machine Vision systems
without progressive-scan cameras. The setting is made in the
following steps (Intermediate values are rounded internally to
the nearest value.)

Long Time
Shutter

For vicosys the Long Time Shutter mode is not available.
You should use long time shutter mode primarily for grabbing
weakly illuminated test objects. The image acquisition takes
place over several image acquisition cycles. 
Note: The duration of the image acquisition is determined by
the exposure time entered. It is not necessary to enter the
image acquisition command several times in the program.
Exposure Time … Exposure time in quantity of half frames

Exposure
Time in µs

The exposure is made with the set exposure time. 
Exposure Time  … Exposure Time in µs

Exposure
Time from
Result

The exposure is made with the exposure time read from the
result structure.
Result No. … Result, which contains the exposure time.
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Input Value Exposure Time

10000 1/10040 s

4000 1/4394 s

2000 1/2068 s

1000 1/1005 s

500 1/495 s

250 1/250 s

125 1/125 s

100 1/120 s

Table 4: Exposure time for Short Time Shutter without progressive-scan sensors

7.2.14 Synchronous Flash

Image 79: Dialogue Synchronous Flash

Enter a trigger-controlled image acquisition command with Image >
Synchronous Flash. This command contains the flash signal output and the
synchronization between trigger, flash, and image acquisition. 

If you use the digital I/Os for receiving the trigger impulse, for the flash impulse
output as well as for the start of image acquisition, you can set the delay from
trigger to image acquisition as well as from image acquisition to flash.

Parameters

• Hardware type
• Digital input
• External trigger signal for flash release
• Camera number, acquisition page and output of camera
• Image acquisition signal
• Flash signal
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Time Sequence

Image 80: Synchronous Flash Time Sequence

Advantages of Flash as Compared to Image Acquisition with Shutter and
Continuous Lighting

• The large amount of light, together with control of the flash duration, means
shorter image integration times and hence better acquisition of moving
objects.

• The amount of light required per time unit is lower compared to continuous
lighting.

• The higher light intensity allows an increased depth of field with flash via
stopping-down of the image acquisition optics.

• Better controllability.

Hardware Types - IO ADVICE
Please contact your supplier if you require support for other I/O hardware
types.

Hardware-
type

Beschreibung

PS8 8-way input/output at pictor M ; 4 digital input, 6 digital output.
(lines can be configured individually as inputs or outputs)

DIO4/6 4/6-way input/output port at pictor T-ECAN; 4 digital input, 6
digital output.

DIO4 4-way input/output port at pictor T-SC; 4 digital input, 4 digital
output.

DIO8 8-way input/output port at vicosys; 8 digital input, 8 digital
output.

DIO16 16-way input/output port atvicosys; 16 digital input, 16 digital
output.
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Hardware Types -
Trigger

Hardware
Type

Description

Trigger Fast internal TTL trigger input/output (hardware trigger) of the
camera.

• The input is the image acquisition trigger.
• The output is the flash trigger.
• Available for pictor M16xx, M18xx, and MxxE, as well as

vicosys.
• With vicosys, the “Trigger” hardware type effects the use of

the hardware trigger on the camera. With vicosys, the “Inte-
grate Enable” output (available according to camera type)
must be used directly on the camera with the “Trigger”
setting.

• When using the camera hardware trigger, setting the
trigger-to-image acquisition delay as well as the image
acquisition-to-flash delay is not possible.

sercos The trigger is activated via the sercos 3 fielbus. No additional
output is necessary.

CANopen The trigger is activated via the CANopen fielbus. No additional
output is necessary.

Input Parameters Input Para-
meters for
“Trigger
Signal”

Description

Trigger
Signal

Designation of the input over which the trigger signal is sent.

Timeout This value is given in ms.
Time the system will wait for a trigger signal. If this time
elapses without a signal being recognized, the command is
aborted without an image being acquired. Set a timeout of 0 if
the command should wait indefinitely for a signal.

Delay This value is given in µs.
Delay between the trigger signal and output of the first flash
signal in the list. The delay can be used if, e.g., a delay time is
needed for positioning the object under the camera after the
trigger signal has been generated by a light barrier.

Flash Dura-
tion

Output duration of the flash signal for pictor or vicosys in µs. 
Determines the output level duration of the lighting. (The
Flash Output > Delay field is grayed out.)

Input Para-
meters for
"Flashing
when"

Description

(Low, High,
L->H, H->L)

Status or edge transition of the trigger input which releases the
flash.
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Output Parameters Output Para-
meters
for "Flash
Output"

Description

Delay This value is given in µs.
Image acquisition-to-flash delay.

• Only active when trigger, flash and image acquisition are
controlled via digital I/Os.

• Not valid when controlled via the camera hardware trigger.
• Input is required for the use of flash lighting. The delay is a

camera constant but cannot be neglected.
• Set the value to zero for static exposures.

Duration Flash duration for vicosys in µs

• Can be individually set for each lighting unit of each
connected camera.

• Determines the output level duration of the lighting. (The
Trigger Signal > Flash Duration field is grayed out.)

Output Camera output over which the flash signal is saved.

Output Para-
meters for
"Grab Image"

Description

Delay This value is given in µs.
Trigger-to-image acquisition delay

• Only active when trigger, flash and image acquisition are
controlled via digital I/Os.

• Not valid when controlled via the camera hardware trigger.

Camera Selection of the Camera.

Page Image memory page onto which the image is sent. 
If you wish to configure several image acquisitions for the
same camera, use a separate image acquisition page for
every acquisition.

To ensure reliable
synchronization of
flash and exposure

1. First set a very long shutter time (e.g. 20000 µs) and a shorter flash delay
(e.g. 12000 µs).

2. Shorten the set times in order to achieve shorter process times. 
How much the times can be shortened depends upon the delay time of the
camera and the delay time of the relevant lighting unit.

To edit the image
acquisition list

Enter several sequential image acquisitions in the list if necessary.

1. Specify the output, camera and acquisition page in the drop-down menu
input fields.

2. Edit the entries in the list with the [Insert], [Edit] and [Clear] buttons.
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Tuning Parameters The Tuning parameters enable program time to be saved.

ADVICE
The parameters »Last Image Acquisition« and “Half-frame Mode and Live
Image Mode” are supported by pictor only.

The options for last image acquisition are only active with progressive-scan
camera types: e. g. pictor M1208 … M1856. For older systems (e. g. pictor
1004, 1005, 1006), the program always waits until the image acquisition has
finished.

Tuning para-
meters »Last
Image Acqui-
sition«

Description

Wait until
Image
Acquisition
finishes

After the flash signal has been released, the program waits
until the image has been completely acquired in the image
memory.

Start Only After the flash signal has been released, the program imme-
diately goes on to the next command in the test program.
Advantage: further commands can be processed during the
image acquisition.

“Half-frame
Mode and
Live Image
Mode”
Tuning Para-
meters

Description

The options are active if the functions are supported by the connected
vision system.
Note: The camera must always be calibrated in the mode in which the
image was acquired. The calibration should be made immediately after
the image acquisition.

Half-frame
Mode

In order to save time, only every second image line is
acquired. The acquired image has only half the resolution.
This option is not released for progressive-scan cameras
(pictor M1208 … M1856) – for which a full image acquisition is
always performed.

ADVICE
The mode Area Of Interest can be used by users of multi-camera systems
with the command "Synchronous flash". The AOI is seperately stored for
each camera and is always adopted from the last grab image command.
The Area Of Interest can be set by Image > Grab Image. see "Grab Image",
Page 129
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7.2.15 Video Mode

Insert a command into the test program to switch between live image and
memory image using Image > Video Mode. 

Image 81: Dialogue Video Mode

Options for Vision
Systems

Options for
pictor

Description

Memory
Image

Displays the content of the image memory on the monitor.

Live Image Displays the in realtime received live image. (This is the
fastest mode with the pictor M system.)

Live Image +
Overlay

Displays the live image from the camera and the graphic from
the overlay memory on the video screen.

Live Image +
Grab

Displays the live image from the camera and the graphic from
the overlay memory on the video screen and, at the same
time, acquires an image in the image memory.

Wait for Next
Image

An expert mode for setting the switching of video modes. Use
this option as follows:

• Activate this option in normal cases. The program waits
to change video mode and does not execute further
commands until the last image acquired has been loaded
into the image memory and processed. This introduces
a short delay, but the program is processed more rapidly
afterwards and no further resources are tied up with
processing the image.

• Deactivate the option, if the following commands have to
be executed within a definite time frame or if an older inter-
rupt-controlled sensor is being used.
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7.2.16 Utilities for vicosys

Using Image > Utilities for vicosys, vcwin pro provides the following functions
for use with the vicosys multi-camera system: 

• Multiscreen Mode
• Set Camera Gain
• Sort Cameras
• Set Resolution
• Set Contrast Stretching

Multiscreen Mode Multiscreen Pages top left: Multiscreen Pages top right:

Multiscreen Pages bottom left: Multiscreen Pages bottom right:

Use Multiscreen Mode to display four image pages on the monitor
simultaneously.

Use this function e.g. in the following scenarios:

• To display the images from several cameras on the monitor
• Display the nominal image or the live image and use the other three image

memory pages for continuous display of particular measurement values
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Input Parameters

Input Para-
meters

Description

Activate
Multiscreen
Mode

Option active: vicosys switches to the multiscreen mode. 
Option inactive: vicosys switches to the one screen mode.

Multiscreen
image
memory
pages > top
left

Number of the upper left displayed image memory page.

Multiscreen
image
memory
pages > top
right

Number of the upper right displayed image memory page.

Multiscreen
image
memory
pages >
bottom left

Number of the bottom left displayed image memory page.

Multiscreen
image
memory
pages >
bottom right

Number of the bottom right displayed image memory page.

Setting Camera Gain ADVICE
Set Camera Gain alters the image brightness without changing the image
acquisition time of the camera (shutter). Use this function to shorten the
image acquisition time via increased image brightness. The image quality
may become lower with increased gain.
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Input Parameters

Input Para-
meters

Description

Camera Select the camera that the gain should be applied to.

Gain Gain of the selected camera. The range within which the gain
can be adjusted and the default value both depend on the
camera type, and are read and displayed automatically.

Sorting Cameras Sort Cameras changes the allocation of the connected cameras to the camera
numbers in vicosys.

ADVICE
The vicosys sorts the cameras according to ascending serial number. If a
serial number changes (e.g. through exchange), a new sorting is performed.

Use this function to restore the original sequence after exchanging a camera.
For changing the sequence of the cameras click on the camera number
afterwards click on the arrow buttons to the right for upwards and downwards.

Use

• Insert the command into the test program in order to modify the camera list.
• If the quantity of cameras registered in the camera list and the relevant

serial numbers on the cameras do not correspond to the cameras currently
connected, an error message appears on the screen of the vicosys.

• To read the camera list from the vicosys, click on the [Read] button.
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Parameters

Parameters Description

No. Sorting number of the camera

Serial
Number

Serial number of the camera

Camera Designation and type of the camera

Set Resolution Use Image > Utilities for vicosys > Set Resolution to change the monitor
resolution of the monitor for vicosys .

Use this command to accelerate image display by reducing monitor resolution
(camera image is scaled 1:1, 1:2, 1:3, … ) . On the other hand, the image
quality of high-resolution cameras can be improved by increasing the resolution.

ADVICE
A resolution of 640 x 480 pixels is set initially when the product is delivered.

ADVICE
In order to display an image on the monitor, a set scaling principle is used
by vicosys. This can result in black bars. Scaling is necessary in order to
maintain the 4:3 aspect ratio. A camera with 1280 x 1024 pixel resolution, for
example, is scaled down to 1280 x 960 pixels.

Use
Insert the command in the test program to change the monitor resolution.
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Input Parameters

Input Para-
meters

Description

640 × 480 For the fastest image display

800 × 600 For fast image display

1024 × 768 For medium image quality

1280 × 1024 For best image quality

Reboot This option can only be used by for versions older then
4.16.200. At newer versions the monitor resolution is changed
immediately.
Reboots vicosys standalone. A warning appears on the
monitor before the reboot. After the reboot, the monitor reso-
lution has been changed. It is possible to interrupt the reboot
process through initialization. This is used to be able to inter-
rupt continuous rebooting caused by two contradictory resolu-
tion settings in the start program.
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Set Contrast
Stretching

Use Image > Utilities for vicosys > Set Contrast Stretching to automatically
stretches the grey values of an image.

ADVICE
Use of the eSet Contrast Stretching feature is based on a licence model.

This option is only available for thermo-vision cameras.

Parameters Description

Camera Here are all cameras displayed that deliver imagedata greater
than 8 bit. Select the camera on which you want to apply the
contrast stretching.

Lower
Border

Enter the lower border here. This value is set to the grey level
"0". You can also use a value from a result.

Upper Border Enter the upper border here. This value is set to the grey level
"255". You can also use a value from a result.

A 12-bit camara provides 4095 as an upper border. If you choose 500 as lower
border and 2000 as upper border, all values between 500 and 2000 are scaled
to 8 bit (0-255).

7.2.17 Linescan Camera

ADVICE
In principle, you can connect linescan cameras at the same time to the
vicosys as any other camera types. However, only one line scan camera can
be connected to a FireWire controller.

ADVICE
Only pictor M41EL:

Perform a shading correction before using this command (see "Shading
Correction", Page 78).

Use the command Image > Linescan Camera to integrate lines from a linescan
camera to an image and to store it in an image page.
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Dialogue structure

4

5

1

3

2

Image 82: Dialogue Linescan Camera

Work Flow
Parametrize Camera

1. Settings for the connected linescan camera.

ADVICE
In Mode Endless, the image of the image page has a total height of Lines
per Image Acquisition + Keep Lines per Image.

In Mode Single Image, the image of the image page has a total height of
Lines per Image Acquisition.

The total height of the image must not be larger than the Maximum
number of lines in Mode Change Maximum Resolution of Image Pages.



vcwin pro 2.21
Part 2 - Command Reference

© Vision & Control GmbH
2015

999.994.306.10-en-1.15 163

Parameter Description

Camera Number of the linescan camera that is configured.
Default values of the camera are transferred at the first time
selection.

Image Page Number of the image page on which the recorded linescan
image is stored.

Lines per
Image Acqui-
sition

Mode Endless: Number of lines that are acquired and
attached below the image.
Mode Single Image: Number of lines that are merged into a
image.

Keep Lines
per Image
(only Mode
Endless)

Number of lines that will kept in the taken image. The image
content is pushed up and the new lines are hung down.

X Start X position of the starting pixel of the line. The display is
from that pixel.

Width (max.
4096)

Number of pixels to be read out from a line, starting at X
Start. The value after max. results from the number of pixels
of a line and depends on the camera.

Work Flow
Parametrize Line
Trigger

2. Settings for the triggering of the image acquisition.

Parameter Description

Internal The camera runs based on time as a function of the shutter
value with the maximum possible line rate. The shutter
value can be set with Image > Configure Shutter.

External The linescan trigger input of the camera is used.

Divisor (only
External)

The divisor indicates in which trigger process a linescan
image is taken.

Divisor

• 1 = Each trigger process starts an image acquisition.
• 2 = Each second trigger process starts an image acquisi-

tion.
• 3 = Each third trigger process starts an image acquisition.
• etc.

Work Flow Mode 3. Select the mode of the camera.

Modes

° Change Maximum Resolution of Image Page (Change Resolution)
° Endless
° Single Image

4. Here define the settings for the camera mode.
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Mode Change
Resolution

Image 83: Dialogue Linescan Camera: configuration window Change Maximum
Resolution of Image Pages

Change Maximum Resolution of Image Pages

• The maximum width of the image page corresponds to the maximum width
of the connected cameras.

• To change the maximum height, enter the new height of the image pages
under Maximum number of lines. The new maximum number of lines is
assumed only after the system restarts.

• Reboot vision system.

vicosys:

° Activate the checkbox Reboot vicosys.
° The device will reboot if the set line number in the command does not

correspond to the set line number in vicosys.

pictor M41EL:

° Execute the command with [OK].
° Go to the "Communication" menu and start the command "Save File

System in Flash".
° Start the pictor manually (interrupt the operating voltage supply).

Mode Endless

Image 84: Dialogue Linescan Camera, configuration window for Mode Endless

• All-over detection of image lines. (E.g.: for infinite materials processing).
• For the mode Endless, the command must be inserted twice in the test

program.
• The command with the option Start Image Acquisition, must be called once

at the start of the program. With this Option you start the endless mode. Now
linescans are acquired continuously in the background. In parallel, the test
program is further executed.
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• The command with the option Wait For Image must be in a loop. Start
Image Acquisition stores the lines in the camera. If the specified number
(Lines per Image Acquisition) is reached, the image is stored by the vision
system in the defined Image Page. Then test functions can be performed on
the image.

Parameter Description

Timeout Waiting time for the image before the command is termi-
nated without an image acquisition.
A timeout of 0 means infinite waiting.

Execu-
tion Status
(only pictor
M41EL)

Result number for status and error messages of the
command.

• The command with option Stop Image Acquisition stops the endless
acquisition.

ADVICE
For vicosys:

If more lines are recorded by the camera than can be processed by the vision
system, an error message is displayed on the monitor output (VGA or DVI) of
the vision system on the screen.

For pictor M41EL:

If more lines are recorded by the camera than can be processed by the vision
system, the vision system writes 4 in the result (Execution Status) and runs
Stop Image Acquisition.

Mode Single Image

Image 85: Dialogue Linescan Camera, configuration window for Mode Single Image

• In Single Image mode, you integrate a defined number of lines into a image
and store them in an image page.

• With the option Immediately the image acquisition starts immediately.
• With the option Camera Trigger the image acquisition starts with the

activation of the trigger input of the camera.

Parameter Description

Timeout Waiting time for the image before the command is termi-
nated without an image acquisition.
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• With the option Digital IO the image acquisition starts with the activation of
the adjusted digital input. In parallel, a lighting or similar can be switched for
any given time via a digital output (OUT) connectors.

Parameter Description

Input Specification of the digital input for the trigger signal for
imaging acquisition.

Output Specification of the digital output for the trigger signal for
lighting control or others.

Start Image
Acquisition
when Input
Status...

State or edge transition of the trigger input for starting
image acquisition.

Timeout (ms) Waiting time for the image before the command is termi-
nated without an image acquisition.

Exposure
Delay (µs)

Delay between trigger signal and image acquisition. Use
the Exposure Delay, if for example after the generation of
the trigger signal for a flash of light you have to wait until the
light reaches its maximum.

Flash Delay
(µs)

Delay between trigger signal and the flash signal. Use the
Flash Delay, if for example you have to wait a moment
after the generation of the trigger signal by triggering a light
barrier until the object is positioned under the vision system.

Flash Dura-
tion (µs)

Indication of the duration of the output level.

5. Use the [OK] button to insert the command into the test program.

Status and error
messages

0 = No Errors

• The command was successfully executed.

1 = Timeout

• The timeout in Endless mode with Wait For Image was achieved.
• The timeout in Single Image mode with Camera Trigger or Digital IO was

achieved.
• Increase the timeout for the image acquisition. Enter a timeout of 0 if the

command has to wait endlessly.

2 = Invalid Parameter

• At least one parameter is invalid.
• Check the settings of the command. Check that the used mode of the

command is supported by the vision system used.

3 = Selected camera is not a linescan camera

• In the dialogue under point 1 Camera Options -> Camera, select a linescan
camera.

4 = Error during image acquisition

• The processing time of the image processing functions in the loop takes
longer than the recording time of the required quantity of lines (Lines per
Image Acquisition).

• Optimize the processing of the image processing functions.
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5 = Tried to capture a endless image while not in endless mode

• In Endless mode, the option Wait For Image was performed, without starting
before Start Image Acquisition.

• Enter the command with mode Endless and the option Start Image
Acquisition at the start of the program.

6 = Error while initializing camera

• Check whether the line camera is connected correctly and is supplied with
operating voltage.

7.3 Locate Commands

7.3.1 360° Pattern Search

Overview
Teach-in Window

Search Window

Image 86: 360° Pattern
Search - taught-in pattern

Search Window

Image 87: 360° Pattern
Search - taught-in pattern is
detected

Search Window

Image 88: 360° Pattern
Search - rotated pattern is
detected

With Locate > 360° Pattern Search, you can locate objects in the image.

In addition to the position, the angular position
is determined in relation to the initial taught-in
pattern. The command autonomously deter-
mines the angular position in relation to the
pattern. Searching takes place in multiple
phases, first as a rough search and then as
a detailed search in a higher resolution. Use
the command to find and classify one or more
rotated objects.

0°

90°-90°

-180°

ADVICE
There are only nominal number + positive tolerance + 1 objects searched
and stored, even if more objects that match the pattern are available.

Work Flow: Teach-in
Pattern

1. Switch to the tab control "Teach-in Pattern".

2. Determine, by means of the geometry rectangle, which image content has
to be read as the pattern. (Information for teaching, see also: "Teaching in
Detection Windows and Test Windows", Page 110)

3. With the button [Read Pattern] you read-in all image information located in
the geometry as the pattern, and stored it internally in the command.

4. In the reference window, verify if the pattern is complete.
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ADVICE
For the 360° pattern search you can also use patterns that are stored on the
vision system. These must be stored by using the command Locate > Save
Pattern (see "Save Pattern", Page 226). In this case, no pattern must be
learned. The pattern can be selected in the tab control "Parameters".

Work Flow: Define
Search Area

1. Switch to the tab control "Search Window".

2. Please set the geometry, size and position of your search window. In this
area, your pattern is searched (see also: "Teaching in Detection Windows
and Test Windows", Page 110).

3. If necessary, set the parameters (X Point, Y Point, phi Line) for position
tracking (see also: "Position Tracking of Objects", Page 118).

Work Flow:
Parameterizing and
Testing

1

12

3

4

6

8

10

11

5

2

7

9

Image 89: Dialog 360° Pattern Search, tab control Parameter

1. Switch to the tab control "Parameters".

2. Determine in the area "Pattern Source" whether a pattern should be taken
from a file or the taught-in pattern.

3. Here you specify the accuracy of the search method using a sliding
controller.

The finer the accuracy is set, the better fine-structured objects or patterns
will be found. A coarser search by comparison requires less processing time.

Find the optimum setting by trying out different levels of fineness and
observe the corresponding resolutions in the dialog to the right in the area
"Pattern Source" tab Pre-Search/Fine Search/Original. The search
accuracy setting should also be verified with different rotation positions of the
pattern.
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The search algorithm begins its calculations on a very coarse image and
tracks the pattern found up to here up to a certain point in a somewhat finer
image. With a very fine setting the position found is then pixel-accurate; with
a coarser one the corresponding position can, however, only be determined
in specific increments. The processing time, however, is significantly reduced
because of the lower data volume.

Parameter Description

Pre-Search Specifies the degree of precision for the first search phase
in the search window.

Fine Search Specifies the degree of precision when searching for the
pattern in the second search phase.

Pixel Preci-
sion Position
Correction

If you activate this checkbox, with a successful pattern
search a pixel-accurate search of the respective x/y position
is performed. You receive a precise position value for the
object found.

4. Configure search angle and angle range

You can provide the angle range here in which the pattern is to be found.
This means, for example, that an object is only detected in a specific
rotation position or it can only be fed into the test in a specific test process-
conditional rotation position. As all possible positions and angles of rotation
of the pattern are searched for in the image with the pattern search, the
amount of possible combinations plays a decisive role for the processing
time. With twice as big a search angle range, you therefore generally get
twice the processing time. Furthermore with circular- symmetrical objects the
pattern must also be found in a complete 360° search, which the following
example explains.

Image 90: Angle Range
of a symmetrical object

The red angle range is symmetrical to the blue angle
range. As the object consists of 16 such areas, a
search must now only be made in the angle range
360°/16 = 22.5°. The processing time decreases
significantly.

Parameter Description

From: - To: Specifies the angle search area in which the pattern is
searched for.

Step Specifies the angle step increment with which the search
steps are to be carried out.
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5. Object Options

Parameter Description

May exceed
search range

If you activate this checkbox the object may exceed out of
the search area with up to 25% of its area and is still found.
This is especially beneficial with the possibility that test
objects under certain circumstances are not always within
the search area because of position instability or inaccu-
rate provision. This setting, however, means a longer test
method processing time.

Allow
mirrored

Also mirrored objects are found.

Check
contrast

Has a detrimental effect on the level of correlation if the
contrast deviates considerably from the contrast in the
taught-in pattern.

6. Grade of Match

You can enter the level of similarity that must be achieved with the pattern
comparison here, so that the pattern is marked as found and the tracking
was successful. The entry is in percentage and should not be selected too
low. Values of more than 75% are proven settings in everyday industrial
work.

Parameter Description

Min.: Minimum level of correlation, in per cent, for the found
pattern to the taught-in pattern in order for a pattern to be
processed as a valid pattern.

7. Number of patterns found

Here you can enter the number of patterns to be found. Only the maximum
target number (plus tolerance) + 1 object is sought and found, even if more
objects that match the pattern are available.

Parameter Description

Only first
match

Only the first object found, according to the sort sequence,
will be evaluated.

Nominal Number of objects that should be found, so that the
command is considered successful.

+/- Permitted upward and downward deviations from this target
value.

RES: Result number/name in which the number of patterns found
is to be saved.

8. Sort Order

Parameter Description

Grade of
Match

Objects are sorted by their grade of match.

Direction Objects are sorted by their position in the image (according
to the specified sequence).

9. Here you can configure the settings for storing the results.
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Parameter Description

Image/World Saves the pattern’s center of gravity and the angular posi-
tion line in image coordinates or world units.

Point From this point, the positions of the objects found will be
saved.

Line From this line the angular position lines found will be saved.

Angle From this angle the rotation angles found will be saved.

Mirrored From this result the values for classify a mirrored object will
be saved. (0 = not mirrored, 1 = mirrored)

Grade of
Match

From this result the grades of match will be saved.

10.Result Patterns Found

After activating the [Test] button, all patters found are list in the area
"Patterns Found" depending on sort. Only the maximum target number (plus
tolerance) + 1 object is sought and found, even if more objects that match
the pattern are available. In parallel, the patterns found are highlighted in the
video image with a red cross as a position and a red arrow (angular position
line). Use the arrow keys to scroll through the respective matching pattern.

11.Evaluation Area

Here you can see the good/bad evaluation of the command, notes for
parameterization (tolerance range exceedance) as well as error messages.

12.Use the [OK] button to insert the command into the test program.

7.3.2 Blob Analysis

Overview A blob (Binary Large Object) is a group of adjacent and contiguous pixels with
the same or similar grey values.

Search Window

Image 91: Blob Analysis - a
dark blob found

Search Window

Image 92: Blob Analysis -
three bright blobs found

Search Window

Image 93: Blob Analysis - a
dark and three bright blobs
found

With Locate > Blob Analysis you include a command for finding the center
of gravity and area of planar areas of equal gray value within the image. You
can save up to 50 the center of gravitys and areas in the points and results
structure. Center of gravitys and areas in excess of 50 are not evaluated. You
use the command to count objects, to find objects or for position tracking.

Work Flow: Teach-in 1. Switch to the tab control "Teach-in".

2. Here you can determine, by means of the geometry rectangle, in which area
the image content has to be analysed. (Information for teaching, see also:
"Teaching in Detection Windows and Test Windows", Page 110).
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3. If necessary, set the parameters (X Point, Y Point) for position tracking (see
also: "Position Tracking of Objects", Page 118)

4. Use the [Test] button to check whether the blobs are found in the detection
window with the default parameters.

Workflow: Define
Parameters 1

2

3

4

8

9

5

7

6

Image 94: Dialog Blob Analysie, tab control Parameters

1. Switch to the tab control "Parameters".

2. Set in the "Object Properties" the conditions for the threshold of the binary
detection and the allowable area (number of pixels) of the objects to be
searched.
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Parameter Description

Threshold Grey value threshold for detection and separation of the
objects.

Min./Max.
Area

States how many pixels the objects have to encompass in
order to be detected. Objects with more or fewer pixels are
ignored.

Colour Light: Only parts of the image will be assigned to the
objects that are within of the specified gray value range.
Dark: Only parts of the image will be assigned to the objects
that are outside of the specified gray value range.
Light and Dark: Parts of the image will be assigned to the
objects that are within and outside of the specified gray
value range.

Automatic Mark this option in the case of a clear division into bright/
dark objects. The threshold is automatically defined during
execution.

[Teach-in] Using the [Teach-in] button you automatically determine the
gray value distribution of the threshold, the area, the color
and if declared the roundness. The minimal and maximal
area is determined from the area of the largest object and
the tolerances ±25%.
After teaching, you can optimize the parameters and the
search window manually.

3. Determine here the parameters for roundness.

Parameter Description

Check The Checkbox activates roundness testing for individual
blobs.

Nominal Range, within the roundness of all the blobs must remain. A
nominal roundness of 100 is a perfect circle.

Tolerances Permitted upward and downward deviations from the
nominal roundness.

4. Here you set the nominal quantity of objects to be found. If the number of
objects found lies within this range, the command ends with a good result
(otherwise with bad).

Parameter Description

Result Result number/name for saving the number of objects
found.

Nominal Number of objects that should be found, so that the
command is considered successful.

Toleraces Permitted upward and downward deviations from the
nominal number.

5. Save Center of Gravity and Area
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Parameter Description

From Point From this point, the centre of gravity of the objects found
will be saved.

From Res From this result in the result structure the area of the
objects found will be saved.

Image/World This radio button determines whether the storage of points
and areas are in image or world coordinates.

6. Save Roundness and Object Contour

Parameter Description

From RES From this result in the result structure the roundness of the
objects found will be saved.

From Contour From this contour in the contour structure the contour of the
objects found will be saved.

7. After activating the [Test] button, all objects and its parameters found
are listed in the area "Objects Found". In parallel, the objects found are
highlighted in the video image with a red rectangle and a red cross (centre of
gravity).

8. Evaluation Area
Here you can see the good/bad evaluation of the command, notes for
parameterization (tolerance range exceedance) as well as error messages.

9. Use the [OK] button to insert the command into the test program.

Result No. Number of the current object.
X X coordinate of the center of gravity of the

current object.
Y Y coordinate of the center of gravity of the

current object.
Area Areas in pixels or world units.
Roundness Roundness of the current object.
Quantity Number of objects found.

Example
Test Window

Located objects (Center of
gravity is tagged with a cross)

Image 95: Video image: blob analysis with 5 located objects
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7.3.3 Data-Matrix Code

General Vision systems of Vision & Control GmbH are able to read Data-Matrix code
with different moduls. One differentiates between standard variants and an
extended variant. Both modules are accommodated in a dialogue.

Standard Reader
Software

Image 96: Dialogue Data Matrix Code, tab
control Parameters

Use the Locate > Data-Matrix Code command in the test program to read
Data-Matrix Code according to the ECC200 specification. 

Always orientate the code perpendicular to the camera:

Align the Finder Pattern (L) to the bottom-left.
Align the Alternative Pattern (frequency line) at the top-right.

During the evaluation, not only the index but also all the coded information is
read and can be saved as necessary. The command functions according to the
error handling algorithms specified by the ECC in order to ensure the highest
data security.

Use this command for data acquisition if the test program should take over the
tasks of de-encrypting the Data-Matrix code and the associated tasks.

Brief Guide 1. Define the position tracking in the Teach-in tab: no, X point, Y point.

2. Activate teach-in mode by double-clicking with the right-hand mouse button.

3. Change the size and position of the search window in the video image with
the controls. The search window must enclose the Data-Matrix code.
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4. Deactivate teach-in mode by double-clicking with the right-hand mouse
button.

5. Modify and test the read parameters in points 1-4 above according to the
read mode selected.

6. Insert the command into the test program with the [OK] button.

Teaching-in the Test
Window

The search window must enclose the code symbol.

Position and Appearance of the Test Window

After double clicking with the right mouse button on the Teach-in tab, you can
position and adapt the test window on the control monitor or on the monitor
window. 
>> "Teaching in Detection Windows and Test Windows", Page 110

Tracking the Position

The test window can either always remain at the same image position or follow
a reference object. 
>> "Position Tracking of Objects", Page 118

Specification of the
Data-Matrix Code

The Data-Matrix Code must comply with the ECC200 specification and
correspond to a data area and a maximum size of 26 × 26 (88 numeric
characters, 63 alphanumeric characters). The symbol cells displayed in the
video image must be at least 5-6 pixels in size. Moreover, the search window
must be bordered by at least a third of the code size as margins, so that the
code can be detected cleanly. Small variations in the angle of rotation are
tolerated up to 45°.

The following code conversions are supported:

Specification according to ECC200 Max. figures and charac-
ters contained

Row/
Column

Data Bytes Error
Bytes

ECC % Numeric Alphanu-
meric

10 x 10 3 5 62.5 6 3

12 x 12 5 7 58.3 10 6

14 x 14 8 10 55.6 16 10

16 x 16 12 12 50.0 24 16

18 x 18 18 14 43.8 36 25

20 x 20 22 18 45.0 44 31

22 x 22 30 20 40.0 60 43

24 x 24 36 24 40.0 72 52

26 x 26 44 28 38.9 88 64

Read Parameters for
the Different Modes

ADVICE
For time-critical applications we recommend the Quick Read or Standard
Read modes.
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ADVICE
If invalid values are inserted in the parameters, the vision system reverts to
the standard default values.

The following read modes are available:

• Standard Read
• Quick Read
• Automatic
• Read with standard parameters

The read modes differ in which parameters should be manually adjusted
or determined by the user and which are automatically preset by the image
processing system.

How the parameters can be set in the different read modesParameters

Standard
Read

Quick Read Automatic With Stan-
dard Parame-
ters

Demo Can be
enabled

Can be
enabled

Can be
enabled

Can be
enabled

Matrix Prop-
erty
Module Size,
Matrix Size,
Black/White

Preset values are modified via
dialog or determined from the
[Teach-in] button.

Not
adjustable:
The system
determines
the value
automatically.

Not
adjustable:
The system
determines
the value
automatically.

Matrix
Search Para-
meters
Search
Threshold,
Frequency
Recognition
Value, Edge
Threshold

The preset values can be modified via dialog. Not
adjustable:
The system
uses the stan-
dard default
values.

Module Para-
meters
Module
Stamping,
Frequency
Line
Threshold

Not
adjustable:
The system
uses the stan-
dard default
values.

The preset
values can be
modified via
dialog.

Not
adjustable:
The system 
uses the stan-
dard default
values.

Not
adjustable:
The system
uses the stan-
dard default
values.

Module Para-
meters
Module
Recognition
Threshold,
Test Size in
Pixels

The preset
values can be
modified via
dialog.

The preset
values can be
modified via
dialog.

The preset
values can be
modified via
dialog.

Not
adjustable:
The system
uses the stan-
dard default
values.
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Parameters 
»Matrix Prop-
erty«

Description

Module Size 16 [(10 × 10) to (26 × 26)]

Matrix Size
dX/dY

100 × 100 [(90 × 90) to (330 × 330)]

Colors Black [Black/White]

Button
[Teach-in]

Determine Data-Matrix size, module size and color via teach-
in mode in the dialog box.

Parameters 
»Matrix
Search Para-
meters«

Description

Search
Threshold 
4 [1 to 100]

Threshold for searching for the position of the code. 
The program only gives the Data-Matrix Code if the actual
threshold lies below the threshold set.

Frequency
Recognition
Value
7 [4 to 20]

The number of detection beams per module point on the
frequency line. 
Higher values can increase the detection accuracy if required.

Edge
Threshold 
40 [5 to 200]

Threshold for detecting the L side. 
Smaller values can increase the contrast if required, larger
values can reduce interference.

Parameters 
»Module
Parameters«

Description

Module
Stamping %
X/Y 
100 [50 to
130]

The size of the area of the module points in relation to the
area of the gaps on the frequency line. 
Module Stamping becomes smaller if the area of the module
points is reduced compared with the area of the gaps.

Frequency
Line
Threshold 
10 [1 to 200]

Detection from the opposite side to the L side. 
Reduce values when poor contrast or increase when there is
interference, as required

Module
Recognition
Threshold 
50 [0 to 100]

Influences averaging of all module gray scale values from their
pixels. 
50: Mean value 
>50: If the light module points are smaller than the dark ones 
<50: If the dark module points are smaller than the light ones

Test Size in
Pixels 
1 [1 to 10]

Number of pixels per module
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Evaluation Parameters Parameters Description

Result String Result no. for saving the text read.

Result
for No. of
Corrections

Result no. for saving the no. of corrections.

Search
Threshold
Result

Result no. for saving the search threshold.

Edge
Threshold
Result

Result no. for saving the edge threshold.

Test Clicking on Test displays the recognized parameters in the display field.

Parameters Description

Read Text Detected content of Data-Matrix Code

Search
Threshold

Values determined by program

Medium
Edge
Threshold

Values determined by program

No. of
corrections

Values determined by program

Button [Test] Execution of Data-Matrix decoding

Button
[GrabImage]

New image acquisition

Advanced Read
Function

Image 97: Dialogue Data Matrix Code -
Advanced, tab control Parameters

Image 98: Dialogue Data Matrix Code -
Advanced, tab control Advanced Read
Function

To use the advanced functionality please activate the checkmark Advanced
Read Function.
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Brief Guide • Define the position tracking in the Teach-in tab: no, X point, Y point.
• Activate teach-in mode by double-clicking with the right-hand mouse button.
• Change the size and position of the search window in the video image with

the controls. The search window must enclose the Data-Matrix code.
• Deactivate teach-in mode by double-clicking with the right-hand mouse

button.
• Change register to Advanced Read Function
• Please test the data matrix code with the button Automatic
• Insert the command into the test program with the [OK] button.

The use of the extended Data-Matrix Code software is based on a license
model. They can test your code in register Extended Read Function with the
button Automatic before you buy a license. With acquisition of the license
afterwards also all other modes (Parameterisation) of the extended read
function are to you at the disposal.

Teaching-in the
Search Window

The search window must enclose the code symbol.

Position and Appearance of the Test Window

After double clicking with the right mouse button on the Teach-in tab, you can
position and adapt the test window on the control monitor or on the monitor
window. 
>> "Teaching in Detection Windows and Test Windows", Page 110

Tracking the Position

The test window can either always remain at the same image position or follow
a reference object. 
>> "Position Tracking of Objects", Page 118

Specification of the
Advanced Read
Function software
modul

The extended Data-Matrix Code software reads ECC200 specified code. The
symbol cells (modules), represented in the video picture, must be large at least
2-3 pixels. The algorithm tolerates the following general features:

• 360° rotation invariant codes
• Code sizes of 10 to 90% of the image size
• Codes with a module number from 8 to 144 (2335 alphanumeric characters)

for square code and from 8 x 18 to 16 x 48 (72 alphanumeric characters) for
rectangle codes

• Reads nailed, cut and dotted codes

Further the module offers extended features.

• Complete automatic mode without any parameters
• Fast algorithm detects and reads codes with up to 150 fps
• Reading of mirrored codes
• The “L” corner can be covered (not visible)
• The “L” pattern can be partly destroyed
• The frequency lines can be partly destroyed (to about 20%)
• The algorithm is robust towards distorted and sheared codes
• Evaluation of the code's print quality according to ISO/AIM DPM (>>

"Evaluating the print quality", Page 392)
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Description of the
registers

Register Description

Parameter Options for parameterising the software module, the change-
over between standard and extended software as well as the
test and expenditure part.

Teach-In Options for the configuration of the teach-in window.

Advanced
Read Func-
tion

Description of the codes, which can be read by the software,
the demo part, as well as the license part to activate the
extended software.

Read modes Automatic Parameter-free reading from Data-Matrix Code without
previous knowledge by the user - fast decoding of high-
quality, printed codes

Standard
Read

Parameter dependent read function

Read Several
Codes

The command reads all codes found in the image and saves
the content into different strings.

Teach Mode Teach in mode makes it possible to train a Data-Matrix Code
samples. This sample wil be decoded in the automatic mode
and all corresponding parameters of this individual code will
be stored in a parameter list. At this point such codes with
similar characteristic can be read very fast.

• Code size varies from +20% to - 20%
• Similar number of modules
• Similar module size
• Similar module proportion (lenght-wide ratio)

The stored parameters can be manually refined afterwards.

Parameter description Parameter Description

Module Size Adjust the module size for the code which can be read of 8
to 144.

Matrix Size Definition of the size of the data matrix code in pixels.

both The algorithm seeks for black modules on bright back-
ground as well as white modules on dark background.

black The algorithm seeks for black modules on bright back-
ground.Colour

white The algorithm seeks for white modules on dark back-
ground.

Shape The form can vary between square and rectangular. The
option any looks for both forms in the picture.

any The algorithm seeks for mirrored and non-mirrored codes.

no The algorithm seeks for non-mirrored codes.Mirrored

yes The algorithm seeks for mirrored codes.
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Parameter Description

Min. Aspect Ratio

Defines the maximal proportion of opposite lines in
percent. 50% means, that at opposite lines (sides of the
code) the smaller line (b) should be at least 50% of the
longer line (a).

Min. Line Ratio Defines the maximal proportion of neighbour lines ("L") in
percent. 20% means, that at neighbour lines the smaller
line should be at least 20% of the longer line.

Size Variation The deviations in per cent from the matrix size dx and dy.

Max. Deviation
from Edge Angle

The angle of everyone of the 4 data matrix corners should
lie in a range from 90°. The maximum deviation (Shearing)
amounts to thereby 45°.

Cell Size The minimum and maximum size of a cell indicates in
pixels. It can be appropriate between for min. 1 and max.
50.

Module Recogni-
tion Threshold

It takes a module probe colour in percent (0% = darkest
colour / 100% = brightest colour).

Zoom Factor for
Search in Pixels

This parameter means which zoom shot factor is to be
used for finding the code in the image. It can be appro-
priate between min. 1 and max. 4.

Zoom Factor for
Read in Pixels

This parameter means which zoom shot factor is to be
used for reading the code in the image. It can be appro-
priate between min. 0 and max. 4.

Filter for Matrix
Cell

Use of a Closing filter for preprocessing the image infor-
mation. This function needs the choice of a colour (black,
white). Otherwise the algorithm does not know, in which
direction (colour) it shall work.

Noise reduction Reduces background image noise. Values between 5
(slight/minimal noise) and 35 (strong noise) are possible.

ADVICE
The matrix characteristics can be determined by the software automatically. In
addition you press the button Teach-in in the extended read function (register
Parameters).



vcwin pro 2.21
Part 2 - Command Reference

© Vision & Control GmbH
2015

999.994.306.10-en-1.15 183

Use from results

Different parameters can be determined out of results. Please note, this mode
needs a result for everyone of the following parameters.

• Module Size
• Matrix Size
• Colour
• Shape
• Mirrored
• Min. Aspects Ratio
• Min. Line Ratio
• Cell Size min./max.
• Zoom Factor for Search in Pixels
• Zoom Factor for Read in Pixels

Output parameters Parameter Description

Read Text Expenditure of the decoded text in the dialogue.

Number of
Corrections

Number of accomplished corrections for decoding the Data-
Matrix Code.

Test Button for executing the software module.

Grab Image Button for grabbing an image of the sensor into the current
image memory page.

Code Number Result number for the storage of the number of codes.

String from Result number for the storage of the read text.

No. of Correc-
tions from

Result number for the storage of the corrections.

Print Quality Radio buttons with the options "none", "ISO 15415" and "AIM
DPM-1-2006" for selecting a standardised print quality evalua-
tion for the Data Matrix Code. 
Note: For evaluating the print quality according to one of the
guidelines, you should use the corresponding lighting defini-
tion for the respective guideline.

[Print Quality]
From Result

First result number for saving the results of the individual print
quality parameters.

Error display Error Description

No errors No error was determined.

Error in
module size

Use of invalid parameters.

No Data-
Matrix Code
found

No Data-Matrix Code could be found in the image.



vcwin pro 2.21
Part 2 - Command Reference

184 999.994.306.10-en-1.15 © Vision & Control GmbH 2015

7.3.4 Angular Position

Image 99: Dialogue Angular Position, tab
control Parameters

The Locate > Angular Position command determines a structure's angle of
rotation. This structure must be taught previously. An angle and a straight line
can be saved. The given angle is relative to the taught object with a proportion
of 1/100°. The straight line is used for further processing, and is called phi-
straight line.

ADVICE
To compensate for noise in the radial direction, increase the width of the
arc. In this way you determine the average of the gray values of several
concentric rings. To accelerate processing, lessen the width of the arc.

Teaching-in the Test
Window

ADVICE
A center or focal point must be defined in order to update the window.
Otherwise measurement errors may result. If no tracking must be carried
out, the object may only be rotated and not moved in the X or Y directions.
Otherwise, measurement errors arise due to position variations.

Position and Appearance of the Test Window

After double clicking with the right mouse button on the Teach-in tab, you can
position and adapt the test window on the control monitor or on the monitor
window. 
>> "Teaching in Detection Windows and Test Windows", Page 110

Tracking the Position

The test window can either always remain at the same image position or follow
a reference object. 
>> "Position Tracking of Objects", Page 118
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Input Parameters You can teach-in an object in the video image with the [Teach-in Angular
Position] button. After this, set the grade of match. If the preset grade of match
is not reached during the detection then the command is unsuccessful.

Parameters Description

Grade of
Match

Minimum required gray value compliance (correlation) of the
determined gray value distribution with the nominal gray value
distribution along the circular ring-shaped detection window for
teaching.

Features of Grade of Match:

• Indicates to the compliance, which exists after the internal rotation of the
determined gray value distribution .

• Is set directly and must be varied if the test is unsuccessful.
• Is not influenced by the brightness in the test window.
• Is stated in per cent, 100% means exact compliance, 0% means no

compliance.
• Useful settings are 60 to 80%, even 95% under good illumination.

Evaluation Parameters Angular
Position
(1/100
degree)

Description

Result Result number for saving the determined angular position
(1/100 degree).

Nominal and
Tolerances

Nominal angular position and the permitted ± tolerances. Set
suitable parameters interactively with the aid of the [Test]
button. 
For technical reasons, tolerances cannot exceed 32768 in
value (corresponds to 215). The tolerance range is from
+32767 to –32767. 
The angular position in the first half circle is from +90° to -90°
clockwise and further from -90° to +90°. 
The value given by the program should be divided by 100 to
maintain the correct angle in degrees (°). This division factor
should also be used when superimposing. 
Examples: 9000 corresponds to +90° / –9000 corresponds to
-90°. See Diagram for angle specifications under the table.

Offset Offset for the angular position (1/100 degree). If the object
already had an initial rotation during the image acquisition, the
offset can be added in order to relate the determined angular
position to the X or Y coordinate.

ADVICE
The straight line with a 0° angle is defined as a parallel to the X axis through
the circle center.
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Angle value:

Angular
Position Line

Description

Line Line structure number for saving the line through the central
point of the circular detection ring which has been rotated to
the determined angle of rotation to the x-axis. If you select {-1}
or {nd}, the data will not be stored.

Co-ordinate
system

Description

Image/World Storing the lines in image coordinates or world coordinates 
In contrast to angular position tracking for detection beams
and test windows with the help of a pre-defined line, this is
concerned with the determination of angular position of an
object as a location parameter for gripping by robot and posi-
tioning systems. 
An angular position tracking is only required, as a rule, in the
range between ± 90° and – as the direction of the line used
is not defined – is also not possible outside this range. For
the employment of pictor /vicosys within a robot system it is
essential to be able to recognize the rotary angle of an object
over the range of 0° to 360°.

Rotary Angle
Detection Without
Use of the Angular
Position Command

The following section describes how to determine the angular position in a
range of 0° to 360° without using the Angular Position command, and by
conventional means. You calculate the angle of a line with two clearly defined
points.

In the case of objects with a clear line which can be determined through two
points, the angle of rotation can be determined as an angle between 2 points on
the X and Y axes. The direction of the line is defined from point P1 to point P2.
In this case, one obtains an angle between –180° and +180°.
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In order to obtain the angle in the other range (e.g. 0° to 360°), the angle value
determined must be added to a specific offset.

The angle between a line and an axis lies in the range from –90° to +90°
because the direction of the line is not defined.

The line through the two circle center points is used to determine the angular
position of the above object.

Procedure

1. Acquire image.

2. Determine the center point of circle 1 by blob analysis for the objects with the
surface in the area of the circle.

3. Determine the center point of circle 2 by blob analysis for the objects with the
surface in the area of the circle.

4. Determine the angle between P1, P2 and x-axis, nominal angle 0°, tolerance
(0/+180°).

5. If successful, jump to step 7.

6. Add 360° to the angle (in order to convert from a negative angle in the value
range 180° to 360°).

7. Insert a command to superimpose or send the angular position to the host
computer.

Rotary Angle
Detection with the
Angular Position
Command

The following section describes how to determine the rotary angle using the
Angular Position function.

For objects in which no clear lines can be defined, the rotation can be
determined with the Angular Position command. The requirement is a
homogenous background.

Procedure

Determine the angle of rotation of the object at the time of testing compared
with the time of teaching as follows:

1. Acquire image.

2. Determine the center point of contour of the object during teaching by
Blob Analysis or by combining Locate Contour and Center of Gravity of
Contour.

3. Specify the nominal gray scale value distribution along an annulus around
the contour focal point with the Angular Position command: During the
test, the determined gray value distribution is compared with the nominal
gray value distribution along a circular ring around the center point of the
contour. In this, the angle of rotation is determined by an internal correlation
calculation.
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4. Insert a command to superimpose or send the angular position to the host
computer.

The rotary angle to the determined axes is obtained by adding a defined offset
in the Angular Position command. The circular ring diameter must be selected
so that the angular position can be clearly determined during teaching.

Test The determined angular position (1/100 degree) and the grade of match are
displayed in the test.

7.3.5 Rotation based on Moments

Overview
0°180°

90°

Image 100: simple rotation
detection 180°

0°180°

90°

-90°

Image 101: advanced rota-
tion detection 360° with
extensity display

0°180°

90°

-90°

Image 102: advanced rota-
tion detection 360° result

With Locate > Rotation based on Moments you can locate objects very fast in
the image and determine its angular position. The object is found by its specific
brightness distribution (moment). The command is only suitable for scattered
objects in high-contrast images.

The test object must have a clear axis of inertia (long, straight, narrow test
parts).

For the advanced rotary position sensing, the eccentricity (expansion along the
axis of inertia) is considered to determine the location from 0° to 360°. The test
object should be wider on one side.

Workflow
Teach-in

1. Switch to the tab control "Teach-in".

2. Determine here by means of the given geometries in witch area moments
should be searched (see also "Teaching in Detection Windows and Test
Windows", Page 110).

3. If necessary, set the parameters (X Point, Y Point, phi Line) for position
tracking (see also: "Position Tracking of Objects", Page 118).
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Work Flow
Parameterizing and
Testing

1

2

4

3

5

11

6

7

8

9

10

Image 103: Dialog Rotation based on Moments, tab control Parameters

1. Switch to the tab control "Parameters".

2. Choose in the area "Threshold" the threshold for detection and subdivision of
the subjects of the image.

Parameter Description

Fixed
Threshold

Enter the gray value threshold for detection and subdivision
of the objects.

From Result
No.

You can choose a gray value threshold from the result
structure here.

Automatic With definite distribution in light and dark objects, you can
use this option. The threshold is set automatically.

3. Choose in the area "Sorting" if a special sorting of the results should take
place. After a test, the rows or columns (except automatic) and also the
bonding-box around each object are displayed in the monitor window.

3

1 2

Image 104: Sorting: 3
Rows

31

2

Image 105: Sorting: 3
Columns

31

2

Image 106: Sorting:
Automatic
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Parameter Description

Rows, using
n Rows.

Division of the inspection area into n-rows. The sorting of
the objects in the rows is performed after the x-coordinates
of the center of gravity points, then the y-coordinates of the
center of gravity points.

Columns,
using n
Columns.

Division of the inspection area into n-columns. The sorting
of the objects in the columns is performed after the y-coor-
dinates of the center of gravity points, then the x-coordi-
nates of the center of gravity points.

Automatic Sorting of all objects whose bounding-box in the y-direction
overlaps (vertical projection), first in the x-direction. Then,
the so created rows are sorted in the y-direction.

4. Search Mode

Parameter Description

One Object All found areas are interpreted as a single object.

Multiple
Objects

All found areas are interpreted as multiple objects.

5. Rotation

0°

-90°

+90°

± 180°

Min. axis of inertia

Parameter Description

Simple (180°) Sets the angular position according to the minimum axis of
inertia. The minimum axis of inertia is an undirected straight
line. Use this straight line only if the object rotates by less
than 180°.

Advanced
(360°)

Carries out a 360° recognition based on eccentricity after
simple angular position recognition.

6. In the area "Filter" you can specify conditions for the objects to be evaluate.
Read more: see "Use of filters", Page 192.

7. In the area "Output" set the options for saving the results.
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Parameter Description

Count Here you enter the number or the name of the result for
saving the number of objects found in the result structure.

Center of
Gravity

Enter the number or name for saving the center of gravity
point in the point structure. If "Multiple Object" was selected
multiple center of gravity points are saved with index exten-
sion (see also: "Names for Geometry Variables", Page 63).

Angle Enter the number or name for saving the angle in the result
structure. If "Multiple Object" was selected multiple angles
are saved with index extension (see also: "Names for
Geometry Variables", Page 63).

Rotation Line Enter the number or name for saving the rotation line in the
line structure. If "Multiple Object" was selected multiple rota-
tion lines are saved with index extension (see also: "Names
for Geometry Variables", Page 63).

World Coordi-
nates

The storage of the values appears in world coordinates.

Image Coor-
dinates

The storage of the values appears in image coordinates.

8. In the area "Number of Objects" whether the detected number of objects is
within the tolerance range, and therefore the command is evaluated with
good or bad during execution.

Parameter Description

Nominal Here you set the nominal quantity of objects to be found.

'+' / '-' Permitted upward and downward deviations from this target
value.

9. In the area "Found Objects" all to the corresponding requirements found
objects are listed.

Parameter Description

SX X-coordinate of the determined Center of gravity point.

SY Y-coordinate of the determined Center of gravity point.

Angle Angle of the axis of inertia of the found object in 1/100° rela-
tive to 0°.

Area Number of pixels of the found object.

Quantity Number of found objects, corresponding to the conditions.

10.Testing and setting the appropriate parameters
By activating the [Test] button the command with the set parameters is
executed. In the area to the left of the [Test] button, the evaluation of
the command (error-free ) as well as instructions for setting parameters
(tolerance range errors) and error messages are displayed. In the "Found
Objects" area, all matching objects are displayed. In the video image the
center of gravity point and the vector of the axis of inertia are displayed.
If necessary, change the settings in step 2 till 6 until the result meets your
requirements.

11.Use the [OK] button to insert the command into the test program.
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Use of filters You can use filters to filter by criterias (Area or Color) within the algorithm.

A filter contains condition blocks. These blocks are linked by a logical OR. Only
one condition block must fit the requirements.

Each condition block can contain up to two filters. These are linked by a logical
AND. Both of these filters have to be fulfilled, so that the condition block is
fulfilled.

In the area "Filter", click on the button [Add]. In the dialog "Add Filter" you can
define conditions. In the area "Filter" the logical links are shown as full text.

To modify or delete a filter, select it and click [Modify] or [Delete].

To insert a new filter, click into the corresponding condition block and then click
[Add].

To insert a new condition block, select the top line "One of the following
condition-blocks must match:" and click [Add].

Parameter Description

Area

Min. The object must contain at least this number of pixels, so that
it is detected. Objects with fewer pixels are ignored.

Max. The object must be less than this number of pixels, so that it is
detected. Objects with more pixels are ignored.

Color

Black Only objects with darker color than the set threshold will be
considered.

Black and
White

Objects with brighter and darker color than the set threshold
will be considered.

White Only objects with brighter color than the set threshold will be
considered.
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7.3.6 Color Blob Analysis

Overview

Image 107: Color Blob
Analysis - test object

Image 108: Color Blob
Analysis - blob detected

With Locate > Color Blob Analysis you determine center of gravity points
and areas of colored areas in the image. For this, internally the color image is
binarized and then evaluated. You can save up to 50 center of gravity points
and values in the point- and result structure. Center of gravity points and areas
in excess of 50 are not evaluated. Use this command for counting colored
objects, finding objects or for position tracking.

Work Flow
Define Area of
Binarization

1. Switch to the tab control "Teach-in".

2. Please set here by means of the geometry rectangle in which area of the
image the objects are to be searched. In this area your image is converted
into a black-and-white image (see also: "Teaching in Detection Windows and
Test Windows", Page 110).

3. If necessary, set the parameters (X Point, Y Point, phi Line) for position
tracking (see also: "Position Tracking of Objects", Page 118).
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Work Flow
Parameterizing and
Testing

1

2

3

4

7

8

5

6

Image 109: Dialog Farbblobanalyse, Register Parameter

1. Switch to the tab control "Parameters".

2. Please set here the parameters for color range, nominal color and color
deviation.

Parameter Description

RGB Mode/
HSI Mode

Selection whether in the RGB or HSI color space should be
checked.
Use the HSI mode if you want to check the hue or the satu-
ration irrespective of the brightness.

Slider Red,
Green, Blue

If the selection "RGB Mode" is active.
Values of the corresponding color channel.

Slider H, S, I If the selection "HSI Mode" is active.
Values for color (Hue), saturation and intensity.

Tolerance Minimum and maximum tolerances of the respective color
channel.

[Get] The average color of the test window is taken as the default
for the target color.



vcwin pro 2.21
Part 2 - Command Reference

© Vision & Control GmbH
2015

999.994.306.10-en-1.15 195

ADVICE
Using the button [Get]

For best results, go to the tab control "Teach-in", here reduce the
binarization window and place it in a unique color range. Then, go to the
tab control "Parameters" and click the button [Get] to get the values of the
color of the binarization window.

Then adjust the test window as usual.

3. Determine in the area "Object Properties" the minimum and maximum area
of the objects to be found.

Parameter Description

Min. Area/
Max. Area

Sets the minimum and maximum number of pixels of the
object. Only objects with pixel quantity within this range are
detected.

Color

Light and
Dark

Parts of the image will be assigned to the objects that are
within and outside of the specified color range.

Light Only parts of the image will be assigned to the objects that
are within of the specified color range.

Dark Only parts of the image will be assigned to the objects that
are outside of the specified color range.

4. Here you set the nominal quantity of objects to be found. If the number of
pixels found lies within this range, the command ends with a good result
(otherwise with bad).

Parameter Description

Result Here you enter the number or name of the result in the
result structure in which the determined objects should be
saved.

Nominal Enter here the nominal quantity of objects to be found.

Tolerances Allows an upper and lower deviation from the nominal quan-
tity.

5. Here you can specify the storage options for the center of gravity and the
area of the color blobs.

Parameter Description

From Point From this point, the center of gravity points of the objects
found are stored.

From Result From this position in the result structure, the area values of
the objects found are stored.

Image/World The ratio buttons determine if the storage of the points is
made in image coordinates or world units.

6. Testing and setting the appropriate parameters
By activating the [Test] button the command with the set parameters is
executed. In the area "Found Objects" all corresponding blobs are shown.
In parallel, the objects found are marked in the video image with a red
rectangle and a cross as center of gravity point.
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7. Evaluation Area
Here you can see the good/bad evaluation of the command, notes for
parameterization (tolerance range exceedance) as well as error messages.

8. Use the [OK] button to insert the command into the test program.

7.3.7 Test Colour

Image 110: Dialogue Test Color, tab contol
Parameters

You can add a command for the colour test into the test program using Locate
> Test Colour. 

A colour search is performed within a test window in order to recognize surface
defects. The colour location and brightness or the colour components red,
green and blue can be individually tested. The proportions of the red, green and
blue colour components which have been determined can be stored.

Parameters

• Position and size of the test window
• Number of a reference point (with position tracking)
• Defined RGB nominal colour location and tolerances
• Result
• Nominal gray value and tolerances

Teaching-in the Test
Window

The test window is for teaching positioning on an object with the reference
colour with the Chromaticity method.

Position and Appearance of the Test Window

After double clicking with the right mouse button on the Teach-in tab, you can
position and adapt the test window on the control monitor or on the monitor
window. 
>> "Teaching in Detection Windows and Test Windows", Page 110

Tracking the Position

The test window can either always remain at the same image position or follow
a reference object. 
>> "Position Tracking of Objects", Page 118
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Method 1: Defining
Colour using Colour
Location

1. Select the Colour Locations option. Click on the [Read] button. 

° The colour is taken from the test window.
° The colour is displayed in miniature.
° The colour is set as the nominal chromaticity coordinate.

2. Define permitted colour deviation

3. Specify how colour deviation is saved in the result structure.

»Colour
Aberration«
Input Para-
meters

Description

Result Result number for saving the determined colour deviation.

Tolerance Tolerance for nominal chromaticity, see chromaticity (RGB
model).

Method 2: Defining
Colour using Colour
Components

1. Select the Colour Components option.

2. Set nominal colours with the Red, Green, and Blue slide controls. 
The colour is displayed in miniature.

3. Define permitted colour deviation.

4. Specify how the colour components in results are saved.

Parameters Description

Colour Aber-
ration > Red,
Green, Blue

Set tolerances with the red, green and blue slide controls.

Save Colours
in Results >
Red, Green,
Blue

Result numbers for saving the determined colour components.

Evaluation Parameters Brightness Description

Result Result number for saving the determined average gray value.

Nominal
Gray Value
and Toler-
ances

Nominal average gray value in the test window and the
permitted tolerances (0 to 255).
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Test The test displays:

• Brightness … Determined average gray value.
• Colour Deviation … Determined deviation from nominal chromaticity.

7.3.8 Focus

Image 111: Dialogue Focus, tab control
Parameters

You can insert a command for determining a focus value as a criterion for the
image sharpness into the test program using Locate > Focus. A prerequisite
for this command is a location in the measurement window containing
information about sharpness. 

You can use this command for the following options:

• automatically focusing the camera when it is connected to motion systems
• automatically post-focusing cameras by combining the Focus command with

an adjustment command for the camera

Brief Guide 1. Define the position tracking in the Teach-in tab: no, X point, Y point.

2. Activate teach-in mode by double-clicking with the right-hand mouse button.

3. Modify the size and position of the search window in the video image using
the arrow controls.

4. Deactivate teach-in mode by double-clicking with the right-hand mouse
button.

5. Specify the following in the Parameters tab:

° Structure used for focusing
° Result no.
° Nominal focus and tolerances (quality criterion)

6. Test the command with the [Test] button and modify the parameters set in
points 1 to 5 until the test result is error free.

7. Insert the command into the test program with the [OK] button.
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Teaching-in the Test
Window

Position and Appearance of the Test Window

After double clicking with the right mouse button on the Teach-in tab, you can
position and adapt the test window on the control monitor or on the monitor
window. 
>> "Teaching in Detection Windows and Test Windows", Page 110

Tracking the Position

The test window can either always remain at the same image position or follow
a reference object. 
>> "Position Tracking of Objects", Page 118

Input Parameters ADVICE
For the sharpness information required it is preferable to use multiple lines
with edges that are as sharp as possible.

Focusing Description

Edge Focusing on an edge.

Area Focusing on an area.

Evaluation Parameters Parameters Description

Result Result number for storing the focus value.

Nominal
Focus and
Tolerances

The nominal focus value and the allowed ± tolerances.

The Focus Value test result is calculated as a normalized sum of all focuses of
the edges/areas in the image area. In order to exclude edges/areas of low focus
(e.g. noise) only those edges are considered which lie within 5% of the sharpest
focus and areas which lie within 20% of the sharpest focus.

Test Change the focusing of the camera in the same section of the image. Using test
produces the focus value. The higher the value, the better the focus is. Take
note that the focus values between different images cannot be compared to
each other.

7.3.9 Locate Line

Overview

Image 112: Detection
window at the desired posi-
tion

Image 113: Composed line,
using 5 detection points

With Locate > Locate Line you write a command into your test program, that
detects points and composes a line from these points.
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Work Flow
Teach-in

1. Switch to the tab control "Teach-in".

2. Set here the position of your detection window (see also: "Teaching in
Detection Windows and Test Windows", Page 110). In this window points
are detected (single detection points) and the line is defined.

3. Define the quantity of detection points (single detection points). These are
evenly distributed over the width of the detection window.

4. Configure if all detection points must be found so that the line can be defined
from all single detection points.

5. If necessary, set the parameters (X Point, Y Point) for position tracking (see
also: "Position Tracking of Objects", Page 118).

Workflow
Parameterizing and
Testing

1

2

7

8

6

4

3

5

Image 114: Dialog Locate Line, tab control Parameters

1. Switch to the tab control "Parameter".

2. Choose in the area "Detection Algorithm" the best fitting algorithm and its
parameters for your image (see also: "Principles of Detection", Page 376).

3. In the area "Coordinate System", set whether you want to save the line in
image- or world coordinates.

Parameter Description

Image The storage of the line is carried out in image coordinates.

World The storage of the line is carried out in world coordinates.

4. In the area "Edge Transition", specify the type of an edge along the detection
direction in the window as light to dark or dark to light.
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Parameter Description

Light->Dark Only edge transitions from light to dark will be considered.

Dark->Light Only edge transitions from dark to light will be considered.

5. Set here the options for saving the detected line.

Parameter Description

Line Number or name under which the coordinates of the found
line are stored in the line structure.

RES for
Straightness

Number or name under which the straightness is stored in
the result structure.

Tolerance Perpendicular distance in pixels between the furthest above
and underneath point. These points form a tolerance band
around the straight line.

6. Testing and setting the appropriate parameters
By activating the [Test] button the command with the set parameters is
executed. The values of the straight lines found will be displayed in the
docking window Lines. If declared, the result of the straightness is shown in
the docking window Results and in the dialog (above the [Test] button). In
parallel, the composed line with the corresponding detection points is shown
in the video image.
Change the settings in step 2 until the result meets your requirements. If
necessary, switch to the tab control "Teach-in" and adjust the number of
detection points.

7. Evaluation Area
Eventually error messages are shown here.

8. Use the [OK] button to insert the command into the test program.

7.3.10 Test Gray Value

Image 115: Dialogue Test Gray Value, tab
control Parameters

With Locate > Test Gray Value, you include a command in the test program
allowing you to determine a specific grayscale value. You can choose here
between four kinds of measurement:
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• Average Gray Value - determines the average grayscale value in a
specified grayscale range

• Minimum Gray Value - determines the lowest grayscale value (darkest
point) in a specified grayscale range, and returns its coordinates

• Maximum Gray Value - determines the highest grayscale value (brightest
point) in a specified grayscale range, and returns its coordinates

• Gray Scale Value (max-min) - determines the difference between the
highest and the lowest grayscale values in a specified grayscale range
("greyscale dynamics")

The command checks whether the value determined is within the preset
tolerance range. The determined value is then saved in the result structure.
When measuring the Minimum Gray Value and Maximum Gray Value, you
can also save the coordinates of the determined point in the result structure.
The position of the first point that is found with the respective minimum and
maximum gray scale values is always used. Use this command to monitor and
control the brightness of the lighting. In the case of more complex structures,
you can change the settings for the Gray Scale Value Range to adjust and
narrow down the measurement.

Brief Guide 1. Define the following parameters in the Teach-in tab:

° Shape of the test window: rectangle, ellipse, ellipsoid ring, contour from
contour buffer, circular ring

° Position tracking: no, X point, Y point or phi line

2. Activate teach-in mode by double-clicking with the right-hand mouse button.

3. Modify the size and position of the search window in the video image using
the arrow controls.

4. Deactivate teach-in mode by double-clicking with the right-hand mouse
button.

5. Specify the following in the Parameters tab:

° Result
° Nominal gray value
° Tolerances
° with Minimum/Maximum Gray Value: point with the minimum/maximum

greyscale value (Point number), Image/World coordinates

6. Test the command with the [Test] button and modify the parameters set in
points 1 to 5 until the test result is error free.

7. Insert the command into the test program with the [OK] button.

Teaching-in the Test
Window

The test window can have the following shapes: rectangle, ellipse, ellipsoid ring,
contour from contour buffer, circular ring (i.e., gray value test in a circular ring
segment).

Position and Appearance of the Test Window

After double clicking with the right mouse button on the Teach-in tab, you can
position and adapt the test window on the control monitor or on the monitor
window. 
>> "Teaching in Detection Windows and Test Windows", Page 110
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Tracking the Position

The test window can either always remain at the same image position or follow
a reference object. 
>> "Position Tracking of Objects", Page 118

The rotary angle results from the angle between the position tracking line and
the X axis. The direction and size of the window are maintained.

Evaluation Parameters Parameters Description

Gray Scale Value Range Grayscale limits specifying the maximum and
minimum grayscale values that are allowed for
the value to be determined.

Point with the minimum/
maximum gray scale value

Point number for storing the position of the
determined point.

Image/World Saving in image coordinates or world coordi-
nates.

Result Result number used for storing the result in
the result structure.

Nominal Gray Value Nominal gray value

Tolerances Accepted positive and negative tolerances in
gray values from 0 to 255.

Test The test displays the Average Gray Value calculated in the test window.
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7.3.11 Test Brightness Percentage

Image 116: Dialogue Test Brightness
Percentage, tab control Parameter

You can determine the percentage of bright points in an image window using
Locate > Test Brightness Percentage. The command tests whether the result
lies within a certain tolerance range. Any points whose gray values exceed
the gray value threshold are considered “bright”. The detected brightness
percentage is stored in the result structure.

Brief Guide 1. Define the following parameters in the Teach-in tab:

° Shape of the test window: rectangle, ellipse, ellipsoid ring, contour from
contour buffer, circular ring

° Position tracking: no, X point, Y point or phi line

2. Activate teach-in mode by double-clicking with the right-hand mouse button.

3. Modify the size and position of the search window in the video image using
the arrow controls.

4. Deactivate teach-in mode by double-clicking with the right-hand mouse
button.

5. Specify the following in the Parameters tab:

° Gray value threshold
° Result
° Nominal brightness percentage
° Tolerances for brightness percentage in %

6. Test the command with the [Test] button and modify the parameters set in
points 1 to 5 until the test result is error free.

7. Insert the command into the test program with the [OK] button.

Teaching-in the Test
Window

Position and Appearance of the Test Window

After double clicking with the right mouse button on the Teach-in tab, you can
position and adapt the test window on the control monitor or on the monitor
window. 
>> "Teaching in Detection Windows and Test Windows", Page 110
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Tracking the Position

The test window can either always remain at the same image position or follow
a reference object. 
>> "Position Tracking of Objects", Page 118

Input Parameters Parameters Description

Gray Value
Threshold

Gray value threshold above which a point will be considered
bright.

Evaluation Parameters Parameters Description

Result Result Number for storing the percentage of bright points.

Nom.
Brightness
Percentage
and Toler-
ances

Nominal percentage of bright points and accepted ± toler-
ances in per cent.

Test The test displays the Detected Brightness Percentage calculated in the test
window.

7.3.12 Brightness Offset

Image 117: Dialogue Brightness Offset, tab
control Parameters

You can determine the deviation of the actual mean gray value of a test object
within a test window from an expected nominal gray value using Locate >
Brightness Offset. The brightness offset is saved internally for the image
memory page with vicosys. The Brightness Offset is automatically added to the
threshold value set with commands using the Binary algorithm (Locate, Blob
Analysis). The Brightness Offset is reset with each new image acquisition.

Brief Guide 1. Define the following parameters in the Teach-in tab:

° Shape of the test window: rectangle, ellipse, ellipsoid ring, contour from
contour buffer, circular ring

° Position tracking: no, X point, Y point or phi line

2. Activate teach-in mode by double-clicking with the right-hand mouse button.
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3. Modify the size and position of the search window in the video image using
the arrow controls.

4. Deactivate teach-in mode by double-clicking with the right-hand mouse
button.

5. Define the nominal gray value in the Parameters tab.

6. Test the command with the [Test] button.

7. Insert the command into the test program with the [OK] button.

Teaching-in the Test
Window

Position and Appearance of the Test Window

After double clicking with the right mouse button on the Teach-in tab, you can
position and adapt the test window on the control monitor or on the monitor
window. 
>> "Teaching in Detection Windows and Test Windows", Page 110

Tracking the Position

The test window can either always remain at the same image position or follow
a reference object. 
>> "Position Tracking of Objects", Page 118

Input Parameters Parameters Description

Nominal
Gray Value

A reference gray value (0 to 255) to which the offset is related.

Evaluation Parameters Parameters Description

Brightness
Offset

The determined difference from the reference gray value: The
brightness offset is stored internally.

Test The test displays:

• Average Gray Value … Nominal pixel quantity determined in the test window.
• Brightness Offset … Determined brightness offset in ± gray values.

7.3.13 Locate Edges on Circle

Overview

Image 118: Detection
Window at position

+
+

+ +
+

+
+
+

+++
+

+
+

Image 119: Found edge
transitions at the balls

With Locate > Locate Edges on Circle you can teach-in a command for
counting the edges on an arc. The number of edges found is used as a quality
criterion and is stored in the result structure.

To compensate for the noise in the radial direction, increase the width of the
arc. In this way you determine the average of the gray values from several
concentric rings. If required, we recommend changing the radius by linking it
to a result number. A binary and a gradient algorithm are available for contour
determination.
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Work Flow Teach-in 1. Switch to the tab control "Teach-in".

2. Set the position of the detection area Circular Ring Segment as well as
the angles and radii: (see also: "Teaching in Detection Windows and Test
Windows", Page 110 ). In this section edges (single detections) are sought.

3. Set the search direction (clockwise / counterclockwise).

4. If necessary, set the parameters (X Point, Y Point, Rad. RES) for position
tracking (see also: "Position Tracking of Objects", Page 118 ).

Work Flow
Parameterizing and
Testing

1
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Image 120: Dialog Locate Edges on Circle, tab control Parameters

1. Switch to the tab control "Parameters".

2. Set here the detection algorithm. You will find further information at:
"Principles of Detection", Page 376.

Parameter Description

Binary With the binary algorithm, the edges are recognized when a
defined gray value threshold is reached.
Parameters: threshold value, noise filter

Gradient In edge detection with gradient, the edges are determined
with the gradient process.
Parameters: threshold value, noise filter, diffusion

3. Here you can set the parameters for the detection algorithm. You will find
further information at: "Principles of Detection", Page 376.)

4. The positions of the edges are determined in the middle of the arc and can
be stored in the point structure in the order in which they were found. The
type of transition can be either light-dark or dark-light.
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Parameter Description

all All dark-light and light-dark edge transitions are counted.

Light > Dark Only light-dark transitions are counted.

Dark > Light Only dark-light transitions are counted.

5. Here you can specify the storage options for the edges found.

Parameter Description

Quantity in
Result

Here you enter the number or name of the result in the
result structure in which the determined edge number
should be saved.

Nominal No.
of Edges

Here you set the nominal quantity of edges to be found.
If the number of edges found lies within this range, the
command ends with a good result (otherwise with bad).

Tolerances Allows an upper and lower deviation from the nominal quan-
tity.

Start Saving
at Point

Number or name of the point structure, in which the detec-
tion point for the first edge found, is stored.

Coordinate
System

Saving in image coordinates or world coordinates.

6. Testing and setting the appropriate parameters
By activating the [Test] button the command with the set parameters is
executed. In this area the number of edges is shown. In parallel, the edges
found are marked in the video image with a red cross.

7. Evaluation Area
Here you can see the good/bad evaluation of the command, notes for
parameterization as well as error messages.

8. Use the [OK] button to insert the command into the test program.
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7.3.14 Count Edges

Image 121: Dialogue Count Edges, tab
control Parameters

You can Teach-in a command for counting edges along a detection beam
with Locate > Count Edges. The number of edges found is used as a quality
criterion and is stored in the result structure. 

To compensate for the noise at right-angles to the detection direction, increase
the width of the detection. In this way you can determine the average of the
gray values from several parallel detections.

A binary and a gradient algorithm are available for contour determination.

Brief Guide 1. Specify the following in the Parameters tab:

° Detection algorithms with corresponding parameters
° Edges (light > dark, dark > light, all)
° Free search direction
° Nominal number of edges
° Result number and tolerances
° Point number from which all the edge positions are stored
° Co-ordinate system

2. Test the command with the [Test] button and modify the parameters set in
points 1 to 5 until the test result is error free.

3. Insert the command into the test program with the [OK] button.

Teaching-in the
Detection Beam

Position and Appearance of the Search Window
After double-clicking with the right mouse button on the Teach-in tab, a
detection beam dialog box and the detection beam will appear on the video
screen. 
More Information:

• "Teaching in Detection Windows and Test Windows", Page 110
• "Teaching-in the Detection Beam", Page 240

Tracking the Position
The detection beam can either always remain at the same image position or
follow a reference object. 
>> "Position Tracking of Objects", Page 118
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Input Parameters To find edges:

Use the [Test] button.
Use the binary algorithm or the gradient algorithm.

The search for edges is carried out at a line. >> "Principles of Detection",
Page 376

Detection
Algorithm

Description

Binary With the binary algorithm, the edges are recognized when a
defined gray value threshold is reached. 
Parameters: threshold value, noise filter

Gradient In edge detection with gradient, the edges are determined with
the gradient process. 
Parameters: threshold value, noise filters 1 and 2, diffusion
(noise filter 1 refers to the pixel before the edge in the detec-
tion direction, noise filter 2 refers to the pixel after the edge,
see example)

Free Search
Direction

If Free Search Direction is inactive, only detection in a 45°
grid is possible, i.e., the detection arrow jumps at an angle of
45° to the position with the best contrast. The speed of the
command is hence maximized. Activate Free search direc-
tion to set the search direction for max. gradient, gradient,
convolution max. coefficient, and convolution.

The type of transition can be either light-dark or dark-light.

Edge Transi-
tion

Description

All All dark-light and light-dark edge transitions are counted.

Light > Dark Only light-dark transitions are counted.

Dark > Light Only dark-light transitions are counted.

Evaluation Parameters Parameters Description

Result Result number for saving the number of detected edges.

Nominal
Quantity of
Edges and
Tolerances

Nominal quantity of edges and permitted ± tolerances (in
number of edges)

Image/World Saving in image coordinates or world coordinates.

Save from
Point

Number of the point structure, in which the detection point for
the first edge found is stored. The detection points of further
edges are stored in the subsequent numbers of the point
structure.

Test The quantity of transitions determined in the test is displayed.
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Examples Counting the Edge Transitions

Parameters Description

All Four edge transitions are counted.

Light > Dark /
Dark > Light

Two edge transitions are counted.

Using 2 Noise Filters for Detection with Gradient

The two noise filters can be so combined that noise is eliminated. Select noise
filter 2 (refers to the pixel after the edge found) to be larger than noise filter 1
(refers to the pixel before the edge found).

7.3.15 Edge Based Object Search

Image 122: Dialogue Edge Based Object
Search, tab control Parameters

Image 123: Dialogue Edge Based Object
Search, tab control License

With Locate > Edge Based Object Search, you can find objects in the
camera's image. To do this, you must first teach in a reference object digitally
as a pattern. The locate algorithm then searches the image to be tested looking
for corresponding edges and can then identify the object in this way within the
search area. When doing so, the position as well as the angular position in
relation to the taught-in pattern is determined. Use the command to find and
classify one or more objects in the image.

The Edge Based Object Search is a very robust and fast object recognition
process which can also find multiple objects in the image. It is independent of
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lighting and angular position as well as being scaling invariant up to +/- 50%
of the original size and it can even recognise patterns with overlaps of up to
80%. Further strengths are the subpixel-accurate search (+/- 0.1 pixels and +/-
0.3 degrees, depending on the size of the pattern), the real-time object search
(up to 100 hits/s possible at 640x480) and parameter-based elimination of
interfering edges.

Searching takes place in two phases, first as a rough preliminary search
and then as a detailed search at a higher resolution. The accuracy and the
processing speed of the search depend heavily on the parameters specified
such as the search angle step increment, the size of the area to be searched
and the size of the pattern to be compared, among others. Higher search
accuracy always means longer processing.

Use of the edge-based object recognition feature is based on a licence
model. You can test the function of the command from within your application.
However, you can only run the function a limited number of times. When you
enter the licence code, the command is released and can be used with all its
parameters and configuration options. You can purchase the licence code
from Vision & Control GmbH and can then enter it via the Communication >
Licence for Special Functions menu.

Brief Guide 1. Select in the tab control Parameters under Pattern Source, whether you
want to teach the pattern itself (go to step 2) or use a in the in the vision
system stored pattern (>> "Save Pattern", Page 226) (select the pattern in
the selection list and proceed with step 5).

2. Go to the tab control Teach-in Patterns. Activate the teach-in mode by
double-clicking the right mouse button and switch to the video image.
Change the size and position of the teach-in window with the controls
pf your mouse (>> "Teaching in Detection Windows and Test Windows",
Page 110).

3. Close the teach-in mode by double clicking with the right mouse button and
then click the [Read Pattern] button.

4. In the dialogue put a checkmark at the edges, that should be taught to
recognize the pattern (see "Image 124: Select Edge Segments dialog").
Refer to the red marks of the edges in the Monitor Window. If there is only
one edge found by the teaching of the pattern, it is automatically selected
and the dialog box will not even appear.

5. Switch to the "Search Window" tab and define the position tracking settings
(>> "Position Tracking of Objects", Page 118).

6. Activate the teach-in mode with double click the right mouse button and
change the size and position of the search window with the controls (>>
"Teaching in Detection Windows and Test Windows", Page 110). Close the
teach-in mode with a double right-click with your mouse.

7. Switch to the "Parameters" tab and adjust the input and evaluation
parameters (see next section).

8. Test the command with the [Test] button and then modify the parameters set
in steps 1-7 until "No errors" is shown as the test result in the bottom line.

9. Add the command to the test program with the [OK] button.
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Selecting edge
segments

Image 124: Select Edge Segments dialog

In the "Select Edge Segments" dialog, you can specify which edges are to be
taught in as object edges. In this way, you can remove irrelevant edges from
the pattern for object recognition so that the test only searches for the edges
that you want. The edges that are found are coloured red in the monitor window.
The red marking is removed as soon as you deactivate an edge. If you select
an edge in the list, it will be highlighted in red bold in the monitor window. You
can select and display multiple edges by holding down the Ctrl key.

As standard, all edges that are found will be listed in the dialog sorted by their
lowest X-coordinate. The Y-coordinates and the edge lengths are also shown.
The edges that are found can be sorted by any parameter as desired. In the first
column "Activated", you can specify whether the respective edge is to be taught
in (checked) or not (not checked).

ADVICE
The "Select Edge Segments" dialog is only available when teaching in a
pattern.
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Input parameters Parameter Description

Resolution Reduction Reduces the resolution of the original
image, thereby making the search faster
but less precise. The parameter values
range from 0 = original resolution to
5 = greatly reduced resolution and represent
the value (22n) of the reduction of the number
of pixels. You can check the resolution that is
set by means of the monitor window.

Edge Point Reduction Reduces the number of edge points used for
the search. Reducing edge points accelerates
searching but might make it too imprecise,
under circumstances, if parameter values are
too high (7 or greater).

Pattern Source Specifies whether the pattern is to be taught
via the "teach-in patterns" tab or as an existing
pattern file saved on the system.
Gibt an, ob das Muster über den Reiter
"Muster einlernen" eingelernt werden soll oder
ein bestehendes, als Datei abgelegtes Muster
verwendet werden soll (>> "Save Pattern",
Page 226).

Pre-Search Specifies the precision with which the first
search level searches for the pattern.

• Coarse - preliminary search with the stan-
dard rough search pattern

• Fine - preliminary search with a detailed
search pattern, however with longer
processing time

Fine Search Specifies the precision with which the second
search level searches for the pattern.

• Regular - standard detailed search
• Subpixel - search pattern with high

subpixel and angle precision, however with
longer processing time

From - To Specifies the boundaries of the angle search
area in which the pattern is searched for [-180
to 180°]. A smaller angle search area and,
with it, a significantly shorter processing time
is especially useful when, due to the test
process, the object is only added to the test in
a certain angular position or range of angular
positions.

Search Angle

Step Specifies the angle step increment with which
the angle search area is to be searched.
A greater step increment allows faster
processing while a smaller one increases the
precision of the search. With the angle step
increment, you also specify the maximum
search precision at the same time.
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Parameter Description

Minimum Allows the object to have a smaller scale [-50
to 0%] in the image in comparison with the
taught-in pattern.

Maximum Allows the object to have a larger scale [0
to 50%] in the image in comparison with the
taught-in pattern.

Scaling

Step Percentage value specifying the step incre-
ment in which the scaled object is searched
for. A greater step increment allows faster
processing while a smaller one increases the
precision of the search.

Grade of Match Percentage value specifying the minimum
level with which the found pattern must corre-
late to the taught-in pattern in order for it to
be processed as a valid pattern. You must
specify or adjust the value according to the
test results. The grade of match is not affected
by the brightness in the test window.

Grade of
Match

Specifies that the found objects (and there-
fore also their result values) are to be sorted
by their degree of match.

Sort Order

Direction Specifies the direction in which the objects
found in the image (and therefore also their
result values) are to be sorted.

Only First
Match

Specifies that only the first found object will
be evaluated that corresponds to the grade
of match. This means that the object search
process ends as soon as a corresponding
object is found.

Nominal Specifies how many objects are to be found
and evaluated. The entire image is examined
and the search is not terminated prematurely.

"+" / "-" Specifies the permissible upper (+) and lower
(-) deviations of the found objects from the
nominal value.

Number
of Objects
Found

RES Result number in which the number of
patterns found is to be saved.



vcwin pro 2.21
Part 2 - Command Reference

216 999.994.306.10-en-1.15 © Vision & Control GmbH 2015

Evaluation parameters Parameter Description

Image/World Specifies whether the geometries are to be saved as
image or world coordinates.

Point First point number for storing the centres of gravity of
the found patterns.

Line First line number for storing the angular position lines
of the found patterns.

Angle First result number for storing the angular positions
of the found patterns. The angle is specified as an
integer value with 3 decimal places (100° → 100000).

Grade of Match First result number for storing the grades of match of
the found patterns.

7.3.16 Locate Contour

Image 125: Dialogue Locate Contour, tab
control Parameters

You can teach in a command for finding a contour within the image using
Locate > Locate Contour. A contour is a series of neighboring points. The
command always finds the first contour in the direction of detection. At the
bottom left is a checkbox used for setting whether the points of the contour
are located until the edge of the window is reached (open contour) or until the
contour meets itself again (closed contour). 

The found contour is buffered in a contour buffer. You can select between a
gradient algorithm and a binary algorithm for locating contours. The maximum
size of a contour and the number of contours to be saved depends upon the
system.

Brief Guide 1. Define the following parameters in the Teach-in tab:

° Position tracking: no, X point, Y point
° Search direction

2. Activate teach-in mode by double-clicking with the right-hand mouse button.

3. Modify the size and position of the detection window in the video image
using the arrow controls.
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4. Deactivate teach-in mode by double-clicking with the right-hand mouse
button.

5. Specify the following in the Parameters tab:

° Detection algorithm
° Edge transition
° Contour no.
° Contour location in the image or in the contour window (closed/open

contour)

6. Test the command with the [Test] button]: 
Modify the parameters set in points 1-5 until the test result is error free.

7. Insert the command into the test program with the [OK] button.

Teaching-in the
Detection Window

After calling the Locate > Locate Contour function, you will see the dialog box
for finding a contour in the Teach-in tab and a detection window on the video
screen.

Variant 1: Entering Parameters in the Edit Mask

Enter the X and Y values for the starting point of the detection window and
its dimensions (dX, dY) into the fields. Change the values as required with
the arrows on the right hand side. Check the changes made to the detection
window on the video screen.

The Search Direction determines the direction of detection. In the above
example it will be from south to north i.e. upwards. 

ADVICE
The search direction can only be changed within the dialog box. It cannot be
changed on the video screen.

Variant 2: Setting Parameters on the Video Monitor

Double click the right-hand mouse button to switch from the Teach-in tab to the
video screen. If you move the mouse pointer over the perimeter of the detection
window, it will turn into a small cross or double-headed arrow.

• at the corners... to resize the window in diagonal direction
• from the edges … to move the window edge horizontally or vertically
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To move the detection window around the screen, position the mouse cursor in
the center of the window and hold down the left mouse button while moving the
mouse.

Double clicking with the right mouse button switches back to the edit window in
the Teach-in tab.

Tracking the Position The detection window can either be at the same image location (no position
tracking) or it can follow a reference object. 
For position tracking: >> "Position Tracking of Objects", Page 118

Input Parameters Detection Algorithm
Set suitable parameters interactively with the aid of the [Test] button.

Detection
Algorithm

Input Parameters / Description

Binary Threshold value, noise filter

Gradient Gray value threshold, width of detection, min. threshold value

>> "Principles of Detection", Page 376

Edge Transition
The type of transition can be either light-dark or dark-light.

Edge Transi-
tion

Input Parameters / Description

Light -> Dark Only light-dark transitions are included.

Dark -> Light Only dark-light transitions are included.

Locate in
the entire
image?

If the option is deactivated, contours are only followed until the
edge of the search window. Open contours can be detected
with this setting. Otherwise, only closed contours can be
detected.

Evaluation Parameters Evaluation
Parameters

Description

Contour Number or name of the contour buffer used to store the found
contour.
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7.3.17 Locate Circle

Overview

Image 126: Detection
Window at position

Image 127: composed circle
with 8 detection points

You can teach in a command for finding a circle or fractions of a circumference
within the image using Locate > Locate Circle. The command relates to
circular contours within a detection window in the image. The direction of
detection is shown by the arrowheads. A circle found within the detection
window is stored as a geometrical circle element. The number of circles to be
saved depends upon the system.

Work Flow
Teach-in

1. Switch to the tab control "Teach-in".

2. Set the position of the detection window as well as the angles and radii (see
also: "Teaching in Detection Windows and Test Windows", Page 110). In
this area points are searched along detection beams and the circle formation
is made.

3. Determine the number of detection points (single detection). These are
distributed evenly over the detection window.

4. Determine whether all of the detection points must be found so that a circle
can be formed from the single detection.

5. If necessary, set the parameters (X Point, Y Point) for position tracking (see
also: "Position Tracking of Objects", Page 118).
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Work Flow
Parameterizing and
Testing

1

2

9

10

8
4
3

7
6

5

Image 128: Dialog Locate Circle, tab control Parameters

1. Switch to the tab control "Parameters".

2. Set here the detection algorithm. You will find further information at
"Principles of Detection", Page 376.

3. In the area "Coordinate System", set whether you want to save the circle and
point in image or world coordinates.

Parameter Description

Image The storage of the values of the circle is carried out in
image coordinates.

World The storage of the values of the circle is carried out in world
coordinates.

4. In the area "Edge Transition", specify the type of an edge along the detection
direction in the window as light to dark or dark to light.

Parameter Description

Light > Dark Only edge transitions from light to dark will be considered.

Dark > Light Only edge transitions from dark to light will be considered.

5. Set here the options for saving the detected circle.

Parameter Description

Circle Number or name under which the coordinates of the found
circle are stored in the circle list. (Coordinates: X,Y,R)

Point Number or name under which the coordinates of the found
circle center point are stored in the point list.
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6. Here you can specify the storage options for the roundness of the circle. The
roundness is the difference between the largest and smallest radius (relative
to gravity).

Parameter Description

Result Number or name under which the roundness is stored in the
result list.

Tolerance Allows an upper and lower deviation from the result.

7. Here you can specify the storage options for the radius of the circle found.

Parameter Description

Result Number or name under which the radius is stored in the
result list. The value of the radius is always stored in world
coordinates.

Nominal
Value

Nominal value of the radius.

Tolerances Allows an upper and lower deviation from the nominal
value.

8. Testing and setting the appropriate parameters
By activating the [Test] button the command with the set parameters is
executed. The values of the circle found will be displayed in the docking
window Circles. If declared, the result of the roundness is shown in the
docking window Results and in the dialog (above the [Test] button). In
parallel, the composed circle with the corresponding detection points is
shown in the video image.
Change the settings in step 2 until the result meets your requirements. If
necessary, switch to the tab control "Teach-in" and adjust the number of
detection points.

9. Evaluation Area
Eventually error messages are shown here.

10.Use the [OK] button to insert the command into the test program.

7.3.18 Mask Check

Teach-In Window

Image 129: Mask Check,
contour of the taught mask

Test Window

Image 130: Mask Check,
Count Pixels with gray value
range 50-70

Test Window

Image 131: Mask Check,
Count Pixels with gray value
range 0-80

Use Locate > Mask Check to test complex structures for completeness and
accuracy. In contrast to the "Count Pixels" command, the structures do not
have to be contiguous.



vcwin pro 2.21
Part 2 - Command Reference

222 999.994.306.10-en-1.15 © Vision & Control GmbH 2015

The command counts the pixels in the test image that are covered by a freely
definable mask. The mask is a binary image that can either be loaded as a file
or taught-in in the dialog. Depending on the definition of the color of the mask
(light or dark), the pixels are counted that lie under either the black (dark) part or
white (light) part of the mask.

The command permits the covered part of the image to be saved to a separate
image memory page. The copied image content can then be further processed
with other algorithms.

There is always one mask taught-in per command.

Define Mask You have two options to define a check mask.

On the one hand, you can teach-in a mask; on the other hand you can use
an image file already existing on the vision system as a check mask. The
latter variant is useful if the test mask should be re-taught or new-through by a
separate subroutine (via overwriting the image file by the Save Image > Image
Section command).

Work Flow
Teach-in Mask

1. Switch to the tab control "Teach-in Mask".

2. Here you can determine, by means of the geometry rectangle, which image
content has to be read as the check mask. (Information for teaching, see
also: "Teaching in Detection Windows and Test Windows", Page 110).

3. Enter the gray value threshold for the binarization of the image.

4. With the button [Read Mask] you read-in all image information located in the
geometry as the mask, and stored it internally in the command. The detected
mask is shown as a thumbnail in the reference window.

5. In the reference window, verify if the mask, now converted into a binary
image, is complete. In the video image the edges of the mask are shown in
red at the same time.

6. In case of an incorrect mask, change the gray value threshold until the mask
fits your needs.

Work Flow
Use External Mask

Preparation: Image File as a Mask

You have the option to use a mask from an image file, in which a image section
was saved. These must be stored on the vision system. Make sure the size of
your mask is smaller than the size of the test image.

Image Section from an Image
Using the Command Control > Save / Load Image you can save an image
section in the image directory of the vision system.
Externally processed image (optional) 
With the option Utilities > Receive Image from Vision System / Send
Image to Vision System you can send an Image to your PC. Here you
can edit it with an image editing program and then transferred it back to the
vision system by using Send Image to Vision System.
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Select External Mask:

1

2

Image 132: Dialog Mask Check, tab control Parameter

1. Switch to the tab control "Parameters".

2. In the area "Mask" choose the option "Image File".

Select from the drop-down list the appropriate image file.
Enter the gray value threshold for the binarization of the image.

Work Flow
Define Test Area

1. Switch to the tab control "Teach-In".

2. Set here the position of the test window, the size is already given through
the window of the mask (see also: "Teaching in Detection Windows and Test
Windows", Page 110).

3. If necessary, set the parameters (X Point, Y Point, phi Line) for position
tracking (see also "Position Tracking of Objects", Page 118).
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Work Flow
Parameterize and
Testing

1

6

2

3

4

5

Image 133: Dialog Mask Check, tab control Parameters

1. Switch to the tab control "Parameters".

2. Adjust the setting parameters for the use of the mask.

Mask Color

Parameter Description

Dark Pixels that are covered by the black part of the mask are
checked.

Light Pixels that are covered by the white part of the mask are
checked.
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Mask

Parameter Description

Taught The mask that is taught-in with the control tab "Teach-in
Mask" is used. It is shown as a thumbnail in the reference
window to the right.

Image File An image file that is located in the vision system is used.
The specified image file is converted to a test mask.
The required threshold is specified under Gray Value
Threshold.

Filename Only available if the option Image File is active.
Choice of the image file with the image section.

Gray Value
Threshold

Only available if the option Image File is active.
Indicates the binary threshold for extracting the test mask
from the image file. We recommend using the image report
function to provide the gray value threshold required.

Copy Mask Area

The command Mask Check copies the image that is determined by the mask
(regardless of its location) to the center of the target page. In combination
with position tracking images can be brought in to a stable position in which
tests can then be carried out without further tracking.

Parameter Description

To Image
Page

Specify the image page, to which the copied and (if required
per phi line position tracking) rotated image should be sent
to for further processing.

Border Pixels

Parameter Description

Ignore Border
Pixels

When using Count Pixels and Copy Mask Area only pixels
that have at least this defined distance from the edge of the
mask are counted.

3. Adjust here the parameters for the testing and evaluation of the mask.

Parameter Description

Count Pixels The pixels are counted, within the set Gray Value Range,
in the region of the window covered by the part of the mask
that corresponds to the set mask color.

Gray Value
Range

Only pixels with gray values within the gray value range are
counted.

Number of
Pixels to
Result

Here you enter the number or name of the result in the
result structure in which the determined pixel number and
the good/bad evaluation of the nominal quantity (incl. toler-
ances) should be saved.

Nominal
Quantity and
Tolerances

Here you set the nominal quantity of pixels to be found.
If the number of pixels found lies within this range, the
command ends with a good result (otherwise with bad).
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4. Testing and Evaluate suitable parameters
The command is executed with the parameters by activating the [Test]
button. The quantity of pixels found is shown in the test area. In parallel, the
determined pixels are marked red in the video image.

5. Here you can see the good/bad evaluation of the command, notes for
parameterization (tolerance range exceedance) as well as error messages.

Repeat step 2 to 4 until the result meets your requirements.

6. Use the [OK] button to insert the command into the test program.

Result Geometry
Variables

In the docking windows geometry lists the following values are given:

Docking
Window

Description

Results Determined quantity of pixels (if Count Pixels are activated)
and good/bad rating (if nominal Quantity and Tolerances are
activated) according to nominal quantity and tolerance.

7.3.19 Save Pattern

Image 134: Dialogue Save Pattern, tab
control: Parameters

With Locate > Save Pattern you write a command for recognising of a pattern
into your test program. The pattern is stored as a file on your vision system.

After inserting this command into the test program, patterns can be taught
in and stored separately from the program without vcwin pro. The number of
stored patterns depends of their size and the amount of memory available on
the vision system.

Existing image files with the same names will be overwritten. All existing
patterns can be displayed and deleted with the function Communication >
System Resources / Initial Program.

ADVICE
For vision systems of the type pictor MxxE, the patterns must be saved on
the vision system's flash, to keep them after the vision system is switched off.
This can be done by the Communication menu > Save File System FLASH
or Direct code Input with FB.
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You can use the stored patterns in the following commands as a reference
pattern (option: Pattern File):

Locate > 360° Pattern Search
Locate > Edge Based Object Search
Locate > Search Pattern
Obsolete > Advanced Pattern Search

You can assign a pattern to multiple search commands in a program or to
different programs.

Brief Guide 1. Define the position tracking in the Teach-in tab: no, X point, Y point

2. Activate teach-in mode by double-clicking with the right-hand mouse button.

3. Change the size and position of the search window in the video image with
the controls.

4. Deactivate teach-in mode by double-clicking with the right-hand mouse
button.

5. Assign a name to the pattern in the Parameters tab. Insert the command
into the test program with the [OK] button.

Teaching-in Pattern
Window

Position and Appearance of the Pattern Window

After double clicking with the right mouse button on the Teach-in tab, you can
position and adapt the pattern window on the control monitor or on the monitor
window. 
>> "Teaching in Detection Windows and Test Windows", Page 110

Tracking the Position

The pattern window can either always remain at the same image position or
follow a reference object. 
>> "Position Tracking of Objects", Page 118

Input Parameters Pattern Name Description

Name of
Pattern in
the Vision
System

Name under which the pattern is saved in the vision system.

Test Test the command with Utilities > Test Step, and check with Communication
> System Resources / Initial Program that the pattern has been successfully
stored.

Image 135: Dialogue System Resources / Initial Program - saved pattern
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7.3.20 Search Pattern

Image 136: Dialogue Search Pattern, tab
control Parameters

Image 137: Dialogue Search Pattern, tab
control Search Window

Image 138: Dialogue Search Pattern, tab
control Teach-in Pattern

You can teach in a command for detecting patterns within the image using
Locate > Search Pattern. The pattern is sought within a pattern window which
must not contain the pattern within a test window. You can use the command
to determine both the position of a reference pattern to be determined in a
search window, as well as making statements about the quality or presence of a
corresponding pattern based on a respective pattern object.

Brief Guide 1. Define the position tracking in the Search Window tab: no, X point, Y point.

2. Activate teach-in mode by double-clicking with the right-hand mouse button.

3. Change the size and position of the search window in the video image with
the controls.

4. Deactivate teach-in mode by double-clicking with the right-hand mouse
button.

5. If no pattern already loaded on the vision system is to be used, teach in the
reference pattern in the Teach-in Pattern tab using the following steps:
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° Double click the right-hand mouse button to activate the teach-in mode.
° Modify the size window in the video image using the arrow controls, then

position the pattern window within the search window.
° Double click the right-hand mouse button to deactivate the teach-in

mode.
° Teach in the pattern using the [Read Pattern] button.

6. Specify the following in the Parameters tab:

° Minimum grade of match of the found pattern to the taught pattern
° Search grid
° Saving of position of point number; grade of match
° Pattern (taught or load from vision system)
° Coordinate system pattern found (grade of match, position)

7. Test the command with the [Test] button: 
Modify the parameters set in points 1-6 until the test result is error free.

8. Insert the command into the test program with the [OK] button.

Teachin-in Patterns Position and Appearance of the Teach-in Pattern Window

After double clicking with the right mouse button on the Teach-in Pattern tab,
you can position and adapt the teach-in pattern window on the control monitor
or on the monitor window. 
>> "Teaching in Detection Windows and Test Windows", Page 110

Teaching-in the
Search Window

Position and Appearance of the Search Window

After double clicking with the right mouse button on the Search Window tab,
you can position and adapt the search window on the control monitor or on the
monitor window. 
>> "Teaching in Detection Windows and Test Windows", Page 110

Tracking the Position

The search window can either always remain at the same image position or
follow a reference object. 
>> "Position Tracking of Objects", Page 118

Input Parameters Search Para-
meters

Description

Min. Grade of
Match

Minimum compliance (correlation) of the pattern found with
the taught pattern in per cent, so that a pattern may be further
processed as a valid pattern.

• You can set the value directly. The values must be changed
if testing is unsuccessful.

• The degree of match is not influenced by the brightness in
the test window.

• 100% means exact compliance, 0% means no compliance.
• Useful settings are 60 to 80%.
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Search Grid Description

Define the degree of precision of the search process by the search grid.

Fine Fine search, e.g. for writing or gravure.

Medium Search for medium-fine structures.

Coarse Coarse search, e.g. for a rectangle without fine structure.

Strategy for Setting Search Grid

For time-critical applications, always search for the pattern with Coarse first.
If Coarse is not successful in the [Test], activate Medium or Fine.

There is an internal exact pixel search after each search procedure:

Function Sensitivity Speed Remarks Sketch

Internal exact pixel search time added to fine/
medium/coarse

seeks struc-
ture around
the position
found with
fine/medium/
coarse

Defining and Selecting
the Reference Pattern

Options for Defining the Reference Pattern

You have two options for defining the reference pattern:

• Defining the pattern in the Teach-in Pattern tab
• Using a pattern stored on the vision system

Option 1: Reading the Pattern in the »Teach-in Pattern« Tab

You will see the dialog box for finding a pattern in the Teach-in Pattern tab and
a rectangular detection window on the video screen. >> "Teaching in Detection
Windows and Test Windows", Page 110
The pattern window can have a maximum size of 256 × 256 pixels and must be
located in the test window. Using the [Read Pattern] button you can read the
image information within the pattern window. The reference pattern detected
is transferred as a miniature into the display and stored internally as a nominal
pattern.

Option 2: Using a Pattern Stored on the vision system

The prerequisite for this is that a pattern is loaded onto the vision system
with Locate > Save Pattern. >> "Teaching in Detection Windows and Test
Windows", Page 110

Check the pattern saved on the vision system using Communication > System
Resources / Initial Program.
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Setting a Reference Pattern in the »Parameters« Tab

During teach-in you set the reference pattern in the Parameters tab with the
Pattern option:

»Parameter
> Pattern«
Option

Description

Taught The pattern taught with Teach-in Pattern is used.

Load File
from Sensor

The pattern stored on the vision system is used.

Evaluation Parameters Save Description

Position Pt. Point number for saving the position of the pattern.

Grade of
Match Result

Gray value compliance (correlation) of the pattern found with
the taught pattern in per cent.

Image/World Saving in image coordinates or world coordinates.

Test Pattern Found

The test displays:

• Position … Position determined for the pattern found.
• Grade of Match … Gray value compliance (correlation) of the pattern found

with the taught pattern in per cent.

Example Three points serve as the reference pattern in the example.
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7.3.21 Inspect Surface

Image 139: Dialogue Inspect Surface, tab
control Parameters

You can insert a command which tests the quality of a surface by detecting
flaws using Locate > Inspect Surface. Defects/flaws are recognized by
searching for transitions using a grid within a test window. Select between one
of two grid types and set the width of the grid corresponding to requirements.
The quantity of edges found is used as a quality criterion and is stored in the
result structure. 

Brief Guide 1. Define the following parameters in the Teach-in tab:

° Shape of the test window: rectangle, ellipse, ellipsoid ring, contour from
contour buffer, circular ring

° Position tracking: no, X Point, Y Point or phi Line

2. Activate teach-in mode by double-clicking with the right-hand mouse button.

3. Modify the size and position of the search window in the video image using
the arrow controls.

4. Deactivate teach-in mode by double-clicking with the right-hand mouse
button.

5. Specify the following in the Parameters tab:

° Detection algorithm
° Grid direction and distance
° Result
° Nominal value (nominal number of edges)
° Tolerances (quality criterion)

6. Test the command with the [Test] button and modify the parameters set in
points 1 to 5 until the test result is error free.

7. Insert the command into the test program with the [OK] button.
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Teaching-in the Test
Window

The test window can have the following shapes: rectangle, ellipse, ellipsoid ring,
contour from contour buffer, circular ring (i.e., inspect surface in a circular ring
segment).

Position and Appearance of the Test Window

After double clicking with the right mouse button on the Teach-in tab, you can
position and adapt the test window on the control monitor or on the monitor
window. 
>> "Teaching in Detection Windows and Test Windows", Page 110

Tracking the Position

The test window can either always remain at the same image position or follow
a reference object. 
>> "Position Tracking of Objects", Page 118

In angular position tracking only the center of the window is rotated. The rotary
angle is produced from the angle between the position tracking line and the X
axis. The test window's direction and size remain intact during angular position
tracking.

Input Parameters Set suitable parameters interactively with the aid of the [Test] button. The
number of transitions found determines the quality of the surface.

Detection
Algorithm

Description

Binary The Binary algorithm recognizes transitions along the grid
when a predefined gray value threshold is reached.
Parameters: threshold value, noise filter

Gray Value The Gray Value algorithm recognizes transitions along the grid
by comparing the actual contrast with a nominal contrast. 
Parameters: contrast, diffusion, noise filter

Gray
Value / Auto
Contrast

This is similar to Gray Value above, but differences in the
color/brightness of objects or even fluctuations in lighting
conditions can be taken into account. The mean gray value
within the test window is determined. The contrast here is the
deviation allowed from this value (expressed as a percentage)
without a flaw being registered. Application: when there is very
low contrast and strong brightness variations. 
Parameters: percentage deviation from mean gray value, diffu-
sion, noise filter

Gradient The Gradient algorithm recognizes transitions along the grid
using the gradient method. 
Parameters: threshold value, width

Grid Direction and Width

Set the raster grid for detection with Raster, either parallel to the X/Y axis (left
selection button) or in a 45° angle (diagonally) to the X/Y axis (right selection
button). The optimum raster grid spacing must be determined through tests.
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Evaluation Parameters Parameters Description

Result Result number for storing the quantity of edges found.

Nominal
Value and
Tolerances

Nominal number of edges and the deviations (quantity of
edges) allowed.

Test The quantity of edges found is displayed in the test.

7.3.22 Search and Identify Objects

Image 140: Dialogue Search and Identify
Objects, tab control Parameters

With Locate > Search and Identify Object you add a command to your test
program that search and identify a previously teached-in object. See also:
"Teach-in Objects", Page 235

Brief Guide 1. Set the threshold for the search in Threshold. If vcwin pro should
automatically set the threshold, set the Automatic option.

2. Set the number of objects to be searched for in Quantity of Objects and set
the tolerance range for the quantity of objects within the object search that
should be taken as successful.

3. Use the Save for All Objects Found section to set in which elements of the
results structure the objects found and the rotary angles produced should be
saved.

Teaching-in the
Search Window

Position and Appearance of the Test Window

After double clicking with the right mouse button on the Teach-in tab, you can
position and adapt the test window on the control monitor or on the monitor
window. 
>> "Teaching in Detection Windows and Test Windows", Page 110
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Tracking the Position

The test window can either always remain at the same image position or follow
a reference object. 
>> "Position Tracking of Objects", Page 118

Image 141: Angular Position Output

7.3.23 Teach-in Objects

Image 142: Dialogue Tech-in Objects

Insert a command for teaching-in objects and for configuring the properties
and tolerances for every single object that should be inspected using Locate >
Teach-in Objects. 

Brief Guide 1. Set up the video image.

2. Use the [Grab Image] button to acquire an image that contains the objects
required.

3. Teach-in the required objects, one after the other, as follows:

° Enter the investigation parameters and the type of object (light and dark,
light, dark) in Object Properties.

° Double click the right-hand mouse button to activate the teach-in mode.
° Modify the size and position of the detection window in the video image

using the arrow controls. The detection window must enclose the object.
° Double click the right-hand mouse button to deactivate the teach-in

mode.
° Click the [Find] button: The object is read-in and added to the list of

objects found.
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4. Mark the objects in the left hand list of Objects Found and transfer them to
the right hand Objects Taught list with the [>>] button. 
This transfers the objects from the vision system to vcwin pro.

5. Mark the entries in the right hand Objects Taught list, one after the other, and
use [Edit] to set the individual test parameters and tolerances required.

6. Use [OK] to Teach-in the objects in the command to the test program. This
simultaneously loads the objects back into the vision system.

Grab Image At first do an image acquisition using the [Grab Image] button.

Live Image … Switch between live image and memory image

Teaching-in the
Search Window

After double clicking with the right-hand button in the Teach-in tab, you will see
a rectangular detection window on the video screen. This window cannot be
numerically set up, but only set up in the video image. >> "Teaching in Detection
Windows and Test Windows", Page 110

Input Parameters Object
Features

Description

The Object Properties decide the threshold of the Binary algorithm and the
permissible areas for the objects to be searched for.

Automatic When the distribution into light/dark objects is clear, this option
should be activated. The threshold is automatically defined
during execution.

[Find] button The [Find] button automatically determines the gray value
range for the threshold. Further properties and the tolerances
are taken up by the Object Properties. 
Smaller objects must be enclosed by the teaching window
at first. After teach-in they can be enlarged by later program
processing into usable search windows.

Threshold The gray value threshold for object recognition can be
changed.

Min./Max.
Area

Determines how many pixels the object is allowed to contain in
order to be recognized. Objects with more or fewer pixels are
ignored.

Colors Description

Light and
Dark

The colour of the objects is brighter or darker than the
surrounding brightness.

Light The colour of the objects is brighter than the surrounding
brightness.

Dark The colour of the objects is darker than the surrounding bright-
ness.

Transfer List The list of Objects Found is on the left hand side of the dialog window.

You can transfer the objects found into the right hand part of the dialog window
by clicking on the [>>] button. The [Clear] button removes entries. The [Edit]
button allows the test parameters of objects entered with teach-in to be defined
and the tolerances for the objects to be set.
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Parameters and
Tolerances of the
Objects

The parameters and tolerances of all the objects entered with teach-in can be
tested and changed in the Object Properties dialog box. This dialog box can
be opened using the [Edit] button.

Parameters Description

As Object
Number

Number of object.

Area The area of the object in pixels or measurement units,
depending on the coordinate type.

Min./Max.
Radius

Smallest/largest radius of the object contour.

Angle
between
Radii

Angle between the smallest and largest radii.

Grade of
Match

Correspondence to the outer contour in %.

Offset Angle Offset for the angular position (1/100 degree). If the object
already had an initial rotation during the image acquisition, the
offset can be added in order to relate the determined angular
position to the X or Y coordinate.

Color The color of the object (only relevant with color cameras,
otherwise black).

Covering
Area

Correspondence to the outer contour in %.

Min./Max.
Diameter

Smallest/largest radius of the object contour.

Angle
between
Diameters

Angle between the smallest and largest radii.
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7.3.24 Count Pixels

Image 143: Dialogue Count Pixels, tab
control Parameters

You can insert a command to count pixels into the test program using Locate
> Count Pixels. The command is an extension of Locate > Test Brightness
Percentage. The command tests whether the number of pixels between two
defined gray levels determined lies within a preset range. The number of pixels
determined is stored in the result structure. 

You use the command for monitoring and for regulating the brightness of a
lighting installation and for surface testing.

Brief Guide 1. Define the following parameters in the Teach-in tab:

° Shape of the test window: rectangle, ellipse, ellipsoid ring, contour from
contour buffer, circular ring

° Position tracking: no, X point, Y point or phi line

2. Activate teach-in mode by double-clicking with the right-hand mouse button.

3. Modify the size and position of the search window in the video image using
the arrow controls.

4. Deactivate teach-in mode by double-clicking with the right-hand mouse
button.

5. Specify the following in the Parameters tab:

° Gray value range
° Result
° Nominal number and tolerances (of pixels in the gray value range)

6. Test the command with the [Test] button and modify the parameters set in
points 1 to 5 until the test result is error free.

7. Insert the command into the test program with the [OK] button.
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Teaching-in the Test
Window

The test window can have the following shapes: rectangle, ellipse, ellipsoid
ring, contour from contour buffer, circular ring (i.e., count pixels in a circular ring
segment).

Position and Appearance of the Test Window

After double clicking with the right mouse button on the Teach-in tab, you can
position and adapt the test window on the control monitor or on the monitor
window. 
>> "Teaching in Detection Windows and Test Windows", Page 110

Tracking the Position

The test window can either always remain at the same image position or follow
a reference object. 
>> "Position Tracking of Objects", Page 118

Input Parameters Parameters Description

Gray Value
Range

The gray scale value range is specified with two gray scale
values, and all pixels that lay between these two values are
counted.

Evaluation Parameters Parameters Description

Result Result number for saving the pixel count determined in the
gray value range.

Nominal
Quantity and
tolerances

Nominal pixel quantity and the permitted ± tolerances (in
pixels).

Test The detected quantity of pixels is displayed in the test window during the
test. In the process, the pixels that are within the gray scale value range are
superimposed into the overlay.

7.3.25 Locate Point

Image 144: Dialogue Locate Point, tab
control Parameters

You can find transitional points in the video image using Locate > Locate
Point. The command applies to a gray value edge cut by the detection beam.



vcwin pro 2.21
Part 2 - Command Reference

240 999.994.306.10-en-1.15 © Vision & Control GmbH 2015

The detection beam is defined by its start and end positions. The direction of
detection is shown by an arrowhead. A point found along the detection beam
is stored as a geometrical point element. The number of points to be saved
depends upon the vision system.

Brief Guide 1. Define the position tracking in the Teach-in tab: no, X point, Y point or phi
line. If required, activate the Endpoint Only option.

2. Activate teach-in mode by double-clicking with the right-hand mouse button.

3. Modify the size and position of the detection beam in the video image using
the arrow controls.

4. Deactivate teach-in mode by double-clicking with the right-hand mouse
button.

5. Specify the following in the Parameters tab:

° Detection algorithm
° Co-ordinate system
° Point no.
° Edge transition

6. Test the command with the [Test] button: 
Modify the parameters set in points 1-5 until the test result is error free.

7. Insert the command into the test program with the [OK] button.

Teaching-in the
Detection Beam

After calling Locate > Locate Point, you will see the dialog box in the Teach-in
tab and a detection beam on the video screen.

Variant 1: Entering Parameters in the Edit Mask

Enter the X and Y values for the start and end points of the beam into the
respective fields. Change the values as required with the arrows on the right
hand side. Watch the shift in position and scale of the beam on the video
screen.

Variant 2: Setting Parameters on the Monitor Window / Control Monitor

Double click the right-hand mouse button to switch from the Teach-in tab to
the monitor window or the control monitor. Moving the mouse pointer over the
arrowhead or the tail of the detection beam causes a small cross to appear.

To edit the detection beam, hold down the left mouse button while the cross is
still visible:

• from the tail … to move beam in parallel
• from the head … to reposition the arrowhead

To move the arrow around the screen, position the mouse cursor on the arrow
and hold down the left mouse button while moving the mouse.
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Double clicking on the detection beam with the left mouse button will reverse its
direction.
Double clicking with the right mouse button switches back to the edit window in
the Teach-in tab.

Tracking the Position The detection beam can either be at a fixed image location (no tracking) or it
can follow a reference object.

Activation of the Endpoint Only option means that position tracking uses only
the front point of the detection beam as a reference point. The base always
remains in the same image position.

For position tracking >> see "Position Tracking of Objects", Page 118

Input Parameters Detection Algorithm
When detection parameters (thresholds, widths, filters) are modified, the dialog
box automatically tests the configuration. However, you can also set adequate
parameters interactively with the [Test] button. Use the transitions found to
define points.

Detection Algo-
rithm

Input Parameters / Description

Binary Gray value threshold, noise filter

Gray Value Contrast, edge diffusion, noise filter

Gray Value with
Subpixel

Contrast, edge diffusion, noise filter, width

Max. Gradient Width of detection, edge diffusion, noise filter

Gradient Gray value threshold, width, edge diffusion, noise filter

Convolution
max. Coefficient

Detection width

Convolution Gray value threshold, width of detection

Helix max.
Gradient

Width of detection, edge diffusion, noise filter
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Detection Algo-
rithm

Input Parameters / Description

Helix Gray value threshold, width of detection, edge diffusion,
noise filter

Free Search
Direction

If Free Search Direction is inactive, only detection in a
45° grid is possible, i.e., the detection arrow jumps at an
angle of 45° to the position with the best contrast. The
speed of the command is hence maximized. Activate Free
Search Direction in order to to set the search direction for
maximum gradient, gradient, convolution max. coefficient,
and convolution freely.

Position with
best Contrast

Searches within the detected edge for the local maximum.

>> "Principles of Detection", Page 376

Edge Transition
The type of transition can be either light-dark or dark-light.

Edge Transi-
tion

Input Parameters / Description

Light -> Dark Only light-dark transitions are included.

Dark -> Light Only dark-light transitions are included.

Evaluation Parameters Evaluation
Parameters

Description

Point Number or name under which the coordinates of the found
point is stored in the point structure.

Image/World Saving in image coordinates or world coordinates.

Test The test displays:

• X … X coordinate of the point found.
• Y … Y coordinate of the point found.

7.3.26 Measure Temperature

Overview

Image 145: Monitor
Window: thermal image

Image 146: Monitor
Window: Detection
Window at position

Image 147: Monitor
Window: Display Point
max. Temp.

Characteristics

• Determining the temperature in a thermal image.
• Determining of minimum, maximum and average temperature.
• Determining of the extreme points of minimum or maximum temperature.
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Definitions Emissivity

• The emissivity is the heat emission emanating from the measurement object,
compared to that of a black body.

• The value is between 0 and 1.

Transmissivity

• The transmissivity is the characteristic of media, which are located between
the camera and measurement object, to allow heat radiation to pass. For
example, these media can be air, cover glasses or protective housing.

• The value is between 0 and 1.

Reflected Temperature

• The reflected temperature indicates the heat emission in the vicinity of the
measurement object reflected by the measurement object.

Function • The command calculates the temperature of an object surface with the
specified parameters.

• The camera sensor receives the thermal radiation from the environment and
converts it into the total temperature Ttotal. Note that the sensor value is not
equal to the visible 8-bit image, but the respective full image value of the
camera used.

• Then the command calculates from the transmitted camera values and the
input parameters the object temperature Tobj.

Tobj Object temperature Tamb Ambient temperature
Ttotal Total temperature ε Emissivity
Trefl Reflected temperature τ Transmissivity

Work Flow: Teach-in 1. Switch to the tab control "Teach-in".

2. Determine here, by means of a geometry, in which image region the
temperature should be determined (see also: "Teaching in Detection
Windows and Test Windows", Page 110).

3. If necessary, set the parameters (X Point, Y Point, phi Line) for position
tracking (see also: 118).
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Work Flow:
Parameterizing 1

8

2

3

5

6

7

4

Image 148: Dialog Measure Temperature, tab control Parameters

1. Switch to the tab control "Parameters".

2. Enter in the group box "Parameters" the ambient and material parameters
for the measurement.

Parameter Description

Emissivity Enter here the emissivity of the material to be measured.
If the value is taken from a result, activate from Result and
select the appropriate result from the drop-down list. The
emissivity is between 0 and 1. If you take this value from
the result multiply it by 1000. 1 = 1000; 0.5 = 500 etc.

Transmis-
sivity

Enter here the transmissivity of the material between the
measuring object and the camera.
If the value is taken from a result, activate from Result and
select the appropriate result from the drop-down list. The
transmissivity is between 0 and 1. If you take this value
from the result multiply it by 1000. 1 = 1000; 0.5 = 500 etc.

Reflected
Temperature

Enter here the reflected temperature.
If the value is taken from a result, activate from Result and
select the appropriate result from the drop-down list.

Ambient
Temperature

Enter here the ambient temperature.
If the value is taken from a result, activate from Result and
select the appropriate result from the drop-down list.

3. Set in the group box "Mode" the kind of temperature to be determined.
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Parameter Description

Minimum
Temperature

The command determines the minimum temperature and
the position in the selected geometry area.

Maximum
Temperature

The command determines the maximum temperature and
the position in the selected geometry area.

Average
Temperature

The command determines the average temperature over all
pixels in the selected geometry area.

Work Flow: Testing
and Saving

4. Test the settings here

By activating the [Test] button the command is executed with the set
parameters. In the group box "Test" the determined temperature is shown. In
parallel, the location of the minimum or maximum temperature is marked in
the video image with a red cross.

5. Configure under "Temperature in °C" the settings for the evaluation of the
command and for storing the result.

Parameter Description

Result Enter here the number or the name of the result under
which the measured temperature is to be stored in the
result list.

Nominal
Temperature

Enter here which temperature must be measured so that
the command is considered successful.

'+' Tolerance Permitted upward deviations from the Nominal Tempera-
ture.

'-' Tolerance Permitted downward deviations from the Nominal Tempera-
ture.

6. Set under "Position of min. / max. Temperature" and "Coordinate
System" the saving option of the temperature extreme point.

Parameter Description

Position of
min. / max.
Temp. in
Point

Enter the number or name in the point structure under
which the coordinates of the temperature extreme point is to
be saved.

Image /
World

Indication whether the point is to be stored in image or in
world coordinates.

7. Evaluation Area

Here you can see the good/bad evaluation of the command, notes for
parameterization (tolerance range exceedance) as well as error messages.

8. Use the [OK] button to insert the command into the test program.

Status- and Error
messages

0 = No Errors

• The command executed successfully with the specified parameters.
• The measured temperature is within the specified target range (incl.

tolerances).
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1 = Temperature out of tolerance range.

• The command determines a temperature that is not within the specified
target range (incl. tolerance).

2 = Invalid Parameter

• At least one parameter is invalid.
• Check the settings of the command. Check that the used mode of the

command is supported by the vision system used.

3 = Tracking variable not defined.

• The specified point for the X- or Y- position tracking is not defined.
• The specified phi Line for the position tracking is not defined.

4 = Not a thermographic image.

• The command was not executed on a thermal image.

5 = Not a thermographic camera.

• The command was not executed on a thermographic camera.

7 = No valid thermography license available.

• The command is not supported by the used vision system.

7.3.27 Locate Helix

Overview Detection Window

Teach-in Window

Image 149: Position of the
Teach-in and Detection
Windows

Image 150: Edge image in
Monitor Window

Image 151: Display of
reference line in Monitor
Window

Characteristics

• The calculation is performed in sub-pixel accuracy.
• Rotations of the coil cusp from up to 10° will be tolerated.
• Edge points with large aberration (e.g. interfering edges as highlights) are

ignored.
• The accuracy is achieved even if the helix is in tilt (rotation of the edge points

of the taught pattern based on the total position of the helix).

Function 1. Searching of coil cusps by comparing with a thought pattern of a single coil
cusp.

2. Determining the position of the cusps.

3. Determining of edge transitions (horizontal and vertical) at the coil cusps
found.

4. Comparing of the determined edge transitions with the existing edge
transition pattern.

5. Determining of a reference line through the found positions of the coil cusps.

6. Checking the amount of coils and storing the results.

7. Determining of other parameters by using the command Evaluate > Check
Point Distances see "Check Point Distances", Page 301.
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Work Flow: Teach-in
Pattern

1. Switch to the tab control "Teach-in Pattern".

2. By means of the geometry rectangle, determine a single coil cusp that has
to be read-in as the pattern. (Information for teaching, see also: "Teaching in
Detection Windows and Test Windows", Page 110).

3. With the button [Read Pattern] you read-in all image information located in
the geometry as the pattern, and stored it internally in the command.

4. In the reference window, verify if the pattern is complete.

Work Flow: Define
Teach-in Area

1. Switch to the tab control "Teach-in".

2. Please set the geometry, size and position of your detection window. In this
area, your pattern is searched (see also: "Teaching in Detection Windows
and Test Windows", Page 110).

3. If necessary, set the parameters (X Point, Y Point) for position tracking (see
also: 118).

4. With the button [Test] you can check whether cusps corresponding to the
thought pattern are found by using default settings.

Work Flow:
Parameterizing 1

8

2

3

4

5

6

7

Image 152: Dialogue Locate Helix, tab control Parameters

1. Switch to the tab control "Parameters".

2. In the area "Search Pattern" determine the search precision method and the
minimal grade of match.
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Parameter Description

Search Preci-
sion

Factor used for image and pattern for the pattern search.

Factor for Search Precision

• 0 = original resolution
• 1 = half resolution
• 2 = quarter resolution
• etc.

The effect of the search accuracy on the taught pattern
is shown in the area "Pattern" in the tab control "Pattern
Search".

Minimal
Grade of
Match

Similarity that must be achieved in an image area with the
pattern, so that the pattern is marked as coil cusp.

• If further image contents, except the actual coil cusps,
are detected as coil cusp, increase the Grade of Match.

• If single coil cusps are not detected, decrease the Grade
of Match.

3. In the area "Locate" set parameters for finding the edge transitions on the
edge of a coil cusp.

Parameter Description

Contrast Criterion for edge detection. Specifies the minimum grey
value difference, from which a transition is considered as an
edge.
The value should be slightly smaller than the grey value
difference between background and helix.

Diffusion Indicates the number of pixels in which the grey value has
to change by a certain amount (contrast) so that the transi-
tion is counted as an edge.
The value should correspond to the number of transition
pixels at the edge between the background and helix. For
an optimal determination of a subpixel edge, enter a diffu-
sion of at least 3.

Width Number of pixels that is averaged transversely over the
edges.
Individual pixels and noise can be compensated.

Noise Filter Number of pixels that are averaged over the front and rear
of the edge.
Using the noise filter pseudo edges and noise are compen-
sated.

Work Flow: Testing
and Saving

4. Test the settings here

After activating the button [Test], all coils found with the search parameters
are list in the area "Test". In parallel, the coils found are highlighted in the
video image with a red cross. Use the arrow keys to scroll through the
respective matching coils.
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Parameter Description

Number of
Coils

Indication of coils found.

Grades of
Match

Indication of the minimal and maximal grade of match.

5. In the area "Number of Coils" enter the requirements for the assessment of
the command and to store the results.

Parameter Description

Result Enter the number or the name of the result under which the
quantity of coils found is to be stored in the result structure.

Nominal
Quantity

Specify here how many coils must be found so that the
command is considered successful.

'+' Tolerance Permitted upward deviations from this target value.

'-' Tolerance Permitted downward deviations from this target value.

6. In the area "Positions of the Coils" and "Coordinate System" enter the
saving options of the coils centres and the reference line from coil points.

Parameter Description

Positions as
a List from
Point

Enter the number or name in the point structure, from which
the positions (points) of the coils found are to be stored.
This can be used as an input for the command Check Point
Distances.

Line from Coil
Positions

Enter the number or name in the line structure, under which
the line determined from the coil points is to be stored.
This can be used as an input for the command Check Point
Distances.

Image /
World

Indication whether the points are to be stored in image or in
world coordinates.

7. Evaluation Area

Here you can see the good/bad evaluation of the command, notes for
parameterization (tolerance range exceedance) as well as error messages.

8. Use the [OK] button to insert the command into the test program.

Error messages Possible error messages

Number of coils outside the tolerance range

• The command has found more or less coils than the Nominal Quantity (incl.
tolerances).

Tracking variable not defined

• The specified point of the X or Y tracking is not defined.

Command does not work on color image

• The command was executed on a color image. Convert the image into a
grayscale image see "Color Conversion", Page 144.
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Pattern not yet taught

• Before executing the command, the pattern of a single coil cusp must be
thought in the "Teach-in Pattern" area.

Not enough edges in the pattern

• At a coil cusp no sufficient number of edge points could be determined. This
can have two causes:

° The parameters for the edge detection are unsuitable (for example to
high contrast).

° A coil cusp was found at a point where no coil cusp exists. In this case,
the Minimal Grade of Match should be increased.

7.3.28 Locate Angle

Image 153: Locate Angle -
Detection Windows

Image 154: Locate Angle -
Positioning of the Detection
Windows

Image 155: Locate Angle -
Display: lines found in the
Detection Windows

With Locate > Locate Angle you determine the angle between two object
edges. You select the edges via two detection windows, in which the individual
edge points are detected. A line, which represents the respective object edge, is
created from each of the edge points.

Workflow
Teach-in

1. Switch to the tab control "Teach-in".

2. If necessary, set the parameters (X Point, Y Point, phi Line) for position
tracking (see also "Position Tracking of Objects", Page 118).

3. Set here the position of the respective detection windows (see also
"Teaching in Detection Windows and Test Windows", Page 110).

ADVICE
Optimal positioning of the windows

• Position the windows so that the detection arrow is perpendicular to the
edge to be probed.

• Position the windows so that the edge is completely covered.
• The values for the rotation are selectable in the range of -180.00°

to +179.99°, and are in 1/100°. The result for the value 9000 is 90°,
17999 is 179.99°.

4. Use the [Test] button to check whether the edges are found in the detection
window with the default parameters.
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Workflow
Define Parameters

5

e

b

d

a

g

c

6

f

7

Image 156: Dialogue Locate Angle, tab control Parameters

5. Switch to the tab control "Parameters".

Set here the parameters:

a) Edge Transition
b) If necessary: Noise Edge Filter
c) Parameters for edge detection
d) Minimum edge completeness in per cent

6. Test the command with the [Test] button:

In the area "Test" the determined data are shown.
Modify the parameters in the points (a) to (d) until the result is error free.

Set further parameters:

e) Result number/name under which the angle is to be stored, as well as the
nominal value and tolerances for the evaluation. The values are given in
1/100°. A value of 27000 corresponds to an angle of 270°.

f) Coordinate System
g) Save settings of the values determined for Edge Completeness, Vertex

Point and Side Line.

7. Use the [OK] button to insert the command into the test program.



vcwin pro 2.21
Part 2 - Command Reference

252 999.994.306.10-en-1.15 © Vision & Control GmbH 2015

Parameters Edge Transition

Here you can specify whether the edge transition is from light to dark or from
dark to light.

Parameter Description

Light->Dark Only edge transitions from light to dark are considered.

Dark->Light Only edge transitions from dark to light are considered.

The detection direction is an important factor for these parameters. You can
find any object edge with both possible settings (light->dark, dark->light) if
you change the detection direction accordingly. Note, however, that the edge
intersections cannot be individually adjusted for each detection area.

Parameters Noise Edge Filters

These parameters are used to improve the creation of the line from the edges
found. If there are numerous interfering edges in the detection area, this filter
reduces the processing time significantly.

Parameter Description

First Edge
Only

If you activate this checkbox the algorithm searches through
every line of the detection area until it finds the first object
edge that corresponds with the set parameters.
If you deactivate the checkbox, all edge points that apply for
the existing parameters are detected and processed.

Remove Short
Edges

If you activate this checkbox, individual edge points or smaller
edges are automatically ignored and filtered out. This interfer-
ence filter is active by default.

Parameters Edge Filter

These parameters are used to improve the edge detection. When using the
arrow keys a test is performed and the result displayed immediately.

Parameter Description

Contrast You enter the differential amount here, which must be at least
in the image with a grey value transition so that an edge point
can be found.

Width Number of pixels over which the sub-pixel algorithm is applied.

Diffusion Length of the edge increase.

Noise Filter The noise filter is the number of pixels in a row that meet the
requirements so that the edge is considered as an edge.
Example: a noise filter of 2 hides all edges that meet the
conditions, but are shorter than 2 pixels.

Parameters Minimal Edge Completeness

You can consequently specify how closed and therefore clear an edge must
be in the image to be detected as an applicable object edge. Pixel gaps, which
can be caused by possible image interferences between individual edge points,
can also be compensated and replaced with a certain tolerance. The edge
completeness always refers to the complete detection window. A measurement
is also performed if the detection window is partially outside the image. In this



vcwin pro 2.21
Part 2 - Command Reference

© Vision & Control GmbH
2015

999.994.306.10-en-1.15 253

case however, the edge completeness decreases according to how much of the
window is outside the image.

Parameter Description

min. Edge
Completeness
(%)

Here you enter the minimum percentage of image lines, that
must have at least one edge point, so that an object edge is
detected.

Parameters Angle

Parameter Description

Result Result number/name in which the angle is to be stored.

Nominal
Angle

Nominal value of the determined angle so that the command is
considered to be successful. The values are given in 1/100°. A
value of 27000 corresponds to an angle of 270°.

+/- Tolerance Allowed upper and lower deviation from the nominal angle.
The values are given in 1/100°. The values of +100 and -100
correspond to a tolerance of +1° and -1°.

Parameters Coordinate System

Parameter Description

Image Storing of the points and lines is in image coordinates.

World Storing of the points and lines is in world coordinates.

Parameters Save Settings

Parameter Description

Edge
Completeness

Result number/name in which the determined edge complete-
ness should be saved.

Vertex Point Point number/name in which the determined vertex should be
saved.

Side Line 1 Line number/name in which the determined side line 1 should
be saved.

Side Line 2 Line number/name in which the determined side line 2 should
be saved.

Results Determined Angle and Edge Completeness

After activating the [Test] button, the determined angle and the edge
completeness are shown in the area "Test". The determined angle is given in
1/100° and the completeness in per cent.

In parallel, the determined lines and the angle are shown in the video image.

Geometry Variables

In the docking windows geometry lists the following values are given:
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Docking
Window

Description

Results Determined angle and good/bad rating according to nominal
angle and tolerance.
Edges completeness (if declared) and good/bad rating
according to min. edges completeness.

Points X and Y value of the vertex (if declared) in the chosen coordi-
nate system type.

Lines Side Line 1 (if declared) in the chosen coordinate system type.
Side Line 2 (if declared) in the chosen coordinate system type.

vertex

detection window 1

detection window 2

side line 1

angle

side line 2

Image 157: Locate Angle, display of the result

7.3.29 Read Character

Image 158: Dialog Read Character, tab
control Parameters

Use Locate > Read Character to teach-in a test command for reading clear
text characters on the basis of a previously taught character set. When
executing the command, position the search window around the character or
characters to be read. 

Within the same program, you can read several character sets. All of them
are saved in the program. The last character set read is set as the current
character set for all subsequent read functions in the test program. When
reading, the characters are recognized in the same way as during the teach-in,
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and compared with the current character set. Characters will be recognized if
the correspondence is greater than or equal to the specified minimum value.

Prerequisites for the Teach-in

• Communication with the vision system must be initialized.
• Character set must have been taught. >> "Set Characters Set", Page 260
• Character type must correspond to the character type taught-in (fixed size or

scalable character set).

The parameters of the taught character set appear in the edit dialog box.

For the evaluation, the character read (as string) or the result of the
correspondence, together with the taught-in characters are stored or sent.

More Information:

• "Send Measuring Values", Page 370
• "Superimpose", Page 270

You can store the character detected in a string or appended it to an existing
string with Evaluation > Evaluate String command. You can store the gravity
center of the first character in a point in order to read several strings at equal
spacing. This point is then used as a reference point for reading the next
character.

Brief Guide The programming of Read Character takes place in the following order:

1. Define character type: fixed size (single characters) or scalable character
set.

2. Define threshold, character color and segmentation (in the case of a scalable
character set).

3. Define the detection window.

4. Test and/or teach character recognition in the detection window.

5. Set the evaluation parameters.

Teaching-in the
Detection Window

Position and Appearance of the Search Window
After double-clicking with the right-hand mouse button, a teach-in dialog box
and a rectangular detection window will appear on the video screen. The search
window is characterized as follows for both character types:

Fixed Size (single characters) Scalable Character Set

• Each character requires its own
command in the program.

• The search window encloses only
one single character.

• The search window is the same
size for all characters within an
edited program. The size specified
for the first character applies to all
subsequent characters.

• The search window encloses all
characters (even several lines).

• The individual characters are
detected automatically by the
segmentation of the search
window.

>> "Teaching in Detection Windows and Test Windows", Page 110
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Tracking the Position
The detection window can either be at the same image location (no tracking) or
it can follow a reference object. >> "Position Tracking of Objects", Page 118

With the aid of position tracking, arrange several read commands for individual
characters advantageously in a loop. See Strategy for Defining a Loop for
Reading Single Characters later on in this section.

Input Parameters The character type must correspond to the taught-in character type. For
information regarding the advantages and disadvantages of individual character
types with Set Character Set: >> "Table 0: Title", Page 261

Threshold
for Character
Position

Description

You can use this threshold for defining the character position within the search
window. The gravity center point of the character is used as the reference for
the character position, this is calculated internally.

Automatic
(Histogram)

Automatic threshold determination with the gray scale value
histogram

Average Gray
Value

Determination of the threshold with the median gray scale
value in the window.

Fixed Manual determination of a fixed threshold in gray values. Initial
values between 80 and 120 are advantageous.

• You must change this if the reading with the [Test] button is
unsuccessful.

• The reading quality is affected by the brightness in the test
window.

Character
Color

Description

Dark The character to be read is a dark color on light background

Light The character to be read is a light color on dark background.

Character
Area for
Segmenta-
tion

Description

All characters in the video image are automatically segmented (separated) for
the character type scalable character set. In so doing, the center of gravity
of each segment is determined. The permissible size range of each character
has to be defined.

Min. Area Minimum area of a single character.

Max. Area Maximum area of a single character.
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Evaluation Parameters Save Description

String String number for storing the character.

New/Attach Option for defining whether the string is newly written or a
character is to be appended to the string.

Image/World Saving in image coordinates or world coordinates.

Position of
Last Char-
acter

Point number for storing the gravity center point of the last
character read (use this point for the character type “single
character [fixed size]” as reference point for the position
tracking before reading the next character.)

Grade of
Match RES

Result number for storing the degree of correspondence
(consistency rate).

Min. Grade of
Match

Required gray value correspondence (correlation) in per cent
of the character found with the assigned taught-in character
for the test procedure.

Test The test displays the following:

Parameters Description

Characters Quantity of characters determined (for the character type fixed
size: 0 or 1).

Grade of
Match

Gray value correspondence (correlation) in per cent of the
pattern found with the taught-in pattern.

Character
Area

Size of the character area in pixels × pixels.
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Recognizing
Characters with Fixed
Sizes

Prerequisite: The character set has been taught-in as fixed size (single
character)

1. Open the Read Character dialog box.

2. Enter the evaluation parameters (string, grade of match, coordinate system).

3. Position the search window around the first character allowing some
clearance. (The largest character in the character set should fit into the
search window.)

4. Click on the [Test] button. 
The character is read in and displayed in clear text together with the
consistency rate (Grade of Match) in comparison to the taught-in nominal
character. If a question mark “?” is displayed, you should change the
detection parameters or teach this character in again.

5. Click on the [OK] button. 
The Read Character dialog box closes. A program step is added which can
read a character in the corresponding position in run mode.

6. Repeat steps 1 to 6 for each further character: See example picture 
Recognize Character • Program script example for 5 characters: fixed
size (single characters).
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Strategy for Defining a Loop for Reading Single Characters

ADVICE
As the gravity center points of the individual characters vary as a result of the
differing geometries of the characters, you should select a search window in
the video image which is larger than the actual character (especially at the
top and bottom).

Prerequisite: The read command for a single character can run in a loop if the
spacing between all the characters is equal and they all have similar sizes.

1. Save the gravity center point of the first character as Position of Last
Character in a point number, e.g. “2”. See example picture Recognize
Character • Program script example for 5 characters: fixed size (single
characters).

2. For teaching-in the next character:

° Select the previously saved point (“2” in the example) for position
tracking.

° Save the determined gravity center point again under the same number
(“2” in the example) as Position of Last Character.

3. Nest the command taught-in with pos. 2 in a loop with the aid of program
control commands.

Result: The position at which each new character is determined is related to the
gravity center point of the previously recognized character in each case. The
search windows of successive characters are shifted relative to one another by
the same amount.

Recognizing
Characters with
Scalable Sizes

Prerequisite: The character set was taught as Scalable character set.

1. Open the Read Character dialog box.

2. Enter the evaluation parameters (string, grade of match, coordinate system).

3. Position the search window around all the characters allowing some
clearance.

4. Click on the [Test] button. 
The characters are read in, automatically segmented, and displayed in clear
text together with the degree of correspondence in comparison to the taught-
in nominal character. If a “?” is displayed, the detection parameters must be
changed, or this character must be taught-in again.

5. Click on the [OK] button. 
The Read Character dialog box closes. A program step is added which can
read all characters in the corresponding positions in run mode.
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7.3.30 Set Characters Set

Image 159: Dialogue Set Character Set

Teach-in character sets or individual characters interactively with Locate > Set
Character Set. When using this command, the detection window is positioned
around one or more characters for teach-in. 

Use the command for preparing the automated reading of clear text characters,
such as those described in the Read Character section. >> "Read Character",
Page 254
Preferably, embed this command in a teaching program which runs before the
actual test program.

Character Set with Fixed Size

You can determine the gravity center point of all pixels of the character color
using the Fixed Size (Single Character) option. The data of the character is
read in relative to this gravity center point. The taught-in characters are inserted
into a character set. In the current character set, the individual characters can
be leafed through, deleted or replaced by new characters. In the case of a
character set with fixed sizes, the window size cannot be changed after the first
character has been inserted.

Scalable Character Set

You can segment all characters present in the window corresponding to color
and surface area using the Scalable Character Set option. The data of the
characters are read one after the other and displayed in the dialog box. An
individual character can be selected and inserted into the current character set.

Brief Guide The programming of Set Character Set takes place in the following order:

1. Define character type: fixed size (single character) or scalable character set.

2. Define threshold, character color and segmentation (in the case of a scalable
character set).
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3. Define the detection window. Read the image of the character(s) in the
search window.

4. Assign a nominal character to the image of the character(s) read and
transfer it into a character set.

5. Click on the [OK] button to transfer the character set to the vision system.

Teaching-in the
Detection Window

Position and Appearance of the Search Window
After double-clicking with the right mouse button on the left corner of the dialog,
you can position and adapt the detection window on the video screen. This
search window is characterized as follows for both character types:

fixed size (single characters) scalable character set

• The search window encloses only
one single character.

• The search window is the same
size for all characters within an
open dialog box. The size specified
for the first character applies to all
subsequent characters.

• The search window encloses all
characters (even several lines).

• The individual characters are
detected automatically by the
segmentation of the search
window.

>> "Teaching in Detection Windows and Test Windows", Page 110

Input Parameters Character
Type

Fixed size (single charac-
ters)

scalable character set

You can switch between the character types fixed size (single characters)
and scalable character set until a character has not been taught.

Advantages • Characters which flow into
one another or are broken
can be recognized.

• It does not need to be
segmented (better recogni-
tion).

• Individual characters can
be inserted into the char-
acter set later.

• All characters can be
taught in a single program
step.

• The characters to be
recognized (read charac-
ters) may be a different
size to the taught-in char-
acters.

Disadvan-
tages

• An individual detection is
required for each char-
acter.

• Only one character can be
taught with one detection.

• The characters to be
recognized (read charac-
ters) must be the same
size as the taught-in char-
acters.

• Characters which flow into
one another or are broken
cannot be recognized.
Good character quality is
required.

• See later below: Problem-
atic characters with scal-
able character set.

Problematic characters with scalable character set
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Threshold
for Character
Position

Description

You can define a binary threshold for determining the gravity center point of
the character (fixed size/single character) or for segmenting the character
(scalable character set). The gravity center point of the character is used as
the reference for the character position, this is calculated internally.

Automatic
(Histogram)

Automatic threshold determination with the gray scale value
histogram.

Average Gray
Value

Determination of the threshold with the median gray scale
value in the window.

Fixed Manual determination of a fixed threshold in gray values. Initial
values between 80 and 120 are advantageous.

• You must change this if the reading with the [Read] button
is unsuccessful.

• The reading quality is affected by the brightness in the test
window.

Character
Color

Description

Black The character to be taught is a dark script on light background.

White The character is a light script on dark background.

Character
Area for
Segmenta-
tion

Description

All characters in the video image are automatically segmented (separated) for
the character type scalable character set. In so doing, the center of gravity of
each segment is determined. The permissible size range of each character
has to be defined.

Min. Area Minimum area of a single character.

Max. Area Maximum area of a single character.
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Setting Parameters for
Reading and Defining
»Characters«

Characters
Found

Description

After reading the characters, a segment is displayed for each character
detected. Scroll between the segments with the cursor keys.

No. of Char-
acters

Quantity of characters found.

Threshold Automatic or manually defined gray value threshold.

Character
Area

Size of the character area in pixels × pixels.

Assignment Nominal character entered which is to be assigned to the
segment displayed in the window. You can enter with the
keyboard all those characters and symbols which can be
displayed in the input field. It is possible to separate them into
upper and lower case letters.

Current
Character
Set

Description

A segment is displayed for each character defined. Scroll between the
segments with the cursor keys.

Characters Nominal character assigned to the segment displayed in the
window.

Number Number of characters in the character set.

Teaching-in Single
Characters (Fixed
Size)

Prerequisite: The Set Character Set dialog box is opened and the character
type Fixed Size (Single Character) has been selected.

1. Position the search window around the first character allowing some
clearance. (The largest character in the character set should fit into the
search window.)

2. Click on the [Read] button. 
The character is read in. The character read is displayed in the segment.

3. Enter the associated nominal character on the keyboard.

4. Click on the [Insert >>] button. 
The defined character is transferred into the current character set. Repeat
steps 1 to 4 for each further character.
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5. Click on the [OK] button. 
The characters included in the current character set are sent to the vision
system.

Example: Program entry for the taught characters teached by Set Character
Set/ fixed size (single character)
Font with fixed size [48,82], black
Number of characters 4:0421

Teaching-in a Scalable
Character Set

Image 160: Examble of search window: Each character detected is a separate segment.

Prerequisite: The Set Character Set dialog box is open and the character type
Scalable Character Size has been selected.

1. Position the search window around all the characters of the character set.

2. Click on the [Read] button. 
The characters are read in and automatically segmented. 
The segments are displayed in the image section of the dialog box together
with the characters which have been read in. Scroll between the characters
with the cursor keys.

3. Enter on the keyboard the nominal character associated with the character
displayed (segment).

4. Click on the [Insert >>] button. 
The defined character is transferred into the current character set.

5. Repeat steps 3 and 4 for each further character (also see Fig. above).

6. Click on the [OK] button. 
The processed character set is sent to the vision system together with the
defined characters. 
The Set Character Set dialog box closes. The character set has been
taught.

Example: Program entry for the taught characters for search window (relates to
example of search window below point 2)
Scalable Font, black
Number of characters 8:80753136
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7.4 Evaluation Commands

7.4.1 Best Fit Line

Image 161: Dialogue Best Fit Line / Straightness

You can define a command for determining the best fit line from the contour
buffer or points from the point structure using Evaluation > Best Fit Line. 

You can also test the selected contours and points for straightness.
Straightness is defined as a cylinder around the best fit line which contains
all the points. So, the straightness is the maximum distance between the
calculated straight and any given point.

Select the points and contours which you want to include from the list of
geometry variables using the mouse and confirm the selection by clicking on
the [OK] button. Defined elements in the list appear dark and undefined ones
appear gray.

Input Parameters Parameters Description

Coordinate
system >
Image/World

Calculation in image coordinates or world coordinates (may
only be specified from contours, not from points).

Determine
> From
Contours/
From Points

Selects whether straightness is defined from contours or from
points.

Evaluation Parameters Evaluation Description

Line Number under which the coordinates of the best fit line will be
stored in the line structure.

Straightness Description

RES Result number used for storing the calculated straightness. If
you select {-1} or {nd}, the point will not be stored.

Tolerance Tolerance allowed during the calculation. It can be set interac-
tively by using the [Test] button.

Test The test displays the calculated Actual Straightness.
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7.4.2 Best Fit Circle / Roundness

Image 162: Dialogue Best Fit Circle / Roundness

You can define a command for determining the best fit circle from the contour
buffer or points from the point structure using Evaluation > Best Fit Circle.

You can also test the selected contours and points for roundness. Roundness
is defined as a cylinder around the Best Fit Circle. So, the roundness is always
defined in world units. The dimensions of this cylinder are defined by the
minimum and maximum radii between which all selected contours and points
lie. The central point of the Best Fit Circle can be stored in the point structure.
The radius of the Best Fit Circle and the corresponding radius can be compared
with a predefined radius. The points and contours to be included are selected
from a list of elements using the mouse. The selection is confirmed by clicking
on the [OK] button. Defined elements in the list appear dark and undefined ones
appear gray.

Input Parameters Parameters Description

Coordinate
system >
Image/World

Calculation in image coordinates or world coordinates (may
only be specified from contours, not from points).

Determine
> From
Contours/
From Points

Selects whether roundness is defined from contours or from
points.

Evaluation Parameters Parameters Description

Circle Enter the number in the circle structure under which the best
fit circle will be stored.

Point Enter the number in the point structure under which the center
of the best fit circle will be stored.
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Radius Description

Result Result number under which the calculated radius will be
stored: If you select {-1} or {nd}, the data will not be stored.

Nominal
Radius and
Tolerances

Nominal radius and the allowed ± tolerances in pixels: Set
suitable parameters interactively with the aid of the [Test]
button.

Roundness Description

Result Result number for saving the resulting Roundness. If you
select {-1} or {nd}, the point will not be stored.

Tolerance Acceptable deviations from the nominal value for the round-
ness. It can be set interactively by using the [Test] button.

Test The test displays:

Parameters Description

Circle X,Y,R Calculated coordinates X, Y, and radius of the circle.

Radius Calculated radius of the circle.

Roundness Calculated roundness of the circle.

7.4.3 Distance

Image 163: Dialogue Distance

Write a command for determining the distance between geometrical variables
in the test program using Evaluation > Distance. To do this use any previously
defined points, lines, planes or circles. Distance describes the shortest
euclidean distance between these geometric variables. 

Selecting a Method The following methods are possible:

• Distance between two points
• Length of a perpendicular (plumb) between a point and a line
• Distance between a point and the center of a circle. Also the minimum and

maximum distances between a point and a circle (i.e. to nearest and farthest
points on the circle).
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• Minimum and maximum distance between a line and a circle (i.e. to nearest
and farthest points on the circle).

• Distance between the centers of two circles

The result (distance) is stored in the result structure. Tolerances can also be
checked.

Distance Point - Point

1. Enter the first point number.

2. Enter the second point number.

3. Select the distance determined either directly or only the X or Y distances.

4. Enter the nominal distance and +/– tolerances in world units (default 1/10
Pixel).

5. Enter the result number.

Distance Point - Line (Plumb)

1. Enter the point number.

2. Enter the line number.

3. Enter the nominal distance and +/– tolerances in world units (default 1/10
Pixel).

4. Enter the result number.

Distance Point - Circle Center

1. Enter the point number.

2. Enter the circle number.

3. Select the to Center option.

4. Enter the nominal distance and +/– tolerances in world units (default 1/10
Pixel).

5. Enter the result number.

Min. / Max. Distance Point - Circle

1. Enter the point number.

2. Enter the circle number.
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3. Activate the to Circumference min./max. option.

4. Enter the nominal distance and +/– tolerances in world units (default 1/10
Pixel).

5. Enter the result number.

Distance Line - Circle Center

1. Enter the line number.

2. Enter the circle number.

3. Activate the to Center option.

4. Enter the nominal distance and +/– tolerances in world units (default 1/10
Pixel).

5. Enter the result number.

Min. / Max. Distance Line - Circle

1. Enter the point number.

2. Enter the circle number.

3. Activate the to Circumference min./max. option.

4. Enter the nominal distance and +/– tolerances in world units (default 1/10
Pixel).

5. Enter the result number.

Distance Between two Circle Centers

1. Enter the first circle number.

2. Enter the second circle number.

3. Select whether the distance should be measured directly or only the X or Y
component.

4. Enter the nominal distance and +/– tolerances in world units (default 1/10
Pixel).

5. Enter the result number.

Evaluation Parameters Evaluation Description

Result Result number for storing the calculated distance.

Nominal
Value and
Tolerances

Nominal distance and the allowed +/– tolerances in pixels.
Set suitable parameters interactively with the aid of the [Test]
button.

Test The test displays the calculated distance.
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7.4.4 Superimpose

Image 164: Dialogue Superimpose

With Evaluation > Superimpose you create a command for superimposing the
value of a variable of the geometry structure, auxiliary texts, measured values,
text and other information into the video image.

Superimpose
Geometry Variables
and Information

You can insert a superimposition command into the test program for the
following geometry variables:

• Point (Shown as a cross)
• X Coordinate of a point as a Line
• Y Coordinate of a point as a Line
• Line
• Circle
• Contour
• Result with additional text
• Counter with additional text
• String
• Text
• Program Name

Enter the number or the name of the element in the corresponding element
structure. Enter the desired additional text for superimposing Result or Counter
in the text box.

The program name must not be entered, it will automatically taken over. Thus,
the program name is displayed correctly, the program must be transfered to the
vision system.

Memory Image for
Superimpose

As an image memory for superimpose one of the following pages is to select:

• Display Page: Superimpose on control monitor or in the monitor window
• Demo Page: Superimpose as overlay in demo mode to illustrate the

processing
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• Work Page (Overlay Memory): Superimpose as overlay in the image, image
content is not overwritten

• Work Page (Image Memory): Superimpose directly in the image, image
content is overwritten

The assignment of the image memory pages can be made via the command
Image>Display see "Display", Page 138.

Superimpose Color The following options can be selected:

• Graphic Color (red)
• 1st Color (green)
• 2nd Color (yellow)
• 3rd Color (blue)

You can change the colors for the display in the monitor window and on an
external monitor by using the command Control > Direct Code Input and a
vicorem code.

Default Change Examble

Graphic red (FF 00 00) 02 40 xx xx xx 02 40 FF FF FF (white)

1st color green (00 FF
00)

02 41 xx xx xx 02 41 00 00 FF (blue)

2nd color yellow (FF FF
00)

02 42 xx xx xx 02 42 A0 20 F0 (purple)

3rd color blue (00 00
FF)

02 43 xx xx xx 02 43 00 00 00 (black)

ADVICE
More information about vicorem and its use can be found in the vicorem
manual. Please contact our support.

ADVICE
There is no takeover of the change color values after reconnecting to a vision
system of the type pictor M. The representation in the vcwin pro is done in the
standard colors.

Settings Text Position These settings are for result, counter, string, text, and program name.

Determining Text Position

Here you define the position of the superimposed information and optionally a
reference point in the image.

Enter the x- and y-coordinate of the superimpose position in image coordinates,
or double-click with the right-hand mouse button in the field Text Position for
positioning the frame in the monitor window /control monitor.

Position Tracking Point

Superimposition can be static or can follow a point.

If you enter a point number, the superimposed information can follow the point
movement. Choose {no} for the reference point creates static overlays.
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Settings Text Depending on the types of "Superimpose from", you can configure the
required parameters. Parameters that have no influence on the respective
superimposition will be grayed out.

Input Field Text:

Enter here the text that is to be superimposed, as well as any additional text (at
option Result or Counter).

ADVICE
A maximum of 39 characters can be entered.

A line break will not occur. Characters which are beyond the image will be cut
off.

Text Size:

Here, the text size can be selected.

Dividing Factor:

Conversion factor for the display. Only integers can be entered, with exception
of zero.

Decimal Place:

Sets the number of decimal places. Results may be displayed in Monitor
Window or on the control monitor in floating point format, showing the decimal
places. A dividing factor and the number of decimal places must be entered in
order to achieve this.

Example:

Using the command "angle", an angle of 26.57 degrees was calculated and
written to the result. The value of the angle is in 1/100 degrees so the angel has
a value of 2657.

superimpose without dividing factor: angle: 2657

superimpose with dividing factor '100': angle: 27

superimpose with dividing factor '100' and decimal place '2': angle:26.57

Delete Graphics By clicking the button [Delete Graphics] the Overlay-Graphic will be deleted.

Test Command By clicking the button [Test] overlays in the monitor window or on the video
screen are displayed.



vcwin pro 2.21
Part 2 - Command Reference

© Vision & Control GmbH
2015

999.994.306.10-en-1.15 273

7.4.5 Evaluate Result

Image 165: Dialogue Evaluate Result

Define a command for the logical operation, classifying and sending of results
from the result structure using Evaluation > Evaluate Result. Determine the
following for each individual result individually: 

• Nominal value and tolerances of the result.
• Should the result be sent to vcwin pro for visualization?
• Should the result be considered when determining the total result?

Independently of this, all the results for determining the sort are taken into
account. The classification is made with a so-called sort table. This defines
which individual results (good, bad or no influence) are assigned to a sort.
Depending upon the individual results, you can assign an overall result (good,
bad) to the sorts. Store the sort determined in the result structure as required.

ADVICE
Do not use this command together with the Send Measuring Values
command.

ADVICE
If this command is used on the system pictor M, special rules need to be
observed. see "Usage at vision systems of the type pictor M"
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Input Parameters Single Result Description

Name Identifier for checking an individual result.

Nominal
Value and
Tolerances

Nominal value and the permitted +/– tolerances of the indi-
vidual result which is to be checked.

RES Number of the individual result from the result structure which
is to be checked.

Dec. Point &
Divisor

The settings "Dec. Point" and "Divisor" concern only the
measurement user window and will be ignored by pictor /
vicosys for sending data.

Dec. Point Sets the number of decimal places. Example: 2 means that
there are two decimal places after the dot.

Divisor Sets the value by which the result is divided. Example: divisor
2 means that the result is divided by 2.

Status Description

All the individual results which are to be entered in the result table. Depending
on how the status boxes are marked, the result can be sent and/or be added
to a total result.

Include Result
in Total Result

Single results are included or not included in determining a
total result.

Send Result Single results are sent or not sent.

Buttons in
the Results
List

Description

Insert Transfers the parameters of a individual result into the result
table.

Edit Changes the parameters of the marked individual result in the
result table

Clear Deletes the marked individual result from the result table.

Evaluation Parameters Total result
Good, when

Description

Each Result
Good

Total result is good if all individual results are good.

One Result
Good

Total result is good if one individual result is good.

Classify Description

Quantity Quantity of possible sorts in the sort table.

Result Result number for saving the calculated sort. If you select {-1}
or {nd}, the data will not be stored.
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Sort Table

Use the [Sort Table] button to open the sort table. You can assign the individual
results to the sorts in the sort table.

The columns are sorted as follows:

• The sort appears at the top (designated by a number).
• The operators for the individual results are lined up underneath

Assign the following logical operands to an individual result per mouse click:
[+] … Result must be good. 
[–] … Result must be bad.
[ ] … Result can be ignored.

The following rules apply for determining the sort:

• If all individual results within the first column correspond to the assigned
operands, then sort number 1 is output.

• If the first column does not comply, the columns to the right are searched for
compliance and – if there is compliance – the corresponding sort is output.

• If no column complies with the individual results, then the sort “0” is output
into the result structure.

Data for
measuring
User Window

Description

Send
Measuring
Values

Activates the transfer of measured values marked with Send
Result and the total result via the data interface to vcwin pro . 
These values can be visually displayed in the Measurement
User Window in vcwin pro . This visualization is only possible
if vcwin pro has started with the measurement user window.
>> "User Window", Page 43

System Time System time of the vision system will be sent or not.

Result for
Messages

Result number for saving the system result calculated. If you
select {-1} or {nd}, the data will not be stored. How this is set
has no influence on the sending of results.

Block ID Send block label for sending values. Different result send
blocks that are labeled with different recognition IDs can be
sent over the data interface.
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Interface Description

Select one of the available data interfaces, to which the result is to be sent.
The interfaces that are available depend on the type of vision system used.

/com Serial interface

/ethernet Ethernet interface

In order to guarantee proper functioning, do not change the entries behind /
com and /ethernet unless you are a network technician.

Test The sort determined is displayed during the test.

Usage at vision
systems of the type
pictor M

ADVICE
At the beginning of the test cycle, set back the Result for Messages value
from Data for Measured User Window! Use the command Combine
Results > Set = 0.

The result of the command Evaluate Result is either good (error equal 0)
or bad (error unequal 0). If the current value of Result for Message is bad
(unequal 0) and the previous value of Result for Message was good, then the
value for Result for Message is set to bad (unequal 0). Even if the value turns
to good, the value for Result for Message still remains bad until is is reset to 0.

If an error occurs in a test cycle, the Result for Message value is bad until it is
explicitly set to 0.

ADVICE
As opposed to vicosys and pictor T, the vision system pictor M takes only
the evaluation in the Result for Message, not whether errors have occurred
during transmission.
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7.4.6 Combine Results

ADVICE
The number of entries possible in the results structure is displayed when
connecting the vision system.

Image 166: Dialogue Combine Results

Use Evaluation > Combine Results to insert a command into the test program
that performs mathematical operations on results and saves the outcome in a
new result field, or sets one bit of a specified result.

Set Sets an element in the result structure to any particular value.

1. Enter the value.

2. Enter the result number.

Add Two elements in the result structure are added together or a value is added to a
result.

Two Results

1. Enter the first result number.

2. Enter the second result number.

3. Enter the nominal value and +/– tolerances.

4. Enter the number of the calculated result.

Result and Value

ADVICE
The addition of 1 to a result can be used as a loop counter.

1. Enter the result number.

2. Enter the value to be added.

3. Enter the nominal value and +/– tolerances.

4. Enter the number of the calculated result.
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Subtract Subtracts either one result from another, a result from a value or a value from a
result.

1. Enter the result number or value for the subtrahend.

2. Enter the result number or value for the minuend.

3. Enter the nominal value and +/– tolerances.

4. Enter the number of the calculated result.

Multiply ADVICE
Values must be in the range between -32767 and 32767. The maximum
accuracy for real numbers is 5 digits.

Multiply two elements in the result structure or multiply a result with a value.

Two Results

1. Enter the number of the first result.

2. Enter the number of the second result.

3. Enter the nominal value and +/– tolerances.

4. Enter the number of the calculated result.

Result and Value

1. Enter the result number.

2. Enter the value to multiply with.

3. Enter the nominal value and positive/negative tolerances.

4. Enter the number of the calculated result.

Divide ADVICE
Values must be in the range between -32767 and 32767. The maximum
accuracy for real numbers is 5 digits.

Divide either one result by another, a result by a value or a value by a result

1. Enter the first result number or the value of the dividend.

2. Enter the second result number or the value of the divisor.

3. Enter the nominal value and positive/negative tolerances.

4. Enter the number of the calculated result.

Set bit One bit from a selected result in the Result field is set to 1. The result is saved
in the Result field at the bottom left.

Example Setting

Bit Result

The following takes place when executing – Set bit

0 3 Bit 0 from result 3 is set to 1. The value in the result
memory is set to 1.

2 3 Bit 2 from result 3 is set to 1. The value in the result
memory is set to 4.
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Erase bit A bit from a selected result in the Result field is set to zero. The result is saved
in the Result field at the bottom left.

Example Setting

Bit Result

Contents of result before
command is executed

The following takes place
when executing – Erase
bit

0 3 128 (contents of result no.
3 is 128)

Bit 0 from result no. 3 is
set to zero. The value in
the selected memory posi-
tion in the result memory
remains at 128.

7 3 128 (contents of result no.
3 is 128)

Bit 7 from result no. 3 is
set to zero. The value in
the selected memory posi-
tion in the result memory
changes to zero.

Test bit ADVICE
When using the Test bit command, set the tolerances to zero.

A bit from a selected result in the Result field is tested. The result (one or zero)
is set in the Result field at the bottom left.

Example Setting

Bit Result

Contents of result before
command is executed

The following takes place
with the execution of the
command – Test bit

0 4 128 (contents of result no.
4 is 128)

Bit 0 from result no. 4 is
tested. The value in the
selected memory posi-
tion in the result memory
changes to zero (false).

7 4 128 (contents of result no.
4 is 128)

Bit 7 from result no. 4 is
tested. The value in the
selected memory posi-
tion in the result memory
changes to one (true).

Trigonometric
Functions

Trigonometric functions apply the operations sin, cos, tan, arcsin, arccos or
arctan to existing results.

1. Select whether the calculation should take place in radians or degrees.

2. Combine the results according to the following principle:



vcwin pro 2.21
Part 2 - Command Reference

280 999.994.306.10-en-1.15 © Vision & Control GmbH 2015

Example:

The result is in whole numbers. Choose the appropriate multiplication factor for
the accuracy required.

Power Power raises the result to the exponent given.

Principle:

The result is in whole numbers! Choose the appropriate multiplication factor for
the accuracy required.

Root Root extracts the root given from the result.

Principle:

The result is an integer! Choose the appropriate multiplication factor for the
accuracy required.

Evaluation Parameters Parameters Description

Result Result number for saving the number of results calculated.

Nominal
Value and
Tolerances

Nominal value and pos./neg. tolerances allowed during the
calculation. You can set suitable parameters interactively with
the aid of the [Test] button.

Test The calculated actual value is displayed during the test.

7.4.7 Define Line

Overview The command Define Line is in the Command Selection under Evaluation.

Image 167: Dialogue Define Line
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Characteristics • Calculation of straight lines from defined values.
• The calculation is made from pre-determined values (these must be present

in the geometry lists).
• The calculated straight lines are stored in the line structure.
• The coordinate system used corresponds to the used variables.
• One process per command.

Line based on 2
Points

Calculating a straight line from two points.

P2
P1

L1

Image 168: Define Line: Line from 2 points

1. Point 1: Select the first point (P1) from the drop-down list.

2. Point 2: Select the second point (P2) from the drop-down list.

3. Line 1: Enter the number / name to store the calculated straight line (L1).

Line based on n
Points

Calculate a straight line that is optimally approximated to a set of points.

P1 P3

P4

P2

P6
P5

L best

Image 169: Best fit line through a number of points

Image 170: Dialogue Define Line: Point List
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1. Click on the [Point List] button to open the list of available points.

2. Select points by clicking on them. Selected points in the list appear
highlighted. Click on [OK] to confirm selection.

3. Enter the number/name to store the calculated best fit line (Lbest).

Perpendicular to Line Calculating a straight line by dropping a perpendicular on a straight line through
a point.

P1

L1

L
per

Image 171: Perpendicular to Line

1. Point: Select the point (P1) through which the perpendicular line goes from
drop-down list.

2. Line: Select the start line (L1) from drop-down list.

3. Line 1: Enter the number / name to store the calculated perpendicular line
(Lper).

Parallel Line through
Point

Calculating a straight line through parallel shifting of a line through a given
point.

P1

L1

L parallel

Image 172: Parallel Line through Point

1. Point: Select the point (P1) from drop-down list. The straight line is shifted to
this point.

2. Line: Select the start line (L1) from drop-down list.

3. Line 1: Enter the number / name to store the calculated parallel line (Lparallel).
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Move Line by Value Calculation of a straight line through shifting a start line by a numerical value in
a certain direction.

L1

L

Image 173: Moving Line by Value

1. Line: Select the start line (L1) from the drop-down list.

2. Value: Enter the numeric value for the displacement.

3. Direction: Enter the movement direction for parallel movement. Use the
buttons with directional arrows for this.

4. Line 1: Enter the number / name to store the calculated displacement line
(L).

Move Line by Result Calculation of a straight line through shifting a start line by a result from the
result structure in a certain direction.

L1

L result

Image 174: Move Line by Result
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1. Line: Select the start line (L1) from drop-down list.

2. Result: Select the result for the displacement from drop-down list.

3. Direction: Enter the movement direction for parallel movement. Use the
buttons with directional arrows for this.

4. Line 1: Enter the number / name to store the calculated displacement line
(Lresult).

Intersection Line
Circle-Circle

Calculating a straight line through the two points of intersection circles.

Cirle 2

L intersection

C2

C1

Cirle 1

Image 175: Intersection Line Circle-Circle

1. Circle 1: Select the first circle (Circle1) from drop-down list.

2. Circle 2: Select the second circle (Circle2) from drop-down list.

3. Line 1: Enter the number / name to store the calculated intersection line
(Lintersection).
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Tangents to Circle Calculation of two circle tangents passing through a given point.

L tng1

C1

P1
Circle 1

L tng2

Image 176: Tangents to Circle

1. Point: Select the point (P1) through which the tangents will pass from drop-
down list.

2. Circle: Select the circle (Circle1) to which the tangents are formed from drop-
down list.

3. Line 1: Enter the number / name to store the first calculated circle tangent
(Ltng1).

4. Line 2: Enter the number / name to store the second calculated circle
tangent (Ltng2).

Symmetry Lines Calculation of two symmetry line (bisecting lines) to two intersection lines.

L1

L2

Image 177: Symmetry Lines

1. Line 1: Select the start line (L1) from drop-down list.

2. Line 2: Select the second start line (L2) from drop-down list.

3. Line 1: Enter the number / name to store the first calculated symmetry line.

4. Line 2: Enter the number / name to store the second calculated symmetry
line.
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Rotate Line by Angle Calculating a rotational line from a starting line and a given angle.

L1

Prot

Lrot

L1 Lrot

Prot

αrot αrot

Image 178: Rotate Line by Angle

1. Line: Select the first start line (L1) from drop-down list.

2. Angle in 1/100°: Enter the angle of rotation (αrot) in 1/100 degrees as an
integer.

3. Apex Point: Select the rotation (Prot) point from drop-down list.

4. Line 1: Enter the number / name to store the calculated rotational line (Lrot).

Rotate Line by an
Angle from RES

Calculating a rotational line from a starting line and a result.

L1

Prot

Lrot

L1 Lrot

Prot

αrot αrot

Image 179: Rotate Line by an Angle from RES

1. Line: Select the first start line (L1) from drop-down list.

2. Result: Select the result with the angle of rotation (αrot) from drop-down list.
The angle must be given in 1/100 degrees in the result.

3. Apex Point: Select the rotation (Prot) point from drop-down list.

4. Line 1: Enter the number / name to store the calculated rotational line (Lrot).
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7.4.8 Contour Distance

Image 180: Dialogue Contour Distance

Define a command for estimating the contour distance using Evaluation >
Contour Distance. For this, the distance value is calculated and compared with
a preset tolerance range. 

Define the distance corresponding to requirements, either using the width
and height of the contour or by entering the minimum or maximum distance
of a given contour to the X axis, to the Y axis, to a point or to a line. Use
the previously determined contours. The distances are calculated in world
coordinates.

Input Parameters Parameters Description

Contour Number in the contour structure in which the contour to be
evaluated is stored.

Point / Line Number of the point / line in the point / line structure for which
the distance should be calculated.

Calculating
in World
Coordinates

Description

Width /Height Specifies if the width or height of the contour should be calcu-
lated.

Min./Max.
Distance
to the Axis,
Point or Line

Geometric element to which the minimum or maximum
distance of the contour should be calculated.

Evaluation Parameters Parameters Description

Result Result number for saving the calculated distance. If you select
{-1} or {nd}, the data will not be stored.

Nominal
Value and
Tolerances

Nominal distance and permitted deviations: Set suitable para-
meters interactively with the aid of the [Test] button.
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7.4.9 Extreme Points of Contour

Image 181: Dialogue Extreme Points of Contour

With Evaluation > Extreme Points of Contour you can define a command for
the calculation of the extreme points on an existing contour. Extreme points are
characterized by a maximum or minimum distance to the X axis, Y axis, to a
point, or to a line. 

All the previously determined contours can be used for this. You can store the
calculated extreme points in the point structure in image coordinates or world
coordinates.

Input Parameters Parameters Description

Contours Number in the contour structure in which the contour to be
evaluated is stored.

Point / Line Number of the point / line in the point / line structure for which
the extreme points are to be calculated.

Extreme
Points

Axis, point or line for which the extreme points are to be calcu-
lated.

Evaluation Parameters Co-ordinate
system

Description

Image/World Calculating the extreme points in image coordinates or world
coordinates.

The following type combinations are possible between the output geometry
variables and the variables to be defined:

Points to be Defined Contour Point or Line

Image Image Image

World Image Image

World Image World
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Extreme
Points

Description

Nearest
Point/
Farthest
Point

Number for saving the coordinates of the nearest/farthest
extreme point in the point structure. It is not saved if {1} is
selected.

Test The coordinates of the calculated extreme points are displayed in the test.

7.4.10 Contour Curvature Analysis

Image 182: Dialogue Contour Curvature Analysis

Write a command for estimating the curvature of a contour /contour segment
into the test program using Evaluation > Contour Curvature Analysis. For
this, the curvature along the contour is calculated and then compared with a
preset tolerance range. Either the segment area or the segment height can be
selected as the measure of curvature.

Every individual point of the contour is tested. Then, the number of points
outside the tolerance range – referred to as bad points here – are estimated
and stored in the result structure.

All the previously determined contours can be used.
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Input Parameters Parameters Description

Contour Number in the contour structure in which the contour to be
evaluated is stored.

Segment
Length

Length of the contour segment in pixels to be evaluated.

Measure of
Curvature
World Coor-
dinates

Description

Segment
Height

Uses the segment height as the measure of curvature in world
coordinate.

Segment
Area

Uses the segment area (in pixels or world units) as the
measure of curvature.

Min./Max. Permitted minimum and maximum measures of curvature in
pixels (valid for either segment height or segment area). 
The suitable parameters for the measure of curvature (Min./
Max.) are defined interactively with the [Test] button. In which,
the bad points are displayed on the video screen and their
number is displayed in the curvature analysis teaching dialog.

Evaluation Parameters Quantity of
Bad Points

Description

Result Result number for saving the number of bad points.

Nominal
Quantity and
Tolerances

(Permitted) nominal number of bad points and tolerances. Use
the [Test] button to establish that the parameters that are suit-
able.

7.4.11 Center of Gravity of Contour

Image 183: Dialogue Center of Gravity of Contour

You can write a command for calculating the center point and the area of an
existing contour into the test program using Evaluation > Center of Gravity of
Contour.
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To do this, use the open or closed contours which have already been
determined (see Locate Contour command). The calculated center point can be
stored in the point structure in image coordinates or world coordinates.

Test the contour area by setting a nominal value and the tolerance range. The
unit for area depends upon the coordinate type of the center point defined and
can be pixels or in world units.

Input Parameters Parameters Description

Contour Number/name in the contour structure in which the contour to
be evaluated is stored.

Only Self-
Contained
Contour

Description

Option
marked

Only closed contours can be used. Otherwise the command
fails.

Option
unmarked

All contours can be used.

Evaluation Parameters Coordinate
system

Description

Image/World Defines whether the Center of Gravity or the Contour Area are
calculating in image coordinates or world coordinates.

Parameters Description

Point for the
determined
Center of
Gravity

Number/name for saving the coordinates of the calculated
center point in the point structure. If you select {-1} or {nd}, the
data will not be stored.

Contour Area Description

Result Result number/name for saving the area enclosed by the
contour: If you select {-1} or {nd}, the data will not be stored.

Nominal
Value and
Tolerances

Nominal area and permitted area deviation: Set suitable para-
meters interactively with the aid of the [Test] button.

Test The test displays:

Parameters Description

Center of
Gravity Point

Calculated coordinates of the gravity center point.

Area Calculated contour area.
Hint: You can use the results for the setting of the nominal
value and its tolerances.
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7.4.12 Contour Comparison / Contour Angle

ADVICE
Use the Locate > Locate Contour command to store contours in the contour
buffer. 

Image 184: Dialogue Contour Comparison / Contour Angle

Define a command for assessing the contour angular position using Evaluation
> Contour Comparison / Contour Angle. For this, you need a closed contour
which is loaded from the contour buffer.

To determine the contour angular position, a reference line is determined and
either set in relation to the X axis or compared with the position of a defined
nominal contour. The gravity center point of the contour and the contour area
are automatically determined and can be assessed and stored.

The contour angular position can be calculated in image or world coordinates.

Selecting a Method From a Line Between the Two Points Furthest Apart

The reference line is defined by the two points furthest apart in the contour.

From the Longest Axis Through the Center Point

The reference line is defined by those two points of the contour which are
furthest away from each other where the line between them also passes
through the center point.
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From a Symmetry Axis Through the Gravity Center Point

The reference line is determined by a symmetry line that divides the contour
in two halves, according to a certain algorithm. Use this option for symmetric
contours.

As a Rotation from a Previously Defined Contour

The rotation position is determined by comparison with a nominal contour. The
nominal contour is loaded from the contour buffer as is the contour to be tested.

As a Rotation From a Taught-in Contour

The angular position is determined by comparison with a taught-in contour. The
nominal contour must have previously been taught-in with the [Teach-in] button
and stored in the test program.

Input Parameters Parameters Description

Contour Number in the contour structure in which the contour to be
evaluated is stored.

Nominal
Contour

Number in the contour structure in which the desired contour
is stored. Only required for the »as Rotation related to a
defined Contour« method.

Co-ordinate
system

Description

Image/World Calculates in image coordinates or world coordinates.

Evaluation Parameters Min. Grade of
Match

Description

This command is to configure a test of the correspondence between the
contour found and the nominal contour.

Covering Rate The minimum degree of coverage in per cent when the
contour parts are reflected around the symmetry axis. Only
required for the »Symmetry Axis through Center of Gravity
Point« method.

Grade of
Match

Correlation with the nominal contour. Only required for the two
»Rotation related to a Contour« methods.

Result Result number for the result of the comparison in the corre-
spondence test: If you select {-1} or {nd}, the data will not be
stored.
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Contour Area Description

Result Result number for saving the area enclosed by the contour: If
you select {-1} or {nd}, the data will not be stored.

Nominal
Value and
Tolerances

Permissible deviation of the area from the nominal area: Set
suitable parameters interactively with the aid of the [Test]
button.

Center of
Gravity Point
and Line

Description

Point / Line Number in the point or line structure under which the deter-
mined center point of contour and the reference line deter-
mined by the relevant process are stored.

Angular
Position
(1/100
degree)

Description

Result Result number for saving the determined angular position
(1/100 degree).

Nominal and
Tolerances

Nominal angular position and the permitted ± tolerances. Set
suitable parameters interactively with the aid of the [Test]
button. 
For technical reasons, tolerances cannot exceed 32768 in
value (corresponds to 215). The tolerance range is from
+32767 to –32767. The angular position in the first half circle
is from 0° to 180° clockwise and further from -179° to 0° clock-
wise. 
The value given by the program should be divided by 100 to
maintain the correct angle in degrees (°). This division factor
should also be used when superimposing. Examples: 9000
corresponds to +90° / –9000 corresponds to –90°. See figure
»Angle Definition« under the table.

Offset Offset for the angular position (1/100 degree). If an initial rota-
tion is already present in the loaded contour, the offset may be
added in order to relate the angular position determined to the
X or Y coordinate.
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Angle Definition

ADVICE
The line is saved in a way that 0° corresponds to a parallel to the X axis. The
angle of rotation is relative to the taught contour in a proportion of 1/100,
counterclockwise.

Image 185: Angular Position Line Output

Test The test displays:

Parameters Description

Contour Area Calculated contour area.

Rotation
Angle

Calculated value of angular contour position.

Grade of
Match

Actual correspondence when testing the min. grade of match.

Example The reference line determined for determining the angular position of the
contour is displayed during the test.
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7.4.13 Define Circle

Image 186: Dialogue Define Circle

Use Evaluation > Define Circle for creating new circles from existing points,
lines and circles in the test program. You can use previously determined points,
lines, and circles for this. 

The generated circles are saved in image or measurement units in the circle
structure under a circle number. The coordinate system of a resulting circle
corresponds to the coordinate system of the original variables.

Selecting a Method The following methods are possible:

• Circle based on 3 points
• Circle based on n points
• Tangential circle line-point
• Tangential circle circle-point

Circle Based on 3 Points
This defines a circle using three points.

1. Enter the numbers of the points P1, P2 and P3.

2. Enter the nominal radius and +/- tolerances.

3. Enter the result number for the radius if required (otherwise {nd}).

4. Enter the number of the new circle.

5. If the circle center should be saved, enter die point number, otherwise enter
or select {–1} or {nd}.



vcwin pro 2.21
Part 2 - Command Reference

© Vision & Control GmbH
2015

999.994.306.10-en-1.15 297

Circle Based on n Points
This option calculates the optimum circle from a list of points.

1. Click on the [Point List] button to open the list of available points (see fig.)

2. Select points by clicking on them. Selected points in the list appear
highlighted. Click on [OK] to confirm selection.

3. Enter the circle number.

4. Enter the nominal radius and +/- tolerances.

5. Enter the result number for the radius if required (otherwise {nd}).

6. Enter the number of the new circle.

7. If the circle center should be saved, enter die point number, otherwise enter
or select {–1} or {nd}.

Tangential Circle Line-Point
A command for the computation of a tangential circle from a point and a line is
written into the test program.

1. Enter the point number.

2. Enter the line number.

3. Enter the nominal radius and +/- tolerances.

4. Enter the result number for the radius if required (otherwise {nd}).

5. Enter the number of the new circle.

6. If the circle center should be saved (see point PK in the illustration), enter die
point number, otherwise enter or select {–1} or {nd}.

Tangential Circle Circle-Point
A command for the computation of a tangential circle around a specified point
(functions as the circle’s center point) to the closest tangent on a circle is written
into the test program.

1. Enter the point number.

2. Enter the circle number.

3. Enter the nominal radius and +/- tolerances.
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4. Enter the result number for the radius if required (otherwise {nd}).

5. Enter the number of the new circle.

6. If the circle center should be saved (see point PK in the illustration), enter die
point number, otherwise enter or select {–1} or {nd}.

Evaluation Parameters Parameters Description

Circle Number under which the circle found (after the detection) will
be stored in the circle structure.

Point Number for storing the coordinates of the center of the circle
in the point structure. If you select {-1} or {nd}, the data will not
be stored.

Radius Description

Result Result number under which the calculated radius will be
stored: If you select {-1} or {nd}, the data will not be stored.

Nominal
Radius and
Tolerances

Nominal radius and the allowed ± tolerances in pixels: Set
suitable parameters interactively with the aid of the [Test]
button.

Test The test displays:

Parameters Description

Circle X,Y,R Calculated coordinates X, Y, and radius of the circle.

Radius Calculated circle radius.

7.4.14 Define Point

Image 187: Dialogue Define Point

Use Evaluation > Define Point to enter the command for creating new points
in the test program. For this, use points, lines, planes, and circles that have
already been detected or enter the coordinates directly.

The calculated points are stored as image or world coordinates under a
user-defined number within the point structure. The coordinate system used
corresponds to the coordinate system of the source elements.
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Selecting a Method The following methods are possible:

• Intersection of two lines
• Intersection of a perpendicular from a point to a line
• Intersection from a point to the center of a circle
• Center of a line connecting two points (i.e. average)
• Two intersections between a line and a circle
• Two intersections between two circles
• Addition of a result to a point (i.e. shift)
• Addition of a fixed value to a point (i.e. shift
• Direct entry in image coordinates
• Direct entry in world coordinates

Intersection of Two Lines

1. Enter the first line number.

2. Enter the second line number.

3. Enter the number of the new point.

Plumb Point - Line

1. Enter the point number.

2. Enter the line number.

3. Enter the number of the new point.

Plumb Point - Circle

1. Enter the point number.

2. Enter the circle number.

3. Enter the number of the new point.

Average of Two Points

1. Enter the first point number.

2. Enter the second point number.

3. Enter the number of the new point.
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Intersection Line - Circle

1. Enter the line number.

2. Enter the circle number.

3. Enter the number of the first intersection point.

4. Enter the number of the second intersection point.

Intersection Circle - Circle

1. Enter the first circle number.

2. Enter the second circle number.

3. Enter the number of the first intersection point.

4. Enter the number of the second intersection point.

Shift Point
This option copies a point to a new position, creating a new point. The original
point is not deleted.

1. Enter the number of the point which is to be shifted.

Enter the offsets (either numeric input in image points or enter the result
from which the value should come).
Enter the value or result number for the Y offset
Enter the value or result number for the Y offset
Enter the value or result number for the XY offset

2. Enter the number of the new point.

Entering Coordinates Directly

1. Set the coordinate system: image coordinates or world coordinates

2. A: Enter image coordinates:

° X coordinate
° Y coordinate
° Camera number

3. B: world coordinates

° X coordinate
° Y coordinate

4. Enter the number of the new point.

Evaluation Parameters Evaluation Description

Point Number(s) or names under which the point(s) found will be
stored in the point structure.

Test The coordinates of the calculated point(s) are displayed during the test.
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7.4.15 Check Point Distances

Overview
+

GRef

+

+
+

Image 188: Point Distances parallel to
Reference Line

+

+
GREF

+
+

Image 189: Distances to Reference Line

The command Evaluation > Check Point Distances calculates the distance
between nearby points to each other and the distances from points to a
reference line.

Function 1. If no reference line is specified, a reference line is calculated from the given
points.

2. The points are sorted along the reference line.

3. Testing of the distances between nearby points.

4. Testing of the distances of the points to the reference line.

5. Display of the determined values.

° Independent from the chosen coordinate system the output is in world
coordinates.

° Only the absolute value is determined. Whether a point is above or below
the reference line will not be calculate.

Dialogue structure

6

1

2

3

4

5

Image 190: Dialogue Check Point Distances
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Work Flow:
Parametrize

1. Enter here the variables to be checked.

Parameter Description

Point List
from Point

Specify here the point from which the calculation starts.

Number of
Points from
Result

Enter the result in which the amount of coils is saved. This
corresponds to the number of points in the point list.

Reference
Line

Enter here the reference line. If no reference line is speci-
fied, a reference line is calculated from the given points.

2. Test the settings here

After activating the [Test] button the variance of the point distances from one
another and the distances to the reference line are displayed in this area.

3. In the area "Point Distances parallel to the Reference Line" enter the
requirements for the assessment of the command and to store the results.

Parameter Description

From Result Number / name for storing the determined distances. If you
select {nd} no storage takes place.

Nominal Nominal distance between the points.

'+' Tolerance Allowable upper deviation from the target value.

'-' Tolerance Allowable lower deviation from the target value.

4. In the area "Distances to the Reference Line" enter the requirements for
the assessment of the command and to store the results.

Parameter Description

From Result Number / name for storing the determined distances of
each point on the reference line. If you select {nd} no
storage takes place.

Nominal Nominal distance of points to the reference line.

'+' Tolerance Allowable upper deviation from the target value.

'-' Tolerance Allowable lower deviation from the target value.

5. Evaluation Area

Here you can see the good/bad evaluation of the command, notes for
parametrization (tolerance range exceedance) as well as error messages.

6. Use the [OK] button to insert the command into the test program.

Error messages Possible error messages:

Distances outside the tolerance range

• The determined distances are outside of the specified nominal range (incl.
tolerances).

• Adjust the tolerances according to the determined values. Check the set
value of good parts and bad parts.
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Input variable not defined

• At least one input variable is not defined.
• Make sure all variables are defined in previous commands. If they are not

defined, execute the commands again. The variables must be stored in the
Geometry List.

Reference line can not be calculated

• No reference line was given and less than 4 points were assigned.
• No reference line was given and the variance of the points around the

calculated line is too large.
• Use more points to determine the reference line.

Insufficient number of points

• Less than two points were assigned for the distance calculation.
• Assign more points for the determination of the distances.

7.4.16 Calculation Script (Ruby) 

The Calculation Script command offers the option of writing test commands in
the form of plain text instructions with the Ruby 1.9 programming language.
For this purpose, the calculation script can access saved geometry variables
of the vision system or parts of the current image. The advantage over other
evaluation commands of vcwin pro is the high complexity which can be
achieved using the many integrated functions.

ADVICE
Licence information: Ruby and its source code can be downloaded from the
website http://www.ruby-lang.org. This is not a prerequisite for the calculation
script command in vcwin pro, however.

ADVICE
When using this command, a basic knowledge of script languages like
Ruby or JavaScript is advantageous. For comprehensive information on
Ruby and object-oriented programming, visit http://www.ruby-lang.org/en/
documentation/.

ADVICE
A list and description of the attributes and methods of the Calculation script
can be found in the Appendix.

The basics The object-oriented Ruby language represents the basis of the command.
It can be used to compose instructions for evaluating geometry variables
or image information in plain text. Object-oriented means that all values or
numbers used in Ruby are objects. These objects are defined by classes
which give the individual objects certain properties and so-called methods
which can be applied to the objects. Objects which originate from a certain
class are instances of this class (class instances) and can be defined with
different properties. They feature the same applicable methods, however. The
instances, which contain the status of the object, are referenced by variables.
The following example summarises the use of the Integer class, which defines
a data type: A class (Integer) creates an instance whose value (e.g. "50") and
properties (whole number) are referenced by a variable (e.g. blob number) and

http://www.ruby-lang.org
http://www.ruby-lang.org/en/documentation/
http://www.ruby-lang.org/en/documentation/
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to which the methods can be applied in order to manipulate the object or create
new ones.

The calculation script command provides you with classes with their own
attributes and methods specifically for vcwin pro. A majority feature the well-
known geometry variables Result, Point, Line, Circle, Contour, Counter and
String. Another is the Image class. Standard classes of Ruby, such as Math,
Integer, Float and String can be used. Each class defines methods which can
only in some cases be applied to the class itself (e.g. to create a new instance)
or only on its instances (e.g. to manipulate the value). Attributes are features of
an object which are also passed to an instance of the class, e.g. the co-ordinate
system being used for a point.

Method call syntax:

Instance.Method(Parameters)

Instance describes the object or the variable to which the method is applied.
Method is the designation of the method, which is always preceded by a dot
[.]. The parentheses after the method contain parameters to be passed to the
object if they were defined in the class. If parameters do not need to be passed,
they remain empty or are left out.

The access to attributes is a class-based method call and therefore uses the
same syntax.

Access to geometry
elements

To access saved geometry elements with the calculation scripts, the following
character sequence is used:

VC::GeometryElement[No.]

For GeometryElement, either Result, Point, Line, Circle, Contour or String
is used depending on the desired element, and the corresponding number of
the element is used for No.. Assignment of the geometry variable to a variable
is then carried out using an equal sign, which then references the value of the
geometry element. To save the co-ordinates of point 15 to variable a as an
instance, for example, the following code must be used:

a = VC::Point[15]

Variable a then contains the co-ordinates of point 15 and is a reference to the
instance of class VC::Point. Since a point is comprised of two co-ordinates
and operation can only be applied to individual numerical values, the individual
numerical values must be individually accessible. For points, the following
values can be output using methods .x and .y:

a = VC::Point[15].x
b = VC::Point[15].y

Now the value of the x-co-ordinate is saved in variable a, and the value of the
y-co-ordinate is saved in variable b. Since concrete numerical values were
now saved in both variables, they are instances of the Float class, not of the
VC::Point class.

The other geometry elements also possess methods so that they can output
individual numerical values or strings.
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Geometry
element

Output value(s) Methods

Results Result value .value

Points Co-ordinates of the point (x, y) .x, .y

Lines Co-ordinates of the start and end
points (x1, y1, x2, y2)

.x1, .y1, .x2, .y2

Circles Co-ordinates of the centre point and
radius (x, y, r)

.x, .y, .r

Strings Character string .string

Contours Point [pointnumber]

Counter Counter value .value

Table 5: Methods for outputing numerical values

Variables and
references

ADVICE
All defined variables are deleted again after the calculation script is exited
and cannot be used by other calculation script commands.

To handle geometry values in a better way, we recommend always creating
variables with meaningful names. This enables you to access them at any time
and have full control of the objects available to you. If variables are declared
but do not describe an object, they have the status nil. This also applies for
undefined geometry elements.

With variables, calculation operations can also be carried out or conditions
implemented.

The variables in Ruby are not static storage locations for instances, rather they
function as references to a respective object and its content. This enables you
to create a relationship between two objects very easily. For example:

a = VC::Result[2]
b = VC::Result[4]

a = b

With this code, the result numbers 2 and 4 were first assigned to variables
a and b, respectively. The result values are 10 (result 2) and 40 (result 4) in
this example. As a result of the equation a = b, not only does instance b no
longer refer to the output object VC::Result[4], but instance a does as well.
Both instances now have the value 40 and reference the same object, which
means that a change to one instance changes the other as well. To continue the
example:

b.value += 4

This line changes the value of the result value of variable b by +4. Since a and
b now reference the same object as a result of line a = b, the in the variable
a referenced result 4 in the vision system VC::Result[4] increases by +4.
If you then output the values of the variables via puts a.value and puts
b.value to the output window, the value 44 is yielded for both.

References can also be broken under certain conditions. If, for example, you
assign a new instance to variable c (which references the same instance as
variable d) using a class method such as new, variable d retains its old value,
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but variable references the new instance. Now the variables do not reference
the same instance anymore and will display different values in the output
window. When an instance is not referenced by a variable any longer, it gets
deleated.

To avoid undesired referencing errors, you can use the .clone method. Here is
the example from above, except this time with the .clone method:

a = VC::Result[2]
b = VC::Result[4]

a = b.clone

b.value += 4

.clone causes the VC::Result object instantiated by b on the third line to be
copied and transferred to a. Instance a now references a copied object and no
longer the same thing as b . If b is then increased by +4, a retains the old value
of b. Upon output, a has the value 40 and b has 44.

Working with the
dialog Script window

[Test ] Button

Output window

Result

Line ID

Ruby menu

VC Methods

Image 191: Dialog Calculation Script

Script window

When opening a new calculation script command, the comment "# Script Name"
is located in the first line. Enter the name of your script here. The first line is
written as description in the vcwin programlisting. So that several calculation
script commands in the vcwin pro program can be differentiante. If the first line
contains no comment, instead the first 100 characters of the first line is written
as description in the vcwin programlisting.

You enter the code for your calculation script in the script window. Pressing
[ENTER] adds line wraps, and the Tab key allows you to indent lines of code
for clearer code formatting. Normal code, such as variables, operators and
methods are displayed in black, whereas namespaces for accessing geometry
variables or image content intrinsic to vcwin pro in red and system terms
intrinsic to Ruby, such as loop expressions, in blue.

Test button and test result

With the Test button, you can check the current code for syntactic correctness
and display the result of the command to the right of the button. The result
can be true or false here, but the conditions for it must be defined by the
user using the return command. If, for example, a certain condition in the
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calculation script is to be decisive for the result of the command, whether or
not the command is evaluated as good or bad after the condition arises must
be specified in the code with return true or return false. If the code
cannot be executed due to syntax errors, the error type with the corresponding
line is displayed in the output window and the message "Ruby interpreter error"
appears when the test results are provided.

Output window

In addition to error descriptions (which are output in red), the output window
displays the output generated with the calculation script and can thus be
used as a log for debugging. Using the puts command, variable contents or
character strings can be displayed in the output window to check, for example,
whether loops or conditions are running as intended or to test individual
variables. The puts command can also display manipulations via methods or
attributes. A version better-suited for debugging is the short form p, as it outputs
the object as a string and thus also displays empty variables such as nil.

Output is provided after successful processing of the line in which the
instruction is located if the written script is free of syntax errors. A few examples:

Calculation script Output

puts "condition fulfilled" Conditions fulfilled

a = 5 + 4
puts a

9

VC::Result[5].value = 15
p VC::Result[5].value

15

Line ID

Using the line ID, you can read where you are in the script with the cursor at
any time. The first number indicates the line, and the second the position of the
line. Since the line of the error is specified with error messages in the selection
window, you can quickly and easily locate the sought line and remedy the error
using the line ID.

Ruby menu

The Ruby menu contains methods of standard classes which can be applied to
the classes intrinsic to vcwin pro or their instances. Methods of the Math class
for advanced calculation operations, methods for whole numbers (Integer) and
floating-point numbers (Float) and methods for strings are available.

The methods can very easily be inserted in the calculation script at the current
cursor position with a mouse click. A comprehensive list and description of the
methods can be found in the appendix.

Methods

Here you can find all methods and additional templates intrinsic to vcwin pro
sorted by the respective classes. Using these menus, you can very easily insert
the desired method into the calculation script at the current cursor position with
a mouse click. Geometry elements saved in vcwin pro or the vision system are
displayed in the menu of the corresponding class and can also be inserted into
the code with a mouse click if it reduces the writing expenditure. If you would
like to use an element in your script which has not yet been defined, you can
use the template, in which you need only add the element number.

A comprehensive list and description of the methods can be found in the
Appendix.
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Advanced operation Define geometry elements

To define new geometry elements or set a value to a undefined geometry
element, you have to create a new instance using a class method, which
automatically sets a new geometry element in the Vision System and assigns
the specified value. Example:

VC::Result[5] = VC::Result.new(10)

With this code, you assign the value 10 to the new result geometry element
number 5. The method call differs depending on the class you want to
create, for example the point class method to create a new instance in world
coordinates is VC::Point.world(x, y). A comprehensive list and
description of all the methods can be found in the Appendix.

If you want to add a new value to an already existing element, you can do
this as described above or by manipulating the values directly. This works by
using special class methods, such as .value of the VC::Result class which
accesses the result value, or the .x method of the VC::Point class which
accesses the x coordinate of a point:

VC::Result[5].value = 20

VC::Point[1].x = 5

A comprehensive list and description of the methods can be found in the
Appendix (see Page 383).

To set a defined geometry element to undefined, you have to assign the nil
expression to the element. When assigned, the geometry element does not
store any values and is not defined. When the calculation script wants to
process this element, it throws an exception error, cancels the operation and
returns "false" as result of the command. Example:

VC::Point[1] = nil

Now the point element number 1 is not defined anymore and the instance
stores the nil value. Using the puts command to output the VC::Point[1]
instance, no value will be shown in the output window. When you use the
command p VC::Point[1], the output will display nil (value as a string). All
undefined geometry elements are nil by default.

Calculation operations

Using so-called operators, you can execute calculations with the values from
geometry elements in the calculation script. The following table contains an
overview of the individual operations:

Calculation opera-
tion

Operator
(symbol)

Syntax

Addition + b = a + 5

Subtraction - a = b - 3

Multiplication * c = 3 * b

Division / a = b / 3

Power ** c = 3**3

Modulo (division with
remainder)

% c = a%b

Increase/decrease
variable

+= / -= a += 4
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The operations + and += can be applied to strings in the same way, e.g. to
concatenate individual character strings to one another.

Lists and arrays

You can use arrays to save several elements within an object. In arrays, several
elements are stored in a type of list which you can access using an index. You
can thus, for example, save consecutive result values within a variable and
evaluate them using loops and conditions. Arrays can be implemented in two
ways:

Range: a = VC::Result[2..5] (saves the defined VC::Result objects of
element numbers 2 through 5 in variable a)

Start and count: a = VC::Result[2,4] (saves four result values starting
with element number 2, i.e. 2, 3, 4, 5)

You can also use arrays to define several elements at once, as shown in the
following example:

a = VC::Result.new(10)
VC::Result[2..5] = a

Results 2–5 thus all refer to the same VC::Result object and are all given the
value 10.

Loops and conditions

Loops are important control structures in programming languages. They repeat
an instruction or an instruction block until a certain condition is valid or until a
break condition arises. They are especially suitable for running through multiple
values or for repeating certain program parts. Ruby provides a number of loops
(e.g. for loop, while loop, etc.), but they will not be discussed in more detail at
this point.

Conditions enable branching in the program flow and are a common component
of loops. It executes code depending on a certain value. Example: If a condition
is fulfilled, execute code part A. If not, execute code part B. Conditions can
be implemented in the same way as loops in various ways (e.g. if-then-else,
unless).

Logical operators which place a certain requirement on one or more values are
used to implement conditions. Common logical operators include == (equal to),
!= (not equal to), > (greater than), < (less than), >= (greater than or equal to)
and <= (less than or equal to).

The following is a practical example for implementing an each do loop which
runs through an array of references to point elements of the vision system and
changes the values of the array using an if-then-else condition.

pointlist = VC::Point [10,20]

|point|

point.x = point.x+100
end

end

if point != nil then

pointlist.each do

In the first line, the point elements with numbers 10–29 are saved in an array
with the designation pointlist. The loop each do is applied to this array. It
runs through all elements of the array and designates it internally as a point,
which was defined in the third line. The condition starts in the fourth line with
keyword if. This is followed by the condition point != nil. This expression
describes the requirement that the elements of the array may not be empty (i.e.
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all point elements must be defined and contain co-ordinates). If this condition
is fulfilled, then the following instruction block is executed, which in that case
contains only the instruction point.x = point.x+100. This shifts the
respective point by the value 100 in the x-direction. The end in the penultimate
line ends the condition block, whereas the end in the last line ends the each do
loop.

In this case, there was no else block for the so-called if-then-else condition. This
means that if the if condition was not fulfilled, no instructions were executed
(i.e. no shifting of the "empty" point), and the next element of the array was
subsequently tested.

To break a loop when a condition has arisen, use the command break inside
this condition. If a result for the test command is obtained through the fulfillment
of a condition or the complete run-through of a loop (e.g. if all points, without
exception, were shifted in direction x), insert the instruction return true or
return false into the respective instruction block to obtain a positive or
negative result of the command from the test.

Defining methods

You can also define your own methods in your calculation script to utilise
individually adjusted functions. In contrast to variables, they can also be used
by other calculation script commands as soon as they have been executed at
least once. The basic structure for the definition of methods is as follows:

def new_method
    (instruction block)
end

You can define variables, create loops, etc. within the instruction block.
The designation (in this case, new_method) is the name of the method
and must then be applied to the desired object in the calculation script with
.new_method. The example code above will create a global method which
is not linked to a specific class. To enhance an instance of a class with a
new method, you have to add the the referenced variable to the syntax (def
variable.neue_methode)

Image class The Image class is different from the other classes intrinsic to vcwin pro in that
it does not define or access geometry elements. Instead, this class enables
access to the image contents of a certain image memory page and enables
the user to evaluate image information, e.g. greyscale values, with his/her
calculation script.

Since accessing image data via the calculation script is very computationally
intensive, we recommend only accessing smaller sections of the image and not
the entire image. For this reason, the number of pixel values has been limited to
1,000,000 per access.

Accessing image information in an image section is carried out using the
createArea method:

image = VC::Image.createArea(-1, 200,200, 100,100)

Here, the image information of a square, 100 x 100 pixel image section is
written to variable image at position 200, 200. The parentheses contain the
following parameters: (image page number, x-position, y-position, x-stretch,
y-stretch). If, as in the example, the image page number is set to -1 or if no
parameter at all is used at this point, the calculation script accesses the current
image page.
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The image variable then contains the following information: Image format
(greyscale value, RGB), width, height and an array with all greyscale or colour
values of the pixels being viewed. These values can be queried using special
attributes:

Information Attribute Value

Image format .format 1 for greyscale images (constant
VC::Image::Grey8), 3 for RGB images
(constant VC::Image::Rgbx)

Width .width Width in pixels

Height .height Height in pixels

Greyscale
value

.grey[y][x] Greyscale value(s) at position [y] [x]

Colour value
red

.red[y][x] Colour value(s) red at position [y] [x]

Colour value
green

.green[y][x] Colour value(s) green at position [y] [x]

Colour value
blue

.blue[y][x] Colour value(s) blue at position [y] [x]

To run through several image sections in succession, as with the line scan
camera, you should use a loop which accesses image sections step by step
and processes the information further. Ensure, however, that you do not query
image information until the loop is run through and that you do not reference
them further, as otherwise the upper pixel limit will be reached after too many
run-throughs and the command will be aborted. The following example shows
how you could create a functional loop for querying image information:

(0..1000).step(1)do
|y|
image = VC::Image.createArea(-1,0,y,2500,1)

for x in 0..2500
if image.grey[0][x] > 80 then  

return false
end

end
end

return true

The first line contains a step loop which specifies a certain range (0..1000)
run through in a certain number of steps (1). The affected variable is defined
in the second line |y|. This is followed by the createArea method, which
specifies an image section of 2,500:1 pixels at position 0, y. Since y is
incremented from 0 to 1,000 by the loop, the entire image can be run through
step by step. The if-then-else condition then queries the individual greyscale
values in the image section and checks whether they are greater than 80. If
this is the case for a greyscale value, the instruction block is exited and the
command is terminated as having failed.
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7.4.17 Evaluate String

Image 192: Dialogue Evaluate String

String variables are variables for storing characters which have been read.
Up to 20 string variables can be stored in the pictor or vicosys. The maximum
length of the string variables is 54 characters. 

Use Evaluation > Evaluate String to compare the strings previously read with
one another or converted into numerical values for other uses. The following
options are available:

The Evaluate
String Option

Description

Set String Setting a string variable with a text.

Compare
Two Strings

Two strings are compared alphabetically with one another. The
result of the comparison (smaller, equal or greater) is spec-
ified. The function is evaluated as unsuccessful if the result
deviates.

Compare
String with
Text

The string is compared alphabetically with a defined text.

Append
String

The first string is appended to the second string and saved.

Convert
String to
Result

A string of numerical characters is converted into a number.
The number may be stored in a result variable for further eval-
uation.

Convert
Result to
String

The value of a result variable is converted into a string and
stored in a string variable.
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7.4.18 Angle

Image 193: Dialogue Angle

Write a command for determining the angle between geometrical variables
into the test program using Evaluation > Angle. To do this, use any previously
defined lines, circles, planes or even image coordinate axes as operands. 

Selecting a Method The following methods are possible:

• Angle between two lines
• Angle between two points and the X axis
• Angle between two points and the Y axis
• Angle between line and the X axis
• Angle between line and the Y axis
• Angle between three points
• Angle between two tangents from a point to a circle

Angles are stored in the result structure with 1/100 of a degree precision.
Tolerances can also be checked.

Angle Between 2 Lines (0° to 90°)

1. Enter the first line number.

2. Enter the second line number.

3. Enter the nominal angle and +/– tolerances.

4. Enter the result number.

Angle between 2 Points and X or Y Axis (-180° to 180°)

1. Enter the first point number.

2. Enter the second point number.

3. Enter the nominal angle and +/– tolerances.

4. Enter the result number.
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Angle Between a Line and X or Y Axis (-90° to 90°)

1. Enter the line number.

2. Enter the nominal angle and +/– tolerances.

3. Enter the result number.

Angle Between 3 Points (-180° to 180°)

1. Enter the first point number.

2. Enter the second point number.

3. Enter the pivot point number (PD).

4. Enter the nominal angle and +/– tolerances.

5. Enter the result number.

Angle Between Tangents Point - Circle

1. Enter the point number.

2. Enter the circle number.

3. Enter the nominal angle and +/– tolerances.

4. Enter the result number.

Evaluation Parameters Evaluation Description

Result Result number for storing the calculated angle (in 1/100 of a
degree).

Nominal
Value and
Tolerances

Nominal angle and pos./neg. tolerances allowed during the
calculation. You can set suitable parameters interactively with
the aid of the [Test] button.

Test The test displays the calculated angle in 1/100 of a degree.

7.5 Control Commands
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7.5.1 Asynchronous Processes

ADVICE
Use of the Asynchronous Processes feature is based on a licence model.

The command Asynchronous Processes is only available for FireWire
cameras.

Image 194: Dialogue Asynchronous Processes

Control > Asynchronous Processes allows you to wait for new images from a
camera, while other pictures of other cameras are also being processed.

Parameters Camera ADVICE
Hint: The image acquisition is started by the digital input of the camera.

This only applies to the edges Low to High and High to Low.

Parameter Description

Camera Designation of the camera.

Page Designation of the image memory page, on which the image
should be saved to.

Edge Status or edge transition of the trigger input which releases the
image acquisition.
Possible states: Low -> High, High ->Low, Live Image (contin-
uous image acquisition).



vcwin pro 2.21
Part 2 - Command Reference

316 999.994.306.10-en-1.15 © Vision & Control GmbH 2015

Parameters Image
Section

Parameter Description

Use AOI Activate the checkbox if you want to make an image acquisi-
tion of a smaller, limited area (Region/Area of Interest).

Position Starting point (x-, y- coordinates) of the rectangle which forms
the AOI.
The origin (0,0) of the image-coordinate system is located in
the top left corner.

Width /Height Edge lengths of the rectangle in relation to the starting point.

Parameters Program ADVICE
Here, for every program choose separately, whether you want to jump to
a subroutine or a label. When using labels, it is necessary to ensure that
there is a jump-back to the command "Asynchronous Processes" after the
processing.

Parameter Description

Jump to
Label

Jump to a label.

Call Subrou-
tine

Jump to a subroutine.

Label: Enter the name of the label here. Make sure that the label
already exist in the program.

Parameters Image
Overflow Handling

ADVICE
There is no time schedule for subroutines, so it is possible that a camera
captures several images, when returning to the "Asynchronous Processes"
command. In this case, an error treatment is necessary. You can configure
the error treatment under "Image Overflow Handling".

The standard error treatment stops the vicosys and provides a warning notice
with the error description „image overflow on camera xx“.

Parameter Description

Custom
Image
Overflow
Handling

Activate the checkbox if you want to aberrate from the stan-
dard error treatment.

Jump to
Label

As soon as an image overflow is detected the program imme-
diately jump to that label.

Call Subrou-
tine

As soon as an image overflow is detected the program imme-
diately calls this subroutine.

Label: Enter the name of the label here. Make sure that the label
already exist in the program.
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Short description Using "Asynchronous Processes" you can define different processes. Each
process shall have to be assigned at least one camera with the appropriate
image memory page and at least one program. The priority of the process
depends on the position of the process. Process 0 has the highest priority.

The parameters of a process are handled synchronous. This means the
process is waiting until until the acquisition of all captured images is completed
and the images are available on the image memory pages of the vicosys. The
processes, in relation to each other, run asynchronously.

The command "Asynchronous Processes" checks every process if a new image
(using more than one camera in an single process, every image has to be
new) exists. In this case the processing routine of the corresponding process is
called.

Depending on the configuration of the process a jump to a label or a call of
a subroutine will be executed. Within this block, the captured images are
processed.

When using a subroutine, it is necessary to ensure that  there is a "RETURN"
at the end of the section. Automatically there is a jump to the next command
behind the command "Asynchronous Processes".

When using a label, it is necessary to ensure that  there is a jump directly
behind or previous to the command "Asynchronous Processes".

ADVICE
Use a endless loop!

If all processes are checked and if applicable processed, the command
"Asynchronous Processes" ends itself and returns to the main program.
Therefore it is necessary to ensure that the command is embedded in an
endless loop. This loop will be left only for the labels and subroutines.

ADVICE
Pay attention to the priorities of your processes!

For each cycle of "Asynchronous Processes", only one program will be
processed. Even if there is more then one program in a process, only one of
them will be processed.

The processing of the other programs of the process take place the next
cycles. In the meantime, if a process with a higher priority provides an image
for processing, this process is preferred.
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Short Overview
"Asynchronous
Processes"

The following program represents a short overview of the embedding of
"Asynchronous Processes".
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Using the Debug-Mode, the results are as follows:
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7.5.2 Send Image

Image 195: Dialogue Send Image

Use Control > Send Image to insert a command for sending images of the
current or free electable image memory page from the vision system to the host
computer or to automation equipment. 
The images sent can also be displayed in the vcwin pro Measurement User
Window. 
You can also receive, further process or store the images with an additional
external program. The protocol has been published and is in the format
vicorem .

Use this command to send all images or only error images to the host or to
display error images while the process is running. 
The images sent to the host are saved in C:\temp as standard. The directory
to be used can be changed under Preferences in the Measurement User
Window. 

Sending of data can take place, according to the connection, via the serial or
Ethernet interface.

ADVICE
Saving images of pictor or vicosys can take place only by means of the
measuring user window of vcwin or by a separately programmed tool. With
the multi-camera system vicosys the user has additionally the possibility of
saving images on an external storage device.

Brief Guide To display an image in the top left of the Measurement User Window:

1. Include the Send Image command in the test program.

2. Transfer the program to the vision system using Communication > Transfer
> Load as File.
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3. Select Options > User Window Selection > Measurement User Window.

4. Restart vcwin pro.

5. Select Preferences in the Measurement User Window, then select the
Display option.

Input Parameters Condition for Sending
Sending can be linked to the result of the last command or command block.

• Unconditional
• After successful Command
• After failed Command
• After successful Block
• After failed Block

Image
Contents

Description

Image
Section Only

Only sends the image section produced in the Teach-in
window. The transfer time is hence reduced due the smaller
size of the image section.

With Graphic The graphic information superimposed on the monitor
(overlay) is included in the current image information. This
option should be used, for example, for demonstration
purposes to send the overlay graphics at the same time as the
image. 
Note: Transferred images cannot be used anymore for image
processing tests if you use the With Graphic option.

Send Current
Page

When the Send Current Page option is used, the image page
defined as the current work page in the system is selected. If
Send Current Page is not selected, then the number of the
image page must be given.

Image Format
Images in vcwin (R) can be saved in the JPG or BMP formats. For JPEGs, the
compression can be set.

Synchronization
Before sending image data, the vision system sends a data block with image
information (position, size and send format).

Options For sending images there are 2 further options. (for pictor only)

• Send Quick
• In the background

Send Quick

With the option "Send Quick" image data are send without any protocol to the
communication partner. This leads to an increase of transfer rate.

In the Background

With the option "In the Background" the image is saved on an internal memory
page as ring buffer. If the pictor waits for external events like data transfer, I/Os,
flash commands, waits or process module the image is sent block-by-block in
the background. There is no jitter by using Ethernet. Using the RS232 interface
you can get a jitter of 10 ms.
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With the help of this option defect images can be sent without affecting or
slowing down the process. The transmitting time can extend over several test
cycles. The time for controlling one object can be thus smaller than the time for
sending an image.

The measurement user window can be used with this option.

Numbers of the background pages

System Numbers of pages

M16xx 2

M18xx 8 (but M1821E = 5)

Table 6: Numbers of background pages

ADVICE
If all background pages with image data are occupied, the current image will
be rejected.

Interface

Interface Description

Select one of the available data interfaces, to which the result is to be sent.
The interfaces that are available depend on the type of vision system used.

/com Serial interface

/ethernet Ethernet interface

In order to guarantee proper functioning, do not change the entries behind /
com and /ethernet unless you are a network technician.

When using the serial interface, you can try to increase the transfer speed
using Communication > Interface by setting the baud rate to a maximum of
115200.

In order to preserve the increased speed during the next start, execute
Communication > Save File System In Flash ROM.
In order to change the image transmission speed for pictor in the program,
enter this as a remote control code into the test program (e.g. for conversion
to 115200 baud: E9 01 02).
In order to obtain the image transmission speed for vicosys , configure the
interface setting via the parameters in the dialog box: 
Example: Interface: /com Port: 1 Parameter: 115200,n,8,1;rtson 
Possible settings: Baud rate … 115200 (9600 / 19200 / 38400/ 57600) 
Parity … n/e/o 
Data bits … 8 / 7 
Stop bits … 1 / 2 
RTS/CTS … rtson/rtsoff

To view an image in the Measurement User Window when using an Ethernet
connection, the vision system must operate as a TCP server with port. As this
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corresponds to the presets in Communication > Interface, the fields for Port
and IP address must be left free.

Background:

Interface Meaning for Ethernet connection

/ethernet
without port
and without IP

All vision systems are TCP servers on port 8500.

/ethernet with
port and IP

All vision systems are TCP clients on the set port.

Wait For Reception Readiness … When this option is selected, vcwin pro
waits to receive confirmation of readiness to receive from the host computer
before sending. If this is not received within the Timeout period, the vcwin pro
command is aborted. If this option is not selected, vcwin pro sends the image
data immediately after the send command.

Receive and Display
Images with vcwin pro

The images sent can be received, displayed and saved from within the vcwin
pro Measurement User Window.
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Parameterize Data
Received in vcwin pro

Open the parameter dialog window in the Measurement User Window with the
[Preferences] button. Use the following settings under the Image Files heading:

Parameters Significance

Save Image The image is saved in the file directory given. The file name
contains the prefix given as well as the date received and
the clock time. The image format (JPEG or BMP) cannot be
selected in this dialog window - it is set by sending.

Display vcwin pro displays the image received in the above left section
of the Measurement User Window.

Example of the File Name for a Sent Image: 
The file name is constructed from the prefix B1 as follows:
B1-070528-142115.bmp — Explanation: The image was received on the
May, 28th 2007 at 14:21:15. If several images are received within a second, a
consecutive numbering of the images results: B1-070528-142115-2.bmp.
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7.5.3 Save / Load Image

Overview The command Save / Load Image is located in the Command Selection under
Control.

6

1

3

4

2

5

Image 196: Dialog Save / Load Image

Use this command to save or load images from or in the current image page.

The image is saved in the image directory. The image directory ist located on
the vision system or on the external storage device selected using Control >
External Storage Device.

With Communication > System Resources / Initial Program you can check
which images are stored on the image directory.

Work flow Load Image Use this option to load an image from the image directory to an image page
(edit page).

1. Activate the mode Load Image.

2. Enter the name of the image file.
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Parameter Description

fixed Select the name of the image file from the drop-down list.
If the image is not in the list, enter the full name (image
name and the file extension .bmp / .jpg). The image must
be present in the images directory at the commands execu-
tion time.

from String Select the name or number of the string from the drop-down
list.
The string must be present in the geometry list. The
content of the string must contain the image name with the
extension .bmp / .jpg.
Note that, for an error-free loading, the content of the string
must conform to the naming conventions of the respective
vision system.

3. (6) Use the [OK] button to insert the command into the test program.

Work flow Save Image Use this option to save an image in the image directory.

1. Activate the mode Save Image.

2. Enter the name of the image file.

Parameter Description

fixed Enter the name of the image file. The image is saved in the
images directory with that name and the extension of the
selected image format (.bmp / .jpg).

from String Select the name or number of the string from the drop-down
list.
The string must be created in the geometry list.
The image is saved in the images directory with the name
which is in the string and the extension of the selected
image format (.bmp / .jpg).
Note that, for an error-free saving, the content of the string
must conform to the naming conventions of the respective
vision system.

3. Enter additional storage options.

Parameter Description

Image
Section

Enable this option if you want to save only a section of the
image. When enabled, the dialog expands to the tab control
Teach-in. Switch to the tab control and adjust the image
section here (see "Teaching in Detection Windows and Test
Windows", Page 110).

Save Overlay
in Image

Enable this option if you want to save the overlay. The
Overlay is written fixed in the image.
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4. Enter here how the vision system should react if the specified file already
exists.

Parameter Description

Do not save
image if file
already exists

The image is not saved. A file system error is displayed.

Overwrite file
if file already
exists

The already existing file will be overwritten.

Use index
extension for
file name

With this option, the images are saved with the file name
and a consecutive number (index extension).

5. Select the image format.

Parameter Description

BMP The image is saved in .bmp format without quality loss.
Use this option if you want to apply inspection algorithms on
the image.

JPEG The image is lossy compressed and saved as a .jpeg. This
allows smaller image files and faster image transfer, but at
the expense of image quality.
It is therefore recommended to leave this option disabled,
because the image is changed in its gray values by a
compression. Also for color images, individual color values 
do not match with the original image color.

Compression
Quality (only
JPEG)

Enter the quality with which the JPEG images are stored.
The value can be set in increments of one from 10 to 100.

TIP
Use BMP, when it comes to accurate traceability.

Use JPG, if it is only a rough visual inspection.

6. Use the [OK] button to insert the command into the test program.

7.5.4 Data Transfer

Overview The command Data Transfer is in the Command Selection under Control.

Usage

• Communication of the vision system with machines
• Sending and receiving elements
• Changing the sequences of the test program
• Configuring target sizes
• Generating statistics
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Characteristics

• Several protocols
• Several elements per command
• Several data formats per command

Dialogue structure

1

2

3

4

5

6

7

Image 197: Dialogue Data Transfer
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Work Flow
Parametrize Interface

1. Parametrize the interface

Select the interface to be used /com (serial) or /ethernet from the drop-down
list.

Serial Interface Parameter Description

/com The serial interface /com is used.

Port Port 1 is always used. Enter 1 to configure the interface.

For the devices pictor T and vicosys following values can be
set.

• Empty

° The values last used are assumed.

• 9600,n,8,1;rtson

° Baud rate: 9600, 19200, 38400, 57600, 115200
° Parity: n, e, o (none, even, odd)
° Data bits: 8 or 7
° Stop bits: 1 or 2
° Flow control (optional): rtson, rtsoff (rts/cts on, rts/cts

off)

Parameter

For the devices pictor M following values can be set.

• Empty

° The values last used are assumed.

• 9600

° Baud rate: 9600, 19200, 38400, 57600, 115200

Ethernet Interface: ADVICE
If the vision system is used as a server, the server port is not opened with the
start of the program, but only when the Data Transfer command is executed
the first time.

Parameter Description

/ethernet The Ethernet interface is used.

Client / Server Client: Setting up a connection to the IP port of the server.
Server: Start a server on the specified port of the device.

Port Device as Client: Port of the server to be connected to.
Device as Server: Server port on the vision system.

Parameter Device as Client: IP address of the server.
Device as Server: Value is greyed out and will be ignored.

Available protocols Robot protocols:

• Schunk
• ASCII
• Epson Basic
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Protected protocols:

• 3964R Motorola: High-Byte first (Big-Endian)
• 3964R Intel: Low-Byte first (Little-Endian)
• HEX: remote control protocol vicorem with block header and checksum

Simple protocols:

• RAW Motorola: High-Byte first (Big-Endian), without block header and
checksum

• RAW Intel: Low-Byte first (Little-Endian), without block header and checksum
• ASCII: Values as ASCII characters, separator and end of block

Work Flow
Parametrize Protocol

2. Define the protocol

Depending on the choice, the following parameters can be set.

Parameter Description

for all protocols

Timeout If communication is not established within this time, the
communication attempt is aborted by the vision system. A
running server still persists after the timeout. The value is in
milliseconds.

• Use a short timeout (1 ms), if the image processing
system is only to be activated sporadically.

• Use a long or infinite timeout (timeout = 0), to reliably
exchange data or when waiting for the readiness of
another system.

receive /
send

Specify whether you want to receive or send the data.

3964R (Motorola), 3964R (Intel), Epson Basic

Response
Timeout

Maximum waiting time of the transmitter for an answer to
the call of a connection or the checksum. If exceeding the
value the connection is terminated.

Character
Timeout

Maximum time interval between the individual characters.
An exceeding is classified as a transmission end.

Max.
Connections
Count

Maximum number of connection attempts before communi-
cation attempt is aborted.

Data Retries Maximum number of transmission attempts before transfer
is cancelled.

HEX (remote control protocol vicorem)

Block ID Indication of vicorem blocks.

ASCII

Separator Character to separate values.

Block End
(ASCII
Codes)

Terminating character for all values of a command. By
default 0d 0a (line feed) is used.
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Work Flow Configure
Elements

3. Choose here the appropriate element and configure it.

Parameter Description

Element Type Enter the type here: Point, Line, Circle, Contour, Result,
String or Counter. For option send: additional types Text
and Byte List.

Element Vari-
able

Select the variable from the geometry or result structure.

Coordinate
System

Select here the appropriate coordinate system (image /
world).
For option "receive" and Coordinate System "Image":
For elements of the type Point, Circle, Line or Contour enter
a camera number. The calibration values of this camera are
used for a possible later conversion into world coordinates.

Format Enter the formate of the element:

• char: 1 byte
• short: 2 byte
• long: 4 byte
• float: 4 byte, floating-point

In the float format, enter the exponent for the scaling factor
of 10^x. The transmitted / received result is multiplied by
this scaling factor.
For example, 1234 has to be send as 1.234: exponent -3
The received values of the type Float are rounded to an
integer.

ADVICE
For Results, Point, Circles and Lines, each individual component is sent in
the format selected. For Contours, each component is send in the format
specified, but the number is always send in short.

4. Element List

In this area, all elements to be received or send are listed.

° With [Insert] you add an element from the area Insert Element to the
Element List.

° With [Modify], you can configure an element from the Element List. To do
this, select the element and change its values in the area Insert Element.
Now apply the changed values by clicking the [Modify] button.

° With [Remove] you remove an element from the Element List. To do this,
select the item and click the [Remove] button.

Work-Flow Testing
and Evaluating

5. Test and Result area

Here you can specify a result number / name to store the connection
error codes returned by the command. Error codes are saved in the result
structure.
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ADVICE
The command does not stop when sending not defined geometry
elements. The command is executed and sends the following values:

for char: 0x80

for short: 0x8000

for long: 0x80000000

for float: 0.000000

Test the command with the [Test] button.

6. Evaluation Area

Here you can see the good/bad evaluation of the command, notes for
parameterization as well as error messages.

7. Use the [OK] button to insert the command into the test program.

7.5.5 Direct Code Input

ADVICE
This function should only be called by experienced users.

ADVICE
All the command codes are described in the vicorem reference manual.
However, it is possible that your vision system cannot interpret all the
commands. Please also refer to the hardware manual that came with your
vision system.

Use the Control > Direct Code Input command to call directly vicorem
commands that the vision system supports. So you are able to call options,
which are not available in vcwin pro dialogs. Also, you can use this to call new
commands (created f.e. with vicosys SDK) that have no dialogs yet.
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7.5.6 Save Settings

ADVICE
This command corresponds to the Direct Code Input F9.

Image 198: Dialogue Save Settings

With Control > Save Settings you write a command into the test program that
saves the calibration data, the demomode and the video mode on the flash of
the vision system.

7.5.7 External Storage Device

Overview

Image 199: Dialogue External Storage Device

With Control > External Storage Device, you define the storage device on
which images are stored.

The optionally switchable ring buffer avoids overflow in the storage device. Data
from the external storage device can be inspected and, if required, deleted by
use of Communication > System Resources / Initial Program Area Images.

Selectable storage
devices

• Internal Memory (pre-setting)
• SMB (Windows Share, Ethernet) for pictor T and vicosys
• FTP Server (Ethernet) for pictor M, pictor T and vicosys
• USB Stick/Hard Drive of vicosys(at vicosys 4xxx: also CompactFlash-Slot)

ADVICE
The FTP Server and SMB (Windows Share) options permit data to be
viewed or processed further during the run operation.
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Optimizing Speed In order to achieve maximum memory speed, use USB hard drives on a
vicosys.

If a network storage device is used, it should be noted that the network topology
has an effect on the execution time of save and load commands.

Setting Global
Parameters

Parameter Description

Use Ring
Buffer

If this option is activated, as many images can be saved simul-
taneously as the size of the ring buffer permits.

• The file names of the images saved have consecutive numbers.
• The ring buffer advances one number for each image saved.
• After the ring buffer is full, further storage starts again using the file name of

the first image.
• Images with the same name are overwritten, independently of the settings in

the Save Image command.

ADVICE
The ring buffer counter resets itself with every call of the External Storage
Device command to the value 1.

Internal Memory This option is pre-set. Select this option to save images to the internal memory.

Characteristics

• Storing images on the internal memory is slower than storing on other
media.

• The storage time is heavily dependent on the image size.
• Saving the image is directly synchronous, i.e. saving of the image is

completely finished after execution of the command.

SMB (Windows Share) Select this option to save images on the hard disk of a SMB server. The storage
time depends on the image size, network speed and performance of the server.

ADVICE
Take note of upper / lower case with identification of subdirectories.

Parameter Description

Server DNS name or IP address of the SMB server. In order to be
able to correctly resolve the server DNS name, the vision
system must be informed of a server name via DHCP. Also
see DHCP in the section regarding changing the IP address
>> "Change Vision System's IP-address", Page 98.

Directory Name of the subdirectory (incl. share) on the SMB server
(Windows Share).
Subdirectories must be given in the form subdirectory 1/ subdi-
rectory 2.

User name /
Password

Login name and password of the SMB server.



vcwin pro 2.21
Part 2 - Command Reference

© Vision & Control GmbH
2015

999.994.306.10-en-1.15 335

FTP Server Select the FTP Server option to save images on the hard disk of a FTP server.
The storage time depends on the image size, network speed and performance
of the server.

ADVICE
Take note of upper / lower case with identification of subdirectories.

ADVICE
Note that when connecting with External Storage Device FTP to a server, the
server must not stop or be interrupted during operation. The functionality of
the vision system can thereby be endangered.

Parameter Description

Server IP address of the FTP server.

Directory Name of the subdirectory (incl. share) on the FTP server.
Subdirectories must be given in the form subdirectory 1/ subdi-
rectory 2.

User name /
Password

Login name and password of the FTP server.

USB Stick/Hard Drive ADVICE
To prevent data loss, unmount USB sticks/hard drives before shutting down
or removal with the command External Storage Device > Unmount USB
Device

Select the USB Stick/Hard Drive option to store images on the first partition of a
USB stick or a USB hard disk (file system FAT 16 or FAT 32). The storage time
depends on the image size and write speed of the USB stick/hard drive.

Parameter Description

Directory Name of the subdirectory on the USB stick/hard drive.
Subdirectories must be given in the form subdirectory 1/ subdi-
rectory 2.

Unmount USB Device Select Unmount USB Device, in order to deregister a USB stick or a hard drive.

After unmounting the storage device, the program saves no more images until
execution of the next External Storage Device command.
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7.5.8 Copy Geometry Variables

Image 200: Dialogue External Storage Device

Use Control > Copy Geometry Variables as a complex control command for
time-saving access to geometry variables and results. 

Copy groups of geometry variables or results backwards or forwards between
the work area and index area. Use this command in combination with
commands which create a large number of similar geometry variables or results
(e.g. blob analysis, transition at line), for each of which a separate subroutine
must normally be written.

Index Area and Work Area

The Index and Work Areas are not specific memory areas, but rather areas
that can be individually defined for the groups of elements points, lines, circles,
results and contours. Elements should always be changed in the Work Area, not
in the Index Area.

Loop Control

Programs only execute in the work area. By generating a loop, one can load
the geometry variables from the index area into the work area one after the
other for processing or vice versa. In this way, a single evaluation program can
be used for all similar geometry variables and results. (See also the example at
the end of this topic.)

Input Parameters Copy Description

Quantity Quantity of variables to be copied.

Item Category of variables to be copied: points, lines, circles,
results, contours.

to Work Area Copy takes place from the index area to the work area.

to Index Area Copy takes place from the work area to the index area.
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The index defines which geometry element is to be copied next to the “index
area”/“work area”. In so doing, an increment (integer) is added to the number of
previously copied elements.

Index Description

Direct Increment is entered directly.

From Result Increment is read from the result no. to be entered.

From
Counter

Increment is read from the counter no. to be entered.

Areas Description

Work Area
from

First number in the work area of the geometry structure

Index Area
from

First number in the index area of the geometry structure

Examples Example 1: Using the Blob Analysis Command

Data are copied out of the index area into the work area.

1. Store the area center points which have been found by the Blob Analysis
command (e.g. 10 points) one after the other in the point structure.

2. Set the number of the first point stored in point 1 as the start of the index
area.

3. Set a free number as the start of the work area. The index area and work
area must not overlap.

4. Set the number of variables “1” to be copied, type of variable point and
copying direction to work area.

5. Select index From Result.

6. Interleave with the Combine Results command and execute program
control commands.

Example 2: See the demo program geocopy.vc. >>"Demo Programs",
Page 389

7.5.9 Indexed Branch

Image 201: Dialogue Indexed Branch

Insert several branches (jumps, subroutines) into the test program using
Control > Indexed Branch. In this, the command jumps to a label whose name
is composed on the fly from a fixed part – the basis label – and a variable part
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which is loaded from a result no. of the index. The advantage with this is that
various subroutines or labels can be called with one and the same command,
dependent upon the index. 

For better clarity, the command is colored blue by default. You can change
the colour using Options -> application settings -> Fontsee "Application
Settings", Page 103

Indexed branch commands always refer to the command or command block
previously executed in the test program. In other words – indexed branch
commands are inserted into the test program after the command or command
block to be evaluated. Depending on the result of the previous command or
command block the Indexed Branch command functions as follows:

Result of the
previous command /
command block

The program branch is implemented (it is other-
wise ignored), if one of the following branch
conditions is fulfilled …

Successful • Successful command / successful command block
or

• Unconditional

Failed • Failed command / failed block or
• Unconditional

If the result of the previous command does not fulfill the branch conditions then
the branch does not take place and the test program proceeds to process the
next command.

Command Types and
Branching Conditions

Command Types

The following branch operations are possible:

• Set labels.
• Set the start of a condition block.
• Set the end of the main program.
• Exit program.

Options for 
Branches

Description

Subroutine The main program notes the start position behind the Indexed
Branch command for the subsequent return from the subrou-
tine to the main program. The subroutine must contain a return
command.

Jumps The program does not note the start position: used for jumping
to labels.

Possible Branching Conditions

ADVICE
A conditional block counts as failed if a single command of the conditional
blocks has failed, e.g. because a tolerance was exceeded.

Conditions used for determining whether to branch or execute the next
command:
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• successful command
• successful command block
• failed command
• failed command block

Input Parameters Parameters Description

Basis Label First (fixed) part of the name of the label/subroutine which is to
be jumped to.

Result for
Index

Result number for saving the second (variable) part of the
label name/ subroutine which is to be jumped to.

Example See the demo program verzweig.vc. >> "Demo Programs", Page 389

7.5.10 Calibrate

Image 202: Dialogue Calibrate

Using Control > Calibrate you add a command for a calibration program. The
calibration program should be run every time, when cameras are changed on
the vision system, the working distance changes or objective is replaced.

In order to carry out measurements with image sensors and other optical
devices, a calibration factor (image scale) has to be ascertained i.e. how
many pixels correspond to a given distance within the image. The calibration
factor can be saved for further tests. Based on the features of image sensors,
separate factors are determined for the X and Y directions. Calibration is carried
out with a previously measured reference object.

ADVICE
You use calibration commands in special test programs. These should
be written very carefully! You must make sure that the reference object is
scanned precisely and that the data makes sense.

Calibration Factors The calibration factor – the scale between image and world coordinates – is
determined through a calibration command. Calibration is always active for the
currently selected vision system.

The calibration factors are valid only until the system is restarted or a new
calibration starts. They can be saved by using the command Control > Save
Settings see "Save Settings", Page 333.
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Absolute and Relative
Calibration

There are two basic types of calibration - absolute and relative.

Absolute calibration: Geometrical variables are defined in image coordinates.

Every relative calibration requires that the previous absolute calibration was
successful. Geometrical variables are defined in world coordinates. The
coordinate units used during relative calibration must be the same in the
X and Y dimensions. The calibration factors are determined by comparing
measured distances with the nominal distances from geometrical variables of
the reference object.

ADVICE
You should make a point of carrying out relative calibration immediately after
absolute calibration to improve the precision of tests.

To calibrate using
distance between two
points

The calibration method Distance between 2 Points is a type of absolute
calibration. The points must be defined in image coordinates. Any deviation in
the position of the reference object from the X or Y image coordinate direction
causes a significant calibration error. This can be compensated by adding either
a Perpendicular Distance (in world coordinates) or a Distance in Result
Structure calibration command.

Parameters

1. Enter the first point number.

2. Enter the second point number.

3. Enter the distance between the points in the X and Y directions (in world
coordinates) in [µm].

To calibrate using
perpendicular
distance point-line

Absolute Calibration
Absolute calibration Perpendicular Distance (in image coordinates) requires
square pixels because any change in the position of the reference object affects
calibration.

Although the margin of error here is smaller than when calibrating with
“Distance between two Points” (see above), the difference between the height
and width of pixels during absolute calibration cannot be compensated for.

Relative Calibration
The relative calibration Perpendicular Distance (in world coordinates) must be
preceded by an absolute Distance between two Points calibration. Any error
due to changes in the position of the reference object can be compensated for.
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Parameters

1. Enter the point number.

2. Enter the line number.

3. Enter the distance between the point and the line in world coordinates in µm.

To calibrate using
the distance from the
result structure

ADVICE
Relative calibration: the geometrical elements or distances (both X and Y)
must be determined with all their calibration factors before the final calibration
factors (X and Y) can be calculated.

Calibration factors can be made more precise by grabbing images repeatedly
and averaging out the distances.

Calibration compares relative distances within the result structure to known
values (relative calibration). Distances can be measured several times, written
into the result structure and the calibration factors adjusted accordingly.

The ratio between the X and Y scales must be known before you can use this
type of calibration. This can be determined using e.g. the calibration command
Distance Point - Point. >> see "Distance", Page 267

Parameters

1. Enter the result number.

2. Enter the distance in world units in µm.

Example See the demo program in the appendix calib_x.vc. >> see "Demo Programs",
Page 389
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7.5.11 Line I/O

Image 203: Dialogue Line I/O

Write control commands for communication between the vision system and the
process environment using Control > Line I/O. 

Use this command for instance to read digital inputs from PLC or to set or reset
outputs.

The current signals are compared to defined nominal states. Depending upon
whether the condition is fulfilled, the command will return either successful
or unsuccessful. Evaluate this result for a single command or for a condition
block and can you use it to control branching.

>> "Branch", Page 349

Test func-
tions

Description

Wait Wait until the required signal appears at the input.

Test Signals Test for the required signal at the input.

Output
Impulse

Send an impulse to the output.

Output Send a defined signal to the output.

Input Parameters Hardware-
type

Beschreibung

PS8 4/4-way input/output at pictor M ; 4 digital input, 4 digital
output.

DIO4/6 4/6-way input/output port at pictor T-ECAN; 4 digital input, 6
digital output.

DIO4 4/4-way input/output port at pictor T-SC; 4 digital input, 4
digital output.

DIO8 8/8-way input/output port at vicosys; 8 digital input, 8 digital
output.

DIO16 16/16-way input/output port atvicosys; 16 digital input, 16
digital output.
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Parameters Description

Inputs/
Outputs

Input or output which needs testing/setting.

Query Status If the Query Status option is activated, then the status at the
input is queried immediately.

Set Static
Output

If the Set Static Output option is activated, then the output is
set to nominal status.

Output
Impulse

If the Output Impulse option is activated, then an impulse
with nominal status is output at the output set.

Impulse
Duration

Duration of the impulse.

Nominal
Status > Low/
High

Status of the input/output to be queried / set.

Wait for Status

If the Wait for Status option is activated, the following parameters apply to the
wait for a signal:

Wait for
Status

Description

Timeout [ms] Input is interrogated for the duration of the timeout.

Debounce
[ms]

If the status of the input coincides with the nominal status, the
program waits for the duration of the debounce time entered.
If this input status still exists after the debounce time has
expired, the result successful is returned.

Test Options for
Inputs

Procedure for the I/O Test
The dialog box is the same for testing either type of I/O hardware. Available
inputs and outputs are listed in one window each. Switch between both
windows with the TAB key.

1. Select the line with the mouse.

2. Enter signal parameters to be queried (for inputs) or to be output (for
outputs).

3. Press the [OK] button. 
The command is transferred into the test program.

Wait for Condition
The maximum time the test program will wait for a signal at an input (timeout)
and how long the signal must remain at the port (impulse duration) can be
defined with millisecond precision.

1. Select an input e.g. {IN_1}.

2. Activate the Wait for Status option.

3. Set timeout to the nominal value e.g. 1000. 
Note: If you set the waiting time to {0}, vcwin pro will carry on waiting until
the condition is fulfilled (No Timeout).

4. The nominal dwell time (debounce time) is set internally at 10 ms and is not
altered, even if a different value is entered into the dialog window.
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5. Specify the state: off  (LOW) or on (HIGH).

Testing Nominal Signal at Input
You can program checking a defined input signal as follows:

1. Select one of the inputs.

2. Activate the Query Status option.

3. Specify the state: off  (LOW) or on (HIGH).

Output of Signals Set Static Output
You can program the output of a defined output signal as follows:

1. Select one of the outputs, e.g. {OUT_3}.

2. Activate the Set Static Output option.

3. Specify the state: off  (LOW) or on (HIGH).

Output Impulse
You can program the output of an impulse as follows:

1. Select one of the outputs.

2. Activate the Output Impulse option.

3. Set the length of the impulse in ms.

4. Specify the state: off  (LOW) or on (HIGH).

Example See the demo program up_lio.vc. >> "Demo Programs", Page 389

7.5.12 Port I/O

Image 204: Dialogue Port I/O

Create control commands for either communication between the vision system
and the process environment (e.g. with a PLC), or for direct control of feed
systems using Control > Port I/O. 

Use this command to read digital inputs and set or reset outputs. A common
use would be input from ADCs and output to DACs.

Basics

The port I/O commands group several lines of a port together. The method is
similar to line I/O except that more than one input/output can be tested at the
same time using a single command.
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The current signals are compared to defined nominal states. Depending upon
whether the condition is fulfilled, the command will return either successful
or unsuccessful. This result can be evaluated for a single command or for a
condition block and can be used to control branching.

>>"Branch", Page 349

Input Parameters The procedure for controlling interfaces is the same for testing either type of I/O
hardware. The Port I/O command always refers to all lines of an interface

Hardware-
type

Beschreibung

PS8 4/4-way input/output at pictor M ; 4 digital input, 4 digital
output.

DIO4/6 4/6-way input/output port at pictor T-ECAN; 4 digital input, 6
digital output.

DIO4 4/4-way input/output port at pictor T-SC; 4 digital input, 4
digital output.

DIO8 8/8-way input/output port at vicosys; 8 digital input, 8 digital
output.

DIO16 16/16-way input/output port atvicosys; 16 digital input, 16
digital output.

Query Inputs The nominal signal is valid for all lines of the port and is entered as a
hexadecimal value.

Wait for Value defines the permissible delay time programmed before a
nominal value 
(signal pattern for a single input) has to appear or no longer appears at the input
port 
In addition, the length of time before the signal pattern must be available can be
entered.

1. Enter the nominal value e.g. {4}.

2. Activate the Query Inputs  and Wait for Value options.

3. Set timeout to the nominal value e.g. {1000}. 
Note: If you set the waiting time to {0}, vcwin pro will carry on waiting until
the condition is fulfilled (no timeout).

4. Select whether the system should wait for exactly the nominal value or for
the first result below or above the nominal value.
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5. The nominal dwell time in the nominal condition is set under debounce time.

Query Value
With this you can write a command for testing the input of the I/O module for a
defined input signal pattern:

1. Enter the nominal value (hex) e.g. {4}.

2. Activate the Query Inputs and Query Value options.

3. Select whether the system should wait for exactly the nominal value (=) or
for the first result below (<) or above (>) the nominal value.

Set Outputs Setting an Output to a Value
With this you can program a defined output signal.

1. Enter the nominal value e.g. {4}.

2. Activate the Set Outputs option.

Example See the demo program up_pio.vc. >> "Demo Programs", Page 389
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7.5.13 Port Control

Image 205: Dialogue Port Control

Depending upon the input signal of the hardware inputs, you can define jump
commands to labels or subroutines using Control > Port Control. With this,
you can arrange several conditions in a branching list if necessary. Branching is
executed for the first condition fulfilled.

For better clarity, the command is colored blue by default. You can change the
colour using Options -> application settings -> Font see "Application Settings",
Page 103

Basics for Command
Processing

The hardware inputs are interrogated cyclically. The program only leaves the
command if one of the two following results occurs:

• Condition was fulfilled.
• Timeout was exceeded.

Timeout does not have any effect on its own. Because of this, a condition must
always be fulfilled before a command can be exited.

In the case of several conditions to be fulfilled, the label at the bottom of the
branch list is jumped to first.

Input Parameters I/O Port
The hardware input to be interrogated is set:

Hardware-
type

Beschreibung

PS8 4/4-way input/output at pictor M ; 4 digital input, 4 digital
output.

DIO4/6 4/6-way input/output port at pictor T-ECAN; 4 digital input, 6
digital output.

DIO4 4/4-way input/output port at pictor T-SC; 4 digital input, 4
digital output.

DIO8 8/8-way input/output port at vicosys; 8 digital input, 8 digital
output.

DIO16 16/16-way input/output port atvicosys; 16 digital input, 16
digital output.
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Times of the Input Signal

Times of the
Input Signal

Description

Timeout [ms] Input is interrogated for the duration of the timeout. If timeout
= 0 is entered, the program waits until one of the conditions is
fulfilled, with a label as the jump target.

Debounce
Time [ms]

If the status of the input coincides with the nominal value, the
program waits for the duration of the debounce time entered. If
the status still coincides after the debounce time has expired,
then the program branching is executed.

Bitmask and Nominal Value
There is a bitmask and a nominal value for defining the nominal signals for
executing the branching.

Bitmask and
Nominal
Value

Description

Bitmask Hexadecimal number which defines which bits of the input are
relevant. Example: 30 (Hex) means bit 4 = 1 and bit 5 =1, i.e.
bit 4 and 5 are used to determine the nominal value.

Nominal
Value

Hexadecimal number which defines the nominal value of the
port signal

Jump at Nominal Value
The following branching conditions are possible:

Jump at
Nominal
Value

Description

Equal Actual value at input is equal to nominal value.

Not Equal Actual value at input is not equal to nominal value.

Greater Actual value at input is greater than nominal value.

Smaller Actual value at input is smaller than nominal value.

Jump Types

ADVICE
After executing the called program part, the program jumps to the instruction
before the Port Control instruction and executes the next instruction.

Jump types Description

Subroutine Subroutine called if condition fulfilled.

Label Jump to the label entered if the condition is fulfilled.
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Branching List All branchings which can be controlled from the input are edited in the
branching list.

To insert an entry into the branching list

1. Mark the position in the branching list under which the new branching
condition is to be inserted with a mouse click (does not apply to the first
entry).

2. Set the branching parameters (above the table).

3. Click on the [Insert] button.

To change an entry in the branching list

1. Mark the branching condition to be replaced with a mouse click.

2. Replace branching parameters (above the table).

3. Click on [Edit] button.

To delete an entry in the branching list

1. Mark the entry with a mouse click.

2. Click on the [Remove] button.

7.5.14 Branch

Image 206: Dialogue Branch

Create program branches and labels for program branches in test programs
using Control > Branch. Conditional jump commands use the success/failure
state of the most recent command or command block. Always write program
control commands immediately after commands where success or failure
determine how the program should react. 

For better clarity, the command is colored blue by default. You can change the
colour using Options -> application settings -> Font see "Application Settings",
Page 103.
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Depending on the result of the previous command or command block the
Branch command functions as follows:

Result of the
previous command /
command block

The program branch is implemented (it is other-
wise ignored), if one of the following branch
conditions is fulfilled …

Successful • Successful command / successful command block
or

• Unconditional

Failed • Failed command / failed block or
• Unconditional

If the result of the previous command does not fulfill the branch conditions then
a branch does only take place, if the Elsewise option is active. If the Elsewise
option is not active, then the next command in the test program is executed.
When the test program is sent to the vision system, program control commands
are not checked.

Command Types and
Branching Conditions

Command Types

The following branch operations are possible:

• Set labels.
• Set the start of a condition block.
• Set the end of the main program.
• Exit program.

The following branch operations are possible:

• Unconditional jump to a label.
• Conditional jump to a label.

The following control commands are possible for jumps:

• Unconditional subroutine call.
• Subroutine call if condition fulfilled.
• Exit subroutine.

Possible Branching Conditions

ADVICE
A conditional block counts as failed if a single command of the conditional
blocks has failed, e.g. because a tolerance was exceeded.

Conditions used for determining whether to branch or execute the next
command:

• successful command
• successful command block
• failed command
• failed command block
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Input Parameters General Control Commands

General
Control
Commands

Description

Set Label Inserts a marker label into the test program: A name for the
label has to be entered.

Start Condi-
tion Block

Defines the beginning of a block of commands in the test
program: The condition block unites the results of several
individual commands into a single result. The final result of
a condition block is therefore unsuccessful if any of the
commands within the block are unsuccessful.

End of Main
Program

Defines the end of the main part of a program. This command
ends the test cycle and starts the program loop anew from the
first command.

Exit Program Defines a command for ending the program. This causes the
program to terminate checkups and return to the start menu.
In the pictorsystem, run mode is stopped and the system then
waits for remote control commands.

Control Commands for Jumps

Control
Commands
for Jumps

Description

Uncondi-
tional jump
to a label

Activating the unconditional option causes an immediate jump
to a defined label within the test program. A name for the label
has to be entered.

Conditional
jump to a
label

The various conditions possible for a conditional jump
command can be chosen from the menu during editing. A
name for the label has to be entered.

The jump is executed during program execution if the conditions chosen are
fulfilled. Each time the conditions refer to the last command or command block
before the jump command and can be:

• a successful condition block
• a successful command
• a failed condition block
• a failed command

Control Commands for Subroutines

ADVICE
Subroutines should never be finished or excited by any other command
except Return. Otherwise the jump back addresses collected in the stack
are not cancelled and this leads to the error message Too many subroutine
calls. In order to reset the stack, insert the Return command into the
subroutine, then call the Utilities > Test Section command.
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Control
Commands
for Subrou-
tines

Description

Uncon-
ditional
subroutine
calls

The options for Subroutine creates calls to subroutines in the
program. The name of the subroutine must be entered from
the keyboard in the Label field.

Conditional
subroutine
calls

Select the condition so that the test program will call a subrou-
tine during editing. The name of the subroutine must be
entered from the keyboard in the Label field. 
When the test program is run, the program will jump to the
defined subroutine if the condition is fulfilled, otherwise the
next command will be executed. The conditions are success
or failure of the preceding command or condition block:

• a successful condition block
• a successful command
• a failed condition block
• a failed command

Leave
subroutine
(Return)

A command to leave the subroutine is put in the test
program. After the subroutine executes, it jumps back to the
call location.

Elsewise Permits conditional jumps and subroutine calls for conditions
that are not fulfilled and so allows the construction of an IF-
THEN-ELSE logical structure.

Example for Elsewise
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7.5.15 Save Process Data

Overview The command Save Process Data is located in the Command Selection under
Control.

Use and function

• Storage of process data in a CSV file.
• Storage of the CSV files on the device or on USB flash drives, CF cards or

servers (command External Storage Device)
• First time running the command creates a table with the specified names.

The values of the elements are stored in the table as a single row. Each
subsequent run extends the table with a new row with the current values of
the elements.

• The option to append the date to the file name automatically creates every
day a new CSV file.

• The CSV files can be opened with a spreadsheet program or processed
automatically.

TIP
Use the command External Storage Device to store the file. As
a result, the processing time of the command will be shortened.

Dialog Structure

1

2

3

Image 207: Dialog Save Process Data
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Work Flow 1. Assign a file name

Select whether the file name is assigned fixed or assumed from a string.

Parameter Description

fixed File name under which the file is stored. The file
name is appended with .csv.

from String The file is stored with the name that is in the string.
The String has to be created in the program before.
The file name is appended with .csv.
Please note: For error-free saving, the content of
the string has to accord to the name conventions of
the vision system.

Append Date If this option is enabled, a new file is created
for each day. The file is stored in the form "File
Name_YYYY-MM-DD.CSV ".

2. Select elements

Group box Element

Here you can select the elements to be stored.

Parameter Description

Column Name Enter here the column name. It is inserted in the
table header (first line). If no name is specified for
all columns, no first row (table header) is inserted in
the table.

Element Type Select here the element type.
(e.g.: Result, Point, Line, Circle, String, Date, Time).

Element Sub Type* Select here the Element Sub Type
(e.g.: x Coordinate at Element Type Point).

Element Variable* Select here the Element Variable. Depending on the
selected Element Type, the corresponding element
list is displayed.

* Grayed out for date and time. The date is written in the column in the form
YYYY-MM-DD, the time HH:MM:SS.

° With [Insert] you add an element to the Element List.
° With [Modify], you can configure an element from the Element List. To

do this, select the element in the group box "Element List". Change its
values in the group box "Element".
Apply the changed values by clicking the [Modify] button.
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Group box "Element Liste"

Here all the elements stored in the table are listed.

° With the button  you can move an element in the element list up resp.
one column forward. For this purpose select the item and click the button.

° With the button  you can move an element in the element list down
resp. one column backward. For this purpose select the item and click the
button.

° With the button  you can remove an element from the element list. For
this purpose select the item and click the button.

3. Use the [OK] button to insert the command into the test program.

If the program executes the command, all elements from the list are saved in
a new row. Each subsequent call of the command adds a new row.

Structure of the data
file

• Character set: ISO-8859-15
• Column separation by ";"
• Strings in quotation marks
• Date and time according to ISO 8601 in the format YYYY-MM-DD and

HH:MM:SS

Error messages Invalid Parameter

• At least one parameter is invalid.
• Check the settings of the command. Check that the used mode of the

command is supported by the vision system used.

File system error

• An error occurred while saving.
• Check if the storage medium is reachable.
• Check if you have access rights for the chosen directory.

Not enough memory

• The storage medium is full.
• Create more space on the storage medium.

Invalid file name

• The file name contains invalid characters.
• Use a valid file name.

Not supported for FTP

• Do not use FTP.
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7.5.16 Process Module

Overview ADVICE
For information also refer to the manual of the process coupling module.

Image 208: Dialogue Process Module

With Control > Process Module, you can have vision systems communicate
with other systems on Fieldbus, Industrial Ethernet and/or through digital I/O. 

Data exchange occurs by means of the writing and reading of elements.

Interface Variants as internal interface of the devices pictor T and vicosys

• CANopen
• sercos 3

ADVICE
The internal interface is configured via Communication > Fieldbus settings

with gateways of the Hilscher netTAP series

• PROFIBUS-DP
• DeviceNet
• CC-Link
• CANopen
• RS232
• EtherCAT
• Ethernet Powerlink
• PROFINET-IO
• Ethernet/IP
• sercos 3
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ADVICE
The gateways of the Hilscher netTAP series are configured by using the
software of the manufacturer.

with gateways of the PKM series

• Digital I/O (8/8)
• Profibus DP (Slave, 30/8)

Establish a
connection to the
process coupling
module

1. Connect the process coupling module via one of the supported interfaces
(refer to the manual for further information about supported interfaces).

° COM1 data port (vicosys) or serial (pictor)
° Ethernet

2. Set the vision system to the command mode (Connection to the vision
system).

3. Select Control > Process Module.

4. Set the interface.

Interface
Parameters

Description

/com,
/ethernet,
/CANopen,
/sercos 3,
/modbus

Available interfaces (if supported).
The Hilscher netTAP gateways connected via ethernet must
be configured by using /modbus.

Timeout Waiting time of the vision system for a response from the
process coupling module. If no acknowledgement occurs
during this time, the connection setup is aborted.

After selecting the interface, use the [Connect] button in order to establish the
communication with the process coupling module. This function is not needed at
the internal interfaces (CANopen and sercos 3).

Reading elements

Image 209: Dialogue Process Module - reading elements

1. When using fieldbus applications, activate the Read mode above the register
list.

2. Select one of the available registers from which elements can be read.

3. Assign an element type with the corresponding number respectively name.
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° Ignore
Nothing is read from this register.

° Result
A Result is read from this register.

° Point (X)
The X coordinate of a point is read from this register.

° Point (Y)
The Y coordinate of a point is read from this register.

4. Enter the byte order (only at /ethernet, /com): Either low-byte (little endian) or
high-byte (big endian) is read first (global setting for all elements).

5. Option: Select the coordinate system for point coordinates (image coordinate
system / world coordinate system). This is a specific setting for the selected
register.

Writing elements

Image 210: Dialogue Process Module - write elements

Before you can write results or point coordinates, they must be defined.

1. Activate Write above the tab list.

2. Select one of the registers into which elements can be written.

3. Enter the byte order (only at /ethernet, /com): Either low-byte (little endian) or
high-byte (big endian) is written first. (global setting for all elements)

4. Assign an element type with the corresponding number respectively name.

° Ignore
Nothing is written in this register.

° Result
A Result is written in this register.

° Point (X)
The X coordinate of a point is written in this register.

° Point (Y)
The Y coordinate of a point is written in this register.

° Constant
A constant value is written in this register. Enter the value as an integer.
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16 bit registers
Interface /modbus

Image 211: Dialogue Process Module - option 16 bit registers

With this option, the internal 32 bit values of the vision system are shortened on
a 16 bit register. The upper 16 bits are cropped. With this option, the number of
available registers doubled.

If the option is not active, the internal 32 bit values of the vision system are
divided to two 16 bit register (word-register).

Synchronization When using external gateways (PKM-PB, PKM-PB/v, Hilscher netTAP...), the
command Process Module is not synchronised to the bus cycle of the bus
system on which the gateway converts.

If several registers of the process coupling module are written, these
changes can be effective in different bus cycles. Therefore, the PLC for data
transmission must be synchronised with the Vision System.

On way to synchronise can be done with a digital START signal from the
PLC and a READY signal from the Vision System. These signals can be sent
through the digital inputs and outputs of the communication partner device.

Another way to synchronise can be done with a counter on the Vision System,
which counts up at each test and writes that value to the fieldbus register.
This should be done either in a separate Process Module command after
the Process Module command or as the last (used) register in the Process
Module command. On the master should be monitored, at which time the value
increases. With each increase, a measurement is made and all new values are
available.

IO Module Connection of the IO module (PKM-PLC8) can be optionally done through
Ethernet or through RS-232. After configuring, establish communication
between the process interfacing module and vcwin pro with the [Connect]
button. The Line IO and Port IO operating modes are activated. The use of
these two operating modes is analogous to the standard control commands
Line IO and Port IO.

>> see "Line I/O", Page 342

>> see "Port I/O", Page 344
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7.5.17 Geometry Sets

Image 212: Dialogue Geometry Sets

A command is written into the test program which allows geometry structures to
be loaded or saved. 

A reference geometry set is a set of points, circles, lines and contours which
can be saved as a file while a test program is running and loaded again later on.

The various geometry elements can also be merged and saved in a single file.

To save geometry
structures from the
program into files

Follow these steps to select geometrical elements and save them as sets to
disk:

1. Select the Save option.

2. Enter the file name under which you want the geometry structure to be
saved.

3. Select an element: circle, line, point or contour.

4. Give the number or range of numbers for the type of geometry variable
selected from above.

5. Use the [Insert], [Remove] or [Edit] buttons to put in, remove or change the
respective element in the element list.

6. Click on the [OK] button.

To load geometry
structures from files
into the test program

ADVICE
The program makes a note of the most recently loaded geometry set to
prevent unnecessary access to the hard disk.

A geometry set is only reloaded after the test program is restarted i.e. the
elements in a set cannot be changed while the test program is running.

1. Select the Load option.

2. Enter the name of the geometry set you want to load.

3. Click on the [OK] button.

Input Parameters Parameters Description

Load/Save Instruction as to whether the reference geometry should be
loaded or saved.

File File in which the reference geometry should be saved.
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7.5.18 Stopwatch

Image 213: Dialogue Stopwatch

Start an internal stopwatch and compare the time since the start of a function
to a nominal value or result using Control > Stopwatch. Use the stopwatch for
controlling or checking the time taken by parts or all of the test program.

Start Stopwatch

Select the Start option. Ready.

Comparing a Measured Time with a Value
During program execution: If the elapsed time is longer than the comparison
value given, then the time has expired (command failed), otherwise not. 
Teach-in:

1. Activate the Compare option.

2. Enter a comparative value.

Storing the Measured Time in the Result Structure
When employing this option, the stopwatch continues to run during the
continuing program execution.
Teach-in:

1. Activate the Read option.

2. Enter the result number.

7.5.19 Save System Time

Evaluate system time
in programs

Image 214: Dialogue Save System Time

1. Save the system time in a result variable (RES) with Save System Time >
Save in Results.

2. Send the result variable with Control > Send Results > HEX, e.g. to a PLC.

3. Leave the system time in Hex format for machine level evaluation.
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Evaluate system time
in the user interface
and with machine
code level evaluation

1. Activate the System Time option in the Evaluation > Evaluate Result
command. 
The following data are sent if the System Time option is not active:

° Total (4 Bytes)
° Res no. 1, res no. 2, …. 

The additional following data can only be sent with the System Time
option activated:

° Date (4 Bytes)
° Time (4 Bytes)

2. Use the Evaluate Result command to transfer the system time to, for
example, a PLC.

3. Leave the system time in Hex format for machine level evaluation.

4. In addition, the system time can also be displayed via the User Window.

To use the Vision
System’s system
time in ASCII format
for logging and
visualization

1. Save the system time in ASCII format as a string using Save System Time
> Save as String.

2. You can define the formatting of the string yourself (see later on in this
section.) 
Additional text is possible.

3. Send the string using Control > Send Results > ASCII to the protocol
computer. Superimpose the string on the screen using Evaluation >
Superimpose.
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Syntax Format for Date and Time

Date YYMD (year, month, day)

Time HMST (hour, minute, second, tick)

Format for conversion: %[flags][width][type]

Flags 0

Width length of the parameter

Types Y year

M month

D day

H hour

I minute

S second

T tick

Example: Format for Conversion The ASCII text sent using Send
Results

%2D.%2M.%2Y %2H :%2I :%2S 25.03.07 14 :03 :45

Date 2D.%2M.%2Y; Clock time %2H:
%2I:%2S

Date 25.03.07; Clock time 14:03:45

7.5.20 Wait

Image 215: Dialogue Wait

Define a command which sets how long the test program should wait until the
required time has elapsed using Control > Wait. Enter the wait time required
[ms] into the dialog window.

7.5.21 Counter

Image 216: Dialogue Counter

Insert a counter value operation into the test program using Control > Counter.
Every counter is accessed via its number. Use this command to program loops
and branches. Proceed as follows:
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1. Enter the number of the counter to be changed.

2. Select the counter operation:

° Increment (+1) … Adds 1 to the counter.
° Decrement (-1) … Subtracts 1 from the counter. If 0 is reached or when

the counter is negative, the result is unsuccessful. Use this option to
program loops in programs in conjunction with Branch commands.

° Set to.... Sets the counter to a positive integer: This field must contain a
value. Entering 0 resets the counter.

ADVICE
Display the counters values using the Evaluation > Superimpose command.
Counter operations do not relate to geometry variables and/or result variables
in any way.

Example See the demo program count.vc. >> "Demo Programs", Page 389

7.6 Obsolete commands

7.6.1 Advanced Pattern Search

Overview ADVICE
Important: The obsolete command Advanced Pattern Search should no
longer be used for new programs. Instead of it use Locate > 360° Pattern
Search.

Both commands work similar. The difference is that the Advanced Pattern
Search uses correlation based on binary values and 360° Pattern Search
uses correlation based on gray values.

Teach-in Window

Image 217: Advanced
Pattern Search -taught-in
pattern

Search Window

Image 218: Advanced
Pattern Search -taught-in
pattern is detected

Search Window

Image 219: Advanced
Pattern Search -rotated
pattern is detected

Use Obsolete > Advanced Pattern Search to locate objects in the image. By
doing so, the angular position (in addition to the position) relative to a taught
pattern is determined. The command finds the angular position with respect to
a pattern. The search takes place in two steps, first a coarse search and then a
finer search with smaller rotation steps.

Use this command to find rotated objects, to classify and subsequently to save
the rotations in another image memory page. The image content so saved can
be used for further processed with other algorithms.
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Work Flow:
Teach-in Pattern

1. Switch to the tab control "Teach-in Pattern".

2. Determine, by means of the geometry rectangle, which image content has
to be read as the pattern. (Information for teaching, see also: "Teaching in
Detection Windows and Test Windows", Page 110.

3. With the button [Read Pattern] you read-in all image information located in
the geometry as the pattern, and stored it internally in the command.

4. In the reference window, verify if the pattern is complete.

Work Flow:
Teach-in Search Area

1. Switch to the tab control "Teach-in".

2. Please set the geometry, size and position of your search window. In this
area, your pattern is searched (see also: "Teaching in Detection Windows
and Test Windows", Page 110).

3. If necessary, set the parameters (X Point, Y Point) for position tracking (see
also: "Position Tracking of Objects", Page 118).

Work Flow:
Parameterizing and
Testing

1

3

2

4

5

8

9

10

7

6

1. Switch to the tab control "Parameters".

2. Determine in the area "Pattern" whether a pattern should be taken from a file
or the taught-in pattern.

3. In the area "Search Parameters" define the following parameters for the
search.
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Parameter Description

Minimal
Match

Minimum compliance (correlation) of the pattern found with
the taught pattern in per cent, so that a pattern may be
further processed as a valid pattern.
Useful settings are 60 to 80%.

Best Match Only the pattern with the best degree of match is saved.

All Over
Threshold

All objects whose matching degree will be higher than the
minimal match are found.

Search Grid

Subpixel Very fine search based on subpixel.

Fine Fine search, e.g. for writing or gravure.

Medium Search for medium-fine structures.

Coarse Coarse search, e.g. for a rectangle without fine structure.

Search Direction

No Direction Every pattern is taken into account.

N/E/S/W With a preferred search direction, the object is always
chosen that is found first in the preferred direction. (N
means that the first object is searched - starting from
bottom to top.) The command fails if the first object found
does not have the required degree of match

4. Set in the area "Gray Value Thresholds" the parameters for binarization.

Parameter Description

Pattern Binarization threshold for the taught pattern. In automatic
mode, the threshold is determined automatically.

Image Binarization threshold for the test image. In automatic
mode, the threshold is determined automatically.

From Result Binarization threshold for the test image is taken from a
result.

5. Quantity of Objects

Parameter Description

Result Enter the result number or name in which the number of
patterns found, is to be saved.

Nominal Enter the number of objects that should be found, so that
the command is considered successful.

Tolerances Enter the permitted upward and downward deviations from
the nominal value.

6. Rotation

Parameter Description

Nominal Angle from which the first test starts.

Increment Rotational increment between two tests.

Plus/Minus Limit of the rotation range for all following tests.
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7. Fine Search

Parameter Description

Do Fine
Search After-
wards

With this option selected, after successful angle determina-
tion by means of the given increment, a search with finer
rotation increments is carried out.

Rotation
Increment

Rotational increment between two tests.

8. Define in the area "Save Results" the settings for storing the results.

Parameter Description

Positions
from Point

Starting point name or number for saving the center of the
pattern found. All following points are saved consecutively.

Coordinate
System

Saving in image coordinates or world units.

Match from
Result

Starting result name or number for saving the degree of
match of the patterns found. All following matches are
saved consecutively.

Rotations
from

Starting result name or number for saving the angle of the
patterns found. The angles are saved clockwise from 0° to
360°.

Save to
Image Page

Image Page, in that the found pattern is stored derotated
and centralized for post-processing.
It is stored as follows:

• using undirected search (without direction) the pattern
with the best match

• using directed search (N/E/S/W) the first pattern found in
the chosen direction

9. Result Patterns Found

After activating the [Test] button, the number of patters found is listed in
the area left to the [Test] button. Furthermore, the Position (in subpixels),
Rotation, and Match value of the first pattern found according to the taught
pattern are shown. In parallel, the edges of the pattern found are marked in
red in the video image. The center is symbolized by a red cross.

10.Use the [OK] button to insert the command into the test program.
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Strategy for Setting
Search Grid

• For critical applications, the pattern must always do a coarse search first.
• If Coarse is not successful in the [Test], activate Medium, Fine or Subpixel.

Function Sensitivity Speed Remarks Sketch

Subpixel grid search   
1 Pixel  

slow exact pixel search  1 x 1

Fine grid search 
2 pixels

– 2 x 2

Medium grid search 
4 pixels

4 x faster than
fine search

4 x 4

Coarse grid search 
8 pixels

16 x faster
than fine
search

fastest, but least accu-
rate algorithm

8 x 8

7.6.2 Gateway Field Bus

ADVICE
Important: The obsolete command "Gateway Field Bus" should no longer be
used for new programs. Instead of it use the command "Process Coupling
Module".

Image 220: Dialogue Gateway Field Bus

Enable the transfer of data into the test program via a field bus gateway to be
configured using Control > Gateway Field Bus. There are various options for
signals, results and points available.

Setting Options for
Information Content

The upper left part of the dialog window allows specification of which
information can be transferred. Every option requires is own individual
parameters to be set in the corresponding fields on the right hand side.

The following options are available:

• Write status flag
• Read control flag
• Wait for control flag
• Write status flag and wait for control flag



vcwin pro 2.21
Part 2 - Command Reference

© Vision & Control GmbH
2015

999.994.306.10-en-1.15 369

• Write / read results
• Write / read points

For further details about the possibilities available for information transfer
please refer to the Fieldbus Gateway documentation.

Setting Transfer
Options

Byte Sequence Description

Low-Byte First Low-Byte is sent before the High-Byte.

High-Byte First High-Byte is sent before the Low-Byte.

Max. No. of
Communication
Attempts

Number of repetitions possible with unsuccessful commu-
nication.

Result for Error
Code

Result number in which the error code is saved. See
vicorem reference manual.

Termination
when Elements
are missing

This option allows the command to be stopped if the
elements specified to be transferred are not found. The
results or points are not found if they are not adjusted to
the correct value before sending, for example because a
command failed.

7.6.3 Coordinate Transfomation

ADVICE
Important: The obsolete command "Coordinate Transfomation" should no
longer be used for new programs.

Image 221: Dialogue Coordinate Transfomation

Write a program to convert from robot coordinates to camera coordinates and
vice versa in the test program using Control > Coordinate Transformation:

• Camera coordinates are in image coordinates.
• Robot coordinates are in world coordinates.

The Transformation is carried out based on the calibration.

Use this command before sending points to the robot and after receiving points
from the robot.
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Input Parameters Transformation Description

Camera Coor-
dinates into
Robot Coordi-
nates / Robot
Coordinates into
Camera Coordi-
nates

Instruction for which coordinate type should be trans-
formed into which other coordinate type.

Point to Trans-
form

Point number in which the point to be transformed is
saved.

Save in Point Point number that should be used to save the transformed
point in.

Test The test is used to show the transformed coordinates.

7.6.4 Send Measuring Values

ADVICE
Important: The obsolete command "Send Measuring Values" should no longer
be used for new programs. Instead of it use the command "Data Transfer".

Image 222: Dialogue Send Measuring Values

Write a command to send measured values which have been stored under a
result number using Evaluation > Send Measuring Values. This way, you can
send measured values e.g. from a vision system to a CAQ system. 

You can only send to an interface, not to a defined memory location in the file
system of the receiver.

Do not use this command together with the send result option of the Evaluate
Resultcommand. 
>> "Evaluate Result", Page 273
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Input Parameters Send Description

Results Results are sent.

Strings Strings are sent.

Interface Description

Select one of the available data interfaces, to which the result is to be sent.
The interfaces that are available depend on the type of vision system used.

/com Serial interface

/ethernet Ethernet interface

In order to guarantee proper functioning, do not change the entries behind /
com and /ethernet unless you are a network technician.

Character Set

ASCII … The results are output directly to the serial interface in ASCII format.
Information separators are sent between the individual results, a “new-line”
character is sent at the end. No answer is expected.

ADVICE
A communication participant (e.g. vision system) must start as a TCP
server and then it waits for the connection set-up. The other communication
participant, as a TCP client, then sets up a TCP link to the server. Data can
be sent in both directions when a connection exists.

The Interface
»Character
Set > ASCII«

Meaning of the ASCII setting

/ethernet
without port
and without
IP

All vision systems are TCP servers on port 23.

/ethernet
with port and
IP

All vision systems are TCP clients on the set port.

HEX … The results are output directly to the serial interface as hexadecimal
long values (4 bytes) in block format. No answer is expected.

The block format corresponds to the communication format in remote control
mode.

The various data blocks must be identified by different block identification keys.
The identification keys (d0 - df) are reserved for data acceptance in the vcwin
pro communication server.
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The Interface
»HEX«

Meaning of the HEX setting

/ethernet
without port
and without
IP

All vision systems are TCP servers on port 8500.

/ethernet
with port and
IP

All vision systems are TCP clients on the set port.

HEX to I/O Box … The results are output via the serial interface as
hexadecimal long values (4 bytes) in block format. After sending, the command
waits for confirmation from the I/O box.

The block format is a remote control format amended for the I/O box (e.g. pictor
Datasave).

The various data blocks must be identified by different block identification keys.
The identification keys (d0 - df) are reserved for data acceptance in vcwin pro
communication server.

Transfer List In the left part of the dialog box is a list of results and strings to be sent. Results
and strings will be sent in the order in which they appear in the list. Firstly, an
element in the result structure is selected from the field to the right of the dialog
box using the mouse. The selected result is then inserted in the transfer list by
clicking on the [< Insert] button. The [Remove >] button can be used to remove
entries from the transfer list.

Test In order to see the values sent, connect a terminal to the serial interface of the
vision system. Use the identical connection set-up parameters (9600, 8, no
parity, 1 stop bit, no handshake) that were used for connecting with vcwin pro.

7.6.5 Robot Communication

WARNING
Important: The obsolete command "Robot Communication"
should no longer be used for new programs.

Image 223: Dialogue Robot Communication
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Insert commands for the communication with robots into the test program using
Control > Robot Communication. The choice is available between sending
and receiving points and results. The command allows the choice between and
setting of robot-specific protocols.

Brief Guide 1. Select the type of operation Send or Receive.

2. Select between the sending/receiving of results or points from the
elements list.

3. Select and configure the protocol required.

4. Insert the command into the test program with the [OK] button.

Input Parameters Parameters Description

Send/
Receive

Type of operation for the robot communication.

Results/
Points

Select the elements to send/receive from the list. The list
of elements to be selected can be opened with the [List >>]
button.

The contents of the marked element list is sent, beginning with the smallest
number or the elements are set to the values received.

Co-ordinate
system

Description

Image/World Receiving in image or world coordinates.

Protocol Description

Types of
protocol

The 3964R Hex protocol in the Motorola and Intel formats are
available.

Acknowl-
edgement
Delay [ms]

Wait time that is set for receiving the acknowledgement signal
from the robot during sending/receiving.

Signal Delay
[ms]

Wait time that is set for the acknowledgement signal from the
robot when receiving results/points.
The standard setting of 300 ms for the acknowledgement
delay and 100 ms for the signal delay must be adjusted to
correspond to the speed of the communication partner.
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Repetition,
when Error
During

Description

Connecting Number of repetitions permissible with an unsuccessful
connection set-up.

Transferring Number of repetitions permissible with unsuccessful transfer
or with Timeout when receiving an acknowledgement or char-
acters.
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8 PART 3 - APPENDICES

8.1 Function and Command Reference (Firmware Overview)

Function Reference Menu > Utilities

Function Subfunction / Option pictor M pictor T vicosys

Online Debugging 4.22.128 4.16.230 4.16.213

Display Calibration Data - 4.16.239 4.16.239

Export Calibration Data - 4.16.239 4.16.239Calibrate Camera

Import Calibration Data - 4.16.239 4.16.239

Export White Balance Data - 4.16.243 4.16.239White Balance

Import White Balance Data - 4.16.243 4.16.239

Function Reference Menu > Communication

Function Subfunction / Option pictor M pictor T vicosys

Set Password - 4.16.239 4.16.239

Save on PC - 4.16.239 4.16.239

System Resources / Initial
Program

Load to Vision System - 4.16.239 4.16.239

Make Data Backup - 4.16.239 4.16.239

Restore Data Backup - 4.16.239 4.16.239

Function Reference Monitor Window

Function Subfunction / Option pictor M pictor T vicosys

Overlay multicolored Overlay - 4.16.245 4.16.245

Command Reference

Command Option pictor M pictor T vicosys

Image Commands

False Colors HSI Mode - - 4.16.213

for GigE area cameras - - 4.16.220GenICam Register

for GigE line scan cameras - - 4.16.239

Set Resolution without reboot - - 4.16.200Utilities for vicosys

Set Contrast Stretching - - 4.16.2201

Locate Commands

360° Pattern Search - 4.16.230 4.16.175

Data Matrix Code Advanced Read Function 4.18.982 - -

Edge Based Object Search 4.20.1133 - -

Measure Temperature - - 4.16.2511

Locate Helix - 4.16.250 4.16.250
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Command Option pictor M pictor T vicosys

Locate Angle - 4.16.240 4.16.240

Evaluation Commands

Check Point Distances - 4.16.250 4.16.250

Calculation Script (Ruby) - 4.16.230 4.16.213

Control Commands

for GigE cameras - - 4.16.2414Asynchronous Processes

for FireWire cameras - - 4.16.2244

Save/Load Image from String - 4.16.251 4.16.251

CANopen, Sercos - 4.16.233 4.16.233

Modbus 4.23.130 4.16.230 4.16.230

Process Module

Modbus: limit values to a 16 bit
register

4.23.131 4.16.239 4.16.239

Save Process Data - 4.16.251 4.16.251

1 License Thermal imaging functions required
2 License Data matrix code required
3 License Edge-based object search required
4 License Asynchronous processes required

8.2 Principles of Detection

Basics The term detection comes from contact based measurement technology and
was used to refer to obtaining measurement values by direct physical contact
with the test object. Today, this term has been adopted to refer also to contact-
less measurement procedures for the recognition of edges in images.

Synonyms for detect are “investigate” and “locate”. The results of detection
are either points or contours (a contour is a series of points). These results are
stored temporarily in the point structure and contour buffers respectively.

Positioning Options An important aspect of detection is the ability to compensate for variable object
position within the image. There are several basic methods of positioning
tracking beams:

• Absolute positioning
• Relative positioning - follow a point
• Relative positioning - follow a line

Dependent upon the quality of the image (i.e. the transitions between bright
and dark), the mathematical algorithms used for detection can become very
complex. For this reason, vision systems from Vision & Control GmbH offer a
choice of several methods. This ensures a flexible response to varied conditions
in the real world and thus maximizes the quality of results.



vcwin pro 2.21
Part 3 - Appendices

© Vision & Control GmbH
2015

999.994.306.10-en-1.15 377

Overview of Detection
Algorithms

• "Binary Detection", Page 377
• "Gray Value Detection", Page 377
• "Gradient method", Page 378
• "Convolution Methods", Page 379
• "Sub-Pixel Detection", Page 380
• "Helix Detection (optional)", Page 381
• "Contour Detection", Page 381

8.2.1 Binary Detection

Parameters 

• Gray value threshold
• Noise filter

The binary detection algorithm makes use of a simple gray value threshold
and a noise filter to locate transitions in an image.

The noise filter ensures that spurious transitions e.g. dust are ignored. If the
threshold is crossed more than once within the space of a few pixels, this is
ignored and does not qualify as a true edge.

Binary detection is used for well-lit, high-contrast objects where speed is the
dominant consideration (preferably transition detected).

Advantage

• Fast

Disadvantages

• Highly dependent upon lighting conditions
• No two-dimensional noise reduction

Attainable precision using Gradient with Threshold is usually ± 1 pixel,
dependent upon the object.

8.2.2 Gray Value Detection

Parameters 

• Contrast
• Diffusion
• Noise filter
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This detection method does not make use of a static threshold but relies on
there being enough contrast. For a transition to be recognized, the gray value
must change a minimum amount within a certain number of pixels (defined by
the diffusion parameter).

The algorithm contains a noise filter to ensure that spurious peaks or
troughs are ignored. To be accepted, the required gray value change must be
maintained over the width of the noise filter. The process can also be used with
vertical illumination.

Advantages

• Fast
• Fairly independent of lighting conditions

Disadvantage

• No two-dimensional noise reduction

Attainable precision using gray value detection is usually ± 1 pixel, dependent
upon the object.

8.2.3 Gradient method

The gradient algorithms were developed as a scanning method specifically with
the aspects of industrial image processing in mind. They link high scanning
reliability with high scanning precision using two-dimensional interference
suppression. 

With the gradient method, the greyscale values of several neighbouring image
points are offset against one another, thereby determining the greyscale value
gradient. To achieve two-dimensional interference suppression, in addition to
binary and greyscale value scanning, the image points along a scan beam as
well as neighbouring image points of a scan window are offset against one
another (Scan Width parameter).

Types of scanning The history of the gradient can be evaluated mathematically in different ways.
For the range of vision systems from Vision & Control GmbH, the following
options were selected:

• Edge search until a gradient threshold is reached
• Search for the maximum gradient along a search area (maximum edge

probability if only one edge is expected)
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Gradient with
threshold

Parameter

• Threshold (0…255)
• Scan width
• Other parameters, such as Diffusion and Noise Filter, can be set for some

commands.

Advantage

• Two-dimensional interference suppression
• Minimal lighting dependency

Disadvantage

• When using two-dimensional interference suppression, somewhat slower
than the greyscale value method

The precision that can be achieved depends on the object, generally approx. ±1
pixel.

Maximum gradient ADVICE
Since a maximum gradient is always found with this method, regardless of
the image information, you must make a concrete statement on whether there
really is an edge behind the found gradient using the Minimum gradient
parameter.

Parameter

• Scan width
• Minimum gradient (0…255, pre-setting in vcwin pro = 5)
• Other parameters, such as Diffusion and Noise Filter, can be set for some

commands.

Advantage

• Edge location is defined mathematically
• Two-dimensional interference suppression
• Minimal lighting dependency

Disadvantage

• When using two-dimensional interference suppression, somewhat slower
than the greyscale value method

The edge precision that can be achieved depends on the object, approx. ±0.5
pixels.

8.2.4 Convolution Methods

These detection algorithms have been specially developed for industrial image
processing. They are similar to gradient methods, but also include a two-
dimensional spectrum analysis.

Detection Methods There are two types of detection in the Vision & Control GmbH vision systems,
which are distinguished according to the post-processing of the specified
coefficient gradient:

• Convolution with threshold
• Convolution with maximum coefficient
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Convolution with
Threshold

Parameters

• Threshold
• Detection width

Advantages

• Two-dimensional noise reduction
• Fairly independent of lighting conditions

Disadvantage

• Slightly slower than gray value detection if 2-dimensional noise reduction is
used.

Attainable precision using Convolution with Threshold is usually ± 1 pixel,
dependent upon the object.

Convolution Max.
Coefficient

Parameters

• Detection Width
• Minimum Coefficient (0…255, default setting in vcwin pro = 5)

As with the maximum coefficient process, a minimum expected value for the
edge is preset in the parameter Minimum Coefficient.

Advantages

• Position of edge is determined.
• Two-dimensional noise reduction.
• Fairly independent of lighting conditions

Disadvantages

• Slightly slower than gray value detection if 2-dimensional noise reduction is
used.

Attainable precision using Gradient with Threshold is usually ± 0.5 pixels,
dependent upon the object.

8.2.5 Sub-Pixel Detection

Parameters 

• Contrast (for gray value detection)
• Diffusion (for gray value detection)
• Noise filter (for gray value detection)
• Number of detections (for fine analysis)

Advantages

• High precision

Disadvantages

• Calculation intensive
• Noise reduction possible

Attainable precision using sub-pixel detection can be as high as ± 1/10 of a
pixel, dependent upon the object.

Procedure … Sub-pixel detection involves two processes:

1 Gray value detection: >> "Gray Value Detection", Page 377

2 Fine analysis … Three areas are investigated during fine analysis:
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• Dark area
• Transitions
• Bright area

Number of Detections … The Number of Detections parameter is used to
further increase the precision of detection. Found edges are used to calculate
the actual edge using statistical methods.

8.2.6 Helix Detection (optional)

The helix detection method is used for detecting the highest point of a coiled
object e.g. a spring or the element in a light bulb. The process determines the
highest point of a coil. Only horizontally or vertically aligned coils are possible.

Detection Methods The object is detected using the gradient method and the peak of a coil in the
helix is detected. There are two methods of helix detection:

• “Helix (max.Gradient)” detection
• “Helix (Gradient)” detection

Helix (Max. Gradient) Parameters

• Minimum gradient
• Detection width
• >> "Gradient method", Page 378

Helix (Gradient) Parameters

• Gradient threshold
• Detection width
• >> "Gradient method", Page 378

8.2.7 Contour Detection

Procedure … The contour of an object is followed from a defined starting point.
The scope of the search can be confined to an image window or can be in the
complete image. 

Closed Contour … A closed contour is one where the starting point is reached
again.

The coordinates of all points along a contour are temporarily stored in a
“contour buffer”. The system supports up to 10 contour buffers, each containing
up to 2000 coordinates. The contents of the contour buffers can then be used
by test commands. Complete contour buffers can be used as operands for
calculations e.g. to determine the dimensions of a circular object which is larger
than the recorded image.
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Detection Methods There are three methods of contour detection:

• Binary method (along an ISO gray value line)
• Gradient method (along the maximum gradients of a gray value line)
• Gradient method with subsequent fine analysis of points along edges

(optional)

Binary Contour
Detection

Parameters

• Gray value threshold
• Noise filter

The contour of an object is detected using a constant gray value threshold i.e.
the contour will be quasi "isometric".

Advantages

• The starting point is sure to be reached again in closed contours.

Disadvantages

• Highly dependent upon lighting conditions
• No noise reduction

Attainable precision can be as high as 1 pixel, dependent upon the object.

Gradient Contour
Detection

Parameters

• Threshold
• Detection width
• Min. threshold

The contour of an object is detected using the maximum gradient of gray values
around the object.

This method should only be used when the edges are distinct, as the maximum
gray value gradients within images of real objects do not always coincide with
the required edges.

If this prerequisite is fulfilled, a relatively high precision of about ± 0.5 of a pixel
can be attained. Moreover, it is also possible to carry out a fine analysis of the
found contour location (see Contour detection with the gradient procedure, with
subsequent fine analysis of the found edge location).

The parameters Threshold and Detection Width are the parameters for
detecting the starting point.

The parameter Min. Threshold refers to the determination of the contour.
The contour determination is aborted if the threshold is undershot, i.e. the
determined gradient is too small.

Advantages

• The actual position of the edge is determined.
• Fairly independent of lighting conditions.
• Higher precision than the binary method.

Disadvantages

• Risk of uncertainty when the object contours are not distinct .

Attainable precision using gradient contour detection is generally about ± 0,5
pixel, dependent upon the object.
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Contour Detection
Using the Gradient
Method with
Subsequent Fine
Analysis

Parameters

• Threshold
• Detection width
• Min. threshold

Procedure … During the first step of this process, contour tracing is carried out
according to the procedure described in the “Gradient Contour Detection" topic.
This is followed by a fine analysis of the area around the contour (dark area,
transition, bright area).

This method should only be used when the edges are distinct, as the maximum
gray value gradients within images of real objects do not always coincide with
the required edges. If this prerequisite is fulfilled, a relatively high precision can
be attained.

The parameters Threshold and Detection Width are the parameters for
detecting the starting point.

The parameter Min. Threshold refers to the determination of the contour.
The contour determination is aborted if the threshold is undershot, i.e. the
determined gradient is too small.

Advantages

• High precision fairly independent of lighting conditions.

Disadvantage

• Risk of uncertainty when the object contours are not distinct.

As in the sub-pixel detection method, attainable precision can be as high as
1/10 of a pixel, dependent upon the object.

8.3 Methods for calculation script

In this chapter, you will find the description of all methods intrinsic to vcwin pro.

Instance methods are methods which you can apply to each object or instance
of an object, whereas class methods create new objects. Constants are values
which you can use for comparison to individual attribute values of objects. They
contain constant numerical values.

Result class Method Description

.value Value of the result (Integer)

.state Evaluation of the result (Boolean: true = good, false =
bad)

.clone Copies the object

.to_s Conversion to string

Table 7: Instance methods

Method Description

VC::Result.new( value,
state=true )

Defines a new VC::Result object with result value
(value) and evaluation (state). If the parameter state is
not defined, it is true by default.

Table 8: Class methods
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Point class Method Description

.x Value of the x-co-ordinate (Integer)

.y Value of the y-co-ordinate (Integer)

.coordinate_system Co-ordinate system used (Integer: 0 for image co-ordi-
nates, 1 for world co-ordinates)

.camera Number of the camera (Integer)
Since the calibration of the camera is decisive when
converting a point from image to world co-ordinates,
you should use this command to identify the right
camera.

.isImage? Indicates whether the point is in image co-ordinates
(Boolean)

.isWorld? Indicates whether the point is in world co-ordinates
(Boolean)

.toImage(camera=-1) Copies the point to image co-ordinates. If a camera is
not defined, the camera of the current image page (-1)
is set by default.

.toImage!(camera=-1) Converts the point to image co-ordinates. If the point
is already in image co-ordinates, no conversion is
carried out. If the camera parameter is not defined,
the camera of the current image page (-1) is set by
default.

.toWorld Copies the point to world co-ordinates.

.toWorld! Converts the point to world co-ordinates. If the point is
already in world co-ordinates, no conversion is carried
out.

.clone Copies the point without changing the co-ordinate
system.

.to_a Conversion to array

.to_s Conversion to string

Table 9: Instance methods

Method Description

VC::Point.image( x, y,
camera=-1 )

Defines a new VC::Point object in the image co-ordi-
nate system with x-co-ordinate (x), y-co-ordinate (y)
and camera used (camera). If the camera parameter
is not defined, the camera of the current image page
(-1) is set by default.

VC::Point.world( x, y ) Defines a new VC::Point object in the world co-ordi-
nate system with x-co-ordinate (x) and y-co-ordinate
(y).

Table 10: Class methods
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Constant Description

VC::CoordinateImage Value 0 (Integer)

VC::CoordinateWorld Value 1 (Integer)

Table 11: Constants

Lines class Method Description

[0/1] Co-ordinates of the first point [0] or second point [1] of
the line

.x1, .x2 Value of the x-co-ordinate of point 1 or 2 (Integer)

.y1, .y2 Value of the y-co-ordinate of point 1 or 2 (Integer)

.coordinate_system Co-ordinate system used (Integer: 0 for image co-ordi-
nates, 1 for world co-ordinates)

.camera Number of the camera (Integer)
Since the calibration of the camera is decisive when
converting a line from image to world co-ordinates,
you should use this command to identify the right
camera.

.isImage? Indicates whether the line is in image co-ordinates
(Boolean)

.isWorld? Indicates whether the line is in world co-ordinates
(Boolean)

.toImage(camera=-1) Copies the line to image co-ordinates. If a camera is
not defined, the camera of the current image page (-1)
is set by default.

.toImage!(camera=-1) Converts the line to image co-ordinates. If the line
is already in image co-ordinates, no conversion is
carried out. If the camera parameter is not defined,
the camera of the current image page (-1) is set by
default.

.toWorld Copies the line to world co-ordinates.

.toWorld! Converts the line to world co-ordinates. If the line is
already in world co-ordinates, no conversion is carried
out.

.clone Copies the line without changing the co-ordinate
system.

.to_a Conversion to array

.to_s Conversion to string

Table 12: Instance methods
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Method Description

VC::Line.fromPoints(p1,
p2)

Defines a new VC::Line object from two existing
point (p1, p2). If the points are in different co-ordinate
systems, they must first be converted to the same co-
ordinate system.

VC::Line.image( x1,
y1, x2, y2,
camera=-1 )

Defines a new VC::Line object in the image co-ordi-
nate system with x- and y-co-ordinates of two points
(x1, y1, x2, y2) and the camera used (camera). If the
camera parameter is not defined, the camera of the
current image page (-1) is set by default.

VC::Line.world( x1,
y1, x2, y2 )

Defines a new VC::Line object in the world co-ordinate
system with x- and y-co-ordinates of two points (x1,
y1, x2, y2).

Table 13: Class methods

Constant Description

VC::CoordinateImage Value 0 (Integer)

VC::CoordinateWorld Value 1 (Integer)

Table 14: Constants

Circle class Method Description

.x Value of the x-co-ordinate of the centre point (Integer)

.y Value of the y-co-ordinate of the centre point (Integer)

.r Value of the radius (Integer)

.coordinate_system Co-ordinate system used (Integer: 0 for image co-ordi-
nates, 1 for world co-ordinates)

.camera Number of the camera (Integer)
Since the calibration of the camera is decisive when
converting a point from image to world co-ordinates,
you should use this command to identify the right
camera.

.isImage? Indicates whether the circle is in image co-ordinates
(Boolean)

.isWorld? Indicates whether the circle is in world co-ordinates
(Boolean)

.toImage(camera=-1) Copies the circle to image co-ordinates. If a camera is
not defined, the camera of the current image page (-1)
is set by default.

.toImage!(camera=-1) Converts the circle to image co-ordinates. If the circle
is already in image co-ordinates, no conversion is
carried out. If the camera parameter is not defined,
the camera of the current image page (-1) is set by
default.

Table 15: Instance methods
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Method Description

.toWorld Copies the circle to world co-ordinates.

.toWorld! Converts the circle to world co-ordinates. If the circle
is already in world co-ordinates, no conversion is
carried out.

.clone Copies the circle without changing the co-ordinate
system.

.to_a Conversion to array

.to_s Conversion to string

Table 15: Instance methods

Method Description

VC::Circle.fromPoint
(centre, radius)

Defines a new VC::Circle object from an existing point
(centre) and a radius value (radius).

VC::Circle.image( x, y,
r, camera=-1 )

Defines a new VC::Circle object in the image co-
ordinate system with x-co-ordinate (x), y-co-ordinate
(y), radius size (r) and camera used (camera). If the
camera parameter is not defined, the camera of the
current image page (-1) is set by default.

VC::Circle.world( x, y,
r )

Defines a new VC::Circle object in the world co-ordi-
nate system with x-co-ordinate (x), y-co-ordinate (y)
and radius size (r).

Table 16: Class methods

Constant Description

VC::CoordinateImage Value 0 (Integer)

VC::CoordinateWorld Value 1 (Integer)

Table 17: Constants

String class Method Description

.string Value of the character string (String)

.clone Copies the object

Table 18: Instance methods

Method Description

VC::String.new( string ) Defines a new VC::String object with a character string
(string).

Table 19: Class methods
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Contour class Method Description

<< point Adds a new point (point) to the contour

[pointnumber] Point (pointnumber) in the contour

.length Number of points in the contour (Integer)

.points Points of the contour in an array

.camera Number of the camera (Integer)
Since the calibration of the camera is decisive when
converting a point from image to world co-ordinates,
you should use this command to identify the right
camera.

.clone Copies the object

.to_a Conversion to an array

.to_s Conversion to a string

Table 20: Instance methods

Method Description

VC::Contour.fromPoints
( *points )

Defines a new VC::Contour object from several
existing points (points). If the first point is in image
co-ordinates, the associated camera is used for the
contour. If it is in world co-ordinates, the camera of the
current image page is used. All points are converted
to image co-ordinates appropriate for the specified
camera.

VC::Contour.empty
(camera=-1)

Defines a new, empty VC::Contour object with the
specified camera (camera). If the camera parameter is
not defined, the camera of the current image page (-1)
is set by default. The new empty contour can then be
provided with the method << with points.

Table 21: Class methods

Counter class Method Description

.value Value of the counter (Integer)

.clone Copies the object

.to_a Conversion to an array

Table 22: Instance methods

Method Description

VC::Counter.new( value )Defines a new VC::Counter object with a specific initial
value (value).

Table 23: Class methods
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Image class Method Description

.format Image type (Integer: 0 = greyscale value, 3 = RGB
image)

.width Image width (Integer)

.height Image height (Integer)

.grey Greyscale value (Integer)

.red Colour value red (Integer)

.green Colour value green (Integer)

.blue Colour value blue (Integer)

Table 24: Instance methods

Method Description

VC::Image.create( page_number=-1 ) Defines a new VC::Image object
from the specified image page
(page_number). We do not recom-
mend using this method, as it fails
with images containing over 1,000,000
pixels.

VC::Image.createArea( page_number=-1,
px, py, dx, dy )

Defines a new VC::Image object with
image information from the specified
image page (page_number). In addi-
tion, the position of the image section
(px, py) and the x- and y-stretch (dx,
dy) must be specified.

Table 25: Class methods

Constant Description

VC::Image::Grey8 Value 0 (Integer)

VC::Image::Rgbx Value 3 (Integer)

VC::Image::MaxPixels Value 1,000,000 (Integer)

Table 26: Constants

8.4 Demo Programs

Overview You can find the demo programs in the program directory vcwin pro . Open a
demo program in the programming window in order to learn more about the
demo programs through the program comments. The following table contains
an overview of the demo program. The demo programs can be modified and
new demo programs can be added.
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File name System Description

Calibrating

calib.vc All Calibrates the coordinate system of the
camera.

Counter

counter.vc All Displays the use of the Counter command
invcwin pro.

Image Acquisition

single.vc pictor Mxxxx,
vicosys

vicosys: Usual image acquisition with standard
image acquisition and display on a monitor.

single-fast.vc pictor Mxxxx,
vicosys

Fast image acquisition with standard image
acquisition and  without display on a
monitor.

multi-camera-
parallel.vc

vicosys Simultaneous image acquisition with two
cameras in a multi-screen.

multi-camera-
sequential.vc

vicosys Alternating image acquisition from two
cameras in a multi-screen.

Program Handling

simple.vc pictor Mxxxx,
vicosys

Program structure with trigger input, image
acquisition, image processing, analysis, and
output (digital outputs / monitor).

geocopy.vc All Displays the effect of the vcwin pro command
Copy Geometry Variables for the work with
program loops in vcwin pro .

demo.vc pictor Mxxxx/
E, vicosys

A simple test program with image acquisition,
image processing, and visualization.

UP_LIO.vc pictor Mxxxx/
E, vicosys

Program structure with selection of the
subprogram through digital I/O (LineI/O).

UP_PIO.vc pictor Mxxxx/
E, vicosys

Program structure with selection of the
subprogram through digital I/O (PortI/O).

Measurement User Window

send-pic.vc pictor Mxxxx/
E, vicosys

Cyclically sends the currently recorded JPG
image through Ethernet.

send-
data_ethernet.vc

pictor Mxxxx/
E, vicosys

Sends measurements to the user window over
Ethernet.

send-
data_rs232.vc

pictor Mxxxx/
E, vicosys

Sends measurements to the user window over
RS232

Applications

distance.vc All Measures a section in the image, incl. position
tracking of the test object and good/bad evalu-
ation.

radius.vc All Measures the radius of a circle in the image,
incl. position tracking of the test object and
good/bad evaluation.
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File name System Description

datamatrix.vc pictor Mxxxx/
E, vicosys

Data-Matrix

ocr.vc pictor Mxxxx/
E, vicosys

OCR

completeness1.vcpictor Mxxxx/
E, vicosys

Integrity checks on orbits.

completeness2.vcpictor Mxxxx/
E, vicosys

Integrity checks on fixed positions.
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8.5 Evaluating the print quality

Guidelines ISO/IEC 15415 and AIM DPM-1-2006 are standardised guidelines for
evaluating the print quality of 2D and DPM codes. They define ten parameters
in each case which are intended to provide a measurement of the readability
and quality of a code. AIM DPM-1-2006 is an ISO enhancement which concerns
itself specifically with the quality of DPM codes.

The guidelines contain the following parameters whose results are stored in
vcwin pro in the same order in the result structure:

ISO/IEC 15415

[0] Overall Quality
[1] Fixed Pattern Damage
[2] Decode Quality
[3] Axial Non-Uniformity
[4] Grid Non-Uniformity
[5] Unused Error Correction
[6] Modulation
[7] Symbol Contrast
[8] Mean Light
[9] Mean Dark

AIM DPM-1-2006

[0] Overall Quality
[1] Fixed Pattern Damage
[2] Decode Quality
[3] Axial Non-Uniformity
[4] Grid Non-Uniformity
[5] Unused Error Correction
[6] Cell Modulation
[7] Cell Contrast
[8] Mean Light
[9] Mean Dark

The functions of the Symbol Contrast / Cell Contrast and Modulation / Cell
Modulation parameters are identical. They were renamed with AIM DPM-1-2006
to emphasise differences in the way of determining the value.

Each parameter can have a result between 0 and 4, whereby 4 is the best value
and 0 the worst. The Overall Quality parameter receives the value of the lowest
result of the evaluated parameters [1] - [7] and describes the determined print
quality. For a satisfactory result, it should have a value of at least 2. However,
in theory, the code can also be read and output even if the overall evaluation is
lower.

Parameter • Overall Quality is the lowest result of the individual sub-evaluations [1] - [7]
and describes the overall quality in terms of readability.

• Fixed Pattern Damage evaluates the condition of the fixed elements
"Finder Pattern" (the lines arranged in an L-shape which delimit the code),
"Alternative Pattern" (dotted lines opposite the Finder Pattern) and the quiet
zones around the code. If there are gaps or print faults in these areas, this
can lead to read problems and will accordingly be given a worse evaluation.
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• Decode Quality examines the syntax of the code and decodes it (if
possible) with a reference decoder algorithm. Only the two results "Pass" (4)
or "Fail" (0) are possible for this parameter. If this test is not successful, no
further quality checking can be carried out.

• Axial Non-Uniformity describes any horizontal or vertical distortion of the
code or the module.

• Grid Non-Uniformity describes any general distortion or displacement of
the code or the module.

• Unused Error Correction evaluates the number of remaining correction
bytes in the error correction overhead that were not used for error correction.
The higher the number the better the quality of the code and therefore the
higher the result.

• Modulation or Cell Modulation returns a value for the uniformity of the
intensity of light and dark modules in the code. A consistent intensity of the
light and dark modules simplifies matching and makes the code easier to
decode.

• Symbol Contrast or Cell Contrast evaluates the contrast between light and
dark modules within the code.

• Mean Light is the average brightness of the light modules in % or greyscale
value (for 8-bit resolutions). According to AIM DPM-1-2006, this value should
be between 70 and 86% or, as the case may be, a greyscale value between
180 and 220 in order to create a good, reproducible brightness ratio. In ISO/
IEC 15415, the lighting is defined additionally.

• Mean Dark is the average brightness of the dark modules in % or greyscale
value (for 8-bit resolutions) (see Mean Light).

For evaluating the print quality according to one of the guidelines, you should
use the corresponding lighting definition for the respective guideline.
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8.6 Dot Matrix

8.7 Technical support

If you have any technical questions about our products, simply contact our
technical support, where our competent employees are ready to listen to your
problems, questions and suggestions.

You can call us at: +49(0)3681/ 7974-20

8.7.1 Update
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